source: projects/specs/trunk/w/wvdial/wvdial-vl.spec @ 521

Revision 521, 7.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A heuristic autodialer for PPP connections
2Name: wvdial
3Version: 1.60
4Release: 1%{?_dist_release}
5License: LGPLv2
6URL: http://alumnit.ca/wiki/index.php?page=WvDial
7Group: System Environment/Daemons
8Source0: http://alumnit.ca/download/wvdial-%{version}.tar.gz
9Patch1: wvdial-1.60-remotename.patch
10Patch2: wvdial-1.60-dialtimeout.patch
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12BuildRequires: libwvstreams-devel >= 0:4.4, openssl-devel
13BuildRequires: pkgconfig
14Requires: ppp >= 2.3.7
15
16%description
17WvDial automatically locates and configures modems and can log into
18almost any ISP's server without special configuration. You need to
19input the username, password, and phone number, and then WvDial will
20negotiate the PPP connection using any mechanism needed.
21
22%prep
23%setup -q
24%patch1 -p1 -b .remotename
25%patch2 -p1 -b .dialtimeout
26
27%build
28make \
29        CPPOPTS="$RPM_OPT_FLAGS -fno-rtti" \
30        XX_LIBS="-lcrypt" \
31        PREFIX=%{_prefix} \
32        BINDIR=%{_bindir} \
33        MANDIR=%{_mandir} \
34        PPPDIR=%{_sysconfdir}/ppp/peers $@
35
36%install
37[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
38make install \
39        PREFIX=${RPM_BUILD_ROOT}%{_prefix} \
40        BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
41        MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
42        PPPDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/ppp/peers
43rm $RPM_BUILD_ROOT/%{_sysconfdir}/ppp/peers/wvdial-pipe
44touch $RPM_BUILD_ROOT/%{_sysconfdir}/wvdial.conf
45
46%clean
47[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
48
49%files
50%defattr(-,root,root)
51%doc CHANGES* COPYING* README* TODO FAQ
52%attr(0755,root,root)   %{_bindir}/*
53%attr(0644,root,root)   %{_mandir}/man1/*
54%attr(0644,root,root)   %{_mandir}/man5/*
55%attr(0600,root,daemon) %config %{_sysconfdir}/ppp/peers/wvdial
56%verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/wvdial.conf
57
58%changelog
59* Tue Oct 14 2008 Shu KONNO <owa@bg.wakwak.com> 1.60-1vl5
60- applied new versioning policy, spec in utf-8
61
62* Mon Nov 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.60-0vl1
63- initial build for Vine Linux
64
65* Mon Oct 29 2007 Bill Nottingham <notting@redhat.com> - 1.60-3
66- fix remotename patch (#348831, #344391)
67
68* Wed Oct 10 2007 Ondrej Vasik <ovasik@redhat.com> - 1.60-2
69- added option for dial timeout(#200375)
70
71* Fri Aug 17 2007 Harald Hoyer <harald@rawhide.home> - 1.60-1
72- version 1.60
73- changed license tag to LGPLv2
74
75* Thu Jun 28 2007 Harald Hoyer <harald@redhat.com> - 1.56-1
76- version 1.56
77
78* Wed Apr 18 2007 Harald Hoyer <harald@redhat.com> - 1.54.0-6
79- specfile review
80
81* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.54.0-5.2.2.1
82- rebuild
83
84* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.54.0-5.2.2
85- bump again for double-long bug on ppc(64)
86
87* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.54.0-5.2.1
88- rebuilt for new gcc4.1 snapshot and glibc changes
89
90* Mon Dec 19 2005 Harald Hoyer <harald@redhat.com>
91- rebuilt
92
93* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
94- rebuilt
95
96* Thu Mar 03 2005 Harald Hoyer <harald@redhat.com>
97- rebuilt
98
99* Wed Feb 09 2005 Harald Hoyer <harald@redhat.com>
100- rebuilt
101
102* Tue Sep 21 2004 Harald Hoyer <harald@redhat.com> 1.54.0-3
103- added openssl-devel build req (bug 132887)
104
105* Mon Aug 31 2004 Harald Hoyer <harald@redhat.com> 1.54.0-2
106- added empty wvdial.conf file (bug 130622)
107
108* Mon Jun 21 2004 Harald Hoyer <harald@redhat.com> 1.54.0-1
109- version 1.54.0
110
111* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
112- rebuilt
113
114* Tue Jun 01 2004 Karsten Hopp <karsten@redhat.de> 1.53-14
115- remove -O0
116
117* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
118- rebuilt
119
120* Mon Sep  8 2003 Nalin Dahyabhai <nalin@redhat.com> 1.53-12
121- rebuild
122
123* Mon Sep  8 2003 Nalin Dahyabhai <nalin@redhat.com> 1.53-11
124- rebuild
125
126* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
127- rebuilt
128
129* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
130- rebuilt
131
132* Thu Nov 14 2002 Nalin Dahyabhai <nalin@redhat.com> 1.53-8
133- remove unpackaged files after %%install
134
135* Mon Aug 12 2002 Nalin Dahyabhai <nalin@redhat.com> 1.53-7
136- add missing URL
137- document --remotename in the man page
138
139* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 1.53-6
140- rebuilt with gcc-3.2 (we hope)
141
142* Fri Aug  9 2002 Nalin Dahyabhai <nalin@redhat.com> 1.53-5
143- re-allow specifying the remotename at startup-time
144- add man page for the configuration file
145
146* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 1.53-4
147- build using gcc-3.2-0.1
148
149* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.53-3
150- automated rebuild
151
152* Sun May 26 2002 Tim Powers <timp@redhat.com> 1.53-2
153- automated rebuild
154
155* Wed Apr 10 2002 Nalin Dahyabhai <nalin@redhat.com> 1.53-1
156- update to 1.53
157
158* Thu Apr  4 2002 Nalin Dahyabhai <nalin@redhat.com> 1.52-1
159- update to 1.52
160
161* Wed Mar 27 2002 Nalin Dahyabhai <nalin@redhat.com> 1.51-1
162- update to 1.51
163
164* Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-1
165- update to 1.50
166- use lockdev for locking
167
168* Thu Jan 24 2002 Than Ngo <than@redhat.com> 1.41-18
169- fix to build against g++ 3
170
171* Wed Sep 12 2001 Tim Powers <timp@redhat.com>
172- rebuild with new gcc and binutils
173
174* Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com>
175- bump the release and rebuild
176
177* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
178- bump the release and rebuild
179
180* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
181- change Copyright: tag to License:
182
183* Mon Apr  2 2001 Nalin Dahyabhai <nalin@redhat.com>
184- include the actual TODO file in docs, not a dangling symlink to it (#34385)
185
186* Mon Feb 12 2001 Nalin Dahyabhai <nalin@redhat.com>
187- Merge in latest -libs patch from rp3.
188
189* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
190- Merge in latest -libs patch from rp3.
191
192* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
193- automatic rebuild
194
195* Tue Jul  2 2000 Jakub Jelinek <jakub@redhat.com>
196- Rebuild with new C++
197
198* Sat Jun 17 2000 Bill Nottingham <notting@redhat.com>
199- add %%defattr
200
201* Fri Jun 16 2000 Nalin Dahyabhai <nalin@redhat.com>
202- Merge in latest -libs patch from rp3.
203
204* Sun Jun  4 2000 Nalin Dahyabhai <nalin@redhat.com>
205- FHS fixes.
206
207* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
208- fix build with more strict c++ compiler
209
210* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
211- rebuild for sparc baud rates > 38400.
212
213* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
214- sync up to copy in rp3's CVS repository for consistency, except for
215  changes to Makefiles
216
217* Thu Jan 13 2000 Nalin Dahyabhai <nalin@redhat.com>
218- update to 1.41, backing out patches that are now in mainline source
219
220* Sat Sep 18 1999 Michael K. Johnson <johnsonm@redhat.com>
221- improved the speed up dialing patch
222- improved the inheritance patch
223
224* Fri Sep 17 1999 Michael K. Johnson <johnsonm@redhat.com>
225- added explicit inheritance to wvdial.conf
226- speed up dialing
227
228* Mon Sep 13 1999 Michael K. Johnson <johnsonm@redhat.com>
229- improved the chat mode fix to allow specifying the remotename
230  so that multiple wvdial instances can't step on each other.
231
232* Fri Sep 10 1999 Michael K. Johnson <johnsonm@redhat.com>
233- chat mode fix to make CHAP/PAP work with chat mode
234
235* Mon Aug 02 1999 Michael K. Johnson <johnsonm@redhat.com>
236- Packaged 1.40
237
238* Wed Jul 28 1999 Michael K. Johnson <johnsonm@redhat.com>
239- Initial Red Hat package
Note: See TracBrowser for help on using the repository browser.