source: projects/specs/trunk/w/wv/wv-vl.spec @ 521

Revision 521, 5.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# option for not using libwmf-0.2.0 or higher
2# rpmbuild -ba | --rebuild --without libwmf
3%define           LIBWMF  1
4%{?_without_libwmf:%define LIBWMF 0}
5
6Summary: an MS-Word document converter
7Summary(ja): MS Word 文章コンバータ
8Name:  wv
9Version: 1.2.4
10Release: 1%{?_dist_release}
11Group: Applications/Text
12License: GPLv2
13URL: http://wvware.sourceforge.net/
14Source0: http://download.sourceforge.net/wvware/%{name}-%{version}.tar.gz
15
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: zlib-devel
18BuildRequires: glib2-devel
19BuildRequires: libgsf-devel
20BuildRequires: libpng-devel
21BuildRequires: libxml2-devel
22BuildRequires: libjpeg-devel
23%if %{LIBWMF}
24BuildRequires: libwmf-devel >= 0.2.6
25Requires: libwmf >= 0.2.6
26%endif
27
28%description
29wv is an MS-Word document converter.
30If you want to get EUC-JP html files, see the example below.
31wvHtml foobar.doc foobar.html.utf8
32iconv -f UTF-8 -t EUC-JP foobar.html.utf8 | \
33sed 's/UTF-8/EUC-JP/g' > foobar.html.euc
34
35%if %{LIBWMF}
36This package is configured to use libwmf, so it can convert wmf files
37into png.  Please install libwmf-0.2.0 or higher too.
38%else
39This package is configured not to use libwmf, so it can't convert
40wmf files into png.
41%endif
42
43%description -l ja
44wv は MS Word ドキュメントのコンバータです.EUC-JP エンコードの
45html ファイルを作成したいのであれば,次の例を参考にしてください.
46
47wvHtml foobar.doc foobar.html.utf8
48iconv -f UTF-8 -t EUC-JP foobar.html.utf8 | \
49sed 's/UTF-8/EUC-JP/g' > foobar.html.euc
50
51%if %{LIBWMF}
52このパッケージは libwmf を使用するように設定されているので,wmf
53ファイルを png に変換することができます.libwmf のバージョン 0.2.0 以上
54をあわせてインストールしてください.
55%else
56このパッケージは libwmf を使用しないように設定されているので,
57wmf ファイルを png に変換することはできません.
58%endif
59
60%package devel
61Summary: Development tools for programs to manipulate MS-Word documents
62Summary(ja): MS Word ドキュメントを処理するプログラムを開発するためのツール
63Group: Development/Libraries
64Requires: wv = %{version}
65Requires: zlib-devel
66Requires: glib2-devel
67Requires: libgsf-devel
68Requires: libpng-devel
69Requires: libxml2-devel
70Requires: libjpeg-devel
71%if %{LIBWMF}
72Requires: libwmf-devel >= 0.2.6
73%endif
74
75%description devel
76The wv-devel package contains the header files and static
77libraries necessary for developing programs using wv.
78
79If you want to develop programs which will manipulate MS-Word documents, you
80should install wv-devel. You'll also need to install the wv package.
81
82%description devel -l ja
83wv-devel パッケージには wv を使用したプログラムの開発に必要な
84ヘッダファイルおよび静的ライブラリが含まれています.
85
86MS Word ドキュメントを処理するプログラムを開発したいのであれば,
87wv-devel パッケージをインストールすべきです.wv パッケージを
88インストールする必要もあります.
89
90%prep
91%setup -q
92
93%build
94%configure --disable-static \
95%if %{LIBWMF}
96        --with-libwmf \
97%endif
98make %{?_smp_mflags}
99
100%install
101rm -rf $RPM_BUILD_ROOT
102%makeinstall
103
104rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%post -p /sbin/ldconfig
110
111%postun -p /sbin/ldconfig
112
113%files
114%defattr(-,root,root)
115%doc COPYING README
116%{_bindir}/wv[A-Z]*
117%{_libdir}/lib*.so.*
118%{_datadir}/wv
119%{_mandir}/man1/*
120
121%files devel
122%defattr(-,root,root)
123%{_includedir}/wv
124#{_libdir}/lib*.a
125%{_libdir}/lib*.so
126%{_libdir}/pkgconfig/*.pc
127
128%changelog
129* Tue May  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-2
130- spec in UTF-8
131- removed *.a file from devel package
132
133* Thu May  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-1
134- applied new versioning policy
135- removed *.la file from devel package
136- added %%post and %%postun for /sbin/ldconfig
137
138* Thu Dec 21 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
139- new upstream release
140  includes security fix CVE-2006-4513 <BTS:428>
141
142* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.0-0vl4
143- rebuild
144
145* Thu May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl3
146- added Requires: libwmf-devel to wv-devel
147
148* Tue Mar 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
149- rebuilt with libgsf-1.14.0
150
151* Thu Nov 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
152- new upstream release
153
154* Fri Feb 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
155- updated to 1.0.3
156- Patch1 was merged to upstream, dropped
157- added Japanese summary and description
158- added --with-expat to %configure
159- rewrite build option "--without libwmf"
160
161* Sat Sep 29 2004 SATO Masakiyo <info@pocomoco.net> 1.0.0-0vl3
162- correct wv.spec for CAN-2004-0645
163
164* Sat Aug 28 2004 SATO Masakiyo <info@pocomoco.net> 1.0.0-0vl2
165- added patch1 for CAN-2004-0645
166
167* Tue Sep 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-0vl1
168- update to 1.0.0
169- rebuild with new toolchains
170- fixed spec file
171
172* Thu Oct 03 2002 Shoji Matsumoto <shom@vinelinux.org> 0.7.2-0vl1
173- update
174
175* Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
176- 0.6.7-0vl1: was ported to VineSeedPlus with better macros
177- build with libwmf by default
178
179* Fri Jun  2 2001 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
180- 0.6.5-0vl1
181- subpackage devel
182- not to require libwmf by default
183- macro-usage change
184
185* Mon Dec  6 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
186- [wv-0.5.41-1]
187- First attempt.
Note: See TracBrowser for help on using the repository browser.