source: projects/specs/trunk/w/wu-ftpd/wu-ftpd-vl.spec @ 521

Revision 521, 8.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: An FTP daemon provided by Washington University.
2Name: wu-ftpd
3Version: 2.6.2
4Release: 5vl0
5License: BSD
6Group: System Environment/Daemons
7URL: http://www.wu-ftpd.org/
8#Source: ftp://ftp.wu-ftpd.org/pub/wu-ftpd/wu-ftpd-%{version}.tar.gz
9Source: wu-ftpd-2.7.0-20020304.tar.bz2
10Source1: ftpd.log
11Source2: ftp.pamd
12Source3: wu-ftpd-xinetd
13Source4: ftpaccess
14Patch0: wu-ftpd-2.6.0-redhat.patch
15Patch5: wu-ftpd-2.6.0-owners.patch
16Provides: ftpserver
17BuildRequires: pam-devel, openssl-devel
18Prereq: fileutils, openssl
19#rawhide# Requires: xinetd, /etc/pam.d/system-auth
20Requires: /etc/pam.d/system-auth
21Buildroot: %{_tmppath}/%{name}-root
22
23%description
24The wu-ftpd package contains the wu-ftpd FTP (File Transfer Protocol)
25server daemon. The FTP protocol is a method of transferring files
26between machines on a network and/or over the Internet. Wu-ftpd's
27features include logging of transfers, logging of commands, on the fly
28compression and archiving, classification of users' type and location,
29per class limits, per directory upload permissions, restricted guest
30accounts, system wide and per directory messages, directory alias,
31cdpath, filename filter, and virtual host support.
32
33%prep
34%setup -q -n %{name}
35mkdir rhsconfig
36%patch0 -p1 -b .redhat
37%patch5 -p1 -b .owners
38find . -type d -name CVS |xargs rm -rf
39
40%configure --enable-quota --enable-pam --disable-rfc931 --enable-ratios \
41        --enable-passwd --disable-dnsretry --enable-ls --enable-ipv6 \
42        --enable-tls
43
44perl -pi -e "s,/\* #undef SHADOW_PASSWORD \*/,#define SHADOW_PASSWORD 1,g" src/config.h
45
46# Make the version what we want it to be
47cat >src/newvers.sh <<EOF
48echo 'char version[] = "Version wu-%{version}-%{release}";' >vers.c
49EOF
50chmod 0755 src/newvers.sh
51
52%build
53make
54
55%install
56rm -rf $RPM_BUILD_ROOT
57mkdir -p $RPM_BUILD_ROOT/etc $RPM_BUILD_ROOT%{_sbindir}
58make install DESTDIR=$RPM_BUILD_ROOT
59install -c -m755 util/xferstats $RPM_BUILD_ROOT%{_sbindir}
60cd rhsconfig
61install -c -m 600 ftpusers  ftphosts ftpgroups ftpconversions $RPM_BUILD_ROOT/etc
62strip -R .comments $RPM_BUILD_ROOT%{_sbindir}/* || :
63mkdir -p $RPM_BUILD_ROOT/etc/{pam,logrotate}.d
64install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/ftpd
65install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/ftp
66ln -sf in.ftpd $RPM_BUILD_ROOT/usr/sbin/wu.ftpd
67ln -sf in.ftpd $RPM_BUILD_ROOT/usr/sbin/in.wuftpd
68
69#rawhide# mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d
70#rawhide# install -m644 %SOURCE3 $RPM_BUILD_ROOT/etc/xinetd.d/wu-ftpd
71
72install -c -m0600 %{SOURCE4} $RPM_BUILD_ROOT/etc
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%post
78if [ ! -f /var/log/xferlog ]; then
79    touch /var/log/xferlog
80    chmod 600 /var/log/xferlog
81fi
82cd /usr/share/ssl
83if [ ! -e certs/ftpd-rsa-key.pem ]; then
84(echo US
85 echo .
86 echo .
87 echo .
88 echo .
89 echo .
90 echo .) |openssl req -newkey rsa:1024 -nodes -out certs/ftpd-rsa.pem -x509 -days 365 -keyout private/ftpd-rsa-key.pem &>/dev/null
91fi
92
93%files
94%defattr(-,root,root)
95#rawhide# %config(noreplace) /etc/xinetd.d/wu-ftpd
96%doc README ERRATA CHANGES CONTRIBUTORS
97%doc doc/HOWTO doc/TODO doc/examples
98%{_mandir}/*/*.*
99%config /etc/ftp*
100%config /etc/pam.d/ftp
101%config /etc/logrotate.d/ftpd
102
103%defattr(0755,bin,bin)
104%{_sbindir}/*
105%{_bindir}/*
106
107%changelog
108* Thu Mar 28 2002 Yoshihiro Ota <ota@j.email.ne.jp> 2.6.2-5vl0
109- catch up to rawhide version 2.6.2-5
110- commented xinitrd related with #rawhide#
111
112* Sun Jan 06 2002 Toru Sagami <sagami@vinelinux.org> 2.6.0-14vl3
113- build for current develop trees (VineSeedPlus)
114- Conflicts: proftpd
115
116* Wed Nov 28 2001 Toru Sagami <sagami@vinelinux.org> 2.6.0-14vl2
117- remake wu-ftpd-2.6.1-sec.patch for 2.6.0 for security fix
118
119* Tue Jun 27 2000 Jun Nishii <jun@vinelinux.org>
120- rebuild on Vine Linux 2.0
121
122* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
123- fix up security fix
124
125* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
126- revert 7.0's PAM and xinetd changes for 6.2 updates
127
128* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
129- fix security bug w/ SITE EXEC
130
131* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
132- Modify PAM configuration to use system-auth
133- Miscellaneous FHS fixes
134
135* Mon May 22 2000 Trond Eivind Glomsrƒi <teg@redhat.com>
136- Add /etc/xinetd.d/wu-ftpd
137
138* Sat May 20 2000 Bill Nottingham <notting@redhat.com>
139- use normal getpwnam/getpwuid for standard password files (for NIS, etc.)
140
141* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
142- make binaries readable
143
144* Mon Mar 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
145- recompile
146
147* Fri Mar 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
148- fix bug in configure script
149
150* Sun Mar  5 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
151- remove the conflict between PAM and alternative passwd files and enable PAM
152
153* Sun Mar  5 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
154- fix up behavior for missing entries in shadow password files when the
155  non-shadow password file contains all info.
156  This fixes the MD5 problem.
157- remove the nlstbug patch; it's now included in the bero patch.
158
159* Mon Feb 28 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
160- fix up NLST behavior on broken symlinks
161
162* Sat Feb 12 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
163- Merge some features from BeroFTPD people requested:
164  - alternate passwd/shadow files for virtual hosts
165  - ratios
166- switch to using autoconfed build - it's much better on linux.
167  build makes some faulty assumptions based on its glibc 2.0 and
168  kernel 2.0.x knowledge.
169
170* Fri Feb  5 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
171- fix a bug (the port-allow ftpaccess option was broken)
172- handle compressed man pages
173
174* Thu Oct 21 1999 Cristian Gafton <gafton@redhat.com>
175- version 2.6.0, but no autoconf yet
176
177* Tue Sep 21 1999 Cristian Gafton <gafton@redhat.com>
178- patch for allowing logins by users that do not have a local account on the
179  machine, but are autheticated by PAM from a different database.
180
181* Mon Sep 06 1999 Cristian Gafton <gafton@redhat.com>
182- fix ident patch
183
184* Tue Aug 31 1999 Michael K. Johnson <johnsonm@redhat.com>
185- fixed roff subtlety
186
187* Wed Aug 25 1999 <jbj@redhat.com>
188- fix ftpd.c mapped_path buffer overflow.
189
190* Mon Aug 23 1999 <jbj@redhat.com>
191- apply fix for login bug (#1599).
192
193* Sat Aug 21 1999 <jbj@redhat.com>
194- include all quick-fixes from ftp.vr.net (#3482,#3866).
195
196* Sat Jun 12 1999 <alan@redhat.com>
197- Added the new -I option to toggle the use of ident
198
199* Mon Jun  7 1999 <jbj@redhat.com>
200- update to 2.5.0 (pathname patch no longer needed).
201- use "/bin/ps -f -p #" to get correct ftpwho info (#2455).
202- revert glob patch in order to fix "cd ~user" (#2798) and "ls foo*" (#2944).
203
204* Mon Apr 19 1999 <ewt@redhat.com>
205- fixed pathname overflow patch
206
207* Sat Apr 17 1999 <ewt@redhat.com>
208- use libc glob function
209- patched up some overflows - ick.
210
211* Fri Apr 16 1999 Cristian Gafton <gafton@redhat.com>
212- version 2.4.2-vr17. Thank GOD! - important patches are already in. Joy an
213  happyness will reign the world now.
214
215* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
216- auto rebuild in the new build environment (release 6)
217
218* Mon Feb 15 1999 Cristian Gafton <gafton@redhat.com>
219- update to 2.4.2-beta18-vr14 from ftp.vr.net
220
221* Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
222- fix busted symlinks.
223
224* Thu Jul 16 1998 Jeff Johnson <jbj@redhat.com>
225- update to 2.4.2-beta18
226
227* Tue Jun 09 1998 Prospector System <bugs@redhat.com>
228- translations modified for de
229
230* Tue Jun  9 1998 Jeff Johnson <jbj@redhat.com>
231- updated to 2.4.2-beta17 (fix problems #679/#680)
232
233* Thu May 07 1998 Prospector System <bugs@redhat.com>
234- translations modified for de, fr, tr
235
236* Sun May 03 1998 Cristian Gafton <gafton@redhat.com>
237- fixed the ps patch for the new ps convention (use ps www instead of ps -www)
238
239* Sun Apr 12 1998 Cristian Gafton <gafton@redhat.com>
240- added %clean section
241
242* Sat Apr 11 1998 Cristian Gafton <gafton@redhat.com>
243- updated to 2.4.2b16
244- BuildRoot
245
246* Fri Dec 12 1997 Cristian Gafton <gafton@redhat.com>
247- added a patch to prevent a possible PORT command exploit
248- cleaned up the .linux patch to get a clean compile on glibc
249
250* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
251- fixed copyright field
252
253* Mon Oct 13 1997 Michael K. Johnson <johnsonm@redhat.com>
254- Updated to new pam conventions.
255
256* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
257- Updated to beta 15, which fixes a number of security holes. Release 1
258  if for RH 4.2, release 2 is glibc based.
259
260* Mon Mar 03 1997 Michael K. Johnson <johnsonm@redhat.com>
261- Moved from pam.conf to pam.d
262
263* Mon Mar 03 1997 Erik Troan <ewt@redhat.com>
264- xferstats should look for perl in /usr/bin, not /usr/local/bin
265- provides the "ftpserver" virtual package
266
267* Thu Feb 13 1997 Michael K. Johnson <johnsonm@redhat.com>
268- Updated to beta-12, and created a new PAM patch from scratch, since
269  the old one made massive changes to ftpd and caused some problems.
Note: See TracBrowser for help on using the repository browser.