source: projects/specs/trunk/w/wpa_supplicant/wpa_supplicant-vl.spec @ 9331

Revision 9331, 11.4 KB checked in by inagaki, 9 years ago (diff)

2015-02-05 Ryoichi INAGAKI <ryo1@…>

  • wicd, wpa_supplicant: updated
  • xfce4-dict: fixed spec file
  • xfcet-settings: added patch


Line 
1%define build_gui 1
2
3Summary: WPA/WPA2/IEEE 802.1X Supplicant
4Name: wpa_supplicant
5Version: 2.3
6Release: 1%{?_dist_release}
7License: BSD
8Group: System Environment/Base
9URL: http://w1.fi/wpa_supplicant/
10
11Source0: http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
12Source1: %{name}.build-config
13Source2: %{name}.conf
14Source3: %{name}.init.d
15Source4: %{name}.sysconfig
16Source6: %{name}.logrotate
17
18# distro specific customization and not suitable for upstream,
19# works around busted drivers
20Patch0: wpa_supplicant-assoc-timeout.patch
21# ensures that debug output gets flushed immediately to help diagnose driver
22# bugs, not suitable for upstream
23Patch1: wpa_supplicant-flush-debug-output.patch
24# disto specific customization for log paths, not suitable for upstream
25Patch2: wpa_supplicant-dbus-service-file-args.patch
26# quiet an annoying and frequent syslog message
27Patch3: wpa_supplicant-quiet-scan-results-message.patch
28# allow more private key encryption algorithms
29Patch5: wpa_supplicant-openssl-more-algs.patch
30# distro specific customization for Qt4 build tools, not suitable for upstream
31Patch6: wpa_supplicant-gui-qt4.patch
32# Fix libnl3 includes path
33Patch7: libnl3-includes.patch
34# Less aggressive roaming; signal strength is wildly variable
35Patch8: rh837402-less-aggressive-roaming.patch
36
37## Vine patches
38Patch700: wpa_supplicant-2.3-vineqt4.patch
39
40BuildRoot: %{_tmppath}/%{name}-%{version}-root
41%if %{build_gui}
42BuildRequires: qt4-devel
43%endif
44BuildRequires: openssl-devel
45BuildRequires: readline-devel
46BuildRequires: dbus-devel
47BuildRequires: libnl3-devel
48BuildRequires: docbook-utils
49
50Requires(post): /sbin/chkconfig
51Requires(preun): /sbin/chkconfig /sbin/service
52Requires(postun): /sbin/service
53
54%description
55wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
56for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
57component that is used in the client stations. It implements key negotiation
58with a WPA Authenticator and it controls the roaming and IEEE 802.11
59authentication/association of the wlan driver.
60
61%if %{build_gui}
62%package gui
63Summary: Graphical User Interface for %{name}
64Summary(ja): %{name} のグラフィカルユーザインタフェース
65Group: Applications/System
66
67%description gui
68Graphical User Interface for wpa_supplicant written using QT4
69
70%description -l ja gui
71QT4 を用いた wpa_supplicant のグラフィカルユーザインタフェース
72%endif
73
74%prep
75%setup -q
76%patch0 -p1 -b .assoc-timeout
77%patch1 -p1 -b .flush-debug-output
78%patch2 -p1 -b .dbus-service-file
79%patch3 -p1 -b .quiet-scan-results-msg
80%patch5 -p1 -b .more-openssl-algs
81%patch6 -p1 -b .qt4
82%patch7 -p1 -b .libnl3
83%patch8 -p1 -b .rh837402-less-aggressive-roaming
84
85%patch700 -p1 -b .qt4
86
87%build
88pushd wpa_supplicant
89  cp %{SOURCE1} .config
90  echo "CONFIG_LIBNL32=y" >> .config
91
92  CFLAGS="${CFLAGS:-%optflags} -fPIE -DPIE" ; export CFLAGS ;
93  CXXFLAGS="${CXXFLAGS:-%optflags} -fPIE -DPIE" ; export CXXFLAGS ;
94  LDFLAGS="${LDFLAGS:-%optflags} -pie -Wl,-z,now" ; export LDFLAGS ;
95  # yes, BINDIR=_sbindir
96  BINDIR="%{_sbindir}" ; export BINDIR ;
97  LIBDIR="%{_libdir}" ; export LIBDIR ;
98  make %{?_smp_mflags}
99%if %{build_gui}
100  QTDIR=%{_libdir}/qt4 make wpa_gui-qt4 %{?_smp_mflags}
101%endif
102  make eapol_test
103popd
104
105%install
106rm -rf %{buildroot}
107
108# init scripts
109install -D -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/rc.d/init.d/%{name}
110install -D -m 0644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
111install -D -m 0644 %{SOURCE6} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
112
113# config
114install -D -m 0600 %{SOURCE2} %{buildroot}/%{_sysconfdir}/%{name}/%{name}.conf
115
116# binary
117install -d %{buildroot}/%{_sbindir}
118install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
119install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
120install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
121install -D -m 0644 %{name}/dbus/dbus-wpa_supplicant.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
122install -D -m 0644 %{name}/dbus/fi.w1.wpa_supplicant1.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
123install -D -m 0644 %{name}/dbus/fi.epitest.hostap.WPASupplicant.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
124
125%if %{build_gui}
126# gui
127install -d %{buildroot}/%{_bindir}
128install -m 0755 %{name}/wpa_gui-qt4/wpa_gui %{buildroot}/%{_bindir}
129%endif
130
131# running
132mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
133
134# man pages
135install -d %{buildroot}%{_mandir}/man{5,8}
136install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
137install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
138
139# some cleanup in docs
140rm -f  %{name}/doc/.cvsignore
141rm -rf %{name}/doc/docbook
142chmod -R 0644 %{name}/examples/*.py
143
144%clean
145rm -rf %{buildroot}
146
147%post
148if [ $1 = 1 ]; then
149    /sbin/chkconfig --add %{name}
150fi
151
152%preun
153if [ $1 = 0 ]; then
154    /sbin/service %{name} stop > /dev/null 2>&1
155    killall -TERM wpa_supplicant >/dev/null 2>&1
156    /sbin/chkconfig --del %{name}
157fi
158
159%postun
160if [ $1 -ge 1 ]; then
161    /sbin/service %{name} condrestart > /dev/null 2>&1
162fi
163
164%files
165%defattr(-, root, root)
166%doc COPYING %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
167%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
168%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
169%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
170%{_sysconfdir}/rc.d/init.d/%{name}
171%{_sysconfdir}/dbus-1/system.d/%{name}.conf
172%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
173%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
174%{_sbindir}/wpa_passphrase
175%{_sbindir}/wpa_supplicant
176%{_sbindir}/wpa_cli
177%dir %{_localstatedir}/run/%{name}
178%dir %{_sysconfdir}/%{name}
179%{_mandir}/man8/*
180%{_mandir}/man5/*
181
182%if %{build_gui}
183%files gui
184%defattr(-, root, root)
185%{_bindir}/wpa_gui
186%endif
187
188%changelog
189* Thu Feb  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.3-1
190- updated to 2.3
191- built with libnl3 instead of libnl
192- added Patch 6, 7 and 8 from Fedora
193- added Patch700
194
195  * Mon Aug 22 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.3-3
196- import Patch8 from Fedora 1:0.7.3-9 to fix some crashes
197  - Wed Jul 27 2011 Dan Williams <dcbw@redhat.com> - 1:0.7.3-9
198  - Fix various crashes with D-Bus interface (rh #678625) (rh #725517)
199
200* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
201- rebuild with openssl-1.0.0c
202- add BuildRequires: qt4-designer, libnl-devel
203
204* Thu Jan 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-1
205- new upstream release
206- update patches
207- change License to BSD due to linkage against OpsnSSL since there is no
208  OpenSSL exception in upstream GPLv2 license text.
209- build with qt4
210- update build config
211
212* Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
213- new upstream release
214- remove hostap/madwifi/prism54 drivers, use 'wext' instead.
215- drop upstream patches
216- import some fedora patches
217  - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
218  - Better scanning behavior on resume from suspend/hibernate
219  - Better interaction with newer kernels and drivers
220
221* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
222- start wpa_supplicant by default.
223
224* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
225- new upstream release
226- import some fedora patches
227
228* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
229- rebuild with new openssl
230
231* Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
232- new upstream release
233
234* Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
235- initial build for Vine Linux based on FC package.
236
237* Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
238- Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
239- Fix up madwifi-ng private ioctl()s for r1331 and later
240- Update madwifi headers to r1475
241
242* Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
243- Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
244
245* Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
246- Fix control interface key obfuscation a bit
247
248* Sun Apr  2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
249- Work around older & incorrect drivers that return null-terminated SSIDs
250
251* Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
252- Add patch to make orinoco happy with WEP keys
253- Enable Prism54-specific driver
254- Disable ipw-specific driver; ipw2x00 should be using WEXT instead
255
256* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
257- Increase association timeout, mainly for drivers that don't
258        fully support WPA ioctls yet
259
260* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
261- Add additional BuildRequires #rh181914#
262- Add prereq on chkconfig #rh182905# #rh182906#
263- Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
264
265* Wed Mar  1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
266- Install wpa_passphrase too #rh183480#
267
268* Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
269- Don't expose private data on the control interface unless requested
270
271* Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
272- Downgrade to 0.4.8 stable release rather than a dev release
273
274* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
275- Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
276
277* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
278- Move initscript to /etc/rc.d/init.d
279
280* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
281- bump again for double-long bug on ppc(64)
282
283* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
284- rebuilt for new gcc4.1 snapshot and glibc changes
285
286* Sun Feb  5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
287- Update to 0.5.1
288- Add WE auth fallback to actually work with older drivers
289
290* Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
291- Bring package into Fedora Core
292- Add ap_scan control interface patch
293- Enable madwifi-ng driver
294
295* Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
296- upgrade to 0.4.7
297- added package w/ wpa_gui in it
298
299* Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
300- upgrade to 0.4.6
301- adding ctrl interface changes recommended
302  by Hugo Paredes <hugo.paredes@e-know.org>
303
304* Sun Oct  9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
305- upgrade to 0.4.5
306- updated config file wpa_supplicant is built with
307  especially, the ipw2100 driver changed to just ipw
308  and enabled a bunch more EAP
309- disabled dist tag
310
311* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
312- fix typo in init script
313
314* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
315- fixing init script using fedora-extras' template
316- removing chkconfig default startup
317
318* Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
319- upgrade to 0.4.2
320- new sample conf file that will use any unrestricted AP
321- make sysconfig config entry
322- new BuildRoot for Fedora Extras
323- adding dist tag to Release
324
325* Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
326- upgrade to 0.3.8
327
328* Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
329- compile ipw driver in
330
331* Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
332- upgrade to 0.3.6
333
334* Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
335- fixing init script
336
337* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
338- fixing init script
339- adding post/preun items to add/remove via chkconfig
340
341* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
342- adding sysV scripts
343
344* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
345- Initial RPM release.
346
Note: See TracBrowser for help on using the repository browser.