source: projects/specs/trunk/w/wpa_supplicant/wpa_supplicant-vl.spec @ 4635

Revision 4635, 10.7 KB checked in by shaolin, 13 years ago (diff)
  • wpa_supplicant: import Patch8 from Fedora 1:0.7.3-9 to fix some crashes
Line 
1Summary: WPA/WPA2/IEEE 802.1X Supplicant
2Name: wpa_supplicant
3Version: 0.7.3
4Release: 3%{?_dist_release}
5License: BSD
6Group: System Environment/Base
7URL: http://w1.fi/wpa_supplicant/
8
9Source0: http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
10Source1: %{name}.build-config
11Source2: %{name}.conf
12Source3: %{name}.init.d
13Source4: %{name}.sysconfig
14Source6: %{name}.logrotate
15
16# import from Fedora package
17# distro specific customization and not suitable for upstream,
18# works around busted drivers
19Patch0: wpa_supplicant-assoc-timeout.patch
20# ensures that debug output gets flushed immediately to help diagnose driver
21# bugs, not suitable for upstream
22Patch1: wpa_supplicant-flush-debug-output.patch
23# disto specific customization for log paths, not suitable for upstream
24Patch2: wpa_supplicant-dbus-service-file-args.patch
25# quiet an annoying and frequent syslog message
26Patch3: wpa_supplicant-quiet-scan-results-message.patch
27# recover from streams of driver disconnect messages (iwl3945)
28Patch4: wpa_supplicant-squelch-driver-disconnect-spam.patch
29# allow more private key encryption algorithms
30Patch5: wpa_supplicant-openssl-more-algs.patch
31# Send PropertyChanged notificationes when the BSS list changes
32Patch7: wpa_supplicant-bss-changed-prop-notify.patch
33# Don't crash trying to pass NULL to dbus
34Patch8: 0001-dbus-clean-up-new-D-Bus-interface-getters-setters.patch
35
36BuildRoot: %{_tmppath}/%{name}-%{version}-root
37
38BuildRequires: qt4-devel
39BuildRequires: qt4-designer
40BuildRequires: openssl-devel
41BuildRequires: readline-devel
42BuildRequires: dbus-devel
43BuildRequires: libnl-devel
44
45Requires(post): chkconfig
46Requires(preun): chkconfig
47
48%description
49wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
50for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
51component that is used in the client stations. It implements key negotiation
52with a WPA Authenticator and it controls the roaming and IEEE 802.11
53authentication/association of the wlan driver.
54
55%package gui
56Summary: Graphical User Interface for %{name}
57Summary(ja): wpa_supplicant のグラフィカルユーザインタフェース
58Group: Applications/System
59
60%description gui
61Graphical User Interface for wpa_supplicant written using QT4
62
63%description -l ja gui
64QT4 を用いた wpa_supplicant のグラフィカルユーザインタフェース
65
66%prep
67%setup -q
68%patch0 -p1 -b .assoc-timeout
69%patch1 -p1 -b .flush-debug-output
70%patch2 -p1 -b .dbus-service-file
71%patch3 -p1 -b .quiet-scan-results-msg
72%patch4 -p1 -b .disconnect-spam
73%patch5 -p1 -b .more-openssl-algs
74%patch7 -p1 -b .bss-changed-prop-notify
75%patch8 -p1 -b .dbus-rework
76
77%build
78pushd wpa_supplicant
79  cp %{SOURCE1} ./.config
80  CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ;
81  CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ;
82  make %{_smp_mflags}
83  PATH=$PATH:%{_libdir}/qt4/bin QTDIR=%{_libdir}/qt4 make wpa_gui-qt4 %{_smp_mflags}
84popd
85
86%install
87rm -rf %{buildroot}
88
89# init scripts
90install -D -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/rc.d/init.d/%{name}
91install -D -m 0644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
92install -D -m 0644 %{SOURCE6} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
93
94# config
95install -D -m 0600 %{SOURCE2} %{buildroot}/%{_sysconfdir}/%{name}/%{name}.conf
96
97# binary
98install -d %{buildroot}/%{_sbindir}
99install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
100install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
101install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
102install -D -m 0644 %{name}/dbus/dbus-wpa_supplicant.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
103install -D -m 0644 %{name}/dbus/fi.w1.wpa_supplicant1.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
104install -D -m 0644 %{name}/dbus/fi.epitest.hostap.WPASupplicant.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
105
106# gui
107install -d %{buildroot}/%{_bindir}
108install -m 0755 %{name}/wpa_gui-qt4/wpa_gui %{buildroot}/%{_bindir}
109
110# running
111mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
112
113# man pages
114install -d %{buildroot}%{_mandir}/man{5,8}
115install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
116install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
117
118# some cleanup in docs
119rm -f  %{name}/doc/.cvsignore
120rm -rf %{name}/doc/docbook
121
122
123%clean
124rm -rf %{buildroot}
125
126%post
127if [ $1 = 1 ]; then
128        chkconfig --add %{name}
129fi
130
131%preun
132if [ $1 = 0 ]; then
133        service %{name} stop > /dev/null 2>&1
134        killall -TERM wpa_supplicant >/dev/null 2>&1
135        /sbin/chkconfig --del %{name}
136fi
137
138
139%files
140%defattr(-, root, root)
141%doc COPYING %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
142%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
143%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
144%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
145%{_sysconfdir}/rc.d/init.d/%{name}
146%{_sysconfdir}/dbus-1/system.d/%{name}.conf
147%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
148%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
149%{_sbindir}/wpa_passphrase
150%{_sbindir}/wpa_supplicant
151%{_sbindir}/wpa_cli
152%dir %{_localstatedir}/run/%{name}
153%dir %{_sysconfdir}/%{name}
154%{_mandir}/man8/*
155%{_mandir}/man5/*
156
157%files gui
158%defattr(-, root, root)
159%{_bindir}/wpa_gui
160
161%changelog
162* Mon Aug 22 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.3-3
163- import Patch8 from Fedora 1:0.7.3-9 to fix some crashes
164  - Wed Jul 27 2011 Dan Williams <dcbw@redhat.com> - 1:0.7.3-9
165  - Fix various crashes with D-Bus interface (rh #678625) (rh #725517)
166
167* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
168- rebuild with openssl-1.0.0c
169- add BuildRequires: qt4-designer, libnl-devel
170
171* Thu Jan 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-1
172- new upstream release
173- update patches
174- change License to BSD due to linkage against OpsnSSL since there is no
175  OpenSSL exception in upstream GPLv2 license text.
176- build with qt4
177- update build config
178
179* Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
180- new upstream release
181- remove hostap/madwifi/prism54 drivers, use 'wext' instead.
182- drop upstream patches
183- import some fedora patches
184  - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
185  - Better scanning behavior on resume from suspend/hibernate
186  - Better interaction with newer kernels and drivers
187
188* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
189- start wpa_supplicant by default.
190
191* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
192- new upstream release
193- import some fedora patches
194
195* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
196- rebuild with new openssl
197
198* Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
199- new upstream release
200
201* Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
202- initial build for Vine Linux based on FC package.
203
204* Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
205- Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
206- Fix up madwifi-ng private ioctl()s for r1331 and later
207- Update madwifi headers to r1475
208
209* Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
210- Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
211
212* Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
213- Fix control interface key obfuscation a bit
214
215* Sun Apr  2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
216- Work around older & incorrect drivers that return null-terminated SSIDs
217
218* Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
219- Add patch to make orinoco happy with WEP keys
220- Enable Prism54-specific driver
221- Disable ipw-specific driver; ipw2x00 should be using WEXT instead
222
223* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
224- Increase association timeout, mainly for drivers that don't
225        fully support WPA ioctls yet
226
227* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
228- Add additional BuildRequires #rh181914#
229- Add prereq on chkconfig #rh182905# #rh182906#
230- Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
231
232* Wed Mar  1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
233- Install wpa_passphrase too #rh183480#
234
235* Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
236- Don't expose private data on the control interface unless requested
237
238* Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
239- Downgrade to 0.4.8 stable release rather than a dev release
240
241* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
242- Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
243
244* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
245- Move initscript to /etc/rc.d/init.d
246
247* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
248- bump again for double-long bug on ppc(64)
249
250* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
251- rebuilt for new gcc4.1 snapshot and glibc changes
252
253* Sun Feb  5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
254- Update to 0.5.1
255- Add WE auth fallback to actually work with older drivers
256
257* Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
258- Bring package into Fedora Core
259- Add ap_scan control interface patch
260- Enable madwifi-ng driver
261
262* Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
263- upgrade to 0.4.7
264- added package w/ wpa_gui in it
265
266* Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
267- upgrade to 0.4.6
268- adding ctrl interface changes recommended
269  by Hugo Paredes <hugo.paredes@e-know.org>
270
271* Sun Oct  9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
272- upgrade to 0.4.5
273- updated config file wpa_supplicant is built with
274  especially, the ipw2100 driver changed to just ipw
275  and enabled a bunch more EAP
276- disabled dist tag
277
278* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
279- fix typo in init script
280
281* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
282- fixing init script using fedora-extras' template
283- removing chkconfig default startup
284
285* Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
286- upgrade to 0.4.2
287- new sample conf file that will use any unrestricted AP
288- make sysconfig config entry
289- new BuildRoot for Fedora Extras
290- adding dist tag to Release
291
292* Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
293- upgrade to 0.3.8
294
295* Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
296- compile ipw driver in
297
298* Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
299- upgrade to 0.3.6
300
301* Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
302- fixing init script
303
304* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
305- fixing init script
306- adding post/preun items to add/remove via chkconfig
307
308* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
309- adding sysV scripts
310
311* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
312- Initial RPM release.
313
Note: See TracBrowser for help on using the repository browser.