source: projects/specs/trunk/w/wpa_supplicant/wpa_supplicant-vl.spec @ 521

Revision 521, 9.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: WPA/WPA2/IEEE 802.1X Supplicant
2Name: wpa_supplicant
3Version: 0.6.4
4Release: 1%{?_dist_release}
5License: GPL
6Group: System Environment/Base
7URL: http://w1.fi/wpa_supplicant/
8
9Source0: http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
10Source1: %{name}.config
11Source2: %{name}.conf
12Source3: %{name}.init.d
13Source4: %{name}.sysconfig
14Source6: %{name}.logrotate
15
16Patch0: wpa_supplicant-assoc-timeout.patch
17Patch1: wpa_supplicant-0.5.7-qmake-location.patch
18Patch2: wpa_supplicant-0.5.7-flush-debug-output.patch
19Patch3: wpa_supplicant-0.5.7-use-IW_ENCODE_TEMP.patch
20Patch4: wpa_supplicant-0.5.10-dbus-service-file.patch
21Patch5: wpa_supplicant-0.6.4-handle-invalid-ies.patch
22Patch6: wpa_supplicant-0.6.4-scan-fixes-1.patch
23Patch7: wpa_supplicant-0.6.4-scan-fixes-2.patch
24Patch8: wpa_supplicant-0.6.4-validate-wext-event.patch
25Patch9: wpa_supplicant-0.6.4-set-mode-handler.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28
29BuildRequires: qt-devel
30BuildRequires: openssl-devel
31BuildRequires: readline-devel
32BuildRequires: dbus-devel
33
34Requires(post): chkconfig
35Requires(preun): chkconfig
36
37%description
38wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
39for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
40component that is used in the client stations. It implements key negotiation
41with a WPA Authenticator and it controls the roaming and IEEE 802.11
42authentication/association of the wlan driver.
43
44%package gui
45Summary: Graphical User Interface for %{name}
46Summary(ja): wpa_supplicant のグラフィカルユーザインタフェース
47Group: Applications/System
48
49%description gui
50Graphical User Interface for wpa_supplicant written using QT3
51
52%description -l ja gui
53QT3 を用いた wpa_supplicant のグラフィカルユーザインタフェース
54
55%prep
56%setup -q
57%patch0 -p1 -b .assoc-timeout
58%patch1 -p1 -b .qmake-location
59%patch2 -p1 -b .flush-debug-output
60%patch3 -p1 -b .use-IW_ENCODE_TEMP
61%patch4 -p1 -b .dbus-service-file
62%patch5 -p1 -b .handle-invalid-ies
63%patch6 -p1 -b .scan-fixes-1
64%patch7 -p1 -b .scan-fixes-2
65%patch8 -p1 -b .validate-wext-event
66%patch9 -p1 -b .set-mode-handler
67
68%build
69pushd wpa_supplicant
70  cp %{SOURCE1} ./.config
71  CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ;
72  CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ;
73  make %{_smp_mflags}
74  QTDIR=%{_libdir}/qt3 make wpa_gui %{_smp_mflags}
75popd
76
77%install
78rm -rf %{buildroot}
79
80# init scripts
81install -d %{buildroot}/%{_sysconfdir}/rc.d/init.d
82install -d %{buildroot}/%{_sysconfdir}/sysconfig
83install -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/rc.d/init.d/%{name}
84install -m 0644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
85install -d %{buildroot}/%{_sysconfdir}/logrotate.d
86install -m 0644 %{SOURCE6} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
87
88# config
89install -d %{buildroot}/%{_sysconfdir}/%{name}
90install -m 0600 %{SOURCE2} %{buildroot}/%{_sysconfdir}/%{name}
91
92# binary
93install -d %{buildroot}/%{_sbindir}
94install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
95install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
96install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
97install -d %{buildroot}/%{_sysconfdir}/dbus-1/system.d/
98install -m 0644 %{name}/dbus-wpa_supplicant.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
99install -d %{buildroot}/%{_datadir}/dbus-1/system-services/
100install -m 0644 %{name}/dbus-wpa_supplicant.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
101
102# gui
103install -d %{buildroot}/%{_bindir}
104install -m 0755 %{name}/wpa_gui/wpa_gui %{buildroot}/%{_bindir}
105
106# running
107mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
108
109# man pages
110install -d %{buildroot}%{_mandir}/man{5,8}
111install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
112install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
113
114# some cleanup in docs
115rm -f  %{name}/doc/.cvsignore
116rm -rf %{name}/doc/docbook
117
118
119%clean
120rm -rf %{buildroot}
121
122%post
123if [ $1 = 1 ]; then
124        chkconfig --add %{name}
125fi
126
127%preun
128if [ $1 = 0 ]; then
129        service %{name} stop > /dev/null 2>&1
130        /sbin/chkconfig --del %{name}
131fi
132
133
134%files
135%defattr(-, root, root)
136%doc COPYING %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
137%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
138%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
139%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
140%{_sysconfdir}/rc.d/init.d/%{name}
141%{_sysconfdir}/dbus-1/system.d/%{name}.conf
142%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
143%{_sbindir}/wpa_passphrase
144%{_sbindir}/wpa_supplicant
145%{_sbindir}/wpa_cli
146%dir %{_localstatedir}/run/%{name}
147%dir %{_sysconfdir}/%{name}
148%{_mandir}/man8/*
149%{_mandir}/man5/*
150
151%files gui
152%defattr(-, root, root)
153%{_bindir}/wpa_gui
154
155%changelog
156* Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
157- new upstream release
158- remove hostap/madwifi/prism54 drivers, use 'wext' instead.
159- drop upstream patches
160- import some fedora patches
161  - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
162  - Better scanning behavior on resume from suspend/hibernate
163  - Better interaction with newer kernels and drivers
164
165* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
166- start wpa_supplicant by default.
167
168* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
169- new upstream release
170- import some fedora patches
171
172* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
173- rebuild with new openssl
174
175* Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
176- new upstream release
177
178* Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
179- initial build for Vine Linux based on FC package.
180
181* Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
182- Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
183- Fix up madwifi-ng private ioctl()s for r1331 and later
184- Update madwifi headers to r1475
185
186* Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
187- Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
188
189* Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
190- Fix control interface key obfuscation a bit
191
192* Sun Apr  2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
193- Work around older & incorrect drivers that return null-terminated SSIDs
194
195* Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
196- Add patch to make orinoco happy with WEP keys
197- Enable Prism54-specific driver
198- Disable ipw-specific driver; ipw2x00 should be using WEXT instead
199
200* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
201- Increase association timeout, mainly for drivers that don't
202        fully support WPA ioctls yet
203
204* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
205- Add additional BuildRequires #rh181914#
206- Add prereq on chkconfig #rh182905# #rh182906#
207- Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
208
209* Wed Mar  1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
210- Install wpa_passphrase too #rh183480#
211
212* Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
213- Don't expose private data on the control interface unless requested
214
215* Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
216- Downgrade to 0.4.8 stable release rather than a dev release
217
218* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
219- Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
220
221* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
222- Move initscript to /etc/rc.d/init.d
223
224* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
225- bump again for double-long bug on ppc(64)
226
227* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
228- rebuilt for new gcc4.1 snapshot and glibc changes
229
230* Sun Feb  5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
231- Update to 0.5.1
232- Add WE auth fallback to actually work with older drivers
233
234* Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
235- Bring package into Fedora Core
236- Add ap_scan control interface patch
237- Enable madwifi-ng driver
238
239* Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
240- upgrade to 0.4.7
241- added package w/ wpa_gui in it
242
243* Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
244- upgrade to 0.4.6
245- adding ctrl interface changes recommended
246  by Hugo Paredes <hugo.paredes@e-know.org>
247
248* Sun Oct  9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
249- upgrade to 0.4.5
250- updated config file wpa_supplicant is built with
251  especially, the ipw2100 driver changed to just ipw
252  and enabled a bunch more EAP
253- disabled dist tag
254
255* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
256- fix typo in init script
257
258* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
259- fixing init script using fedora-extras' template
260- removing chkconfig default startup
261
262* Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
263- upgrade to 0.4.2
264- new sample conf file that will use any unrestricted AP
265- make sysconfig config entry
266- new BuildRoot for Fedora Extras
267- adding dist tag to Release
268
269* Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
270- upgrade to 0.3.8
271
272* Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
273- compile ipw driver in
274
275* Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
276- upgrade to 0.3.6
277
278* Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
279- fixing init script
280
281* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
282- fixing init script
283- adding post/preun items to add/remove via chkconfig
284
285* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
286- adding sysV scripts
287
288* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
289- Initial RPM release.
290
Note: See TracBrowser for help on using the repository browser.