source: projects/specs/trunk/w/wpa_supplicant/wpa_supplicant-vl.spec @ 12350

Revision 12350, 11.5 KB checked in by tomop, 4 years ago (diff)

updated 2 packages

libtirpc-1.2.5-1

wpa_supplicant-2.9-1

Line 
1%define build_gui 1
2
3Summary: WPA/WPA2/IEEE 802.1X Supplicant
4Name: wpa_supplicant
5Version: 2.9
6Release: 1%{?_dist_release}
7Group: System Environment/Base
8License: BSD
9URL: https://w1.fi/wpa_supplicant/
10Vendor: Project Vine
11Distribution: Vine Linux
12
13Source0: https://w1.fi/releases/%{name}-%{version}.tar.gz
14Source2: %{name}.conf
15Source3: %{name}.init.d
16Source4: %{name}.sysconfig
17Source6: %{name}.logrotate
18
19# distro specific customization and not suitable for upstream,
20# Fedora-specific updates to defconfig
21Patch0: wpa_supplicant-config.patch
22# works around busted drivers
23Patch1: wpa_supplicant-assoc-timeout.patch
24# ensures that debug output gets flushed immediately to help diagnose driver
25# bugs, not suitable for upstream
26Patch2: wpa_supplicant-flush-debug-output.patch
27# quiet an annoying and frequent syslog message
28Patch3: wpa_supplicant-quiet-scan-results-message.patch
29# distro specific customization for Qt4 build tools, not suitable for upstream
30Patch4: wpa_supplicant-gui-qt4.patch
31# fix AP mode PMF disconnection protection bypass
32Patch5: 0001-AP-Silently-ignore-management-frame-from-unexpected-.patch
33
34## Vine patches
35
36BuildRoot: %{_tmppath}/%{name}-%{version}-root
37%if %{build_gui}
38BuildRequires: qt4-devel
39%endif
40BuildRequires: openssl-devel
41BuildRequires: readline-devel
42BuildRequires: dbus-devel
43BuildRequires: libnl3-devel
44BuildRequires: docbook-utils
45
46Requires(post): /sbin/chkconfig
47Requires(preun): /sbin/chkconfig /sbin/service
48Requires(postun): /sbin/service
49
50%description
51wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
52for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
53component that is used in the client stations. It implements key negotiation
54with a WPA Authenticator and it controls the roaming and IEEE 802.11
55authentication/association of the wlan driver.
56
57%if %{build_gui}
58%package gui
59Summary: Graphical User Interface for %{name}
60Summary(ja): %{name} のグラフィカルユーザインタフェース
61Group: Applications/System
62
63%description gui
64Graphical User Interface for wpa_supplicant written using QT4
65
66%description -l ja gui
67QT4 を用いた wpa_supplicant のグラフィカルユーザインタフェース
68%endif
69
70
71%prep
72%setup -q
73%autopatch -p1
74
75
76%build
77pushd wpa_supplicant
78  cp defconfig .config
79
80  export CFLAGS="${CFLAGS:-%optflags} -fPIE -DPIE"
81  export CXXFLAGS="${CXXFLAGS:-%optflags} -fPIE -DPIE"
82  export LDFLAGS="${LDFLAGS:-%optflags} -pie -Wl,-z,now"
83  # yes, BINDIR=_sbindir
84  export BINDIR="%{_sbindir}"
85  export LIBDIR="%{_libdir}"
86  make %{_smp_mflags} V=1
87%if %{build_gui}
88  make wpa_gui-qt4 %{_smp_mflags} V=1 QTDIR=%{_libdir}/qt4
89%endif
90  make eapol_test
91popd
92
93%install
94rm -rf %{buildroot}
95
96# init scripts
97install -D -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/rc.d/init.d/%{name}
98install -D -m 0644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
99install -D -m 0644 %{SOURCE6} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
100
101# config
102install -D -m 0600 %{SOURCE2} %{buildroot}/%{_sysconfdir}/%{name}/%{name}.conf
103
104# binary
105install -d %{buildroot}/%{_sbindir}
106install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
107install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
108install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
109install -m 0755 wpa_supplicant/eapol_test %{buildroot}/%{_sbindir}
110install -D -m 0644 %{name}/dbus/dbus-wpa_supplicant.conf \
111  %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
112install -D -m 0644 %{name}/dbus/fi.w1.wpa_supplicant1.service \
113  %{buildroot}/%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
114
115%if %{build_gui}
116# gui
117install -d %{buildroot}/%{_bindir}
118install -m 0755 %{name}/wpa_gui-qt4/wpa_gui %{buildroot}/%{_bindir}
119%endif
120
121# running
122mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
123
124# man pages
125install -d %{buildroot}%{_mandir}/man{5,8}
126install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
127install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
128
129# some cleanup in docs
130rm -f  %{name}/doc/.cvsignore
131rm -rf %{name}/doc/docbook
132chmod -R 0644 %{name}/examples/*.py
133
134%clean
135rm -rf %{buildroot}
136
137%post
138if [ $1 = 1 ]; then
139    /sbin/chkconfig --add %{name}
140fi
141
142%preun
143if [ $1 = 0 ]; then
144    /sbin/service %{name} stop > /dev/null 2>&1
145    killall -TERM wpa_supplicant >/dev/null 2>&1
146    /sbin/chkconfig --del %{name}
147fi
148
149%postun
150if [ $1 -ge 1 ]; then
151    /sbin/service %{name} condrestart > /dev/null 2>&1
152fi
153
154%files
155%defattr(-, root, root)
156%license COPYING
157%doc %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
158%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
159%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
160%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
161%{_sysconfdir}/rc.d/init.d/%{name}
162%{_sysconfdir}/dbus-1/system.d/%{name}.conf
163%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
164%{_sbindir}/wpa_passphrase
165%{_sbindir}/wpa_supplicant
166%{_sbindir}/wpa_cli
167%{_sbindir}/eapol_test
168%dir %{_localstatedir}/run/%{name}
169%dir %{_sysconfdir}/%{name}
170%{_mandir}/man8/*
171%{_mandir}/man5/*
172
173%if %{build_gui}
174%files gui
175%defattr(-, root, root)
176%{_bindir}/wpa_gui
177%endif
178
179%changelog
180* Tue Mar 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.9-1
181- new upstream release.
182- replaced all patches to rawhide's.
183
184* Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.6-2
185- rebuilt with openssl-1.1.1.
186- imported Patch62-64 from rawhide.
187
188* Sat Mar 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.6-1
189- updated to 2.6.
190- imported Patch9-60 from rawhide.
191
192* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.5-3
193- rebuilt with new toolchain.
194
195* Tue Mar 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.5-2
196- rebuild with openssl-1.0.2g
197
198* Thu Oct 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.5-1
199- update to 2.5
200- update SOURCE1
201- remove Patch7 (libnl3-includes.patch)
202- add Patch 9,10,11 from Fedora
203- remove Patch 6, 700
204
205* Thu Feb  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.3-1
206- updated to 2.3
207- built with libnl3 instead of libnl
208- added Patch 6, 7 and 8 from Fedora
209- added Patch700
210
211  * Mon Aug 22 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.3-3
212- import Patch8 from Fedora 1:0.7.3-9 to fix some crashes
213  - Wed Jul 27 2011 Dan Williams <dcbw@redhat.com> - 1:0.7.3-9
214  - Fix various crashes with D-Bus interface (rh #678625) (rh #725517)
215
216* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
217- rebuild with openssl-1.0.0c
218- add BuildRequires: qt4-designer, libnl-devel
219
220* Thu Jan 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-1
221- new upstream release
222- update patches
223- change License to BSD due to linkage against OpsnSSL since there is no
224  OpenSSL exception in upstream GPLv2 license text.
225- build with qt4
226- update build config
227
228* Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
229- new upstream release
230- remove hostap/madwifi/prism54 drivers, use 'wext' instead.
231- drop upstream patches
232- import some fedora patches
233  - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
234  - Better scanning behavior on resume from suspend/hibernate
235  - Better interaction with newer kernels and drivers
236
237* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
238- start wpa_supplicant by default.
239
240* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
241- new upstream release
242- import some fedora patches
243
244* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
245- rebuild with new openssl
246
247* Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
248- new upstream release
249
250* Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
251- initial build for Vine Linux based on FC package.
252
253* Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
254- Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
255- Fix up madwifi-ng private ioctl()s for r1331 and later
256- Update madwifi headers to r1475
257
258* Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
259- Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
260
261* Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
262- Fix control interface key obfuscation a bit
263
264* Sun Apr  2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
265- Work around older & incorrect drivers that return null-terminated SSIDs
266
267* Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
268- Add patch to make orinoco happy with WEP keys
269- Enable Prism54-specific driver
270- Disable ipw-specific driver; ipw2x00 should be using WEXT instead
271
272* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
273- Increase association timeout, mainly for drivers that don't
274        fully support WPA ioctls yet
275
276* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
277- Add additional BuildRequires #rh181914#
278- Add prereq on chkconfig #rh182905# #rh182906#
279- Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
280
281* Wed Mar  1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
282- Install wpa_passphrase too #rh183480#
283
284* Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
285- Don't expose private data on the control interface unless requested
286
287* Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
288- Downgrade to 0.4.8 stable release rather than a dev release
289
290* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
291- Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
292
293* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
294- Move initscript to /etc/rc.d/init.d
295
296* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
297- bump again for double-long bug on ppc(64)
298
299* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
300- rebuilt for new gcc4.1 snapshot and glibc changes
301
302* Sun Feb  5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
303- Update to 0.5.1
304- Add WE auth fallback to actually work with older drivers
305
306* Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
307- Bring package into Fedora Core
308- Add ap_scan control interface patch
309- Enable madwifi-ng driver
310
311* Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
312- upgrade to 0.4.7
313- added package w/ wpa_gui in it
314
315* Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
316- upgrade to 0.4.6
317- adding ctrl interface changes recommended
318  by Hugo Paredes <hugo.paredes@e-know.org>
319
320* Sun Oct  9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
321- upgrade to 0.4.5
322- updated config file wpa_supplicant is built with
323  especially, the ipw2100 driver changed to just ipw
324  and enabled a bunch more EAP
325- disabled dist tag
326
327* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
328- fix typo in init script
329
330* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
331- fixing init script using fedora-extras' template
332- removing chkconfig default startup
333
334* Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
335- upgrade to 0.4.2
336- new sample conf file that will use any unrestricted AP
337- make sysconfig config entry
338- new BuildRoot for Fedora Extras
339- adding dist tag to Release
340
341* Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
342- upgrade to 0.3.8
343
344* Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
345- compile ipw driver in
346
347* Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
348- upgrade to 0.3.6
349
350* Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
351- fixing init script
352
353* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
354- fixing init script
355- adding post/preun items to add/remove via chkconfig
356
357* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
358- adding sysV scripts
359
360* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
361- Initial RPM release.
362
Note: See TracBrowser for help on using the repository browser.