source: projects/specs/trunk/w/wpa_supplicant/wpa_supplicant-vl.spec @ 12558

Revision 12558, 12.7 KB checked in by tomop, 3 years ago (diff)

updated 2 packages

lzip-1.22-1

wpa_supplicant-2.9-2

Line 
1%bcond_with systemd
2%bcond_with gui
3
4Summary: WPA/WPA2/IEEE 802.1X Supplicant
5Name: wpa_supplicant
6Version: 2.9
7Release: 2%{?_dist_release}%{?with_systemd:.systemd}
8Group: network,system
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: BSD
13URL: https://w1.fi/wpa_supplicant/
14Source0: https://w1.fi/releases/%{name}-%{version}.tar.gz
15Source2: %{name}.conf
16Source3: %{name}.init.d
17Source4: %{name}.sysconfig
18Source6: %{name}.logrotate
19Source100: %{name}.service
20Source101: %{name}.sysconfig.systemd
21
22# distro specific customization and not suitable for upstream,
23# Fedora-specific updates to defconfig
24Patch0: wpa_supplicant-config.patch
25# works around busted drivers
26Patch1: wpa_supplicant-assoc-timeout.patch
27# ensures that debug output gets flushed immediately to help diagnose driver
28# bugs, not suitable for upstream
29Patch2: wpa_supplicant-flush-debug-output.patch
30# quiet an annoying and frequent syslog message
31Patch3: wpa_supplicant-quiet-scan-results-message.patch
32# distro specific customization for Qt4 build tools, not suitable for upstream
33Patch4: wpa_supplicant-gui-qt4.patch
34# fix AP mode PMF disconnection protection bypass
35Patch5: 0001-AP-Silently-ignore-management-frame-from-unexpected-.patch
36
37# fix some issues with P2P operation
38Patch6: 0001-P2P-Always-use-global-p2p_long_listen.patch
39Patch7: 0001-D-Bus-Fix-P2P-NULL-dereference-after-interface-remov.patch
40Patch8: 0001-p2p-Limit-P2P_DEVICE-name-to-appropriate-ifname-size.patch
41
42#fix for bz1915236
43Patch9: 0001-D-Bus-Allow-changing-an-interface-bridge-via-D-Bus.patch
44
45#expose OWE capability in D-Bus
46Patch10: 0001-dbus-Export-OWE-capability-and-OWE-BSS-key_mgmt.patch
47
48## Vine patches
49
50BuildRoot: %{_tmppath}/%{name}-%{version}-root
51%if %{with gui}
52BuildRequires: qt4-devel
53%endif
54BuildRequires: openssl-devel
55BuildRequires: readline-devel
56BuildRequires: dbus-devel
57BuildRequires: libnl3-devel
58BuildRequires: docbook-utils
59%if %{with systemd}
60%{?systemd_requires}
61%else
62Requires(post): /sbin/chkconfig
63Requires(preun): /sbin/chkconfig /sbin/service
64Requires(postun): /sbin/service
65%endif
66
67%description
68wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
69for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
70component that is used in the client stations. It implements key negotiation
71with a WPA Authenticator and it controls the roaming and IEEE 802.11
72authentication/association of the wlan driver.
73
74
75%if %{with gui}
76%package gui
77Summary: Graphical User Interface for %{name}
78Summary(ja): %{name} のグラフィカルユーザインタフェース
79Group: admin-tools
80
81%description gui
82Graphical User Interface for wpa_supplicant written using QT4
83
84%description -l ja gui
85QT4 を用いた wpa_supplicant のグラフィカルユーザインタフェース
86%endif
87
88
89%debug_package
90
91
92%prep
93%setup -q
94%autopatch -p1
95
96
97%build
98pushd wpa_supplicant
99  cp defconfig .config
100
101  export CFLAGS="${CFLAGS:-%optflags} -fPIE -DPIE"
102  export CXXFLAGS="${CXXFLAGS:-%optflags} -fPIE -DPIE"
103  export LDFLAGS="${LDFLAGS:-%optflags} -pie -Wl,-z,now"
104  # yes, BINDIR=_sbindir
105  export BINDIR="%{_sbindir}"
106  export LIBDIR="%{_libdir}"
107  make %{_smp_mflags} V=1
108%if %{with gui}
109  make wpa_gui-qt4 %{_smp_mflags} V=1 QTDIR=%{_libdir}/qt4
110%endif
111  make eapol_test
112popd
113
114%install
115rm -rf %{buildroot}
116
117%if %{with systemd}
118# systemd unit
119install -D -m 0644 %{SOURCE100} %{buildroot}%{_unitdir}/%{name}.service
120install -D -m 0644 %{SOURCE101} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
121%else
122# init scripts
123install -D -m 0755 %{SOURCE3} %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
124install -D -m 0644 %{SOURCE4} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
125%endif
126
127# logrotate
128install -D -m 0644 %{SOURCE6} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
129
130# config
131install -D -m 0600 %{SOURCE2} %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
132
133# binary
134install -d %{buildroot}/%{_sbindir}
135install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
136install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
137install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
138install -m 0755 wpa_supplicant/eapol_test %{buildroot}/%{_sbindir}
139install -D -m 0644 %{name}/dbus/dbus-wpa_supplicant.conf \
140  %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
141install -D -m 0644 %{name}/dbus/fi.w1.wpa_supplicant1.service \
142  %{buildroot}/%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
143
144%if %{with gui}
145# gui
146install -d %{buildroot}/%{_bindir}
147install -m 0755 %{name}/wpa_gui-qt4/wpa_gui %{buildroot}/%{_bindir}
148%endif
149
150# running
151mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
152
153# man pages
154install -d %{buildroot}%{_mandir}/man{5,8}
155install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
156install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
157
158# some cleanup in docs
159rm -f  %{name}/doc/.cvsignore
160rm -rf %{name}/doc/docbook
161chmod -R 0644 %{name}/examples/*.py
162
163
164%clean
165rm -rf %{buildroot}
166
167
168%post
169%if %{with systemd}
170%systemd_post wpa_supplicant.service
171%else
172if [ $1 = 1 ]; then
173    /sbin/chkconfig --add %{name}
174fi
175%endif
176
177%preun
178%if %{with systemd}
179%systemd_preun wpa_supplicant.service
180%else
181if [ $1 = 0 -o -x /bin/systemctl ]; then
182    /sbin/service %{name} stop > /dev/null 2>&1
183    killall -TERM wpa_supplicant >/dev/null 2>&1
184    /sbin/chkconfig --del %{name}
185fi
186%endif
187
188%postun
189%if %{with systemd}
190%systemd_postun_with_restart wpa_supplicant.service
191%else
192if [ $1 -ge 1 ]; then
193    /sbin/service %{name} condrestart > /dev/null 2>&1
194fi
195%endif
196
197
198%files
199%defattr(-, root, root)
200%license COPYING
201%doc %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
202%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
203%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
204%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
205%if %{with systemd}
206%{_unitdir}/%{name}.service
207%else
208%{_sysconfdir}/rc.d/init.d/%{name}
209%endif
210%{_sysconfdir}/dbus-1/system.d/%{name}.conf
211%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
212%{_sbindir}/wpa_passphrase
213%{_sbindir}/wpa_supplicant
214%{_sbindir}/wpa_cli
215%{_sbindir}/eapol_test
216%dir %{_localstatedir}/run/%{name}
217%dir %{_sysconfdir}/%{name}
218%{_mandir}/man8/*
219%{_mandir}/man5/*
220
221%if %{with gui}
222%files gui
223%defattr(-, root, root)
224%{_bindir}/wpa_gui
225%endif
226
227
228%changelog
229* Mon Mar 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.9-2
230- diasabled gui as default.
231- added systemd support (disabled as default).
232- replaced all patches to rawhide's.
233
234* Tue Mar 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.9-1
235- new upstream release.
236- replaced all patches to rawhide's.
237
238* Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.6-2
239- rebuilt with openssl-1.1.1.
240- imported Patch62-64 from rawhide.
241
242* Sat Mar 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.6-1
243- updated to 2.6.
244- imported Patch9-60 from rawhide.
245
246* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.5-3
247- rebuilt with new toolchain.
248
249* Tue Mar 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.5-2
250- rebuild with openssl-1.0.2g
251
252* Thu Oct 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.5-1
253- update to 2.5
254- update SOURCE1
255- remove Patch7 (libnl3-includes.patch)
256- add Patch 9,10,11 from Fedora
257- remove Patch 6, 700
258
259* Thu Feb  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.3-1
260- updated to 2.3
261- built with libnl3 instead of libnl
262- added Patch 6, 7 and 8 from Fedora
263- added Patch700
264
265  * Mon Aug 22 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.3-3
266- import Patch8 from Fedora 1:0.7.3-9 to fix some crashes
267  - Wed Jul 27 2011 Dan Williams <dcbw@redhat.com> - 1:0.7.3-9
268  - Fix various crashes with D-Bus interface (rh #678625) (rh #725517)
269
270* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
271- rebuild with openssl-1.0.0c
272- add BuildRequires: qt4-designer, libnl-devel
273
274* Thu Jan 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-1
275- new upstream release
276- update patches
277- change License to BSD due to linkage against OpsnSSL since there is no
278  OpenSSL exception in upstream GPLv2 license text.
279- build with qt4
280- update build config
281
282* Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
283- new upstream release
284- remove hostap/madwifi/prism54 drivers, use 'wext' instead.
285- drop upstream patches
286- import some fedora patches
287  - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
288  - Better scanning behavior on resume from suspend/hibernate
289  - Better interaction with newer kernels and drivers
290
291* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
292- start wpa_supplicant by default.
293
294* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
295- new upstream release
296- import some fedora patches
297
298* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
299- rebuild with new openssl
300
301* Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
302- new upstream release
303
304* Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
305- initial build for Vine Linux based on FC package.
306
307* Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
308- Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
309- Fix up madwifi-ng private ioctl()s for r1331 and later
310- Update madwifi headers to r1475
311
312* Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
313- Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
314
315* Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
316- Fix control interface key obfuscation a bit
317
318* Sun Apr  2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
319- Work around older & incorrect drivers that return null-terminated SSIDs
320
321* Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
322- Add patch to make orinoco happy with WEP keys
323- Enable Prism54-specific driver
324- Disable ipw-specific driver; ipw2x00 should be using WEXT instead
325
326* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
327- Increase association timeout, mainly for drivers that don't
328        fully support WPA ioctls yet
329
330* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
331- Add additional BuildRequires #rh181914#
332- Add prereq on chkconfig #rh182905# #rh182906#
333- Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
334
335* Wed Mar  1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
336- Install wpa_passphrase too #rh183480#
337
338* Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
339- Don't expose private data on the control interface unless requested
340
341* Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
342- Downgrade to 0.4.8 stable release rather than a dev release
343
344* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
345- Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
346
347* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
348- Move initscript to /etc/rc.d/init.d
349
350* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
351- bump again for double-long bug on ppc(64)
352
353* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
354- rebuilt for new gcc4.1 snapshot and glibc changes
355
356* Sun Feb  5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
357- Update to 0.5.1
358- Add WE auth fallback to actually work with older drivers
359
360* Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
361- Bring package into Fedora Core
362- Add ap_scan control interface patch
363- Enable madwifi-ng driver
364
365* Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
366- upgrade to 0.4.7
367- added package w/ wpa_gui in it
368
369* Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
370- upgrade to 0.4.6
371- adding ctrl interface changes recommended
372  by Hugo Paredes <hugo.paredes@e-know.org>
373
374* Sun Oct  9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
375- upgrade to 0.4.5
376- updated config file wpa_supplicant is built with
377  especially, the ipw2100 driver changed to just ipw
378  and enabled a bunch more EAP
379- disabled dist tag
380
381* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
382- fix typo in init script
383
384* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
385- fixing init script using fedora-extras' template
386- removing chkconfig default startup
387
388* Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
389- upgrade to 0.4.2
390- new sample conf file that will use any unrestricted AP
391- make sysconfig config entry
392- new BuildRoot for Fedora Extras
393- adding dist tag to Release
394
395* Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
396- upgrade to 0.3.8
397
398* Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
399- compile ipw driver in
400
401* Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
402- upgrade to 0.3.6
403
404* Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
405- fixing init script
406
407* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
408- fixing init script
409- adding post/preun items to add/remove via chkconfig
410
411* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
412- adding sysV scripts
413
414* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
415- Initial RPM release.
416
Note: See TracBrowser for help on using the repository browser.