source: projects/specs/trunk/w/wnn7egg/wnn7egg-vl.spec @ 521

Revision 521, 6.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4%define Wnn8Exists() %([ -f /usr/lib/wnn8/ja_JP/wnnenvrc ] && echo 1 || echo 0)
5
6Name:          wnn7egg
7Version:       1.02
8Release:       7%{?_dist_release}
9License:       GPL
10Source0:       http://www.omronsoft.co.jp/SP/unix/wnn7s/support/modules/wnn7-elisp-el-%{version}-1.tgz
11Source1:       %{name}-install.sh
12Source2:       %{name}-remove.sh
13Source3:       %{name}-init.el
14Source4:       vine-default-%{name}.el
15
16## Required files from Wnn8 for Linux/BSD FAQ
17## http://www.omronsoft.co.jp/SP/pcunix/wnn8/faq/03clients.html
18Source10: eggrc-wnn7_for-wnn8
19
20## from http://www.jpl.org/ftp/pub/misc/emcws-22.1-20071010.gz
21Source11: busyu.el
22
23## 母音過不足補正機能は余計なお世話!(腫瘍:しゅよう -> しゅうよう)
24Patch10: eggrc-wnn7-boinkabusoku-nil.patch
25
26## for emacs23
27## from ftp://ftp.jpl.org/pub/elisp/wnn7-elisp-el-1.02-1.patch.gz
28## (http://www.jpl.org/ftp/pub/elisp/wnn7-elisp-el-1.02-1.patch.gz)
29Patch100: wnn7-elisp-el-1.02-1.patch.gz
30## http://www.m17n.org/mlarchive/mule-ja/200703/msg00018.html
31#Patch101: wnn7egg-emacs23.patch
32
33URL:           http://www.omronsoft.co.jp/SP/unix/wnn7s/support/wnn7egg_v102s.html
34Group:         Applications/Editors/Emacs
35BuildRoot:     %{_tmppath}/%{name}-%{version}-root
36Summary:       wnn7egg - Japanese input client of Wnn7 for Emacs
37Summary(ja):   wnnななたまご - Wnn7 対応 Emacs 用日本語入力クライアント
38BuildArch:     noarch
39
40# %if %Wnn8Exists
41# Requires:      wnn8-server
42# %else
43# Requires:      wnn7-server
44# %endif
45PreReq:        emacsen
46%prereq_ge     emacsen-common
47BuildRequires: emacsen-common
48
49%description
50EGG for Wnn7, called "wnn-nana-tamago" is Japanese Input Method for Emacsen.
51It is based on Tamago ver.3 (v3.09) and incorporated the communication library
52part of Tamago Ver.4. This only can use with Jserver of Wnn7.
53
54This package includes eggrc-wnn7 placed on Wnn8 for Linux/BSD FAQ
55  http://www.omronsoft.co.jp/SP/pcunix/wnn8/faq/03clients.html
56and busyu.el of emcws-22.1-20071010.gz.
57This eggrc-wnn7 is customized for user's dictionaries of Wnn8, # '
58so if you install Wnn8 on your system, this package sets up for Wnn8.
59This busyu.el requires to search BUSYU.
60Also this package changes to (wnn7-set-boin-kabusoku nil) for eggrc-wnn7.
61Further, you do NOT need the path of wnn7egg for your .emacs.el.
62
63
64%description -l ja
65wnn7egg「wnnななたまご」は,「たまご第 3 版」v3.09 をベースに
66「たまご第 4 版」の通信,ライブラリ部を組み込んだ,Wnn7 の為の
67専用クライアントです.
68
69このパッケージには,Wnn8 for Linux/BSD FAQ
70  http://www.omronsoft.co.jp/SP/pcunix/wnn8/faq/03clients.html
71に置いてある eggrc-wnn7 と
72emcws-22.1-20071010.gz から busyu.el を同封しております.
73eggrc-wnn7 は,辞書を Wnn8 用に修正されており,
74もし Wnn8 がインストールされていると,Wnn8 向けに設定がされます.
75busyu.el がないと,部首検索などができません.
76また,母音過不足補正機能を有効にしない変更を施しています.
77なお,.emacs.el に wnn7egg のパスを通す設定などは一切不要です.
78
79
80%prep
81%setup -q -n wnn7/elisp/emacs20
82
83%{__cp} -af %{SOURCE3} .
84%{__cp} -af %{SOURCE4} .
85%{__cp} -af %{SOURCE10} .
86%{__cp} -af %{SOURCE11} .
87%{__cp} -af ../README .
88
89%patch10 -p0
90pushd ../../..
91%patch100 -p0 -b .emacs23-0
92#% patch101 -p0 -b .emacs23-1
93popd
94
95%build
96
97
98%install
99
100[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
101
102mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
103mkdir -p ${RPM_BUILD_ROOT}%{_libdir}/emacsen-common/packages/install
104mkdir -p ${RPM_BUILD_ROOT}%{_libdir}/emacsen-common/packages/remove
105mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
106
107
108#
109# install el files
110#
111
112%{__cp} eggrc-wnn7* ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
113%{__cp} *.el README ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
114%{__cp} -r its-v309 ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
115%{__install} -m 644 %{name}-init.el \
116    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
117
118#
119# install script (bytecompile el and install elc, remove)
120#
121
122%_installemacsenscript %{name} %{SOURCE1}
123
124%_removeemacsenscript  %{name} %{SOURCE2}
125
126
127%clean
128[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
129
130
131%post
132#
133# bytecompile and install
134#
135
136if [ "$1" = 2 ] ; then
137
138%_emacsenPackageRemove %{name}
139
140fi
141
142%_addemacsenlist %{name}
143
144%_emacsenPackageInstall %{name}
145
146%preun
147
148if [ "$1" = 0 ]; then
149
150%_emacsenPackageRemove %{name}
151
152%_removeemacsenlist %{name}
153
154fi
155
156
157%files
158%defattr(-,root,root)
159%{_datadir}/emacs/site-lisp/%{name}/
160%{_libdir}/emacsen-common/packages/install/%{name}
161%{_libdir}/emacsen-common/packages/remove/%{name}
162
163
164%changelog
165* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.02-7
166- updated wnn7egg-install.sh
167  - *-init.el: changed from hard copy to symbolic link
168    on /etc/emacs-XX.YY/site-start.d
169- fixed wnn7egg-remove.sh
170  - removed variable PIXMAPDIR
171
172* Thu Apr 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.02-6
173- added vine-default-wnn7egg.el
174- updated wnn7egg-init.el
175
176* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.02-5
177- dropped ExclusiveArch
178
179* Sun Feb 22 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.02-4
180- added ExclusiveArch: %%{ix86} x86_64
181- re-applied wnn7-elisp-el-1.02-1.patch.gz: corrected in %%prep
182
183* Sat Feb 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.02-3
184- applied wnn7-elisp-el-1.02-1.patch.gz
185
186* Sun Sep 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.02-2
187- spec in utf-8
188
189* Sat Mar 22 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.02-1vl5
190- used %{?_dist_release}
191
192* Sat Mar 15 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.02-1vl2
193 - delete %%if %%Wnn8Exists Requires: wnn8-server %%else Requires: wnn7-server %%endif
194
195* Sat Mar 15 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.02-1vl1.1
196- delete Vendor: none, Distribution: none
197 * Sat Mar 15 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.02-1vl1
198 - initial build for VineSeed
199
200* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.02-1vlmp4
201- define Wnn8Exists
202- Setup Wnn8 for wnn7egg-install.sh
203
204* Tue Feb 5 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.02-1vlmp3
205- rebuild for VineSeed
206
207* Sun Oct 28 2007 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.02-1vlmp2
208- add eggrc-wnn7-boinkabusoku-nil.patch (wnn7-set-boin-kabusoku nil); default: t
209
210* Mon Oct 15 2007 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.02-1vlmp1
211- initial release for Vine Linux 4.1
Note: See TracBrowser for help on using the repository browser.