source: projects/specs/trunk/w/wl/wl-vl.spec @ 521

Revision 521, 12.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4%define       origname      wl
5%define       origver       2.14.0
6# if the package is not prerelease, set %%{prever} to %{nil}
7%define       prever        %{nill}
8%define       emacsen_pkgdir /usr/lib/emacsen-common/packages
9
10Summary:      IMAP-capable mail/news reader for emacsen
11Summary(ja):  (X)Emacs 用IMAP に対応したメール/ニュースリーダ
12Name:         %{origname}
13Version:      %{origver}
14Release:      3%{?_dist_release}
15
16Source0:      ftp://ftp.gohome.org/%{origname}/stable/%{origname}-%{origver}.tar.gz
17Source1:      %{origname}-install.sh
18Source2:      %{origname}-remove.sh
19Source3:      %{origname}-init.el
20Source4:      vine-default-%{origname}.el
21
22Patch1:       wl-2.14.0-wl-news.patch
23
24Patch10:      wl-2.8.1-texi-ja.diff
25Patch11:      wl-2.8.1-install-utils.diff
26
27
28License:      GPL2
29Group:        Applications/Editors/Emacs
30BuildRoot:    %{_tmppath}/%{name}-%{version}-root
31BuildArch:    noarch
32
33
34Obsoletes:     wl-el, Wanderlust, Wanderlust-xemacs
35PreReq:        emacsen
36%prereq_ge     emacsen-common
37%prereq_ge     semi
38%prereq_ge     w3m-el
39BuildRequires: emacsen-common, semi, w3m-el
40
41
42Vendor:       Project Vine
43Distribution: Vine Linux
44Packager:     MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
45
46
47%description
48Wanderlust is a mail/news reader supporting IMAP for emacsen.
49Overall impression resembles to Mew, but Wanderlust have nifty
50features like IMAP support, threading display, and so on.
51
52#(eigo wakannai)
53#After installation, you must modify your ~/.emacs file to contain
54#at least:
55#
56#    (load "mime-setup")
57#
58#    (autoload 'wl "wl" "Wanderlust t)
59#    (autoload 'wl-draft "wl" "Write draft with Wanderlust." t)
60
61Other detailed information can be available at:
62
63  http://www.gohome.org/wl/index-e.html
64  (sorry, much detailed info is currently available only in Japanese)
65
66
67
68
69%description -l ja
70Wanderlust は、elisp のみで実装された IMAP 対応のメール/ニュースリーダです。
71使用感は Mew に近く、加えてスレッド表示や未読管理などにも対応しています。
72
73主な特徴(Wanderlust web ページより抜粋)
74
75  - elisp のみによる実装
76  - IMAPrev1, NNTP, POP, MH 形式のサポート
77  - Mew っぽい Folder Specification に基づくメッセージへの
78    統一的アクセス
79  - Mew っぽいキーバインドとマーク処理
80  - インタラクティブなスレッド表示
81  - 未読管理
82  - 購読フォルダの一覧を表示するフォルダモード
83  - メッセージキャッシュ、オフライン処理 (IMAP4)
84  - MIME 対応 (by SEMI or tm)
85
86#インストール後、~/.emacs に最低でも以下の記述を追加して下さい:
87#
88#    (load "mime-setup")
89#
90#    (autoload 'wl "wl" "Wanderlust t)
91#    (autoload 'wl-draft "wl" "Write draft with Wanderlust." t)
92
93# Emacs/XEmacs 起動時に以下の設定ファイルを読み込みます。
94# M-x wl で起動します。
95
96# /etc/emacs-??.?/site-start.d/55wl-init.el
97# /etc/xemacs-??.?.??/site-start.d/55wl-init.el
98
99アカウント毎の設定は、
100%{_defaultdocdir}/%{name}-%{origver}/samples/ja/dot.wl
101%{_defaultdocdir}/%{name}-%{origver}/samples/ja/dot.folders
102%{_defaultdocdir}/%{name}-%{origver}/samples/ja/dot.addresses
103をベースに、
104~/.wl
105~/.folders
106~/.address
107を作成下さい。
108
109
110詳しくは、Wanderlust の web ページ
111
112  http://www.gohome.org/wl/
113
114を見て下さい。
115
116
117
118%prep
119rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
120%setup -q -n %{origname}-%{origver}
121
122%patch1 -p1
123
124#%patch10 -p1
125%patch11 -p1
126
127touch doc/*.texi
128
129
130%install
131
132[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
133[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
134
135mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}/etc
136#mkdir -p ${RPM_BUILD_ROOT}%{_libdir}/emacsen-common/packages/install
137#mkdir -p ${RPM_BUILD_ROOT}%{_libdir}/emacsen-common/packages/remove
138mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
139mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
140mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
141
142
143#
144# install el files
145#
146
147cp -a WL-* Makefile wl %{SOURCE3} %{SOURCE4} \
148        ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
149cp -a utils elmo \
150        ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
151cp -a etc/icons \
152        ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}/etc/.
153
154# 2004.12.13 add Irokawa
155cp -a NEWS* \
156        ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
157
158
159
160#
161# build & install info
162#
163
164make EMACS=emacs info
165make EMACS=emacs INFODIR=${RPM_BUILD_ROOT}%{_infodir} install-info
166
167
168#
169# install script( bytecompile el and install elc , remove )   
170#
171
172%_installemacsenscript %{origname} %{SOURCE1}
173
174%_removeemacsenscript  %{origname} %{SOURCE2}
175
176
177
178%post
179
180#
181# bytecompile and install
182#
183
184if [ "$1" = 2 ]; then
185
186%_emacsenPackageRemove %{origname}
187
188fi
189
190%_addemacsenlist %{origname}
191
192%_emacsenPackageInstall %{origname}
193
194
195/sbin/install-info %{_infodir}/wl-ja.info.gz %{_infodir}/dir \
196        --section="Message User Agent"
197/sbin/install-info %{_infodir}/wl.info.gz %{_infodir}/dir \
198        --section="Message User Agent"
199
200
201%preun
202
203if [ "$1" = 0 ]; then
204
205%_emacsenPackageRemove %{origname}
206
207%_removeemacsenlist %{origname}
208
209/sbin/install-info --delete %{_infodir}/wl-ja.info.gz %{_infodir}/dir \
210        --section="Message User Agent"
211/sbin/install-info --delete %{_infodir}/wl.info.gz %{_infodir}/dir \
212        --section="Message User Agent"
213fi
214
215
216
217
218%clean
219[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
220
221
222%files
223%defattr(-,root,root)
224%doc BUGS* COPYING* ChangeLog*
225%doc INSTALL* NEWS* README*
226%doc doc etc samples tests
227
228%{_datadir}/emacs/site-lisp/%{origname}/
229#%{_libdir}/emacsen-common/packages/install/%{origname}
230#%{_libdir}/emacsen-common/packages/remove/%{origname}
231%{emacsen_pkgdir}/install/%{origname}
232%{emacsen_pkgdir}/remove/%{origname}
233
234%{_infodir}/wl*.info*
235
236 
237
238%changelog
239* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.14.0-3
240- fixed wl-init.el
241
242* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.14.0-2
243- added vine-default-wl.el
244- updated wl-install.sh for vine-default-wl.el
245
246* Sat Sep 06 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.0-1vl5
247- applied new versioning policy, spec in utf-8
248- added macro %%emacsen_pkgdir
249
250* Fri Dec  7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.0-0vl5
251- rebuild
252
253* Wed Jan 10 2007 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.14.0-0vl4
254- rebuild
255
256* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl3
257- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
258
259* Fri Sep 30 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.0-0vl2
260- added Patch1 (wl-news.elc was not generated with emacs22)
261
262* Fri Apr 15 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.0-0vl1
263- updated to new upstream release 2.14.0
264
265* Sun Dec 26 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.12.0-0vl1
266- updated to new upstream release 2.12.1
267
268* Mon Dec 13 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.12.0-0vl0.pre
269- updated to new release canditate 2.12.0pre
270
271* Wed Dec 24 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.1-0vl2
272- increased release number for the new flim/semi release
273
274* Tue Jul  8 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.10.1-0vl1
275- updated to new upstream release 2.10.1
276
277* Mon Jun 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl2
278- increased release number for the new apel release
279
280* Wed Dec 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl1
281- updated to new upstream release 2.10.0
282
283* Sat Dec 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl0.1
284- updated to new release canditate 2.10.0pre4
285
286* Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.1-0vl3
287- Obsoletes: wl-el now, instead of Conflicts:
288- added %%triggerpostun -- wl-el
289
290* Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.1-0vl2
291- added PreReq: w3m-el, for shimbun-guys will be happy :)
292
293* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.1-0vl1
294- updated to new upstream release
295
296* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl5
297- modified wl-install.sh to put pixmaps in a proper place even with emacs21
298
299* Sat Dec 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl4
300- modified wl-install.sh to put xemacs pixmaps in a proper place (AGAIN)
301
302* Fri Dec 07 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl3
303- spec file cleaned-up too much now
304
305* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl2
306- modified wl-install.sh to put xemacs pixmaps in a proper place
307
308* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl1
309- updated to 2.6.1 stable release
310- the changelog was incorrect. now merged from original Wanderlust spec file
311
312* Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org>
313- emacsenize
314
315* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
316- 2.6.0-0vl2
317- added patch to fix recursive load problem
318  (see wl:07309, wl:07812)
319
320* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
321- 2.6.0-0vl1
322- updated to 2.6.0 stable release
323
324* Wed Feb 14 2001 MATSUBAYASHI 'Shaolin' Kohji
325- 2.4.1-0vl1
326- updated to 2.4.1 stable release
327- merge emacs/xemacs package again into one source rpm :-)
328
329* Fri Dec 01 2000 MATSUBAYASHI 'Shaolin' Kohji
330- 2.4.0-0vl1
331- updated to 2.4.0 stable release
332
333* Thu Nov 23 2000 MATSUBAYASHI 'Shaolin' Kohji
334- 2.4.0-0.3vl1
335- updated to 2.4.0pre3 release canditate
336
337* Wed Nov 15 2000 MATSUBAYASHI 'Shaolin' Kohji
338- 2.4.0-0.2vl1
339- updated to 2.4.0pre2 release canditate
340
341* Sun Nov 12 2000 MATSUBAYASHI 'Shaolin' Kohji
342- 2.4.0-0.1vl1
343- updated to 2.4.0pre release canditate
344
345* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
346- 1.1.1-0vl3
347- modified %files section to handle compressed man page(s)
348
349* Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
350- 1.1.1-0vl2
351- included a patch to fix Maildir-related problem
352  (Thanks Teranishi-kun!)
353
354* Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
355- 1.1.1-0vl1
356- updated to 1.1.1 release
357
358* Mon Mar 27 2000 MATSUBAYASHI 'Shaolin' Kohji
359- 1.1.0-1vl2
360- added small patch by Mr. Yuuichi Teranishi himself :-)
361
362* Fri Mar 24 2000 MATSUBAYASHI 'Shaolin' Kohji
363- 1.1.0-1vl1
364- updated to 1.1.0 release
365- added a patch (see wl:04506)
366
367* Thu Mar 09 2000 MATSUBAYASHI 'Shaolin' Kohji
368- 1.1.0-0.3vl1
369- updated to 1.1.0pre3 release canditate
370
371* Fri Mar 03 2000 MATSUBAYASHI 'Shaolin' Kohji
372- 1.1.0-0.1vl1, 1.1.0-0.1vl2
373- updated to 1.1.0pre1 release canditate
374- added patches (see wl:04218, wl:04281)
375
376* Mon Feb 21 2000 MATSUBAYASHI 'Shaolin' Kohji
377- 2.2.18-1
378- updated to 2.2.18 beta release
379
380* Wed Jan 12 2000 MATSUBAYASHI 'Shaolin' Kohji
381- 2.2.15-1
382- updated to 2.2.15 beta release
383- included patches (see wl:03792, wl:03793)
384
385* Sat Jan 08 2000 MATSUBAYASHI 'Shaolin' Kohji
386- 2.2.14-1
387- updated to 2.2.14 beta release
388- included patches (see wl:03746, wl:03751)
389
390* Thu Jan 06 2000 MATSUBAYASHI 'Shaolin' Kohji
391- 2.2.13-2
392- included patches (see wl:03604, wl:03709, wl:03713, wl:03722)
393- fixed %install section to get wl be installed in proper directory
394
395* Tue Dec 28 1999 MATSUBAYASHI 'Shaolin' Kohji
396- 2.2.13-1
397- updated to 2.2.13 beta release
398- now utils are also installed
399- included a patch (see wl:03684)
400
401* Tue Dec 21 1999 MATSUBAYASHI 'Shaolin' Kohji
402- 2.2.12-3
403- included patches (see wl:03595, wl:03620, wl:03637, wl:03651)
404
405* Tue Dec  7 1999 MATSUBAYASHI 'Shaolin' Kohji
406- 2.2.12-2
407- updated to 2.2.12 beta release
408- included paches (see wl:03357, wl:03564)
409
410* Mon Dec  6 1999 MATSUBAYASHI 'Shaolin' Kohji
411- 2.2.11-1
412- updated to 2.2.11 beta release
413- included patches (see wl:03526, wl:03528)
414
415* Sat Dec  4 1999 MATSUBAYASHI 'Shaolin' Kohji
416- 2.2.10-2
417- included patches (see wl:03489, wl:03491)
418
419* Fri Dec  3 1999 MATSUBAYASHI 'Shaolin' Kohji
420- 2.2.10-1
421- udpated to 2.2.10 beta release
422- included patches (see wl:03480, wl:03484)
423
424* Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji
425- 2.2.8-1
426- udpated to 2.2.8 beta release for semi-1.13.7
427- included patches (see wl:03171, wl:03182)
428
429* Sat Nov 27 1999 MATSUBAYASHI 'Shaolin' Kohji
430- 1.0.3-4
431- Obsolete: Wanderlust-mule added
432- %post and %preun section modified
433
434* Fri Oct 29 1999 MATSUBAYASHI 'Shaolin' Kohji
435- 1.0.3-3
436- %post and %preun section added for install-info
437
438* Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji
439- 1.0.3-2
440- package name changed from Wanderlust-emacs to Wanderlust
441
442* Wed Sep 15 1999 MATSUBAYASHI 'Shaolin' Kohji
443- 1.0.3-1
444- first release for FSF Emacs 20.4
445
Note: See TracBrowser for help on using the repository browser.