source: projects/specs/trunk/w/wl/wl-vl.spec @ 2750

Revision 2750, 13.4 KB checked in by munepi, 13 years ago (diff)

updated emacs, emacs24, wl, yatex, auctex, IIIMECF; added wl-beta; supported new vine-default

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4## To build wl-2.14.0, we use emacs-23.X
5%define __emacs %(rpm -q --queryformat "%%{name}-%%{version}" emacs | grep "emacs-23")
6
7
8%define       origname      wl
9%define       origver       2.14.0
10# if the package is not prerelease, set %%{prever} to %{nil}
11%define       prever        %{nill}
12%define       emacsen_pkgdir /usr/lib/emacsen-common/packages
13
14Summary:      IMAP-capable mail/news reader for emacsen
15Summary(ja):  (X)Emacs 用IMAP に対応したメール/ニュースリーダ
16Name:         %{origname}
17Version:      %{origver}
18Release:      4%{?_dist_release}
19
20Source0:      ftp://ftp.gohome.org/%{origname}/stable/%{origname}-%{origver}.tar.gz
21Source1:      %{origname}-install.sh
22Source2:      %{origname}-remove.sh
23Source3:      %{origname}-init.el
24Source4:      vine-default-%{origname}.el
25
26Patch1:       wl-2.14.0-wl-news.patch
27
28Patch10:      wl-2.8.1-texi-ja.diff
29Patch11:      wl-2.8.1-install-utils.diff
30
31
32License:      GPLv2
33Group:        Applications/Editors/Emacs
34BuildRoot:    %{_tmppath}/%{name}-%{version}-root
35BuildArch:    noarch
36
37
38Obsoletes:     wl-el, Wanderlust, Wanderlust-xemacs
39Requires(post): emacsen
40%prereq_ge     emacsen-common
41%prereq_ge     semi
42%prereq_ge     w3m-el
43BuildRequires: emacsen-common, semi, w3m-el
44
45
46Vendor:       Project Vine
47Distribution: Vine Linux
48Packager:     shaolin, munepi
49
50
51%description
52Wanderlust is a mail/news reader supporting IMAP for emacsen.
53Overall impression resembles to Mew, but Wanderlust have nifty
54features like IMAP support, threading display, and so on.
55
56#(eigo wakannai)
57#After installation, you must modify your ~/.emacs file to contain
58#at least:
59#
60#    (load "mime-setup")
61#
62#    (autoload 'wl "wl" "Wanderlust t)
63#    (autoload 'wl-draft "wl" "Write draft with Wanderlust." t)
64
65Other detailed information can be available at:
66
67  http://www.gohome.org/wl/index-e.html
68  (sorry, much detailed info is currently available only in Japanese)
69
70
71If you install both wl and wl-beta packages on your system,
72you may add the following configure in your emacs init file
73%if %{?_dist_release} == "vl5"
74~/.emacs.el:
75%else
76~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
77%endif
78
79;; I use wl.
80(setq vine-default-wl-beta nil)
81
82
83%description -l ja
84Wanderlust は、elisp のみで実装された IMAP 対応のメール/ニュースリーダです。
85使用感は Mew に近く、加えてスレッド表示や未読管理などにも対応しています。
86
87主な特徴(Wanderlust web ページより抜粋)
88
89  - elisp のみによる実装
90  - IMAPrev1, NNTP, POP, MH 形式のサポート
91  - Mew っぽい Folder Specification に基づくメッセージへの
92    統一的アクセス
93  - Mew っぽいキーバインドとマーク処理
94  - インタラクティブなスレッド表示
95  - 未読管理
96  - 購読フォルダの一覧を表示するフォルダモード
97  - メッセージキャッシュ、オフライン処理 (IMAP4)
98  - MIME 対応 (by SEMI or tm)
99
100#インストール後、~/.emacs に最低でも以下の記述を追加して下さい:
101#
102#    (load "mime-setup")
103#
104#    (autoload 'wl "wl" "Wanderlust t)
105#    (autoload 'wl-draft "wl" "Write draft with Wanderlust." t)
106
107# Emacs/XEmacs 起動時に以下の設定ファイルを読み込みます。
108# M-x wl で起動します。
109
110# /etc/emacs-??.?/site-start.d/55wl-init.el
111# /etc/xemacs-??.?.??/site-start.d/55wl-init.el
112
113アカウント毎の設定は、
114%{_defaultdocdir}/%{name}-%{origver}/samples/ja/dot.wl
115%{_defaultdocdir}/%{name}-%{origver}/samples/ja/dot.folders
116%{_defaultdocdir}/%{name}-%{origver}/samples/ja/dot.addresses
117をベースに、
118~/.wl
119~/.folders
120~/.address
121を作成下さい。
122
123
124詳しくは、Wanderlust の web ページ
125
126  http://www.gohome.org/wl/
127
128を見て下さい。
129
130
131wl と wl-beta パッケージの両方をインストールする場合、
132%if %{?_dist_release} == "vl5"
133~/.emacs.el:
134%else
135~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
136%endif
137に以下の設定を追加するとよいでしょう。
138
139;; wl を使う
140(setq vine-default-wl-beta nil)
141
142
143%prep
144## we use emacs-23.X to build wl-2.14.0
145[ -z "%__emacs" ] && exit 1
146
147%__rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
148%setup -q -n %{origname}-%{origver}
149
150%patch1 -p1
151
152#%patch10 -p1
153%patch11 -p1
154
155touch doc/*.texi
156
157
158%install
159
160[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
161[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
162
163%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}/etc
164#%__mkdir_p ${RPM_BUILD_ROOT}%{_libdir}/emacsen-common/packages/install
165#%__mkdir_p ${RPM_BUILD_ROOT}%{_libdir}/emacsen-common/packages/remove
166%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
167%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
168%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
169
170
171#
172# install el files
173#
174
175%__cp -a WL-* Makefile wl %{SOURCE3} %{SOURCE4} \
176        ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
177%__cp -a utils elmo \
178        ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
179%__cp -a etc/icons \
180        ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}/etc/.
181
182# 2004.12.13 add Irokawa
183%__cp -a NEWS* \
184        ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
185
186
187
188#
189# build & install info
190#
191
192yes | %__sed -e "s/y/\n/g" | %__make EMACS=%__emacs info
193%__make EMACS=%__emacs INFODIR=${RPM_BUILD_ROOT}%{_infodir} install-info
194
195
196#
197# install script( bytecompile el and install elc , remove )   
198#
199
200%_installemacsenscript %{origname} %{SOURCE1}
201
202%_removeemacsenscript  %{origname} %{SOURCE2}
203
204
205
206%post
207
208#
209# bytecompile and install
210#
211
212if [ "$1" = 2 ]; then
213
214%_emacsenPackageRemove %{origname}
215
216fi
217
218%_addemacsenlist %{origname}
219
220%_emacsenPackageInstall %{origname}
221
222
223/sbin/install-info %{_infodir}/wl-ja.info.gz %{_infodir}/dir \
224        --section="Message User Agent"
225/sbin/install-info %{_infodir}/wl.info.gz %{_infodir}/dir \
226        --section="Message User Agent"
227
228
229%preun
230
231if [ "$1" = 0 ]; then
232
233%_emacsenPackageRemove %{origname}
234
235%_removeemacsenlist %{origname}
236
237/sbin/install-info --delete %{_infodir}/wl-ja.info.gz %{_infodir}/dir \
238        --section="Message User Agent"
239/sbin/install-info --delete %{_infodir}/wl.info.gz %{_infodir}/dir \
240        --section="Message User Agent"
241fi
242
243
244
245
246%clean
247[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
248
249
250%files
251%defattr(-,root,root)
252%doc BUGS* COPYING* ChangeLog*
253%doc INSTALL* NEWS* README*
254%doc doc etc samples tests
255
256%{_datadir}/emacs/site-lisp/%{origname}/
257#%{_libdir}/emacsen-common/packages/install/%{origname}
258#%{_libdir}/emacsen-common/packages/remove/%{origname}
259%{emacsen_pkgdir}/install/%{origname}
260%{emacsen_pkgdir}/remove/%{origname}
261
262%{_infodir}/wl*.info*
263
264 
265
266%changelog
267* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.14.0-4
268- defined %%__emacs
269  - use emacs-23.X to build wl-2.14.0
270- updated wl-init.el
271  - output "Loading vine-default-wl ..." to the buffer *Messages*
272- changed from PreReq: emacsen to Requires(post): emacsen
273
274* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.14.0-3
275- fixed wl-init.el
276
277* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.14.0-2
278- added vine-default-wl.el
279- updated wl-install.sh for vine-default-wl.el
280
281* Sat Sep 06 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.0-1vl5
282- applied new versioning policy, spec in utf-8
283- added macro %%emacsen_pkgdir
284
285* Fri Dec  7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.0-0vl5
286- rebuild
287
288* Wed Jan 10 2007 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.14.0-0vl4
289- rebuild
290
291* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl3
292- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
293
294* Fri Sep 30 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.0-0vl2
295- added Patch1 (wl-news.elc was not generated with emacs22)
296
297* Fri Apr 15 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.0-0vl1
298- updated to new upstream release 2.14.0
299
300* Sun Dec 26 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.12.0-0vl1
301- updated to new upstream release 2.12.1
302
303* Mon Dec 13 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.12.0-0vl0.pre
304- updated to new release canditate 2.12.0pre
305
306* Wed Dec 24 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.1-0vl2
307- increased release number for the new flim/semi release
308
309* Tue Jul  8 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.10.1-0vl1
310- updated to new upstream release 2.10.1
311
312* Mon Jun 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl2
313- increased release number for the new apel release
314
315* Wed Dec 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl1
316- updated to new upstream release 2.10.0
317
318* Sat Dec 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl0.1
319- updated to new release canditate 2.10.0pre4
320
321* Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.1-0vl3
322- Obsoletes: wl-el now, instead of Conflicts:
323- added %%triggerpostun -- wl-el
324
325* Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.1-0vl2
326- added PreReq: w3m-el, for shimbun-guys will be happy :)
327
328* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.1-0vl1
329- updated to new upstream release
330
331* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl5
332- modified wl-install.sh to put pixmaps in a proper place even with emacs21
333
334* Sat Dec 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl4
335- modified wl-install.sh to put xemacs pixmaps in a proper place (AGAIN)
336
337* Fri Dec 07 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl3
338- spec file cleaned-up too much now
339
340* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl2
341- modified wl-install.sh to put xemacs pixmaps in a proper place
342
343* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl1
344- updated to 2.6.1 stable release
345- the changelog was incorrect. now merged from original Wanderlust spec file
346
347* Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org>
348- emacsenize
349
350* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
351- 2.6.0-0vl2
352- added patch to fix recursive load problem
353  (see wl:07309, wl:07812)
354
355* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
356- 2.6.0-0vl1
357- updated to 2.6.0 stable release
358
359* Wed Feb 14 2001 MATSUBAYASHI 'Shaolin' Kohji
360- 2.4.1-0vl1
361- updated to 2.4.1 stable release
362- merge emacs/xemacs package again into one source rpm :-)
363
364* Fri Dec 01 2000 MATSUBAYASHI 'Shaolin' Kohji
365- 2.4.0-0vl1
366- updated to 2.4.0 stable release
367
368* Thu Nov 23 2000 MATSUBAYASHI 'Shaolin' Kohji
369- 2.4.0-0.3vl1
370- updated to 2.4.0pre3 release canditate
371
372* Wed Nov 15 2000 MATSUBAYASHI 'Shaolin' Kohji
373- 2.4.0-0.2vl1
374- updated to 2.4.0pre2 release canditate
375
376* Sun Nov 12 2000 MATSUBAYASHI 'Shaolin' Kohji
377- 2.4.0-0.1vl1
378- updated to 2.4.0pre release canditate
379
380* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
381- 1.1.1-0vl3
382- modified %files section to handle compressed man page(s)
383
384* Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
385- 1.1.1-0vl2
386- included a patch to fix Maildir-related problem
387  (Thanks Teranishi-kun!)
388
389* Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
390- 1.1.1-0vl1
391- updated to 1.1.1 release
392
393* Mon Mar 27 2000 MATSUBAYASHI 'Shaolin' Kohji
394- 1.1.0-1vl2
395- added small patch by Mr. Yuuichi Teranishi himself :-)
396
397* Fri Mar 24 2000 MATSUBAYASHI 'Shaolin' Kohji
398- 1.1.0-1vl1
399- updated to 1.1.0 release
400- added a patch (see wl:04506)
401
402* Thu Mar 09 2000 MATSUBAYASHI 'Shaolin' Kohji
403- 1.1.0-0.3vl1
404- updated to 1.1.0pre3 release canditate
405
406* Fri Mar 03 2000 MATSUBAYASHI 'Shaolin' Kohji
407- 1.1.0-0.1vl1, 1.1.0-0.1vl2
408- updated to 1.1.0pre1 release canditate
409- added patches (see wl:04218, wl:04281)
410
411* Mon Feb 21 2000 MATSUBAYASHI 'Shaolin' Kohji
412- 2.2.18-1
413- updated to 2.2.18 beta release
414
415* Wed Jan 12 2000 MATSUBAYASHI 'Shaolin' Kohji
416- 2.2.15-1
417- updated to 2.2.15 beta release
418- included patches (see wl:03792, wl:03793)
419
420* Sat Jan 08 2000 MATSUBAYASHI 'Shaolin' Kohji
421- 2.2.14-1
422- updated to 2.2.14 beta release
423- included patches (see wl:03746, wl:03751)
424
425* Thu Jan 06 2000 MATSUBAYASHI 'Shaolin' Kohji
426- 2.2.13-2
427- included patches (see wl:03604, wl:03709, wl:03713, wl:03722)
428- fixed %install section to get wl be installed in proper directory
429
430* Tue Dec 28 1999 MATSUBAYASHI 'Shaolin' Kohji
431- 2.2.13-1
432- updated to 2.2.13 beta release
433- now utils are also installed
434- included a patch (see wl:03684)
435
436* Tue Dec 21 1999 MATSUBAYASHI 'Shaolin' Kohji
437- 2.2.12-3
438- included patches (see wl:03595, wl:03620, wl:03637, wl:03651)
439
440* Tue Dec  7 1999 MATSUBAYASHI 'Shaolin' Kohji
441- 2.2.12-2
442- updated to 2.2.12 beta release
443- included paches (see wl:03357, wl:03564)
444
445* Mon Dec  6 1999 MATSUBAYASHI 'Shaolin' Kohji
446- 2.2.11-1
447- updated to 2.2.11 beta release
448- included patches (see wl:03526, wl:03528)
449
450* Sat Dec  4 1999 MATSUBAYASHI 'Shaolin' Kohji
451- 2.2.10-2
452- included patches (see wl:03489, wl:03491)
453
454* Fri Dec  3 1999 MATSUBAYASHI 'Shaolin' Kohji
455- 2.2.10-1
456- udpated to 2.2.10 beta release
457- included patches (see wl:03480, wl:03484)
458
459* Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji
460- 2.2.8-1
461- udpated to 2.2.8 beta release for semi-1.13.7
462- included patches (see wl:03171, wl:03182)
463
464* Sat Nov 27 1999 MATSUBAYASHI 'Shaolin' Kohji
465- 1.0.3-4
466- Obsolete: Wanderlust-mule added
467- %post and %preun section modified
468
469* Fri Oct 29 1999 MATSUBAYASHI 'Shaolin' Kohji
470- 1.0.3-3
471- %post and %preun section added for install-info
472
473* Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji
474- 1.0.3-2
475- package name changed from Wanderlust-emacs to Wanderlust
476
477* Wed Sep 15 1999 MATSUBAYASHI 'Shaolin' Kohji
478- 1.0.3-1
479- first release for FSF Emacs 20.4
480
Note: See TracBrowser for help on using the repository browser.