source: projects/specs/trunk/w/wl-beta/wl-beta-vl.spec @ 5852

Revision 5852, 5.1 KB checked in by munepi, 12 years ago (diff)

updated wl-beta-vl.spec

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4%define pkgname wl
5%define cvsdate 20120304
6
7Summary:      IMAP-capable mail/news reader for emacsen (development version)
8Summary(ja):  Emacsen 用 IMAP に対応したメール/ニュースリーダ(開発版)
9Name:         wl-beta
10Version:      2.15.9
11Release:      4%{?cvsdate:.cvs%cvsdate}%{?_dist_release}
12License:      GPLv2
13Group:        Applications/Editors/Emacs
14Source0:      %{pkgname}-%{version}%{?cvsdate:.cvs%cvsdate}.tar.xz
15Source1:      %{name}-install.sh
16Source2:      %{name}-remove.sh
17Source3:      %{name}-init.el
18Source4:      vine-default-%{name}.el
19# Script used to create the %{pkgname}-%{version}.cvs%{cvsdate}.tar.xz
20# archive from Wanderlust CVS
21Source10:     wl-snapshot.sh
22
23Patch1:       wl-2.14.0-wl-news.patch
24
25#Patch10:      wl-2.8.1-texi-ja.diff
26Patch11:      wl-2.8.1-install-utils.diff
27
28Patch50:      wl-2.15.9-wl-beta.patch
29
30BuildRoot:    %{_tmppath}/%{name}-%{version}-root
31BuildArch:    noarch
32
33Requires(post): emacsen
34%prereq_ge     emacsen-common
35%prereq_ge     semi
36%prereq_ge     w3m-el
37BuildRequires: emacsen-common, semi, w3m-el
38
39Vendor:       Project Vine
40Distribution: Vine Linux
41Packager:     munepi
42
43
44%description
45Wanderlust is a mail/news management system with IMAP4rev1 support for Emacs.
46Overall impression resembles to Mew, but Wanderlust have nifty
47features like IMAP support, threading display, and so on.
48
49This is a development version of Wanderlust.
50
51If you install both wl and wl-beta packages on your system,
52you may add the following configure in your emacs init file
53%if %{?_dist_release} == "vl5"
54~/.emacs.el:
55%else
56~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
57%endif
58
59;; I use wl-beta.
60(setq vine-default-wl nil)
61
62
63%description -l ja
64Wanderlust は、elisp のみで実装された IMAPrev1 対応の
65メール/ニュースリーダです。
66使用感は Mew に近く、加えてスレッド表示や未読管理などにも対応しています。
67
68これは Wanderlust の開発バージョンです。
69
70wl と wl-beta パッケージの両方をインストールする場合、
71%if %{?_dist_release} == "vl5"
72~/.emacs.el:
73%else
74~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
75%endif
76に以下の設定を追加するとよいでしょう。
77
78;; wl-beta を使う
79(setq vine-default-wl nil)
80
81
82%prep
83%__rm -rf ${RPM_BUILD_DIR}/%{pkgname}-%{version}
84
85%setup -q -n %{pkgname}-%{version}
86
87%patch1 -p1
88
89#%patch10 -p1
90%patch11 -p1
91
92%patch50 -p1 -b .vine
93
94touch doc/*.texi
95
96
97%install
98
99[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
100[ "${RPM_BUILD_ROOT}" != "/" ] && %__mkdir_p ${RPM_BUILD_ROOT}
101
102%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}/etc
103%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
104%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
105%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
106
107
108#
109# install el files
110#
111
112%__cp -a WL-* Makefile wl %{SOURCE3} %{SOURCE4} \
113        ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
114%__cp -a utils elmo \
115        ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
116%__cp -a etc/icons \
117        ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}/etc/.
118%__cp -a NEWS* \
119        ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
120
121
122#
123# build & install info
124#
125
126# %__make EMACS=emacs info
127# %__make EMACS=emacs INFODIR=${RPM_BUILD_ROOT}%{_infodir} install-info
128
129
130#
131# install script( bytecompile el and install elc , remove )   
132#
133
134%_installemacsenscript %{name} %{SOURCE1}
135
136%_removeemacsenscript  %{name} %{SOURCE2}
137
138
139
140%post
141
142#
143# bytecompile and install
144#
145
146if [ "$1" = 2 ]; then
147
148%_emacsenPackageRemove %{name}
149
150fi
151
152%_addemacsenlist %{name}
153
154%_emacsenPackageInstall %{name}
155
156
157# /sbin/install-info %{_infodir}/wl-ja.info.gz %{_infodir}/dir \
158#       --section="Message User Agent"
159# /sbin/install-info %{_infodir}/wl.info.gz %{_infodir}/dir \
160#       --section="Message User Agent"
161
162
163%preun
164
165if [ "$1" = 0 ]; then
166
167%_emacsenPackageRemove %{name}
168
169%_removeemacsenlist %{name}
170
171# /sbin/install-info --delete %{_infodir}/wl-ja.info.gz %{_infodir}/dir \
172#       --section="Message User Agent"
173# /sbin/install-info --delete %{_infodir}/wl.info.gz %{_infodir}/dir \
174#       --section="Message User Agent"
175fi
176
177
178
179
180%clean
181[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
182
183
184%files
185%defattr(-,root,root)
186%doc BUGS* COPYING* ChangeLog*
187%doc INSTALL* NEWS* README*
188%doc doc etc samples tests
189%{_datadir}/emacs/site-lisp/%{name}/
190%{emacsen_pkgdir}/install/%{name}
191%{emacsen_pkgdir}/remove/%{name}
192#%{_infodir}/wl*.info*
193
194 
195
196%changelog
197* Sun Mar  4 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.15.9-4.cvs20120304
198- source snapshot 20120304
199
200* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.15.9-3.cvs20111201
201- source snapshot 20111201
202
203* Tue May 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.15.9-3.cvs20110524
204- source snapshot 20110524
205
206* Thu Apr 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.15.9-2.cvs20110414
207- source snapshot 20110414
208
209* Sun Feb 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.15.9-1.cvs20110220
210- initial build based on wl-2.14.0-3vl6
Note: See TracBrowser for help on using the repository browser.