source: projects/specs/trunk/w/wireshark/wireshark-vl.spec @ 9611

Revision 9611, 15.3 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary:        Network traffic analyzer
4Summary(ja):    ネットワークトラフィック解析プログラム
5Name:           wireshark
6Version:        1.12.6
7Release:        1%{_dist_release}
8License:        GPLv2
9Group:          Applications/System
10Source0:        http://www.wireshark.org/download/src/%{name}-%{version}.tar.bz2
11Source1:        wireshark.pam
12Source2:        wireshark.console
13Source3:        wireshark.desktop
14Patch4:         wireshark-0.99.7-path.patch
15Patch5:         wireshark-1.10.0-lua-vine.patch
16URL:            http://www.wireshark.org/
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires:  libcap-devel
21BuildRequires:  net-snmp-devel >= 5.0
22BuildRequires:  net-snmp-utils >= 5.0
23BuildRequires:  zlib-devel, bzip2-devel
24BuildRequires:  openssl-devel
25BuildRequires:  glib2-devel, gtk2-devel
26BuildRequires:  libelf-devel
27BuildRequires:  python, pcre-devel
28BuildRequires:  gnutls-devel
29BuildRequires:  desktop-file-utils, automake, libtool
30BuildRequires:  bison, flex
31BuildRequires:  krb5-devel
32BuildRequires:  libpcap-devel
33BuildRequires:  lua-devel
34
35Requires:       usermode >= 1.37
36Requires(post): desktop-file-utils
37Requires(postun): desktop-file-utils
38
39Obsoletes:      ethereal
40Obsoletes:      ethereal-base ethereal-gnome ethereal-gtk+
41Obsoletes:      ethereal-kde ethereal-usermode
42Provides:       ethereal ethereal-gnome
43
44Vendor:         Project Vine
45Distribution:   Vine Linux
46Packager: inagaki, Takemikaduchi
47
48%description
49Wireshark is a network traffic analyzer for Unix-ish operating systems.
50
51This package lays base for libpcap, a packet capture and filtering
52library, contains command-line utilities, contains plugins and
53documentation for wireshark. A graphical user interface is also
54included with this package.
55
56%description -l ja
57Wireshark は,UNIX 系 OS 用のネットワークトラフィック解析プログラムです.
58
59このパッケージは,パケットキャプチャ/フィルタリングライブラリである
60libpcap を使ったコマンドラインツールと,プラグイン,ドキュメント等が
61収められています.GUI もこのパッケージに収められています.
62
63%prep
64%setup -q -n %{name}-%{version}
65%patch4 -p1
66%patch5 -p1 -b .lua-vine
67
68%build
69%ifarch s390 s390x
70export PIECFLAGS="-fPIE"
71%else
72export PIECFLAGS="-fpie"
73%endif
74# FC5+ automatic -fstack-protector-all switch
75export RPM_OPT_FLAGS=${RPM_OPT_FLAGS//-fstack-protector/-fstack-protector-all}
76## export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcap -I%{_includedir}/pcre"
77export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcre"
78export CXXFLAGS="$RPM_OPT_FLAGS $CPPFLAGS"
79export LDFLAGS="$LDFLAGS -lm -lcrypto"
80export PATH="$PATH:/usr/kerberos/bin"
81./autogen.sh
82# --disable-warning-as-erros needs for compiling with glib 2.14.0
83%configure \
84   --bindir=%{_sbindir} \
85   --enable-ipv6 \
86   --with-gnu-ld \
87   --disable-static \
88   --disable-usr-local \
89   --enable-wireshark \
90   --with-pic \
91   --with-ssl \
92   --with-pcap \
93   --with-pcre \
94%if %{?_dist_release} != "vl4"
95   --with-krb5 \
96%else
97   --without-krb5 \
98%endif
99   --with-plugins=%{_libdir}/%{name}/plugins/%{version} \
100   --disable-warnings-as-errors \
101   --without-qt \
102   --with-gtk2=yes \
103   --with-gtk3=no
104time make %{?_smp_mflags}
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109# The evil plugins hack
110perl -pi -e 's|-L../../epan|-L../../epan/.libs|' plugins/*/*.la
111
112make DESTDIR=$RPM_BUILD_ROOT install
113
114#symlink tshark to tethereal
115ln -s tshark $RPM_BUILD_ROOT%{_sbindir}/tethereal
116
117#empty?!
118rm -f $RPM_BUILD_ROOT%{_sbindir}/idl2wrs
119
120# install support files for usermode, gnome and kde
121mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d
122install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/wireshark
123mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps
124install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps/wireshark
125mkdir -p $RPM_BUILD_ROOT/%{_bindir}
126ln -s consolehelper $RPM_BUILD_ROOT/%{_bindir}/wireshark
127
128# install man
129## mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
130## install -m 644 *.1 $RPM_BUILD_ROOT/%{_mandir}/man1
131
132# Install python stuff.
133mkdir -p $RPM_BUILD_ROOT%{python_sitelib}
134install -m 644 tools/wireshark_be.py tools/wireshark_gen.py  $RPM_BUILD_ROOT%{python_sitelib}
135
136desktop-file-install --vendor=                             \
137        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications    \
138        %{SOURCE3}
139
140mkdir -p $RPM_BUILD_ROOT/%{_datadir}/pixmaps
141install -m 644 image/wsicon48.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps/wireshark.png
142
143
144# Remove .la files
145rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}/plugins/%{version}/*.la
146
147# Remove .la files in libdir
148rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%post
154/sbin/ldconfig
155update-desktop-database -q
156
157%postun
158/sbin/ldconfig
159update-desktop-database -q
160
161%files
162%defattr(-,root,root)
163%doc AUTHORS COPYING ChangeLog INSTALL NEWS README*
164%{_sbindir}/editcap
165%{_sbindir}/tshark
166%{_sbindir}/mergecap
167%{_sbindir}/text2pcap
168%{_sbindir}/dftest
169%{_sbindir}/capinfos
170%{_sbindir}/captype
171%{_sbindir}/randpkt
172%{_sbindir}/dumpcap
173%{_sbindir}/tethereal
174%{_sbindir}/rawshark
175%{_sbindir}/reordercap
176%{python_sitelib}/*
177%{_libdir}/lib*
178%{_mandir}/man1/editcap.*
179%{_mandir}/man1/tshark.*
180%{_mandir}/man1/mergecap.*
181%{_mandir}/man1/text2pcap.*
182%{_mandir}/man1/capinfos.*
183%{_mandir}/man1/dumpcap.*
184%{_mandir}/man1/reordercap.*
185%{_mandir}/man4/wireshark-filter.*
186%{_libdir}/wireshark
187%config(noreplace) %{_sysconfdir}/pam.d/wireshark
188%config(noreplace) %{_sysconfdir}/security/console.apps/wireshark
189
190%config(noreplace) %{_datadir}/%{name}/init.lua
191%{_datadir}/%{name}/AUTHORS-SHORT
192%{_datadir}/%{name}/COPYING
193%{_datadir}/%{name}/*.html
194%{_datadir}/%{name}/*.css
195%{_datadir}/%{name}/cfilters
196%{_datadir}/%{name}/colorfilters
197%{_datadir}/%{name}/console.lua
198%{_datadir}/%{name}/dfilters
199%{_datadir}/%{name}/diameter
200%{_datadir}/%{name}/dtd_gen.lua
201%{_datadir}/%{name}/dtds
202%{_datadir}/%{name}/help
203%{_datadir}/%{name}/manuf
204%{_datadir}/%{name}/pdml2html.xsl
205%{_datadir}/%{name}/profiles
206%{_datadir}/%{name}/radius
207%{_datadir}/%{name}/services
208%{_datadir}/%{name}/smi_modules
209%{_datadir}/%{name}/tpncp
210%{_datadir}/%{name}/wimaxasncp
211
212%{_datadir}/applications/*.desktop
213%{_datadir}/pixmaps/wireshark.png
214%{_bindir}/wireshark
215%{_sbindir}/wireshark
216%{_mandir}/man1/wireshark.*
217%{_mandir}/man1/rawshark.*
218%{_mandir}/man1/dftest.*
219%{_mandir}/man1/randpkt.*
220
221
222%changelog
223* Thu Jun 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
224- new upstream release
225
226* Wed May 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.5-1
227- new upstream release
228  (including security fix for CVE-2015-3808,3809,3810,3811,3812,3813,3814,3815)
229
230* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
231- new upstream release
232  (including security fix for CVE-2015-2187,2188,2189,2190,2191,2192)
233
234* Sat Jan 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.3-1
235- new upstream release
236  (including security fix for CVE-2015-0559,0560,0561,0562,0563,0564)
237
238* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
239- new upstream release
240  (including security fix for CVE-2014-8710,8711,8712,8713,8714)
241
242* Tue Sep 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
243- new upstream release
244
245* Thu Aug 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
246- new upstream release
247
248* Fri Jun 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
249- new upstream release
250  (including security fix for CVE-2014-4020)
251
252* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
253- new upstream release
254  (including security fix for CVE-2014-2907)
255
256* Sat Mar 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
257- new upstream release
258  (including security fix for CVE-2014-2281,2282,2283,2299)
259
260* Sun Dec 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.5-1
261- new upstream release
262
263* Tue Nov 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.3-1
264- new upstream release
265  (including security fix for CVE-2013-6336,6337,6338,6339,6340)
266
267* Mon Sep 16 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
268- new upstream release
269
270* Sun Jul 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
271- new upstream release
272  (including security fix for CVE-2013-4083,4920,4921,4922,4923,4924,4925,4926,4927,4929,4930,4931,4932,4944,4934,4935,4936)
273
274* Sat Jun 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
275- new upstream release
276- update Patch5 (wireshark-1.10.0-lua-vine.patch)
277- remove Patch3 (wireshark-nfsv4-opts.patch)
278
279* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.7-1
280- new upstream release
281  (including security fix for CVE-2013-2486 - 2487)
282
283* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.6-1
284- new upstream release
285  (including security fix for CVE-2013-2475 - 2488)
286
287* Wed Jan 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.5-1
288- new upstream release
289
290* Tue Jan 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
291- new upstream release
292
293* Wed Oct 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-1
294- new upstream release
295  (including security fix for CVE-2012-5237 - 5240)
296
297* Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
298- new upstream release
299  (including security fix for CVE-2012-4285 - 4298)
300
301* Tue Jul 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
302- new upstream release
303
304* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
305- new upstream release
306
307* Wed May 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
308- new upstream release
309
310* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.7-1
311- new upstream release
312
313* Thu Jan 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.5-1
314- new upstream release
315
316* Tue Nov 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
317- new upstream release
318
319* Sat Nov 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
320- new upstream release
321
322* Thu Sep 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
323- new upstream release
324
325* Sun Jul 31 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
326- new upstream release
327
328* Sun Jun 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-1
329- new upstream release
330  (including security fix for CVE-2011-1957,1958,1959,2174,7175)
331
332* Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
333- new upstream release
334
335* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-2
336- rebuild with krb5-libs-1.8.2
337
338* Wed Mar 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
339- new upstream release
340  (including security fix for CVE-2011-0538 and CVE-2011-0713)
341
342* Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
343- new upstream release
344  (including security fix for CVE-2010-4538)
345
346* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-2
347- rebuild with openssl-1.0.0c
348
349* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
350- new upstream release
351
352* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
353- new upstream release
354  (including security fix for CVE-2010-3445)
355
356* Sun Sep 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
357- new upstream release
358- add Patch5 (wireshark-1.4.0-lua-vine.patch)
359
360* Mon Aug 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
361- new upstream release
362  (including security fix for CVE-2010-2287 and CVE-2010-2284)
363
364* Wed Jul 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.9-1
365- new upstream release
366
367* Tue May 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.8-2
368- rebuilt with libpcap-1.1.1
369
370* Sat May 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
371- new upstream release
372  (including security fix for CVE-2010-1455)
373
374* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
375- new upstream release
376
377* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.5-3
378- rebuilt with python-2.6.4
379
380* Sun Dec 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-2
381- added --enable-wireshark instead of --enable-gtk2
382- added BR: bison, flex
383
384* Sat Dec 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.5-1
385- new upstream release with security fixes (SNA/SMB/IPMI issues)
386
387* Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
388- new upstream release
389  (includeing security fix for CVE-2009-3549,3550 and 3551)
390
391* Wed Sep 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-2
392- add BR: lua-devel (Vine 5.0 and later)
393
394* Sat Sep 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-1
395- new upstream release
396
397* Tue Jul 21 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
398- new upstream release
399
400* Mon Jul 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-1
401- new upstream release
402
403* Sat May 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.8-1
404- new upstream release
405
406* Fri Apr 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-1
407- new upstream release
408
409* Mon Feb  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.6-1
410- new upstream release
411- used more macros
412
413* Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-1
414- new upstream release
415
416* Sun Nov 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-2vl5
417- rebuilt
418
419* Mon Oct 27 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-1
420- new upstream release with security fix
421- add BuildRequires krb5-devel
422- SPEC in UTF-8
423
424* Fri Sep 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.3-1
425- new upstream release with security update
426
427* Wed Apr 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0-1
428- new upstream release with security update
429- add Vendor/Distribution tag
430- add BuildRequires: libcap-devel
431- new versioning policy
432
433* Tue Jan  8 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.99.7-0vl2
434- modified Source3 because of desktop-file-install error, like this:
435    /var/tmp/wireshark-0.99.7-root/usr/share/applications/wireshark.desktop:
436    error: value "wireshark.png" for key "Icon" in group "Desktop Entry" is
437    an icon name with an extension, but there should be no extension as
438    described in the Icon Theme Specification if the value is not an
439    absolute path
440  this warning/error occurs with desktop-file-utils >= 0.14
441
442* Wed Jan 2 2008 Satoshi MACHINO <machino@vinelinux.org> 0.99.7-0vl1
443- new upstream release
444- imported patch4 from fc9
445
446* Sun Sep  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl2
447- rebuilt with libpcap-0.9.7
448- added --disable-warning-as-errors to %%configure for glib-2.14.0
449
450* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl1
451- new upstream release
452- rebuilt with libpcap-0.9.6
453- added --with-pcap, --with-pcre
454
455* Fri Jun  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl2
456- rebuilt with new toolchain and environment
457
458* Thu Feb  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl1
459- new upstream release
460
461* Mon Nov 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.4-0vl1
462- new upstream release
463
464* Wed Oct  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.3-0vl1
465- initial built for Vine Linux based on Fedora
466- Obsoletes: ethereal, Provides: ethereal
467
468* Fri Aug 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.3-fc5.1
469- upgrade to 0.99.3-1
470- CVE-2006-4330 Wireshark security issues (CVE-2006-4333 CVE-2006-4332 CVE-2006-4331)
471
472* Wed Jul 26 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.2
473- fix BuildRequires
474
475* Tue Jul 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.1
476- build for FC5
477
478* Tue Jul 18 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-1
479- upgrade to 0.99.2
480
481* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.99.2-0.pre1.1
482- rebuild
483
484* Tue Jul 11 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-0.pre1
485- upgrade to 0.99.2pre1, fixes (#198242)
486
487* Tue Jun 13 2006 Radek Vokal <rvokal@redhat.com> 0.99.1-0.pre1
488- spec file changes
489
490* Fri Jun  9 2006 Radek Vokal <rvokal@redhat.com> 0.99.1pre1-1
491- initial build for Fedora Core
Note: See TracBrowser for help on using the repository browser.