source: projects/specs/trunk/w/wireshark/wireshark-vl.spec @ 9564

Revision 9564, 15.3 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary:        Network traffic analyzer
4Summary(ja):    ネットワークトラフィック解析プログラム
5Name:           wireshark
6Version:        1.12.5
7Release:        1%{_dist_release}
8License:        GPLv2
9Group:          Applications/System
10Source0:        http://www.wireshark.org/download/src/%{name}-%{version}.tar.bz2
11Source1:        wireshark.pam
12Source2:        wireshark.console
13Source3:        wireshark.desktop
14Patch4:         wireshark-0.99.7-path.patch
15Patch5:         wireshark-1.10.0-lua-vine.patch
16URL:            http://www.wireshark.org/
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires:  libcap-devel
21BuildRequires:  net-snmp-devel >= 5.0
22BuildRequires:  net-snmp-utils >= 5.0
23BuildRequires:  zlib-devel, bzip2-devel
24BuildRequires:  openssl-devel
25BuildRequires:  glib2-devel, gtk2-devel
26BuildRequires:  libelf-devel
27BuildRequires:  python, pcre-devel
28BuildRequires:  gnutls-devel
29BuildRequires:  desktop-file-utils, automake, libtool
30BuildRequires:  bison, flex
31BuildRequires:  krb5-devel
32BuildRequires:  libpcap-devel
33BuildRequires:  lua-devel
34
35Requires:       usermode >= 1.37
36Requires(post): desktop-file-utils
37Requires(postun): desktop-file-utils
38
39Obsoletes:      ethereal
40Obsoletes:      ethereal-base ethereal-gnome ethereal-gtk+
41Obsoletes:      ethereal-kde ethereal-usermode
42Provides:       ethereal ethereal-gnome
43
44Vendor:         Project Vine
45Distribution:   Vine Linux
46Packager: inagaki, Takemikaduchi
47
48%description
49Wireshark is a network traffic analyzer for Unix-ish operating systems.
50
51This package lays base for libpcap, a packet capture and filtering
52library, contains command-line utilities, contains plugins and
53documentation for wireshark. A graphical user interface is also
54included with this package.
55
56%description -l ja
57Wireshark は,UNIX 系 OS 用のネットワークトラフィック解析プログラムです.
58
59このパッケージは,パケットキャプチャ/フィルタリングライブラリである
60libpcap を使ったコマンドラインツールと,プラグイン,ドキュメント等が
61収められています.GUI もこのパッケージに収められています.
62
63%prep
64%setup -q -n %{name}-%{version}
65%patch4 -p1
66%patch5 -p1 -b .lua-vine
67
68%build
69%ifarch s390 s390x
70export PIECFLAGS="-fPIE"
71%else
72export PIECFLAGS="-fpie"
73%endif
74# FC5+ automatic -fstack-protector-all switch
75export RPM_OPT_FLAGS=${RPM_OPT_FLAGS//-fstack-protector/-fstack-protector-all}
76## export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcap -I%{_includedir}/pcre"
77export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcre"
78export CXXFLAGS="$RPM_OPT_FLAGS $CPPFLAGS"
79export LDFLAGS="$LDFLAGS -lm -lcrypto"
80export PATH="$PATH:/usr/kerberos/bin"
81./autogen.sh
82# --disable-warning-as-erros needs for compiling with glib 2.14.0
83%configure \
84   --bindir=%{_sbindir} \
85   --enable-ipv6 \
86   --with-gnu-ld \
87   --disable-static \
88   --disable-usr-local \
89   --enable-wireshark \
90   --with-pic \
91   --with-ssl \
92   --with-pcap \
93   --with-pcre \
94%if %{?_dist_release} != "vl4"
95   --with-krb5 \
96%else
97   --without-krb5 \
98%endif
99   --with-plugins=%{_libdir}/%{name}/plugins/%{version} \
100   --disable-warnings-as-errors \
101   --without-qt \
102   --with-gtk2=yes \
103   --with-gtk3=no
104time make %{?_smp_mflags}
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109# The evil plugins hack
110perl -pi -e 's|-L../../epan|-L../../epan/.libs|' plugins/*/*.la
111
112make DESTDIR=$RPM_BUILD_ROOT install
113
114#symlink tshark to tethereal
115ln -s tshark $RPM_BUILD_ROOT%{_sbindir}/tethereal
116
117#empty?!
118rm -f $RPM_BUILD_ROOT%{_sbindir}/idl2wrs
119
120# install support files for usermode, gnome and kde
121mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d
122install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/wireshark
123mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps
124install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps/wireshark
125mkdir -p $RPM_BUILD_ROOT/%{_bindir}
126ln -s consolehelper $RPM_BUILD_ROOT/%{_bindir}/wireshark
127
128# install man
129## mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
130## install -m 644 *.1 $RPM_BUILD_ROOT/%{_mandir}/man1
131
132# Install python stuff.
133mkdir -p $RPM_BUILD_ROOT%{python_sitelib}
134install -m 644 tools/wireshark_be.py tools/wireshark_gen.py  $RPM_BUILD_ROOT%{python_sitelib}
135
136desktop-file-install --vendor=                             \
137        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications    \
138        %{SOURCE3}
139
140mkdir -p $RPM_BUILD_ROOT/%{_datadir}/pixmaps
141install -m 644 image/wsicon48.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps/wireshark.png
142
143
144# Remove .la files
145rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}/plugins/%{version}/*.la
146
147# Remove .la files in libdir
148rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%post
154/sbin/ldconfig
155update-desktop-database -q
156
157%postun
158/sbin/ldconfig
159update-desktop-database -q
160
161%files
162%defattr(-,root,root)
163%doc AUTHORS COPYING ChangeLog INSTALL NEWS README*
164%{_sbindir}/editcap
165%{_sbindir}/tshark
166%{_sbindir}/mergecap
167%{_sbindir}/text2pcap
168%{_sbindir}/dftest
169%{_sbindir}/capinfos
170%{_sbindir}/captype
171%{_sbindir}/randpkt
172%{_sbindir}/dumpcap
173%{_sbindir}/tethereal
174%{_sbindir}/rawshark
175%{_sbindir}/reordercap
176%{python_sitelib}/*
177%{_libdir}/lib*
178%{_mandir}/man1/editcap.*
179%{_mandir}/man1/tshark.*
180%{_mandir}/man1/mergecap.*
181%{_mandir}/man1/text2pcap.*
182%{_mandir}/man1/capinfos.*
183%{_mandir}/man1/dumpcap.*
184%{_mandir}/man1/reordercap.*
185%{_mandir}/man4/wireshark-filter.*
186%{_libdir}/wireshark
187%config(noreplace) %{_sysconfdir}/pam.d/wireshark
188%config(noreplace) %{_sysconfdir}/security/console.apps/wireshark
189
190%config(noreplace) %{_datadir}/%{name}/init.lua
191%{_datadir}/%{name}/AUTHORS-SHORT
192%{_datadir}/%{name}/COPYING
193%{_datadir}/%{name}/*.html
194%{_datadir}/%{name}/*.css
195%{_datadir}/%{name}/cfilters
196%{_datadir}/%{name}/colorfilters
197%{_datadir}/%{name}/console.lua
198%{_datadir}/%{name}/dfilters
199%{_datadir}/%{name}/diameter
200%{_datadir}/%{name}/dtd_gen.lua
201%{_datadir}/%{name}/dtds
202%{_datadir}/%{name}/help
203%{_datadir}/%{name}/manuf
204%{_datadir}/%{name}/pdml2html.xsl
205%{_datadir}/%{name}/profiles
206%{_datadir}/%{name}/radius
207%{_datadir}/%{name}/services
208%{_datadir}/%{name}/smi_modules
209%{_datadir}/%{name}/tpncp
210%{_datadir}/%{name}/wimaxasncp
211
212%{_datadir}/applications/*.desktop
213%{_datadir}/pixmaps/wireshark.png
214%{_bindir}/wireshark
215%{_sbindir}/wireshark
216%{_mandir}/man1/wireshark.*
217%{_mandir}/man1/rawshark.*
218%{_mandir}/man1/dftest.*
219%{_mandir}/man1/randpkt.*
220
221
222%changelog
223* Wed May 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.5-1
224- new upstream release
225  (including security fix for CVE-2015-3808,3809,3810,3811,3812,3813,3814,3815)
226
227* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
228- new upstream release
229  (including security fix for CVE-2015-2187,2188,2189,2190,2191,2192)
230
231* Sat Jan 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.3-1
232- new upstream release
233  (including security fix for CVE-2015-0559,0560,0561,0562,0563,0564)
234
235* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
236- new upstream release
237  (including security fix for CVE-2014-8710,8711,8712,8713,8714)
238
239* Tue Sep 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
240- new upstream release
241
242* Thu Aug 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
243- new upstream release
244
245* Fri Jun 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
246- new upstream release
247  (including security fix for CVE-2014-4020)
248
249* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
250- new upstream release
251  (including security fix for CVE-2014-2907)
252
253* Sat Mar 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
254- new upstream release
255  (including security fix for CVE-2014-2281,2282,2283,2299)
256
257* Sun Dec 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.5-1
258- new upstream release
259
260* Tue Nov 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.3-1
261- new upstream release
262  (including security fix for CVE-2013-6336,6337,6338,6339,6340)
263
264* Mon Sep 16 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
265- new upstream release
266
267* Sun Jul 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
268- new upstream release
269  (including security fix for CVE-2013-4083,4920,4921,4922,4923,4924,4925,4926,4927,4929,4930,4931,4932,4944,4934,4935,4936)
270
271* Sat Jun 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
272- new upstream release
273- update Patch5 (wireshark-1.10.0-lua-vine.patch)
274- remove Patch3 (wireshark-nfsv4-opts.patch)
275
276* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.7-1
277- new upstream release
278  (including security fix for CVE-2013-2486 - 2487)
279
280* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.6-1
281- new upstream release
282  (including security fix for CVE-2013-2475 - 2488)
283
284* Wed Jan 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.5-1
285- new upstream release
286
287* Tue Jan 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
288- new upstream release
289
290* Wed Oct 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-1
291- new upstream release
292  (including security fix for CVE-2012-5237 - 5240)
293
294* Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
295- new upstream release
296  (including security fix for CVE-2012-4285 - 4298)
297
298* Tue Jul 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
299- new upstream release
300
301* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
302- new upstream release
303
304* Wed May 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
305- new upstream release
306
307* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.7-1
308- new upstream release
309
310* Thu Jan 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.5-1
311- new upstream release
312
313* Tue Nov 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
314- new upstream release
315
316* Sat Nov 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
317- new upstream release
318
319* Thu Sep 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
320- new upstream release
321
322* Sun Jul 31 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
323- new upstream release
324
325* Sun Jun 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-1
326- new upstream release
327  (including security fix for CVE-2011-1957,1958,1959,2174,7175)
328
329* Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
330- new upstream release
331
332* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-2
333- rebuild with krb5-libs-1.8.2
334
335* Wed Mar 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
336- new upstream release
337  (including security fix for CVE-2011-0538 and CVE-2011-0713)
338
339* Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
340- new upstream release
341  (including security fix for CVE-2010-4538)
342
343* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-2
344- rebuild with openssl-1.0.0c
345
346* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
347- new upstream release
348
349* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
350- new upstream release
351  (including security fix for CVE-2010-3445)
352
353* Sun Sep 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
354- new upstream release
355- add Patch5 (wireshark-1.4.0-lua-vine.patch)
356
357* Mon Aug 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
358- new upstream release
359  (including security fix for CVE-2010-2287 and CVE-2010-2284)
360
361* Wed Jul 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.9-1
362- new upstream release
363
364* Tue May 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.8-2
365- rebuilt with libpcap-1.1.1
366
367* Sat May 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
368- new upstream release
369  (including security fix for CVE-2010-1455)
370
371* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
372- new upstream release
373
374* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.5-3
375- rebuilt with python-2.6.4
376
377* Sun Dec 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-2
378- added --enable-wireshark instead of --enable-gtk2
379- added BR: bison, flex
380
381* Sat Dec 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.5-1
382- new upstream release with security fixes (SNA/SMB/IPMI issues)
383
384* Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
385- new upstream release
386  (includeing security fix for CVE-2009-3549,3550 and 3551)
387
388* Wed Sep 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-2
389- add BR: lua-devel (Vine 5.0 and later)
390
391* Sat Sep 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-1
392- new upstream release
393
394* Tue Jul 21 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
395- new upstream release
396
397* Mon Jul 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-1
398- new upstream release
399
400* Sat May 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.8-1
401- new upstream release
402
403* Fri Apr 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-1
404- new upstream release
405
406* Mon Feb  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.6-1
407- new upstream release
408- used more macros
409
410* Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-1
411- new upstream release
412
413* Sun Nov 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-2vl5
414- rebuilt
415
416* Mon Oct 27 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-1
417- new upstream release with security fix
418- add BuildRequires krb5-devel
419- SPEC in UTF-8
420
421* Fri Sep 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.3-1
422- new upstream release with security update
423
424* Wed Apr 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0-1
425- new upstream release with security update
426- add Vendor/Distribution tag
427- add BuildRequires: libcap-devel
428- new versioning policy
429
430* Tue Jan  8 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.99.7-0vl2
431- modified Source3 because of desktop-file-install error, like this:
432    /var/tmp/wireshark-0.99.7-root/usr/share/applications/wireshark.desktop:
433    error: value "wireshark.png" for key "Icon" in group "Desktop Entry" is
434    an icon name with an extension, but there should be no extension as
435    described in the Icon Theme Specification if the value is not an
436    absolute path
437  this warning/error occurs with desktop-file-utils >= 0.14
438
439* Wed Jan 2 2008 Satoshi MACHINO <machino@vinelinux.org> 0.99.7-0vl1
440- new upstream release
441- imported patch4 from fc9
442
443* Sun Sep  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl2
444- rebuilt with libpcap-0.9.7
445- added --disable-warning-as-errors to %%configure for glib-2.14.0
446
447* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl1
448- new upstream release
449- rebuilt with libpcap-0.9.6
450- added --with-pcap, --with-pcre
451
452* Fri Jun  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl2
453- rebuilt with new toolchain and environment
454
455* Thu Feb  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl1
456- new upstream release
457
458* Mon Nov 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.4-0vl1
459- new upstream release
460
461* Wed Oct  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.3-0vl1
462- initial built for Vine Linux based on Fedora
463- Obsoletes: ethereal, Provides: ethereal
464
465* Fri Aug 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.3-fc5.1
466- upgrade to 0.99.3-1
467- CVE-2006-4330 Wireshark security issues (CVE-2006-4333 CVE-2006-4332 CVE-2006-4331)
468
469* Wed Jul 26 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.2
470- fix BuildRequires
471
472* Tue Jul 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.1
473- build for FC5
474
475* Tue Jul 18 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-1
476- upgrade to 0.99.2
477
478* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.99.2-0.pre1.1
479- rebuild
480
481* Tue Jul 11 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-0.pre1
482- upgrade to 0.99.2pre1, fixes (#198242)
483
484* Tue Jun 13 2006 Radek Vokal <rvokal@redhat.com> 0.99.1-0.pre1
485- spec file changes
486
487* Fri Jun  9 2006 Radek Vokal <rvokal@redhat.com> 0.99.1pre1-1
488- initial build for Fedora Core
Note: See TracBrowser for help on using the repository browser.