source: projects/specs/trunk/w/wireshark/wireshark-vl.spec @ 8964

Revision 8964, 14.6 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary:        Network traffic analyzer
4Summary(ja):    ネットワークトラフィック解析プログラム
5Name:           wireshark
6Version:        1.10.10
7Release:        1%{_dist_release}
8License:        GPLv2
9Group:          Applications/System
10Source0:        http://www.wireshark.org/download/src/%{name}-%{version}.tar.bz2
11Source1:        wireshark.pam
12Source2:        wireshark.console
13Source3:        wireshark.desktop
14Patch4:         wireshark-0.99.7-path.patch
15Patch5:         wireshark-1.10.0-lua-vine.patch
16URL:            http://www.wireshark.org/
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires:  libcap-devel
21BuildRequires:  net-snmp-devel >= 5.0
22BuildRequires:  net-snmp-utils >= 5.0
23BuildRequires:  zlib-devel, bzip2-devel
24BuildRequires:  openssl-devel
25BuildRequires:  glib2-devel, gtk2-devel
26BuildRequires:  libelf-devel
27BuildRequires:  python, pcre-devel
28BuildRequires:  gnutls-devel
29BuildRequires:  desktop-file-utils, automake, libtool
30BuildRequires:  bison, flex
31BuildRequires:  krb5-devel
32BuildRequires:  libpcap-devel
33BuildRequires:  lua-devel
34
35Requires:       usermode >= 1.37
36Requires(post): desktop-file-utils
37Requires(postun): desktop-file-utils
38
39Obsoletes:      ethereal
40Obsoletes:      ethereal-base ethereal-gnome ethereal-gtk+
41Obsoletes:      ethereal-kde ethereal-usermode
42Provides:       ethereal ethereal-gnome
43
44Vendor:         Project Vine
45Distribution:   Vine Linux
46Packager: inagaki, Takemikaduchi
47
48%description
49Wireshark is a network traffic analyzer for Unix-ish operating systems.
50
51This package lays base for libpcap, a packet capture and filtering
52library, contains command-line utilities, contains plugins and
53documentation for wireshark. A graphical user interface is also
54included with this package.
55
56%description -l ja
57Wireshark は,UNIX 系 OS 用のネットワークトラフィック解析プログラムです.
58
59このパッケージは,パケットキャプチャ/フィルタリングライブラリである
60libpcap を使ったコマンドラインツールと,プラグイン,ドキュメント等が
61収められています.GUI もこのパッケージに収められています.
62
63%prep
64%setup -q -n %{name}-%{version}
65%patch4 -p1
66%patch5 -p1 -b .lua-vine
67
68%build
69%ifarch s390 s390x
70export PIECFLAGS="-fPIE"
71%else
72export PIECFLAGS="-fpie"
73%endif
74# FC5+ automatic -fstack-protector-all switch
75export RPM_OPT_FLAGS=${RPM_OPT_FLAGS//-fstack-protector/-fstack-protector-all}
76## export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcap -I%{_includedir}/pcre"
77export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcre"
78export CXXFLAGS="$RPM_OPT_FLAGS $CPPFLAGS"
79export LDFLAGS="$LDFLAGS -lm -lcrypto"
80export PATH="$PATH:/usr/kerberos/bin"
81./autogen.sh
82# --disable-warning-as-erros needs for compiling with glib 2.14.0
83%configure \
84   --bindir=%{_sbindir} \
85   --enable-ipv6 \
86   --with-gnu-ld \
87   --disable-static \
88   --disable-usr-local \
89   --enable-wireshark \
90   --with-pic \
91   --with-ssl \
92   --with-pcap \
93   --with-pcre \
94%if %{?_dist_release} != "vl4"
95   --with-krb5 \
96%else
97   --without-krb5 \
98%endif
99   --with-plugins=%{_libdir}/%{name}/plugins/%{version} \
100   --disable-warnings-as-errors
101time make %{?_smp_mflags}
102
103%install
104rm -rf $RPM_BUILD_ROOT
105
106# The evil plugins hack
107perl -pi -e 's|-L../../epan|-L../../epan/.libs|' plugins/*/*.la
108
109make DESTDIR=$RPM_BUILD_ROOT install
110
111#symlink tshark to tethereal
112ln -s tshark $RPM_BUILD_ROOT%{_sbindir}/tethereal
113
114#empty?!
115rm -f $RPM_BUILD_ROOT%{_sbindir}/idl2wrs
116
117# install support files for usermode, gnome and kde
118mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d
119install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/wireshark
120mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps
121install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps/wireshark
122mkdir -p $RPM_BUILD_ROOT/%{_bindir}
123ln -s consolehelper $RPM_BUILD_ROOT/%{_bindir}/wireshark
124
125# install man
126## mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
127## install -m 644 *.1 $RPM_BUILD_ROOT/%{_mandir}/man1
128
129# Install python stuff.
130mkdir -p $RPM_BUILD_ROOT%{python_sitelib}
131install -m 644 tools/wireshark_be.py tools/wireshark_gen.py  $RPM_BUILD_ROOT%{python_sitelib}
132
133desktop-file-install --vendor=                             \
134        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications    \
135        %{SOURCE3}
136
137mkdir -p $RPM_BUILD_ROOT/%{_datadir}/pixmaps
138install -m 644 image/wsicon48.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps/wireshark.png
139
140
141# Remove .la files
142rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}/plugins/%{version}/*.la
143
144# Remove .la files in libdir
145rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
146
147%clean
148rm -rf $RPM_BUILD_ROOT
149
150%post
151/sbin/ldconfig
152update-desktop-database -q
153
154%postun
155/sbin/ldconfig
156update-desktop-database -q
157
158%files
159%defattr(-,root,root)
160%doc AUTHORS COPYING ChangeLog INSTALL NEWS README*
161%{_sbindir}/editcap
162%{_sbindir}/tshark
163%{_sbindir}/mergecap
164%{_sbindir}/text2pcap
165%{_sbindir}/dftest
166%{_sbindir}/capinfos
167%{_sbindir}/randpkt
168%{_sbindir}/dumpcap
169%{_sbindir}/tethereal
170%{_sbindir}/rawshark
171%{_sbindir}/reordercap
172%{python_sitelib}/*
173%{_libdir}/lib*
174%{_mandir}/man1/editcap.*
175%{_mandir}/man1/tshark.*
176%{_mandir}/man1/mergecap.*
177%{_mandir}/man1/text2pcap.*
178%{_mandir}/man1/capinfos.*
179%{_mandir}/man1/dumpcap.*
180%{_mandir}/man1/reordercap.*
181%{_mandir}/man4/wireshark-filter.*
182%{_libdir}/wireshark
183%config(noreplace) %{_sysconfdir}/pam.d/wireshark
184%config(noreplace) %{_sysconfdir}/security/console.apps/wireshark
185
186%config(noreplace) %{_datadir}/%{name}/init.lua
187%{_datadir}/%{name}/AUTHORS-SHORT
188%{_datadir}/%{name}/COPYING
189%{_datadir}/%{name}/*.html
190%{_datadir}/%{name}/*.css
191%{_datadir}/%{name}/cfilters
192%{_datadir}/%{name}/colorfilters
193%{_datadir}/%{name}/console.lua
194%{_datadir}/%{name}/dfilters
195%{_datadir}/%{name}/diameter
196%{_datadir}/%{name}/dtd_gen.lua
197%{_datadir}/%{name}/dtds
198%{_datadir}/%{name}/help
199%{_datadir}/%{name}/manuf
200%{_datadir}/%{name}/pdml2html.xsl
201%{_datadir}/%{name}/profiles
202%{_datadir}/%{name}/radius
203%{_datadir}/%{name}/services
204%{_datadir}/%{name}/smi_modules
205%{_datadir}/%{name}/tpncp
206%{_datadir}/%{name}/wimaxasncp
207
208%{_datadir}/applications/*.desktop
209%{_datadir}/pixmaps/wireshark.png
210%{_bindir}/wireshark
211%{_sbindir}/wireshark
212%{_mandir}/man1/wireshark.*
213%{_mandir}/man1/rawshark.*
214%{_mandir}/man1/dftest.*
215%{_mandir}/man1/randpkt.*
216
217
218%changelog
219* Tue Sep 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
220- new upstream release
221
222* Thu Aug 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
223- new upstream release
224
225* Fri Jun 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
226- new upstream release
227  (including security fix for CVE-2014-4020)
228
229* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
230- new upstream release
231  (including security fix for CVE-2014-2907)
232
233* Sat Mar 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
234- new upstream release
235  (including security fix for CVE-2014-2281,2282,2283,2299)
236
237* Sun Dec 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.5-1
238- new upstream release
239
240* Tue Nov 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.3-1
241- new upstream release
242  (including security fix for CVE-2013-6336,6337,6338,6339,6340)
243
244* Mon Sep 16 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
245- new upstream release
246
247* Sun Jul 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
248- new upstream release
249  (including security fix for CVE-2013-4083,4920,4921,4922,4923,4924,4925,4926,4927,4929,4930,4931,4932,4944,4934,4935,4936)
250
251* Sat Jun 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
252- new upstream release
253- update Patch5 (wireshark-1.10.0-lua-vine.patch)
254- remove Patch3 (wireshark-nfsv4-opts.patch)
255
256* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.7-1
257- new upstream release
258  (including security fix for CVE-2013-2486 - 2487)
259
260* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.6-1
261- new upstream release
262  (including security fix for CVE-2013-2475 - 2488)
263
264* Wed Jan 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.5-1
265- new upstream release
266
267* Tue Jan 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
268- new upstream release
269
270* Wed Oct 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-1
271- new upstream release
272  (including security fix for CVE-2012-5237 - 5240)
273
274* Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
275- new upstream release
276  (including security fix for CVE-2012-4285 - 4298)
277
278* Tue Jul 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
279- new upstream release
280
281* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
282- new upstream release
283
284* Wed May 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
285- new upstream release
286
287* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.7-1
288- new upstream release
289
290* Thu Jan 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.5-1
291- new upstream release
292
293* Tue Nov 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
294- new upstream release
295
296* Sat Nov 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
297- new upstream release
298
299* Thu Sep 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
300- new upstream release
301
302* Sun Jul 31 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
303- new upstream release
304
305* Sun Jun 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-1
306- new upstream release
307  (including security fix for CVE-2011-1957,1958,1959,2174,7175)
308
309* Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
310- new upstream release
311
312* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-2
313- rebuild with krb5-libs-1.8.2
314
315* Wed Mar 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
316- new upstream release
317  (including security fix for CVE-2011-0538 and CVE-2011-0713)
318
319* Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
320- new upstream release
321  (including security fix for CVE-2010-4538)
322
323* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-2
324- rebuild with openssl-1.0.0c
325
326* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
327- new upstream release
328
329* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
330- new upstream release
331  (including security fix for CVE-2010-3445)
332
333* Sun Sep 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
334- new upstream release
335- add Patch5 (wireshark-1.4.0-lua-vine.patch)
336
337* Mon Aug 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
338- new upstream release
339  (including security fix for CVE-2010-2287 and CVE-2010-2284)
340
341* Wed Jul 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.9-1
342- new upstream release
343
344* Tue May 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.8-2
345- rebuilt with libpcap-1.1.1
346
347* Sat May 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
348- new upstream release
349  (including security fix for CVE-2010-1455)
350
351* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
352- new upstream release
353
354* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.5-3
355- rebuilt with python-2.6.4
356
357* Sun Dec 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-2
358- added --enable-wireshark instead of --enable-gtk2
359- added BR: bison, flex
360
361* Sat Dec 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.5-1
362- new upstream release with security fixes (SNA/SMB/IPMI issues)
363
364* Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
365- new upstream release
366  (includeing security fix for CVE-2009-3549,3550 and 3551)
367
368* Wed Sep 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-2
369- add BR: lua-devel (Vine 5.0 and later)
370
371* Sat Sep 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-1
372- new upstream release
373
374* Tue Jul 21 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
375- new upstream release
376
377* Mon Jul 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-1
378- new upstream release
379
380* Sat May 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.8-1
381- new upstream release
382
383* Fri Apr 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-1
384- new upstream release
385
386* Mon Feb  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.6-1
387- new upstream release
388- used more macros
389
390* Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-1
391- new upstream release
392
393* Sun Nov 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-2vl5
394- rebuilt
395
396* Mon Oct 27 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-1
397- new upstream release with security fix
398- add BuildRequires krb5-devel
399- SPEC in UTF-8
400
401* Fri Sep 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.3-1
402- new upstream release with security update
403
404* Wed Apr 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0-1
405- new upstream release with security update
406- add Vendor/Distribution tag
407- add BuildRequires: libcap-devel
408- new versioning policy
409
410* Tue Jan  8 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.99.7-0vl2
411- modified Source3 because of desktop-file-install error, like this:
412    /var/tmp/wireshark-0.99.7-root/usr/share/applications/wireshark.desktop:
413    error: value "wireshark.png" for key "Icon" in group "Desktop Entry" is
414    an icon name with an extension, but there should be no extension as
415    described in the Icon Theme Specification if the value is not an
416    absolute path
417  this warning/error occurs with desktop-file-utils >= 0.14
418
419* Wed Jan 2 2008 Satoshi MACHINO <machino@vinelinux.org> 0.99.7-0vl1
420- new upstream release
421- imported patch4 from fc9
422
423* Sun Sep  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl2
424- rebuilt with libpcap-0.9.7
425- added --disable-warning-as-errors to %%configure for glib-2.14.0
426
427* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl1
428- new upstream release
429- rebuilt with libpcap-0.9.6
430- added --with-pcap, --with-pcre
431
432* Fri Jun  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl2
433- rebuilt with new toolchain and environment
434
435* Thu Feb  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl1
436- new upstream release
437
438* Mon Nov 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.4-0vl1
439- new upstream release
440
441* Wed Oct  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.3-0vl1
442- initial built for Vine Linux based on Fedora
443- Obsoletes: ethereal, Provides: ethereal
444
445* Fri Aug 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.3-fc5.1
446- upgrade to 0.99.3-1
447- CVE-2006-4330 Wireshark security issues (CVE-2006-4333 CVE-2006-4332 CVE-2006-4331)
448
449* Wed Jul 26 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.2
450- fix BuildRequires
451
452* Tue Jul 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.1
453- build for FC5
454
455* Tue Jul 18 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-1
456- upgrade to 0.99.2
457
458* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.99.2-0.pre1.1
459- rebuild
460
461* Tue Jul 11 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-0.pre1
462- upgrade to 0.99.2pre1, fixes (#198242)
463
464* Tue Jun 13 2006 Radek Vokal <rvokal@redhat.com> 0.99.1-0.pre1
465- spec file changes
466
467* Fri Jun  9 2006 Radek Vokal <rvokal@redhat.com> 0.99.1pre1-1
468- initial build for Fedora Core
Note: See TracBrowser for help on using the repository browser.