source: projects/specs/trunk/w/wireshark/wireshark-vl.spec @ 3079

Revision 3079, 11.0 KB checked in by Takemikaduchi, 13 years ago (diff)

glib2,gtk3,clutter: new upstream release, others: rebuild with krb5-libs-1.8.2

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary:        Network traffic analyzer
4Summary(ja):    ネットワークトラフィック解析プログラム
5Name:           wireshark
6Version:        1.4.4
7Release:        2%{_dist_release}
8License:        GPLv2
9Group:          Applications/System
10Source0:        http://www.wireshark.org/download/src/%{name}-%{version}.tar.bz2
11Source1:        wireshark.pam
12Source2:        wireshark.console
13Source3:        wireshark.desktop
14Patch1:         wireshark-0.99.7-pie.patch
15Patch3:         wireshark-nfsv4-opts.patch
16Patch4:         wireshark-0.99.7-path.patch
17Patch5:         wireshark-1.4.0-lua-vine.patch
18URL:            http://www.wireshark.org/
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  libcap-devel
22BuildRequires:  net-snmp-devel >= 5.0
23BuildRequires:  net-snmp-utils >= 5.0
24BuildRequires:  zlib-devel, bzip2-devel
25BuildRequires:  openssl-devel
26BuildRequires:  glib2-devel, gtk2-devel
27BuildRequires:  libelf-devel
28BuildRequires:  python, pcre-devel
29BuildRequires:  gnutls-devel
30BuildRequires:  desktop-file-utils, automake, libtool
31BuildRequires:  bison, flex
32%if %{?_dist_release} != "vl4"
33BuildRequires:  krb5-devel
34BuildRequires:  libpcap-devel
35BuildRequires:  lua-devel
36%else
37BuildRequires:  libpcap
38%endif
39Requires:       usermode >= 1.37
40Requires(post): desktop-file-utils
41Requires(postun): desktop-file-utils
42
43Obsoletes:      ethereal
44Obsoletes:      ethereal-base ethereal-gnome ethereal-gtk+
45Obsoletes:      ethereal-kde ethereal-usermode
46Provides:       ethereal ethereal-gnome
47
48Vendor:         Project Vine
49Distribution:   Vine Linux
50Packager: inagaki
51
52%description
53Wireshark is a network traffic analyzer for Unix-ish operating systems.
54
55This package lays base for libpcap, a packet capture and filtering
56library, contains command-line utilities, contains plugins and
57documentation for wireshark. A graphical user interface is also
58included with this package.
59
60%description -l ja
61Wireshark は,UNIX 系 OS 用のネットワークトラフィック解析プログラムです.
62
63このパッケージは,パケットキャプチャ/フィルタリングライブラリである
64libpcap を使ったコマンドラインツールと,プラグイン,ドキュメント等が
65収められています.GUI もこのパッケージに収められています.
66
67%prep
68%setup -q -n %{name}-%{version}
69#patch1 -p1 -b .pie
70%patch3 -p1
71%patch4 -p1
72%patch5 -p1 -b .lua-vine
73
74%build
75%ifarch s390 s390x
76export PIECFLAGS="-fPIE"
77%else
78export PIECFLAGS="-fpie"
79%endif
80# FC5+ automatic -fstack-protector-all switch
81export RPM_OPT_FLAGS=${RPM_OPT_FLAGS//-fstack-protector/-fstack-protector-all}
82## export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcap -I%{_includedir}/pcre"
83export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcre"
84export CXXFLAGS="$RPM_OPT_FLAGS $CPPFLAGS"
85export LDFLAGS="$LDFLAGS -lm -lcrypto"
86export PATH="$PATH:/usr/kerberos/bin"
87./autogen.sh
88# --disable-warning-as-erros needs for compiling with glib 2.14.0
89%configure \
90   --bindir=%{_sbindir} \
91   --enable-ipv6 \
92   --with-gnu-ld \
93   --disable-static \
94   --disable-usr-local \
95   --enable-wireshark \
96   --with-pic \
97   --with-ssl \
98   --with-pcap \
99   --with-pcre \
100%if %{?_dist_release} != "vl4"
101   --with-krb5 \
102%else
103   --without-krb5 \
104%endif
105   --with-plugins=%{_libdir}/%{name}/plugins/%{version} \
106   --disable-warnings-as-errors
107time make %{?_smp_mflags}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112# The evil plugins hack
113perl -pi -e 's|-L../../epan|-L../../epan/.libs|' plugins/*/*.la
114
115make DESTDIR=$RPM_BUILD_ROOT install
116
117#symlink tshark to tethereal
118ln -s tshark $RPM_BUILD_ROOT%{_sbindir}/tethereal
119
120#empty?!
121rm -f $RPM_BUILD_ROOT%{_sbindir}/idl2wrs
122
123# install support files for usermode, gnome and kde
124mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d
125install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/wireshark
126mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps
127install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps/wireshark
128mkdir -p $RPM_BUILD_ROOT/%{_bindir}
129ln -s consolehelper $RPM_BUILD_ROOT/%{_bindir}/wireshark
130
131# install man
132## mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
133## install -m 644 *.1 $RPM_BUILD_ROOT/%{_mandir}/man1
134
135# Install python stuff.
136mkdir -p $RPM_BUILD_ROOT%{python_sitelib}
137install -m 644 tools/wireshark_be.py tools/wireshark_gen.py  $RPM_BUILD_ROOT%{python_sitelib}
138
139desktop-file-install --vendor=                             \
140        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications    \
141        %{SOURCE3}
142
143mkdir -p $RPM_BUILD_ROOT/%{_datadir}/pixmaps
144install -m 644 image/wsicon48.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps/wireshark.png
145
146
147# Remove .la files
148rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}/plugins/%{version}/*.la
149
150# Remove .la files in libdir
151rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%post
157/sbin/ldconfig
158update-desktop-database -q
159
160%postun
161/sbin/ldconfig
162update-desktop-database -q
163
164%files
165%defattr(-,root,root)
166%doc AUTHORS COPYING ChangeLog INSTALL NEWS README*
167%{_sbindir}/editcap
168#%{_sbindir}/idl2wrs
169%{_sbindir}/tshark
170%{_sbindir}/mergecap
171%{_sbindir}/text2pcap
172%{_sbindir}/dftest
173%{_sbindir}/capinfos
174%{_sbindir}/randpkt
175%{_sbindir}/dumpcap
176%{_sbindir}/tethereal
177%{_sbindir}/rawshark
178%{python_sitelib}/*
179%{_libdir}/lib*
180%{_mandir}/man1/editcap.*
181%{_mandir}/man1/tshark.*
182%{_mandir}/man1/idl2wrs.*
183%{_mandir}/man1/mergecap.*
184%{_mandir}/man1/text2pcap.*
185%{_mandir}/man1/capinfos.*
186%{_mandir}/man1/dumpcap.*
187%{_mandir}/man4/wireshark-filter.*
188%{_libdir}/wireshark
189%config(noreplace) %{_sysconfdir}/pam.d/wireshark
190%config(noreplace) %{_sysconfdir}/security/console.apps/wireshark
191%{_datadir}/wireshark
192
193%{_datadir}/applications/*.desktop
194%{_datadir}/pixmaps/wireshark.png
195%{_bindir}/wireshark
196%{_sbindir}/wireshark
197%{_mandir}/man1/wireshark.*
198%{_mandir}/man1/rawshark.*
199%{_mandir}/man1/dftest.*
200%{_mandir}/man1/randpkt.*
201
202
203%changelog
204* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-2
205- rebuild with krb5-libs-1.8.2
206
207* Wed Mar 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
208- new upstream release
209  (including security fix for CVE-2011-0538 and CVE-2011-0713)
210
211* Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
212- new upstream release
213  (including security fix for CVE-2010-4538)
214
215* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-2
216- rebuild with openssl-1.0.0c
217
218* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
219- new upstream release
220
221* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
222- new upstream release
223  (including security fix for CVE-2010-3445)
224
225* Sun Sep 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
226- new upstream release
227- add Patch5 (wireshark-1.4.0-lua-vine.patch)
228
229* Mon Aug 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
230- new upstream release
231  (including security fix for CVE-2010-2287 and CVE-2010-2284)
232
233* Wed Jul 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.9-1
234- new upstream release
235
236* Tue May 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.8-2
237- rebuilt with libpcap-1.1.1
238
239* Sat May 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
240- new upstream release
241  (including security fix for CVE-2010-1455)
242
243* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
244- new upstream release
245
246* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.5-3
247- rebuilt with python-2.6.4
248
249* Sun Dec 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-2
250- added --enable-wireshark instead of --enable-gtk2
251- added BR: bison, flex
252
253* Sat Dec 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.5-1
254- new upstream release with security fixes (SNA/SMB/IPMI issues)
255
256* Fri Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
257- new upstream release
258  (includeing security fix for CVE-2009-3549,3550 and 3551)
259
260* Wed Sep 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-2
261- add BR: lua-devel (Vine 5.0 and later)
262
263* Sat Sep 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-1
264- new upstream release
265
266* Tue Jul 21 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
267- new upstream release
268
269* Mon Jul 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-1
270- new upstream release
271
272* Sat May 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.8-1
273- new upstream release
274
275* Fri Apr 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-1
276- new upstream release
277
278* Sun Feb  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.6-1
279- new upstream release
280- used more macros
281
282* Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-1
283- new upstream release
284
285* Sun Nov 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-2vl5
286- rebuilt
287
288* Mon Oct 27 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-1
289- new upstream release with security fix
290- add BuildRequires krb5-devel
291- SPEC in UTF-8
292
293* Fri Sep 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.3-1
294- new upstream release with security update
295
296* Wed Apr 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0-1
297- new upstream release with security update
298- add Vendor/Distribution tag
299- add BuildRequires: libcap-devel
300- new versioning policy
301
302* Tue Jan  8 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.99.7-0vl2
303- modified Source3 because of desktop-file-install error, like this:
304    /var/tmp/wireshark-0.99.7-root/usr/share/applications/wireshark.desktop:
305    error: value "wireshark.png" for key "Icon" in group "Desktop Entry" is
306    an icon name with an extension, but there should be no extension as
307    described in the Icon Theme Specification if the value is not an
308    absolute path
309  this warning/error occurs with desktop-file-utils >= 0.14
310
311* Wed Jan 2 2008 Satoshi MACHINO <machino@vinelinux.org> 0.99.7-0vl1
312- new upstream release
313- imported patch4 from fc9
314
315* Sun Sep  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl2
316- rebuilt with libpcap-0.9.7
317- added --disable-warning-as-errors to %%configure for glib-2.14.0
318
319* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl1
320- new upstream release
321- rebuilt with libpcap-0.9.6
322- added --with-pcap, --with-pcre
323
324* Fri Jun  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl2
325- rebuilt with new toolchain and environment
326
327* Thu Feb  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl1
328- new upstream release
329
330* Mon Nov 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.4-0vl1
331- new upstream release
332
333* Wed Oct  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.3-0vl1
334- initial built for Vine Linux based on Fedora
335- Obsoletes: ethereal, Provides: ethereal
336
337* Fri Aug 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.3-fc5.1
338- upgrade to 0.99.3-1
339- CVE-2006-4330 Wireshark security issues (CVE-2006-4333 CVE-2006-4332 CVE-2006-4331)
340
341* Wed Jul 26 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.2
342- fix BuildRequires
343
344* Tue Jul 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.1
345- build for FC5
346
347* Tue Jul 18 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-1
348- upgrade to 0.99.2
349
350* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.99.2-0.pre1.1
351- rebuild
352
353* Tue Jul 11 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-0.pre1
354- upgrade to 0.99.2pre1, fixes (#198242)
355
356* Tue Jun 13 2006 Radek Vokal <rvokal@redhat.com> 0.99.1-0.pre1
357- spec file changes
358
359* Fri Jun  9 2006 Radek Vokal <rvokal@redhat.com> 0.99.1pre1-1
360- initial build for Fedora Core
Note: See TracBrowser for help on using the repository browser.