source: projects/specs/trunk/w/wireshark/wireshark-vl.spec @ 1493

Revision 1493, 10.0 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release including security fix

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary:        Network traffic analyzer
4Summary(ja):    ネットワークトラフィック解析プログラム
5Name:           wireshark
6Version:        1.2.10
7Release:        1%{_dist_release}
8License:        GPLv2
9Group:          Applications/System
10Source0:        http://www.wireshark.org/download/src/%{name}-%{version}.tar.bz2
11Source1:        wireshark.pam
12Source2:        wireshark.console
13Source3:        wireshark.desktop
14Patch1:         wireshark-0.99.7-pie.patch
15Patch3:         wireshark-nfsv4-opts.patch
16Patch4:         wireshark-0.99.7-path.patch
17URL:            http://www.wireshark.org/
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20BuildRequires:  libcap-devel
21BuildRequires:  net-snmp-devel >= 5.0
22BuildRequires:  net-snmp-utils >= 5.0
23BuildRequires:  zlib-devel, bzip2-devel
24BuildRequires:  openssl-devel
25BuildRequires:  glib2-devel, gtk2-devel
26BuildRequires:  libelf-devel
27BuildRequires:  python, pcre-devel
28BuildRequires:  gnutls-devel
29BuildRequires:  desktop-file-utils, automake, libtool
30BuildRequires:  bison, flex
31%if %{?_dist_release} != "vl4"
32BuildRequires:  krb5-devel
33BuildRequires:  libpcap-devel
34BuildRequires:  lua-devel
35%else
36BuildRequires:  libpcap
37%endif
38Requires:       usermode >= 1.37
39Requires(post): desktop-file-utils
40Requires(postun): desktop-file-utils
41
42Obsoletes:      ethereal
43Obsoletes:      ethereal-base ethereal-gnome ethereal-gtk+
44Obsoletes:      ethereal-kde ethereal-usermode
45Provides:       ethereal ethereal-gnome
46
47Vendor:         Project Vine
48Distribution:   Vine Linux
49Packager: inagaki
50
51%description
52Wireshark is a network traffic analyzer for Unix-ish operating systems.
53
54This package lays base for libpcap, a packet capture and filtering
55library, contains command-line utilities, contains plugins and
56documentation for wireshark. A graphical user interface is also
57included with this package.
58
59%description -l ja
60Wireshark は,UNIX 系 OS 用のネットワークトラフィック解析プログラムです.
61
62このパッケージは,パケットキャプチャ/フィルタリングライブラリである
63libpcap を使ったコマンドラインツールと,プラグイン,ドキュメント等が
64収められています.GUI もこのパッケージに収められています.
65
66%prep
67%setup -q -n %{name}-%{version}
68#patch1 -p1 -b .pie
69%patch3 -p1
70%patch4 -p1
71
72%build
73%ifarch s390 s390x
74export PIECFLAGS="-fPIE"
75%else
76export PIECFLAGS="-fpie"
77%endif
78# FC5+ automatic -fstack-protector-all switch
79export RPM_OPT_FLAGS=${RPM_OPT_FLAGS//-fstack-protector/-fstack-protector-all}
80export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcap -I%{_includedir}/pcre"
81export CXXFLAGS="$RPM_OPT_FLAGS $CPPFLAGS"
82export LDFLAGS="$LDFLAGS -lm -lcrypto"
83export PATH="$PATH:/usr/kerberos/bin"
84./autogen.sh
85# --disable-warning-as-erros needs for compiling with glib 2.14.0
86%configure \
87   --bindir=%{_sbindir} \
88   --enable-ipv6 \
89   --with-gnu-ld \
90   --disable-static \
91   --disable-usr-local \
92   --enable-wireshark \
93   --with-pic \
94   --with-ssl \
95   --with-pcap \
96   --with-pcre \
97%if %{?_dist_release} != "vl4"
98   --with-krb5 \
99%else
100   --without-krb5 \
101%endif
102   --with-plugins=%{_libdir}/%{name}/plugins/%{version} \
103   --disable-warnings-as-errors
104time make %{?_smp_mflags}
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109# The evil plugins hack
110perl -pi -e 's|-L../../epan|-L../../epan/.libs|' plugins/*/*.la
111
112make DESTDIR=$RPM_BUILD_ROOT install
113
114#symlink tshark to tethereal
115ln -s tshark $RPM_BUILD_ROOT%{_sbindir}/tethereal
116
117#empty?!
118rm -f $RPM_BUILD_ROOT%{_sbindir}/idl2wrs
119
120# install support files for usermode, gnome and kde
121mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d
122install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/wireshark
123mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps
124install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps/wireshark
125mkdir -p $RPM_BUILD_ROOT/%{_bindir}
126ln -s consolehelper $RPM_BUILD_ROOT/%{_bindir}/wireshark
127
128# install man
129mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
130install -m 644 *.1 $RPM_BUILD_ROOT/%{_mandir}/man1
131
132# Install python stuff.
133mkdir -p $RPM_BUILD_ROOT%{python_sitelib}
134install -m 644 tools/wireshark_be.py tools/wireshark_gen.py  $RPM_BUILD_ROOT%{python_sitelib}
135
136desktop-file-install --vendor=                             \
137        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications    \
138        %{SOURCE3}
139
140mkdir -p $RPM_BUILD_ROOT/%{_datadir}/pixmaps
141install -m 644 image/wsicon48.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps/wireshark.png
142
143
144# Remove .la files
145rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}/plugins/%{version}/*.la
146
147# Remove .la files in libdir
148rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%post
154/sbin/ldconfig
155update-desktop-database -q
156
157%postun
158/sbin/ldconfig
159update-desktop-database -q
160
161%files
162%defattr(-,root,root)
163%doc AUTHORS COPYING ChangeLog INSTALL NEWS README*
164%{_sbindir}/editcap
165#%{_sbindir}/idl2wrs
166%{_sbindir}/tshark
167%{_sbindir}/mergecap
168%{_sbindir}/text2pcap
169%{_sbindir}/dftest
170%{_sbindir}/capinfos
171%{_sbindir}/randpkt
172%{_sbindir}/dumpcap
173%{_sbindir}/tethereal
174%{_sbindir}/rawshark
175%{python_sitelib}/*
176%{_libdir}/lib*
177%{_mandir}/man1/editcap.*
178%{_mandir}/man1/tshark.*
179%{_mandir}/man1/idl2wrs.*
180%{_mandir}/man1/mergecap.*
181%{_mandir}/man1/text2pcap.*
182%{_mandir}/man1/capinfos.*
183%{_mandir}/man1/dumpcap.*
184%{_mandir}/man4/wireshark-filter.*
185%{_libdir}/wireshark
186%config(noreplace) %{_sysconfdir}/pam.d/wireshark
187%config(noreplace) %{_sysconfdir}/security/console.apps/wireshark
188%{_datadir}/wireshark
189
190%{_datadir}/applications/*.desktop
191%{_datadir}/pixmaps/wireshark.png
192%{_bindir}/wireshark
193%{_sbindir}/wireshark
194%{_mandir}/man1/wireshark.*
195%{_mandir}/man1/rawshark.*
196
197
198%changelog
199* Mon Aug 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
200- new upstream release
201  (including security fix for CVE-2010-2287 and CVE-2010-2284)
202
203* Wed Jul 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.9-1
204- new upstream release
205
206* Tue May 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.8-2
207- rebuilt with libpcap-1.1.1
208
209* Sat May 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
210- new upstream release
211  (including security fix for CVE-2010-1455)
212
213* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
214- new upstream release
215
216* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.5-3
217- rebuilt with python-2.6.4
218
219* Sun Dec 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-2
220- added --enable-wireshark instead of --enable-gtk2
221- added BR: bison, flex
222
223* Sat Dec 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.5-1
224- new upstream release with security fixes (SNA/SMB/IPMI issues)
225
226* Fri Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
227- new upstream release
228  (includeing security fix for CVE-2009-3549,3550 and 3551)
229
230* Wed Sep 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-2
231- add BR: lua-devel (Vine 5.0 and later)
232
233* Sat Sep 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-1
234- new upstream release
235
236* Tue Jul 21 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
237- new upstream release
238
239* Mon Jul 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-1
240- new upstream release
241
242* Sat May 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.8-1
243- new upstream release
244
245* Fri Apr 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-1
246- new upstream release
247
248* Sun Feb  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.6-1
249- new upstream release
250- used more macros
251
252* Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-1
253- new upstream release
254
255* Sun Nov 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-2vl5
256- rebuilt
257
258* Mon Oct 27 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-1
259- new upstream release with security fix
260- add BuildRequires krb5-devel
261- SPEC in UTF-8
262
263* Fri Sep 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.3-1
264- new upstream release with security update
265
266* Wed Apr 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0-1
267- new upstream release with security update
268- add Vendor/Distribution tag
269- add BuildRequires: libcap-devel
270- new versioning policy
271
272* Tue Jan  8 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.99.7-0vl2
273- modified Source3 because of desktop-file-install error, like this:
274    /var/tmp/wireshark-0.99.7-root/usr/share/applications/wireshark.desktop:
275    error: value "wireshark.png" for key "Icon" in group "Desktop Entry" is
276    an icon name with an extension, but there should be no extension as
277    described in the Icon Theme Specification if the value is not an
278    absolute path
279  this warning/error occurs with desktop-file-utils >= 0.14
280
281* Wed Jan 2 2008 Satoshi MACHINO <machino@vinelinux.org> 0.99.7-0vl1
282- new upstream release
283- imported patch4 from fc9
284
285* Sun Sep  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl2
286- rebuilt with libpcap-0.9.7
287- added --disable-warning-as-errors to %%configure for glib-2.14.0
288
289* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl1
290- new upstream release
291- rebuilt with libpcap-0.9.6
292- added --with-pcap, --with-pcre
293
294* Fri Jun  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl2
295- rebuilt with new toolchain and environment
296
297* Thu Feb  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl1
298- new upstream release
299
300* Mon Nov 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.4-0vl1
301- new upstream release
302
303* Wed Oct  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.3-0vl1
304- initial built for Vine Linux based on Fedora
305- Obsoletes: ethereal, Provides: ethereal
306
307* Fri Aug 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.3-fc5.1
308- upgrade to 0.99.3-1
309- CVE-2006-4330 Wireshark security issues (CVE-2006-4333 CVE-2006-4332 CVE-2006-4331)
310
311* Wed Jul 26 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.2
312- fix BuildRequires
313
314* Tue Jul 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.1
315- build for FC5
316
317* Tue Jul 18 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-1
318- upgrade to 0.99.2
319
320* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.99.2-0.pre1.1
321- rebuild
322
323* Tue Jul 11 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-0.pre1
324- upgrade to 0.99.2pre1, fixes (#198242)
325
326* Tue Jun 13 2006 Radek Vokal <rvokal@redhat.com> 0.99.1-0.pre1
327- spec file changes
328
329* Fri Jun  9 2006 Radek Vokal <rvokal@redhat.com> 0.99.1pre1-1
330- initial build for Fedora Core
Note: See TracBrowser for help on using the repository browser.