source: projects/specs/trunk/w/wine/wine-vl.spec @ 9881

Revision 9881, 25.9 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1%define pkg_major_version 1.8
2%define pkg_name wine
3%define pkg_release 1%{?_dist_release}
4
5# NEW Release: numbering rule. -- Release: 1%{?_dist_release}
6# spec file for package wine.. # base (SUSE10 and fedora core 9)
7
8Summary:        Allows running Windows 16/32/64 bit programs on Unix.
9Summary(ja):    Unix で 16/32/64ビットWindoowsプログラムを実行させます
10Name:           %{pkg_name}
11Version:        %{pkg_major_version}
12Release:        %{pkg_release}
13URL:            http://www.winehq.org/
14License:        LGPLv2+
15Group:          Applications/System
16
17#--------------------------------------------------------------------
18Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
19#--------------------------------------------------------------------
20
21Source1:        wine.init
22Source3:        wine-README-Fedora
23Source4:        wine-32.conf
24# desktop stuff
25Source100:      wine-notepad.desktop
26Source101:      wine-regedit.desktop
27Source102:      wine-uninstaller.desktop
28Source103:      wine-winecfg.desktop
29Source104:      wine-winefile.desktop
30Source105:      wine-winemine.desktop
31Source106:      wine-winhelp.desktop
32Source107:      wine-wineboot.desktop
33
34# desktop dir
35Source200:      wine.menu
36Source201:      wine.directory
37
38# mime types
39Source300:      wine-mime-msi.desktop
40
41Patch0:         wine-prefixfonts.patch
42Patch1:         wine-1.1.28-rpath.patch
43Patch2:         wine-1.7.40-x86_64_gstreamer.patch
44
45# ADD ja
46Source801: wine_README.ja
47Source803: wine-README-Fedora.ja
48Source804: wine_README_add.ja
49Source805: fonts-replace-list.txt
50Source806: ja_fonts_replace-js2ipa.reg
51Source807: ja_fonts_replace-js2vl.reg
52Source808: ja_fonts_replace-ms2ipa.reg
53Source809: ja_fonts_replace-ms2vl.reg
54
55
56Vendor: Project Vine
57Distribution: Vine Linux
58Packager: daisuke, Takemikaduchi
59
60ExclusiveArch: %{ix86} x86_64
61
62#--------------------------------------------------------------------
63BuildRoot:      %{_tmppath}/%{name}-%{version}-root
64#--------------------------------------------------------------------
65
66## FedoraCore ##
67BuildRequires: bison, flex
68BuildRequires: audiofile, audiofile-devel
69BuildRequires: alsa-lib-devel
70BuildRequires: freeglut-devel, lcms-devel
71## BuildRequires:  libieee1284-devel
72BuildRequires: libjpeg-devel, libpng-devel
73BuildRequires: libstdc++-devel
74BuildRequires: libusb-devel
75BuildRequires: libxml2-devel, libxslt-devel
76BuildRequires: openldap-devel, ncurses-devel
77BuildRequires: unixODBC-devel, openssl-devel
78# BuildRequires: sane-devel
79BuildRequires: zlib-devel
80BuildRequires: desktop-file-utils
81BuildRequires: fontforge
82## BuildRequires: gphoto2, gphoto2-devel
83## BuildRequires: jack-audio-connection-kit-devel
84## BuildRequires:  isdn4k-utils-devel
85BuildRequires: cups-devel
86BuildRequires: dbus-devel
87BuildRequires: gstreamer-plugins-base-devel
88## Requires:       %{_bindir}/xmessage
89
90## X modular(fc) > X 7.2
91BuildRequires:  libX11-devel
92BuildRequires:  mesa-libGL-devel
93BuildRequires:  mesa-libGLU-devel
94BuildRequires:  mesa-libOSMesa-devel
95BuildRequires:  libXxf86dga-devel, libXxf86vm-devel
96BuildRequires:  libXrandr-devel
97BuildRequires:  libXrender-devel
98BuildRequires:  libXext-devel
99BuildRequires:  libXinerama-devel
100BuildRequires:  libXcomposite-devel
101BuildRequires:  libXmu-devel
102BuildRequires:  libXi-devel
103BuildRequires:  libXcursor-devel
104BuildRequires:  fontconfig-devel
105BuildRequires:  giflib-devel
106BuildRequires:  libtiff-devel
107BuildRequires:  pkgconfig
108BuildRequires:  libicu-devel
109BuildRequires:  freetype2-devel
110BuildRequires:  lcms2-devel
111BuildRequires:  gsm-devel
112
113%ifarch x86_64
114BuildRequires: compat32-glibc-devel
115BuildRequires: compat32-glibc-devel
116BuildRequires: compat32-libX11-devel
117BuildRequires: compat32-libxcb-devel
118BuildRequires: compat32-freetype2-devel
119BuildRequires: compat32-libSM-devel
120BuildRequires: compat32-libXext-devel
121BuildRequires: compat32-libXrender-devel
122BuildRequires: compat32-mesa-libGL-devel
123BuildRequires: compat32-mesa-libGLU-devel
124BuildRequires: compat32-mesa-libOSMesa-devel
125BuildRequires: compat32-libxml2-devel
126BuildRequires: compat32-libxslt-devel
127BuildRequires: compat32-openssl-devel
128BuildRequires: compat32-libjpeg-devel
129BuildRequires: compat32-libpng-devel
130BuildRequires: compat32-zlib-devel
131BuildRequires: compat32-alsa-lib-devel
132BuildRequires: compat32-dbus-devel
133BuildRequires: compat32-lcms2-devel
134BuildRequires: compat32-cups-devel
135BuildRequires: compat32-gnutls-devel
136BuildRequires: compat32-gstreamer-devel
137BuildRequires: compat32-gstreamer-plugins-base-devel
138BuildRequires: compat32-gsm-devel
139## extension
140BuildRequires: compat32-libXcursor-devel
141BuildRequires: compat32-libXi-devel
142BuildRequires: compat32-libXxf86vm-devel
143BuildRequires: compat32-libXrandr-devel
144BuildRequires: compat32-libXinerama-devel
145BuildRequires: compat32-libXcomposite-devel
146BuildRequires: compat32-ncurses-devel
147BuildRequires: compat32-fontconfig-devel
148BuildRequires: compat32-libtiff-devel
149BuildRequires: compat32-openldap-devel
150
151Requires:       compat32-freetype2
152Requires:       compat32-ncurses
153%endif
154
155Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
156Requires(post): desktop-file-utils >= 0.8
157Requires(preun): /sbin/chkconfig, /sbin/service
158Requires(postun): /sbin/ldconfig
159Requires(postun): desktop-file-utils >= 0.8
160
161#--------------------------------------------------------------------
162
163%description
164(WINE Is Not an Emulator)
165 While Wine is usually thought of as a Windows(TM) emulator,
166the Wine developers would prefer that users thought of
167Wine as a Windows compatibility layer for UNIX.
168 This package includes a program loader, which allows
169unmodified Windows 3.x/9x/NT binaries to run on x86 and
170x86_64 Unixes.
171Wine does not require MS Windows, but it can use native
172system .dll files if they are available.
173
174
175%description -l ja
176(WINE Is Not an Emulator)
177 WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
178開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
179互換レイヤー」と考えてくれる事を好むでしょう。
180 このパッケージはプログラムローダーを含み、これは未修正の
181Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
182させます。
183 WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
184Windows システムの .dll ファイルが存在するのならば、それを使用する
185事もできます
186
187#--------------------------------------------------------------------
188%package devel
189Summary: Wine development environment
190Summary(ja):    WINE の開発ファイルです
191Group: System Environment/Libraries
192Requires: wine = %{version}-%{release}
193
194%description devel
195This RPM contains the header files and development tools
196for the WINE libraries.
197
198%description devel -l ja
199WINEの開発用ライブラリやヘッダーファイル、そして開発用の
200アプリケーション(例:winebuild)のパッケージです
201(development packages)
202
203#--------------------------------------------------------------------
204%package init
205Summary: WINE binfmt_misc kernel function used for init file.
206Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
207Group: System Environment/Libraries
208Requires: wine = %{version}-%{release}
209
210%description init
211WINE binfmt_misc kernel function used for init file.
212WIN32-binary attribute run with a Linux-binary run the same way as possible.
213(init.d packages)
214** example **
215Until now, "$ wine /file/to/path/arege.exe" and then you were running
216 from the usual binary Linux as "$ /file/to/path/arege.exe"
217 and just be able to run.
218Of course, please be mindful of security.
219
220
221%description init -l ja
222カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
223実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
224ようにします。
225(init.d packages)
226※ 例 ※
227これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
228が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
229だけで実行できるようになります。
230無論、セキュリティに留意して下さい。
231
232
233#--------------------------------------------------------------------
234
235%prep
236
237%setup -q -n %{name}-%{version}
238%ifarch x86_64
239%patch2 -p1
240%endif
241
242# fix typo
243sed -i "s|Thamoa|Tahoma|" po/ja.po
244
245%build
246autoreconf -if
247%ifarch x86_64
248export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
249./configure \
250        --prefix=%{_prefix} \
251        --libdir=%{_libdir} \
252        --with-x \
253        --without-jack \
254        --without-capi \
255        --without-gphoto \
256        --without-hal \
257        --without-mpg123 \
258        --without-sane
259%else
260export CFLAGS="$RPM_OPT_FLAGS"
261%{configure} \
262        --prefix=%{_prefix} \
263        --with-x \
264        --without-jack \
265        --without-capi \
266        --without-gphoto \
267        --without-hal \
268        --without-mpg123 \
269        --without-sane
270%endif
271
272grep "have_x=yes" config.log || exit 1
273
274%{__make} depend
275
276%{__make} %{?_smp_mflags}
277
278%install
279rm -rf ${RPM_BUILD_ROOT}
280%{__make} install DESTDIR=${RPM_BUILD_ROOT}
281
282#-----------------------------------------------------------FC9
283mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
284
285# Allow users to launch Windows programs by just clicking on the .exe file...
286mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
287install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
288
289# add wine dir to desktop
290mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
291install -p -m 644 %{SOURCE200} \
292${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
293
294mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
295install -p -m 644 %{SOURCE201} \
296${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
297
298## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
299## %%{_datadir}/applications
300
301# install desktop files
302desktop-file-install \
303  --vendor=vine \
304  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
305  %{SOURCE100}
306
307desktop-file-install \
308  --vendor=vine \
309  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
310  %{SOURCE101}
311
312desktop-file-install \
313  --vendor=vine \
314  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
315  %{SOURCE102}
316
317desktop-file-install \
318  --vendor=vine \
319  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
320  %{SOURCE103}
321
322desktop-file-install \
323  --vendor=vine \
324  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
325  %{SOURCE104}
326
327desktop-file-install \
328  --vendor=vine \
329  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
330  %{SOURCE105}
331
332desktop-file-install \
333  --vendor=vine \
334  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
335  %{SOURCE106}
336
337desktop-file-install \
338  --vendor=vine \
339  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
340  %{SOURCE107}
341
342desktop-file-install \
343  --vendor=vine \
344  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
345  --delete-original \
346  ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
347
348#mime-types
349desktop-file-install \
350  --vendor=vine \
351  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
352  %{SOURCE300}
353
354
355## other files
356cp %{SOURCE3} README-Fedora
357cp %{SOURCE803} README-Fedora.ja
358cp %{SOURCE801} documentation/README.ja
359cp %{SOURCE804} documentation/README_add.ja
360cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
361
362mkdir -p ${RPM_BUILD_ROOT}/%{_sysconfdir}/ld.so.conf.d/
363install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
364
365# check desktop files
366%check
367desktop-file-validate \
368 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
369desktop-file-validate \
370 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
371desktop-file-validate \
372 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
373desktop-file-validate \
374 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
375desktop-file-validate \
376 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
377desktop-file-validate \
378 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
379desktop-file-validate \
380 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
381desktop-file-validate \
382 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
383desktop-file-validate \
384 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
385
386#--------------------------------------------------------------------
387%clean
388rm -rf ${RPM_BUILD_ROOT}
389
390%post
391/sbin/ldconfig
392update-desktop-database &>/dev/null || :
393### add vinelinux
394if [ "$LANG" = "ja_JP.UTF-8" ]; then
395  echo "WINEのシステムフォントをリプレースするには"
396  echo " fonts-replace-list.txt をお読み下さい。"
397else
398  echo "You need to Japanese fonts name replace, "
399  echo "See fonts-replace-list.txt ."
400fi
401
402%postun
403/sbin/ldconfig
404update-desktop-database &>/dev/null || :
405
406%post init
407if [ $1 = 1 ]; then
408/sbin/chkconfig --add wine
409/sbin/chkconfig --level 2345 wine on
410/sbin/service wine start &>/dev/null || :
411fi
412### add vinelinux
413if [ "$LANG" = "ja_JP.UTF-8" ]; then
414    echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
415    echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
416    echo "(ファイル名は /etc/init.d/wine です)"
417    echo "起動時にファイルシステムのマウントが必要です。"
418    echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
419    echo "(削除も手動でお願いします)"
420    echo ""
421    echo "# cp /etc/fstab /etc/fstab.before  ##バックアップの作成"
422    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
423    echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
424else
425    echo "WINE binfmt_misc feature from the boot files "
426    echo "to be installed and enabled 2,3,4,5 runlevel."
427    echo "(File name in the /etc/init.d/wine )"
428    echo "Filesystem mounted at boot time is required."
429    echo "Root privileges using the following command in the /etc/fstab"
430    echo "please Addenda.(Please delete manually.)"
431    echo ""
432    echo "# cp /etc/fstab /etc/fstab.before   ##(Create backup)"
433    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
434    echo "See also(en)http://www.linux.com/articles/56032 "
435fi
436
437%preun init
438if [ $1 = 0 ]; then
439        /sbin/service wine stop >/dev/null 2>&1
440        /sbin/chkconfig --del wine
441fi
442
443#--------------------------------------------------------------------
444## deleted /usr/share/applications/wine.desktop
445%files
446%defattr(-,root,root,-)
447%doc ANNOUNCE AUTHORS COPYING.LIB  LICENSE LICENSE.OLD
448%doc README VERSION
449%doc README-Fedora
450%doc README-Fedora.ja
451%doc documentation/README* documentation/ChangeLog*
452%doc documentation/ja_fonts_replace*
453%doc documentation/fonts-replace-list.txt
454### %{_bindir}/*
455%{_bindir}/msiexec
456%{_bindir}/regedit
457%{_bindir}/regsvr32
458%{_bindir}/wine
459%{_bindir}/wineboot
460%{_bindir}/wineconsole
461## %{_bindir}/wineprefixcreate
462%{_bindir}/winecfg
463%{_bindir}/wine-preloader
464# winelauncher --> Remove
465%{_bindir}/wineserver
466%{_bindir}/notepad
467%{_bindir}/winedbg
468%{_bindir}/winedump
469%{_bindir}/winefile
470%{_bindir}/winemaker
471%{_bindir}/winemine
472%{_bindir}/winepath
473## winhelp -> renamed winhlp32.exe
474%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
475%{_sysconfdir}/ld.so.conf.d/wine-32.conf
476%{_libdir}/libwine.so.1*
477%dir %{_libdir}/wine
478%{_libdir}/wine/*.cpl.so
479%{_libdir}/wine/*.exe.so
480%{_libdir}/wine/*.exe16.so
481%{_libdir}/wine/*.dll.so
482%{_libdir}/wine/*.dll16.so
483%{_libdir}/wine/*.drv.so
484%{_libdir}/wine/*.drv16.so
485%{_libdir}/wine/*.mod16.so
486## %{_libdir}/wine/*.*16
487%{_libdir}/wine/*.ds.so
488%{_libdir}/wine/*.ocx.so
489%{_libdir}/wine/*.vxd.so
490%{_libdir}/wine/*.acm.so
491%{_libdir}/wine/*.sys.so
492%{_libdir}/wine/*.tlb.so
493%dir %{_libdir}/wine/fakedlls
494%{_libdir}/wine/fakedlls/*
495%dir %{_datadir}/wine
496%{_datadir}/wine/*
497%{_datadir}/applications/vine-wine-mime-msi.desktop
498%{_datadir}/applications/vine-wine.desktop
499%{_datadir}/applications/vine-wine-regedit.desktop
500%{_datadir}/applications/vine-wine-uninstaller.desktop
501%{_datadir}/applications/vine-wine-winecfg.desktop
502%{_datadir}/applications/vine-wine-wineboot.desktop
503%{_datadir}/applications/vine-wine-notepad.desktop
504%{_datadir}/applications/vine-wine-winefile.desktop
505%{_datadir}/applications/vine-wine-winemine.desktop
506%{_datadir}/applications/vine-wine-winhelp.desktop
507%{_datadir}/desktop-directories/Wine.directory
508%{_mandir}/man1/wine.1.*
509%{_mandir}/man1/wineserver.1*
510%{_mandir}/man1/msiexec.1*
511%{_mandir}/man1/notepad.1*
512%{_mandir}/man1/regedit.1*
513%{_mandir}/man1/regsvr32.1*
514%{_mandir}/man1/wineboot.1*
515%{_mandir}/man1/winecfg.1*
516%{_mandir}/man1/wineconsole.1*
517%{_mandir}/man1/winefile.1*
518%{_mandir}/man1/winemine.1*
519%{_mandir}/man1/winepath.1*
520## %{_mandir}/man1/wineprefixcreate.1*
521%lang(de) %{_mandir}/de.UTF-8/man1/*.1*
522%lang(fr) %{_mandir}/fr.UTF-8/man1/*
523%lang(pl) %{_mandir}/pl.UTF-8/man1/wine.1*
524
525#--------------------------------------------------------------------
526%files devel
527%defattr(-,root,root,-)
528%{_bindir}/function_grep.pl
529%{_bindir}/widl
530%{_bindir}/winebuild
531%{_bindir}/winecpp
532%{_bindir}/winedump
533%{_bindir}/wineg++
534%{_bindir}/winegcc
535%{_bindir}/winemaker
536%{_bindir}/wmc
537%{_bindir}/wrc
538%{_includedir}/wine
539%{_libdir}/*.so
540
541%{_libdir}/wine/*.a
542%{_libdir}/wine/*.def
543
544%{_mandir}/man1/widl.1*
545%{_mandir}/man1/winebuild.1*
546%{_mandir}/man1/winecpp.1*
547%{_mandir}/man1/winedump.1*
548%{_mandir}/man1/winegcc.1*
549%{_mandir}/man1/winemaker.1*
550%{_mandir}/man1/wmc.1*
551%{_mandir}/man1/wrc.1*
552%{_mandir}/man1/winedbg.1*
553%{_mandir}/man1/wineg++.1*
554
555
556#--------------------------------------------------------------------
557%files init
558%defattr(-,root,root,-)
559%{_initrddir}/wine
560%doc documentation/README_add.ja
561
562#--------------------------------------------------------------------
563%changelog
564* Sun Dec 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8-1
565- new upstream release
566- remove Patch400,401,402
567- remove Source402,802
568
569* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.54-1
570- update to 1.7.54
571
572* Sat Oct 24 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.53-1
573- update to 1.7.53
574
575* Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.52-1
576- update to 1.7.52
577
578* Sun Sep 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.51-1
579- update to 1.7.51
580
581* Sun Aug 23 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.50-1
582- update to 1.7.50
583
584* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.49-1
585- update to 1.7.49
586
587* Sat Aug 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.48-1
588- update to 1.7.48
589
590* Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.44-1
591- update to 1.7.44
592
593* Sun May 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.42-1
594- update to 1.7.42
595
596* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.40-1
597- update to 1.7.40
598- update Patch2 (wine-1.7.40-x86_64_gstreamer.patch)
599- add BuildRequires: compat32-mesa-libOSMesa-devel, compat32-lcms2-devel, compat32-gsm-devel (x86_64 only)
600- add BuildRequires: mesa-libOSMesa-devel, lcms2-devel, gsm-devel
601
602* Sat Jan 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
603- new upstream release
604
605* Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
606- new upstream release
607
608* Sat Jul 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6-1
609- new upstream release
610- remove Patch1000 (wine-1.4.1-vine.patch)
611- update Patch2 (wine-1.6-x86_64_gstreamer.patch)
612
613* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.17-1
614- update to 1.5.17
615
616* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
617- new upstream release
618- update Patch1000 (wine-1.4.1-vine.patch)
619
620* Thu Mar 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4-1
621- new upstream release
622- add Patch2 (wine-1.4-x86_64_gstreamer.patch)
623- add BuildRequires: gstreamer-plugins-base-devel
624
625* Sat Jul 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
626- update to 1.2.3
627- add Requires: compat32-freetype2 (x86_64 only)
628
629* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
630- new upstream release
631
632* Thu Oct 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
633- new upstream release
634- drop Patch1
635
636* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
637- new upstream release
638- fix %configure (add configu:e and gcc option of x86_64)
639- fix %install (remove wine.desktop and change make install option)
640- add ExclusiveArch: %{ix86} x86_64
641- add BuildRequires for x86_64 (compat32 packages)
642
643* Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
644- update to 1.2-rc2
645- fix spec file
646  - if [ "$LANG" = "ja_JP.eucJP" ];
647  + if [ "$LANG" = "ja_JP.UTF-8" ];
648- convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
649  - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
650- fix %files
651- drop patches (Patch0, Patch400, Patch402)
652
653* Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
654- update BRs
655  - remove freetype-devel
656  - remove libungif-devel, add giflib-devel
657  - remove gphoto2-devel, add libgphoto2-devel
658
659* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
660- update to 1.1.29
661
662* Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
663- update to 1.1.28
664- update winepulse patches
665
666* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
667- update to 1.1.23
668- spec in utf-8
669- add patch1000 to enable FontSmoothing by deafult.
670- update pulseaudio patches
671- remove invalid Provides: Wine HQ
672- remove unneeded patches
673
674* Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
675- Wine development release 1.1.0.
676- Updated specfile (for VineSeed)
677
678#--------------------------------------------------------------------
679
680* Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
681- added  "ja_fonts_replace-*.reg" files.
682- Updated specfile
683
684* Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
685- version upgrade
686- Updated specfile
687- Update to 1.0
688- fix wine.desktop mime types (fc)
689- add desktop package including desktop files and binary handler (fc)
690- pull in some wine alsa/pulseaudio patches (fc)
691-- NEWS "June 17, 2008: Wine 1.0 Released"
692-- read http://www.winehq.org/?issue=348
693
694* Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
695- Updated specfile
696- Update to 1.0-rc4
697- NEWS "June 6, 2008: Wine 1.0-rc4 Released"
698-- ntdll: Add local defines for VIF and VIP flags.
699--  wininet: Include openssl/ssl.h before Windows headers.
700--  shell32: Fixed the French about box.
701--  ChangeLog: Moved to documentation/ChangeLog.BETA.
702--  fonts: Add a non-breaking space glyph to the Tahoma fonts.
703--  ....others , read ChangeLog
704--- Bug fixes only, we are in code freeze.
705
706* Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
707- Updated specfile
708- Update to 1.0-rc3
709- NEWS "May 30, 2008: Wine 1.0-rc3 Released"
710-- The default version is now Windows XP.
711-- Many Richedit improvements.
712-- Beginning of jscript dll support.
713-- Shell folders now respect XDG directory configuration.
714-- Many translation updates.
715-- Lots of bug fixes.
716-- * Bug fixes only, we are in code freeze.
717--- kernel32: Add a builtin 16-bit winhelp.exe.
718--- This should be moved to winhlp32.exe once we support 16-bit modules in
719--- executables.
720---- winhelp -> renamed winhlp32.exe
721---- programs: Remove winelauncher from install rules.
722
723* Fri Apr 04 2008 Seiichirou Babasaki 0.9.59
724- Updated specfile
725- Update to 0.9.59
726- NEWS.. "April 4, 2008: Wine 0.9.59 Released"
727-- * Improved support for the .NET framework.
728-- * Better services handling through a separate services.exe process.
729-- * Support for ATI fragment shader.
730-- * Better support for http proxies.
731-- * Window management fixes.
732-- * Pre-compiled fonts are now available in the source tree.
733-- * Lots of bug fixes.
734
735* Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
736- Updated specfile (split wine-init package)
737- Update to 0.9.58
738- NEWS.. "March 21, 2008: Wine 0.9.58 Released"
739--  * The default version is now Windows XP.
740--  * Many Richedit improvements.
741--  * Beginning of jscript dll support.
742--  * Shell folders now respect XDG directory configuration.
743--  * Many translation updates.
744--  * Lots of bug fixes.
745
746* Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
747- Updated specfile (*.desktop file %check .)
748- Update to 0.9.57
749- NEWS.. "March 7, 2008: Wine 0.9.57 Released"
750--  * Support for multiple OpenGL pixel formats.
751--  * Improved support for color profiles.
752--  * Many window management fixes.
753--  * Better fullscreen support.
754--  * Lots of bug fixes.
755
756* Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
757- Updated specfile
758- ("Build Tool" from the wine-package to move to devel-packages)
759- Update to 0.9.56
760- NEWS.. "February 22, 2008: Wine 0.9.56 Released"
761--  * Proper handling of OpenGL/Direct3D windows with menu bars.
762--  * Stubs for all the d3dx9_xx dlls.
763--  * Several graphics optimizations.
764--  * Many installer fixes.
765--  * Improved MIME message support.
766--  * Lots of bug fixes.
767
768* Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
769- Updated specfile (cf. VineLinux .spec file format)
770- Add Installed messages for "binfmt_misc" .
771- *.desktop file "Name" change to japanese. (UTF8)
772
773* Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
774- Import WINE - Packager: Babasaki
775- Updated specfile (SUSE base + FC9 cfg)
776- Update to 0.9.55
777- Update to 0.9.54 from FC9
778- Update to 0.9.53 from Private package
779
780# FC9 ------------------------------------------------------------- FC9
781
782* Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
783- 0.9.55-1
784- version upgrade
785
786* Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
787- 0.9.54-1
788- version upgrade
789- remove default pulseaudio workaround (#429420,#428745)
790- improve pulseaudio readme
791
792* Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
793- 0.9.53-2
794- add some missing BR
795
796* Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
797- 0.9.53-1
798- version upgrade
799
800* Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
801- 0.9.52-2
802- fix menu bug (#393641)
803
804* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
805- 0.9.52-1
806- version upgrade
807
808* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
809- 0.9.51-3
810- add -n Wine to pulseaudio workaround
811- try to fix menu bug #393641
812
813* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
814- 0.9.51-2
815- add fix for #344281 pulseaudio workaround
816- fix #253474: wine-jack should require jack-audio-connection-kit
817
818* Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
819- 0.9.51-1
820- version upgrade
821
822# ---- abbreviatio ----------------------------------------------------#
823
824# ----------and suse.
825# * Fri Mar 17 2006 - meissner@suse.de
826# - Avoid ulimit leading to out of memory situations by using
827#  the compat address space layout personality. #152115
828
Note: See TracBrowser for help on using the repository browser.