source: projects/specs/trunk/w/wine/wine-vl.spec @ 9489

Revision 9489, 25.5 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define pkg_major_version 1.7.40
2%define pkg_name wine
3%define pkg_release 1%{?_dist_release}
4
5# NEW Release: numbering rule. -- Release: 1%{?_dist_release}
6# spec file for package wine.. # base (SUSE10 and fedora core 9)
7
8Summary:        Allows running Windows 16/32/64 bit programs on Unix.
9Summary(ja):    Unix で 16/32/64ビットWindoowsプログラムを実行させます
10Name:           %{pkg_name}
11Version:        %{pkg_major_version}
12Release:        %{pkg_release}
13URL:            http://www.winehq.org/
14License:        LGPLv2+
15Group:          Applications/System
16
17#--------------------------------------------------------------------
18Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
19#--------------------------------------------------------------------
20
21Source1:        wine.init
22Source3:        wine-README-Fedora
23Source4:        wine-32.conf
24# desktop stuff
25Source100:      wine-notepad.desktop
26Source101:      wine-regedit.desktop
27Source102:      wine-uninstaller.desktop
28Source103:      wine-winecfg.desktop
29Source104:      wine-winefile.desktop
30Source105:      wine-winemine.desktop
31Source106:      wine-winhelp.desktop
32Source107:      wine-wineboot.desktop
33
34# desktop dir
35Source200:      wine.menu
36Source201:      wine.directory
37
38# mime types
39Source300:      wine-mime-msi.desktop
40
41# explain how to use wine with pulseaudio
42Source402:      README-FEDORA-PULSEAUDIO
43Patch400:       http://art.ified.ca/downloads/winepulse-0.30-configure.ac.patch
44Patch401:       http://art.ified.ca/downloads/winepulse-0.30.patch
45Patch402:       http://art.ified.ca/downloads/adding-pulseaudio-to-winecfg-0.4.1.patch
46
47Patch0:         wine-prefixfonts.patch
48Patch1:         wine-1.1.28-rpath.patch
49Patch2:         wine-1.7.40-x86_64_gstreamer.patch
50
51# ADD ja
52Source801: wine_README.ja
53Source802: README-FEDORA-PULSEAUDIO.ja
54Source803: wine-README-Fedora.ja
55Source804: wine_README_add.ja
56Source805: fonts-replace-list.txt
57Source806: ja_fonts_replace-js2ipa.reg
58Source807: ja_fonts_replace-js2vl.reg
59Source808: ja_fonts_replace-ms2ipa.reg
60Source809: ja_fonts_replace-ms2vl.reg
61
62
63Vendor: Project Vine
64Distribution: Vine Linux
65Packager: daisuke, Takemikaduchi
66
67ExclusiveArch: %{ix86} x86_64
68
69#--------------------------------------------------------------------
70BuildRoot:      %{_tmppath}/%{name}-%{version}-root
71#--------------------------------------------------------------------
72
73## FedoraCore ##
74BuildRequires: bison, flex
75BuildRequires: audiofile, audiofile-devel
76BuildRequires: alsa-lib-devel
77BuildRequires: freeglut-devel, lcms-devel
78## BuildRequires:  libieee1284-devel
79BuildRequires: libjpeg-devel, libpng-devel
80BuildRequires: libstdc++-devel
81BuildRequires: libusb-devel
82BuildRequires: libxml2-devel, libxslt-devel
83BuildRequires: openldap-devel, ncurses-devel
84BuildRequires: unixODBC-devel, openssl-devel
85# BuildRequires: sane-devel
86BuildRequires: zlib-devel
87BuildRequires: desktop-file-utils
88BuildRequires: fontforge
89## BuildRequires: gphoto2, gphoto2-devel
90## BuildRequires: jack-audio-connection-kit-devel
91## BuildRequires:  isdn4k-utils-devel
92BuildRequires: cups-devel
93BuildRequires: dbus-devel
94BuildRequires: gstreamer-plugins-base-devel
95## Requires:       %{_bindir}/xmessage
96
97## X modular(fc) > X 7.2
98BuildRequires:  libX11-devel
99BuildRequires:  mesa-libGL-devel
100BuildRequires:  mesa-libGLU-devel
101BuildRequires:  mesa-libOSMesa-devel
102BuildRequires:  libXxf86dga-devel, libXxf86vm-devel
103BuildRequires:  libXrandr-devel
104BuildRequires:  libXrender-devel
105BuildRequires:  libXext-devel
106BuildRequires:  libXinerama-devel
107BuildRequires:  libXcomposite-devel
108BuildRequires:  libXmu-devel
109BuildRequires:  libXi-devel
110BuildRequires:  libXcursor-devel
111BuildRequires:  fontconfig-devel
112BuildRequires:  giflib-devel
113BuildRequires:  libtiff-devel
114BuildRequires:  pkgconfig
115BuildRequires:  libicu-devel
116BuildRequires:  freetype2-devel
117BuildRequires:  lcms2-devel
118BuildRequires:  gsm-devel
119
120%ifarch x86_64
121BuildRequires: compat32-glibc-devel
122BuildRequires: compat32-glibc-devel
123BuildRequires: compat32-libX11-devel
124BuildRequires: compat32-libxcb-devel
125BuildRequires: compat32-freetype2-devel
126BuildRequires: compat32-libSM-devel
127BuildRequires: compat32-libXext-devel
128BuildRequires: compat32-libXrender-devel
129BuildRequires: compat32-mesa-libGL-devel
130BuildRequires: compat32-mesa-libGLU-devel
131BuildRequires: compat32-mesa-libOSMesa-devel
132BuildRequires: compat32-libxml2-devel
133BuildRequires: compat32-libxslt-devel
134BuildRequires: compat32-openssl-devel
135BuildRequires: compat32-libjpeg-devel
136BuildRequires: compat32-libpng-devel
137BuildRequires: compat32-zlib-devel
138BuildRequires: compat32-alsa-lib-devel
139BuildRequires: compat32-dbus-devel
140BuildRequires: compat32-lcms2-devel
141BuildRequires: compat32-cups-devel
142BuildRequires: compat32-gnutls-devel
143BuildRequires: compat32-gstreamer-devel
144BuildRequires: compat32-gstreamer-plugins-base-devel
145BuildRequires: compat32-gsm-devel
146## extension
147BuildRequires: compat32-libXcursor-devel
148BuildRequires: compat32-libXi-devel
149BuildRequires: compat32-libXxf86vm-devel
150BuildRequires: compat32-libXrandr-devel
151BuildRequires: compat32-libXinerama-devel
152BuildRequires: compat32-libXcomposite-devel
153BuildRequires: compat32-ncurses-devel
154BuildRequires: compat32-fontconfig-devel
155BuildRequires: compat32-libtiff-devel
156BuildRequires: compat32-openldap-devel
157
158Requires:       compat32-freetype2
159Requires:       compat32-ncurses
160%endif
161
162Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
163Requires(post): desktop-file-utils >= 0.8
164Requires(preun): /sbin/chkconfig, /sbin/service
165Requires(postun): /sbin/ldconfig
166Requires(postun): desktop-file-utils >= 0.8
167
168#--------------------------------------------------------------------
169
170%description
171(WINE Is Not an Emulator)
172 While Wine is usually thought of as a Windows(TM) emulator,
173the Wine developers would prefer that users thought of
174Wine as a Windows compatibility layer for UNIX.
175 This package includes a program loader, which allows
176unmodified Windows 3.x/9x/NT binaries to run on x86 and
177x86_64 Unixes.
178Wine does not require MS Windows, but it can use native
179system .dll files if they are available.
180
181
182%description -l ja
183(WINE Is Not an Emulator)
184 WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
185開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
186互換レイヤー」と考えてくれる事を好むでしょう。
187 このパッケージはプログラムローダーを含み、これは未修正の
188Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
189させます。
190 WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
191Windows システムの .dll ファイルが存在するのならば、それを使用する
192事もできます
193
194#--------------------------------------------------------------------
195%package devel
196Summary: Wine development environment
197Summary(ja):    WINE の開発ファイルです
198Group: System Environment/Libraries
199Requires: wine = %{version}-%{release}
200
201%description devel
202This RPM contains the header files and development tools
203for the WINE libraries.
204
205%description devel -l ja
206WINEの開発用ライブラリやヘッダーファイル、そして開発用の
207アプリケーション(例:winebuild)のパッケージです
208(development packages)
209
210#--------------------------------------------------------------------
211%package init
212Summary: WINE binfmt_misc kernel function used for init file.
213Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
214Group: System Environment/Libraries
215Requires: wine = %{version}-%{release}
216
217%description init
218WINE binfmt_misc kernel function used for init file.
219WIN32-binary attribute run with a Linux-binary run the same way as possible.
220(init.d packages)
221** example **
222Until now, "$ wine /file/to/path/arege.exe" and then you were running
223 from the usual binary Linux as "$ /file/to/path/arege.exe"
224 and just be able to run.
225Of course, please be mindful of security.
226
227
228%description init -l ja
229カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
230実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
231ようにします。
232(init.d packages)
233※ 例 ※
234これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
235が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
236だけで実行できるようになります。
237無論、セキュリティに留意して下さい。
238
239
240#--------------------------------------------------------------------
241
242%prep
243
244%setup -q -n %{name}-%{version}
245%ifarch x86_64
246%patch2 -p1
247%endif
248%patch401 -p1
249
250%build
251autoreconf -if
252%ifarch x86_64
253export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
254./configure \
255        --prefix=%{_prefix} \
256        --libdir=%{_libdir} \
257        --with-x \
258        --without-jack \
259        --without-capi \
260        --without-gphoto \
261        --without-hal \
262        --without-mpg123 \
263        --without-sane
264%else
265export CFLAGS="$RPM_OPT_FLAGS"
266%{configure} \
267        --prefix=%{_prefix} \
268        --with-x \
269        --without-jack \
270        --without-capi \
271        --without-gphoto \
272        --without-hal \
273        --without-mpg123 \
274        --without-sane
275%endif
276
277grep "have_x=yes" config.log || exit 1
278
279%{__make} depend
280
281%{__make} %{?_smp_mflags}
282
283%install
284rm -rf ${RPM_BUILD_ROOT}
285%{__make} install DESTDIR=${RPM_BUILD_ROOT}
286
287#-----------------------------------------------------------FC9
288mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
289
290# Allow users to launch Windows programs by just clicking on the .exe file...
291mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
292install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
293
294# add wine dir to desktop
295mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
296install -p -m 644 %{SOURCE200} \
297${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
298
299mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
300install -p -m 644 %{SOURCE201} \
301${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
302
303## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
304## %%{_datadir}/applications
305
306# install desktop files
307desktop-file-install \
308  --vendor=vine \
309  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
310  %{SOURCE100}
311
312desktop-file-install \
313  --vendor=vine \
314  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
315  %{SOURCE101}
316
317desktop-file-install \
318  --vendor=vine \
319  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
320  %{SOURCE102}
321
322desktop-file-install \
323  --vendor=vine \
324  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
325  %{SOURCE103}
326
327desktop-file-install \
328  --vendor=vine \
329  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
330  %{SOURCE104}
331
332desktop-file-install \
333  --vendor=vine \
334  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
335  %{SOURCE105}
336
337desktop-file-install \
338  --vendor=vine \
339  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
340  %{SOURCE106}
341
342desktop-file-install \
343  --vendor=vine \
344  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
345  %{SOURCE107}
346
347desktop-file-install \
348  --vendor=vine \
349  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
350  --delete-original \
351  ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
352
353#mime-types
354desktop-file-install \
355  --vendor=vine \
356  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
357  %{SOURCE300}
358
359
360## other files
361cp %{SOURCE3} README-Fedora
362cp %{SOURCE803} README-Fedora.ja
363cp %{SOURCE801} documentation/README.ja
364cp %{SOURCE804} documentation/README_add.ja
365cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
366
367mkdir -p ${RPM_BUILD_ROOT}/%{_sysconfdir}/ld.so.conf.d/
368install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
369
370
371# deploy pulseaudio readme (802jp)
372cp %{SOURCE402} .
373cp %{SOURCE802} .
374
375# check desktop files
376%check
377desktop-file-validate \
378 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
379desktop-file-validate \
380 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
381desktop-file-validate \
382 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
383desktop-file-validate \
384 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
385desktop-file-validate \
386 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
387desktop-file-validate \
388 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
389desktop-file-validate \
390 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
391desktop-file-validate \
392 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
393desktop-file-validate \
394 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
395
396#--------------------------------------------------------------------
397%clean
398rm -rf ${RPM_BUILD_ROOT}
399
400%post
401/sbin/ldconfig
402update-desktop-database &>/dev/null || :
403### add vinelinux
404if [ "$LANG" = "ja_JP.UTF-8" ]; then
405  echo "WINEのシステムフォントをリプレースするには"
406  echo " fonts-replace-list.txt をお読み下さい。"
407else
408  echo "You need to Japanese fonts name replace, "
409  echo "See fonts-replace-list.txt ."
410fi
411
412%postun
413/sbin/ldconfig
414update-desktop-database &>/dev/null || :
415
416%post init
417if [ $1 = 1 ]; then
418/sbin/chkconfig --add wine
419/sbin/chkconfig --level 2345 wine on
420/sbin/service wine start &>/dev/null || :
421fi
422### add vinelinux
423if [ "$LANG" = "ja_JP.UTF-8" ]; then
424    echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
425    echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
426    echo "(ファイル名は /etc/init.d/wine です)"
427    echo "起動時にファイルシステムのマウントが必要です。"
428    echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
429    echo "(削除も手動でお願いします)"
430    echo ""
431    echo "# cp /etc/fstab /etc/fstab.before  ##バックアップの作成"
432    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
433    echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
434else
435    echo "WINE binfmt_misc feature from the boot files "
436    echo "to be installed and enabled 2,3,4,5 runlevel."
437    echo "(File name in the /etc/init.d/wine )"
438    echo "Filesystem mounted at boot time is required."
439    echo "Root privileges using the following command in the /etc/fstab"
440    echo "please Addenda.(Please delete manually.)"
441    echo ""
442    echo "# cp /etc/fstab /etc/fstab.before   ##(Create backup)"
443    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
444    echo "See also(en)http://www.linux.com/articles/56032 "
445fi
446
447%preun init
448if [ $1 = 0 ]; then
449        /sbin/service wine stop >/dev/null 2>&1
450        /sbin/chkconfig --del wine
451fi
452
453#--------------------------------------------------------------------
454## deleted /usr/share/applications/wine.desktop
455%files
456%defattr(-,root,root,-)
457%doc ANNOUNCE AUTHORS COPYING.LIB  LICENSE LICENSE.OLD
458%doc README VERSION
459%doc README-FEDORA-PULSEAUDIO
460%doc README-FEDORA-PULSEAUDIO.ja
461%doc README-Fedora
462%doc README-Fedora.ja
463%doc documentation/README* documentation/ChangeLog*
464%doc documentation/ja_fonts_replace*
465%doc documentation/fonts-replace-list.txt
466### %{_bindir}/*
467%{_bindir}/msiexec
468%{_bindir}/regedit
469%{_bindir}/regsvr32
470%{_bindir}/wine
471%{_bindir}/wineboot
472%{_bindir}/wineconsole
473## %{_bindir}/wineprefixcreate
474%{_bindir}/winecfg
475%{_bindir}/wine-preloader
476# winelauncher --> Remove
477%{_bindir}/wineserver
478%{_bindir}/notepad
479%{_bindir}/winedbg
480%{_bindir}/winedump
481%{_bindir}/winefile
482%{_bindir}/winemaker
483%{_bindir}/winemine
484%{_bindir}/winepath
485## winhelp -> renamed winhlp32.exe
486%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
487%{_sysconfdir}/ld.so.conf.d/wine-32.conf
488%{_libdir}/libwine.so.1*
489%dir %{_libdir}/wine
490%{_libdir}/wine/*.cpl.so
491%{_libdir}/wine/*.exe.so
492%{_libdir}/wine/*.exe16.so
493%{_libdir}/wine/*.dll.so
494%{_libdir}/wine/*.dll16.so
495%{_libdir}/wine/*.drv.so
496%{_libdir}/wine/*.drv16.so
497%{_libdir}/wine/*.mod16.so
498## %{_libdir}/wine/*.*16
499%{_libdir}/wine/*.ds.so
500%{_libdir}/wine/*.ocx.so
501%{_libdir}/wine/*.vxd.so
502%{_libdir}/wine/*.acm.so
503%{_libdir}/wine/*.sys.so
504%{_libdir}/wine/*.tlb.so
505%dir %{_libdir}/wine/fakedlls
506%{_libdir}/wine/fakedlls/*
507%dir %{_datadir}/wine
508%{_datadir}/wine/*
509%{_datadir}/applications/vine-wine-mime-msi.desktop
510%{_datadir}/applications/vine-wine.desktop
511%{_datadir}/applications/vine-wine-regedit.desktop
512%{_datadir}/applications/vine-wine-uninstaller.desktop
513%{_datadir}/applications/vine-wine-winecfg.desktop
514%{_datadir}/applications/vine-wine-wineboot.desktop
515%{_datadir}/applications/vine-wine-notepad.desktop
516%{_datadir}/applications/vine-wine-winefile.desktop
517%{_datadir}/applications/vine-wine-winemine.desktop
518%{_datadir}/applications/vine-wine-winhelp.desktop
519%{_datadir}/desktop-directories/Wine.directory
520%{_mandir}/man1/wine.1.*
521%{_mandir}/man1/wineserver.1*
522%{_mandir}/man1/msiexec.1*
523%{_mandir}/man1/notepad.1*
524%{_mandir}/man1/regedit.1*
525%{_mandir}/man1/regsvr32.1*
526%{_mandir}/man1/wineboot.1*
527%{_mandir}/man1/winecfg.1*
528%{_mandir}/man1/wineconsole.1*
529%{_mandir}/man1/winefile.1*
530%{_mandir}/man1/winemine.1*
531%{_mandir}/man1/winepath.1*
532## %{_mandir}/man1/wineprefixcreate.1*
533%lang(de) %{_mandir}/de.UTF-8/man1/*.1*
534%lang(fr) %{_mandir}/fr.UTF-8/man1/*
535%lang(pl) %{_mandir}/pl.UTF-8/man1/wine.1*
536
537#--------------------------------------------------------------------
538%files devel
539%defattr(-,root,root,-)
540%{_bindir}/function_grep.pl
541%{_bindir}/widl
542%{_bindir}/winebuild
543%{_bindir}/winecpp
544%{_bindir}/winedump
545%{_bindir}/wineg++
546%{_bindir}/winegcc
547%{_bindir}/winemaker
548%{_bindir}/wmc
549%{_bindir}/wrc
550%{_includedir}/wine
551%{_libdir}/*.so
552
553%{_libdir}/wine/*.a
554%{_libdir}/wine/*.def
555
556%{_mandir}/man1/widl.1*
557%{_mandir}/man1/winebuild.1*
558%{_mandir}/man1/winecpp.1*
559%{_mandir}/man1/winedump.1*
560%{_mandir}/man1/winegcc.1*
561%{_mandir}/man1/winemaker.1*
562%{_mandir}/man1/wmc.1*
563%{_mandir}/man1/wrc.1*
564%{_mandir}/man1/winedbg.1*
565%{_mandir}/man1/wineg++.1*
566
567
568#--------------------------------------------------------------------
569%files init
570%defattr(-,root,root,-)
571%{_initrddir}/wine
572%doc documentation/README_add.ja
573
574#--------------------------------------------------------------------
575%changelog
576* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.40-1
577- update to 1.7.40
578- update Patch2 (wine-1.7.40-x86_64_gstreamer.patch)
579- add BuildRequires: compat32-mesa-libOSMesa-devel, compat32-lcms2-devel, compat32-gsm-devel (x86_64 only)
580- add BuildRequires: mesa-libOSMesa-devel, lcms2-devel, gsm-devel
581
582* Sat Jan 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
583- new upstream release
584
585* Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
586- new upstream release
587
588* Sat Jul 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6-1
589- new upstream release
590- remove Patch1000 (wine-1.4.1-vine.patch)
591- update Patch2 (wine-1.6-x86_64_gstreamer.patch)
592
593* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.17-1
594- update to 1.5.17
595
596* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
597- new upstream release
598- update Patch1000 (wine-1.4.1-vine.patch)
599
600* Thu Mar 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4-1
601- new upstream release
602- add Patch2 (wine-1.4-x86_64_gstreamer.patch)
603- add BuildRequires: gstreamer-plugins-base-devel
604
605* Sat Jul 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
606- update to 1.2.3
607- add Requires: compat32-freetype2 (x86_64 only)
608
609* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
610- new upstream release
611
612* Thu Oct 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
613- new upstream release
614- drop Patch1
615
616* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
617- new upstream release
618- fix %configure (add configu:e and gcc option of x86_64)
619- fix %install (remove wine.desktop and change make install option)
620- add ExclusiveArch: %{ix86} x86_64
621- add BuildRequires for x86_64 (compat32 packages)
622
623* Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
624- update to 1.2-rc2
625- fix spec file
626  - if [ "$LANG" = "ja_JP.eucJP" ];
627  + if [ "$LANG" = "ja_JP.UTF-8" ];
628- convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
629  - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
630- fix %files
631- drop patches (Patch0, Patch400, Patch402)
632
633* Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
634- update BRs
635  - remove freetype-devel
636  - remove libungif-devel, add giflib-devel
637  - remove gphoto2-devel, add libgphoto2-devel
638
639* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
640- update to 1.1.29
641
642* Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
643- update to 1.1.28
644- update winepulse patches
645
646* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
647- update to 1.1.23
648- spec in utf-8
649- add patch1000 to enable FontSmoothing by deafult.
650- update pulseaudio patches
651- remove invalid Provides: Wine HQ
652- remove unneeded patches
653
654* Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
655- Wine development release 1.1.0.
656- Updated specfile (for VineSeed)
657
658#--------------------------------------------------------------------
659
660* Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
661- added  "ja_fonts_replace-*.reg" files.
662- Updated specfile
663
664* Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
665- version upgrade
666- Updated specfile
667- Update to 1.0
668- fix wine.desktop mime types (fc)
669- add desktop package including desktop files and binary handler (fc)
670- pull in some wine alsa/pulseaudio patches (fc)
671-- NEWS "June 17, 2008: Wine 1.0 Released"
672-- read http://www.winehq.org/?issue=348
673
674* Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
675- Updated specfile
676- Update to 1.0-rc4
677- NEWS "June 6, 2008: Wine 1.0-rc4 Released"
678-- ntdll: Add local defines for VIF and VIP flags.
679--  wininet: Include openssl/ssl.h before Windows headers.
680--  shell32: Fixed the French about box.
681--  ChangeLog: Moved to documentation/ChangeLog.BETA.
682--  fonts: Add a non-breaking space glyph to the Tahoma fonts.
683--  ....others , read ChangeLog
684--- Bug fixes only, we are in code freeze.
685
686* Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
687- Updated specfile
688- Update to 1.0-rc3
689- NEWS "May 30, 2008: Wine 1.0-rc3 Released"
690-- The default version is now Windows XP.
691-- Many Richedit improvements.
692-- Beginning of jscript dll support.
693-- Shell folders now respect XDG directory configuration.
694-- Many translation updates.
695-- Lots of bug fixes.
696-- * Bug fixes only, we are in code freeze.
697--- kernel32: Add a builtin 16-bit winhelp.exe.
698--- This should be moved to winhlp32.exe once we support 16-bit modules in
699--- executables.
700---- winhelp -> renamed winhlp32.exe
701---- programs: Remove winelauncher from install rules.
702
703* Fri Apr 04 2008 Seiichirou Babasaki 0.9.59
704- Updated specfile
705- Update to 0.9.59
706- NEWS.. "April 4, 2008: Wine 0.9.59 Released"
707-- * Improved support for the .NET framework.
708-- * Better services handling through a separate services.exe process.
709-- * Support for ATI fragment shader.
710-- * Better support for http proxies.
711-- * Window management fixes.
712-- * Pre-compiled fonts are now available in the source tree.
713-- * Lots of bug fixes.
714
715* Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
716- Updated specfile (split wine-init package)
717- Update to 0.9.58
718- NEWS.. "March 21, 2008: Wine 0.9.58 Released"
719--  * The default version is now Windows XP.
720--  * Many Richedit improvements.
721--  * Beginning of jscript dll support.
722--  * Shell folders now respect XDG directory configuration.
723--  * Many translation updates.
724--  * Lots of bug fixes.
725
726* Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
727- Updated specfile (*.desktop file %check .)
728- Update to 0.9.57
729- NEWS.. "March 7, 2008: Wine 0.9.57 Released"
730--  * Support for multiple OpenGL pixel formats.
731--  * Improved support for color profiles.
732--  * Many window management fixes.
733--  * Better fullscreen support.
734--  * Lots of bug fixes.
735
736* Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
737- Updated specfile
738- ("Build Tool" from the wine-package to move to devel-packages)
739- Update to 0.9.56
740- NEWS.. "February 22, 2008: Wine 0.9.56 Released"
741--  * Proper handling of OpenGL/Direct3D windows with menu bars.
742--  * Stubs for all the d3dx9_xx dlls.
743--  * Several graphics optimizations.
744--  * Many installer fixes.
745--  * Improved MIME message support.
746--  * Lots of bug fixes.
747
748* Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
749- Updated specfile (cf. VineLinux .spec file format)
750- Add Installed messages for "binfmt_misc" .
751- *.desktop file "Name" change to japanese. (UTF8)
752
753* Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
754- Import WINE - Packager: Babasaki
755- Updated specfile (SUSE base + FC9 cfg)
756- Update to 0.9.55
757- Update to 0.9.54 from FC9
758- Update to 0.9.53 from Private package
759
760# FC9 ------------------------------------------------------------- FC9
761
762* Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
763- 0.9.55-1
764- version upgrade
765
766* Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
767- 0.9.54-1
768- version upgrade
769- remove default pulseaudio workaround (#429420,#428745)
770- improve pulseaudio readme
771
772* Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
773- 0.9.53-2
774- add some missing BR
775
776* Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
777- 0.9.53-1
778- version upgrade
779
780* Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
781- 0.9.52-2
782- fix menu bug (#393641)
783
784* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
785- 0.9.52-1
786- version upgrade
787
788* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
789- 0.9.51-3
790- add -n Wine to pulseaudio workaround
791- try to fix menu bug #393641
792
793* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
794- 0.9.51-2
795- add fix for #344281 pulseaudio workaround
796- fix #253474: wine-jack should require jack-audio-connection-kit
797
798* Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
799- 0.9.51-1
800- version upgrade
801
802# ---- abbreviatio ----------------------------------------------------#
803
804# ----------and suse.
805# * Fri Mar 17 2006 - meissner@suse.de
806# - Avoid ulimit leading to out of memory situations by using
807#  the compat address space layout personality. #152115
808
Note: See TracBrowser for help on using the repository browser.