source: projects/specs/trunk/w/wine/wine-vl.spec @ 8151

Revision 8151, 25.0 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1%define pkg_major_version 1.6.2
2%define pkg_name wine
3%define pkg_release 1%{?_dist_release}
4
5# NEW Release: numbering rule. -- Release: 1%{?_dist_release}
6# spec file for package wine.. # base (SUSE10 and fedora core 9)
7
8Summary:        Allows running Windows 16/32/64 bit programs on Unix.
9Summary(ja):    Unix で 16/32/64ビットWindoowsプログラムを実行させます
10Name:           %{pkg_name}
11Version:        %{pkg_major_version}
12Release:        %{pkg_release}
13URL:            http://www.winehq.org/
14License:        LGPLv2+
15Group:          Applications/System
16
17#--------------------------------------------------------------------
18Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
19#--------------------------------------------------------------------
20
21Source1:        wine.init
22Source3:        wine-README-Fedora
23Source4:        wine-32.conf
24# desktop stuff
25Source100:      wine-notepad.desktop
26Source101:      wine-regedit.desktop
27Source102:      wine-uninstaller.desktop
28Source103:      wine-winecfg.desktop
29Source104:      wine-winefile.desktop
30Source105:      wine-winemine.desktop
31Source106:      wine-winhelp.desktop
32Source107:      wine-wineboot.desktop
33
34# desktop dir
35Source200:      wine.menu
36Source201:      wine.directory
37
38# mime types
39Source300:      wine-mime-msi.desktop
40
41# explain how to use wine with pulseaudio
42Source402:      README-FEDORA-PULSEAUDIO
43Patch400:       http://art.ified.ca/downloads/winepulse-0.30-configure.ac.patch
44Patch401:       http://art.ified.ca/downloads/winepulse-0.30.patch
45Patch402:       http://art.ified.ca/downloads/adding-pulseaudio-to-winecfg-0.4.1.patch
46
47Patch0:         wine-prefixfonts.patch
48Patch1:         wine-1.1.28-rpath.patch
49Patch2:         wine-1.6-x86_64_gstreamer.patch
50
51# ADD ja
52Source801: wine_README.ja
53Source802: README-FEDORA-PULSEAUDIO.ja
54Source803: wine-README-Fedora.ja
55Source804: wine_README_add.ja
56Source805: fonts-replace-list.txt
57Source806: ja_fonts_replace-js2ipa.reg
58Source807: ja_fonts_replace-js2vl.reg
59Source808: ja_fonts_replace-ms2ipa.reg
60Source809: ja_fonts_replace-ms2vl.reg
61
62
63Vendor: Project Vine
64Distribution: Vine Linux
65Packager: daisuke, Takemikaduchi
66
67ExclusiveArch: %{ix86} x86_64
68
69#--------------------------------------------------------------------
70BuildRoot:      %{_tmppath}/%{name}-%{version}-root
71#--------------------------------------------------------------------
72
73## FedoraCore ##
74BuildRequires: bison, flex
75BuildRequires: audiofile, audiofile-devel
76BuildRequires: alsa-lib-devel
77BuildRequires: freeglut-devel, lcms-devel
78## BuildRequires:  libieee1284-devel
79BuildRequires: libjpeg-devel, libpng-devel
80BuildRequires: libstdc++-devel
81BuildRequires: libusb-devel
82BuildRequires: libxml2-devel, libxslt-devel
83BuildRequires: openldap-devel, ncurses-devel
84BuildRequires: unixODBC-devel, openssl-devel
85# BuildRequires: sane-devel
86BuildRequires: zlib-devel
87BuildRequires: desktop-file-utils
88BuildRequires: fontforge
89## BuildRequires: gphoto2, gphoto2-devel
90## BuildRequires: jack-audio-connection-kit-devel
91## BuildRequires:  isdn4k-utils-devel
92BuildRequires: cups-devel
93BuildRequires: dbus-devel
94BuildRequires: gstreamer-plugins-base-devel
95## Requires:       %{_bindir}/xmessage
96
97## X modular(fc) > X 7.2
98BuildRequires:  libX11-devel
99BuildRequires:  mesa-libGL-devel, mesa-libGLU-devel
100BuildRequires:  libXxf86dga-devel, libXxf86vm-devel
101BuildRequires:  libXrandr-devel
102BuildRequires:  libXrender-devel
103BuildRequires:  libXext-devel
104BuildRequires:  libXinerama-devel
105BuildRequires:  libXcomposite-devel
106BuildRequires:  libXmu-devel
107BuildRequires:  libXi-devel
108BuildRequires:  libXcursor-devel
109BuildRequires:  fontconfig-devel
110BuildRequires:  giflib-devel
111BuildRequires:  libtiff-devel
112BuildRequires:  pkgconfig
113BuildRequires:  libicu-devel
114BuildRequires:  freetype2-devel
115
116%ifarch x86_64
117BuildRequires: compat32-glibc-devel
118BuildRequires: compat32-glibc-devel
119BuildRequires: compat32-libX11-devel
120BuildRequires: compat32-libxcb-devel
121BuildRequires: compat32-freetype2-devel
122BuildRequires: compat32-libSM-devel
123BuildRequires: compat32-libXext-devel
124BuildRequires: compat32-libXrender-devel
125BuildRequires: compat32-mesa-libGL-devel
126BuildRequires: compat32-mesa-libGLU-devel
127BuildRequires: compat32-libxml2-devel
128BuildRequires: compat32-libxslt-devel
129BuildRequires: compat32-openssl-devel
130BuildRequires: compat32-libjpeg-devel
131BuildRequires: compat32-libpng-devel
132BuildRequires: compat32-zlib-devel
133BuildRequires: compat32-alsa-lib-devel
134BuildRequires: compat32-dbus-devel
135BuildRequires: compat32-lcms-devel
136BuildRequires: compat32-cups-devel
137BuildRequires: compat32-gnutls-devel
138BuildRequires: compat32-gstreamer-devel
139BuildRequires: compat32-gstreamer-plugins-base-devel
140## extension
141BuildRequires: compat32-libXcursor-devel
142BuildRequires: compat32-libXi-devel
143BuildRequires: compat32-libXxf86vm-devel
144BuildRequires: compat32-libXrandr-devel
145BuildRequires: compat32-libXinerama-devel
146BuildRequires: compat32-libXcomposite-devel
147BuildRequires: compat32-ncurses-devel
148BuildRequires: compat32-fontconfig-devel
149BuildRequires: compat32-libtiff-devel
150BuildRequires: compat32-openldap-devel
151
152Requires:       compat32-freetype2
153Requires:       compat32-ncurses
154%endif
155
156Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
157Requires(post): desktop-file-utils >= 0.8
158Requires(preun): /sbin/chkconfig, /sbin/service
159Requires(postun): /sbin/ldconfig
160Requires(postun): desktop-file-utils >= 0.8
161
162#--------------------------------------------------------------------
163
164%description
165(WINE Is Not an Emulator)
166 While Wine is usually thought of as a Windows(TM) emulator,
167the Wine developers would prefer that users thought of
168Wine as a Windows compatibility layer for UNIX.
169 This package includes a program loader, which allows
170unmodified Windows 3.x/9x/NT binaries to run on x86 and
171x86_64 Unixes.
172Wine does not require MS Windows, but it can use native
173system .dll files if they are available.
174
175
176%description -l ja
177(WINE Is Not an Emulator)
178 WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
179開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
180互換レイヤー」と考えてくれる事を好むでしょう。
181 このパッケージはプログラムローダーを含み、これは未修正の
182Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
183させます。
184 WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
185Windows システムの .dll ファイルが存在するのならば、それを使用する
186事もできます
187
188#--------------------------------------------------------------------
189%package devel
190Summary: Wine development environment
191Summary(ja):    WINE の開発ファイルです
192Group: System Environment/Libraries
193Requires: wine = %{version}-%{release}
194
195%description devel
196This RPM contains the header files and development tools
197for the WINE libraries.
198
199%description devel -l ja
200WINEの開発用ライブラリやヘッダーファイル、そして開発用の
201アプリケーション(例:winebuild)のパッケージです
202(development packages)
203
204#--------------------------------------------------------------------
205%package init
206Summary: WINE binfmt_misc kernel function used for init file.
207Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
208Group: System Environment/Libraries
209Requires: wine = %{version}-%{release}
210
211%description init
212WINE binfmt_misc kernel function used for init file.
213WIN32-binary attribute run with a Linux-binary run the same way as possible.
214(init.d packages)
215** example **
216Until now, "$ wine /file/to/path/arege.exe" and then you were running
217 from the usual binary Linux as "$ /file/to/path/arege.exe"
218 and just be able to run.
219Of course, please be mindful of security.
220
221
222%description init -l ja
223カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
224実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
225ようにします。
226(init.d packages)
227※ 例 ※
228これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
229が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
230だけで実行できるようになります。
231無論、セキュリティに留意して下さい。
232
233
234#--------------------------------------------------------------------
235
236%prep
237
238%setup -q -n %{name}-%{version}
239%ifarch x86_64
240%patch2 -p1
241%endif
242%patch401 -p1
243
244%build
245autoreconf -if
246%ifarch x86_64
247export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
248./configure \
249        --prefix=%{_prefix} \
250        --libdir=%{_libdir} \
251        --with-x \
252        --without-jack \
253        --without-capi \
254        --without-gphoto \
255        --without-hal \
256        --without-mpg123 \
257        --without-sane
258%else
259export CFLAGS="$RPM_OPT_FLAGS"
260%{configure} \
261        --prefix=%{_prefix} \
262        --with-x \
263        --without-jack \
264        --without-capi \
265        --without-gphoto \
266        --without-hal \
267        --without-mpg123 \
268        --without-sane
269%endif
270
271grep "have_x=yes" config.log || exit 1
272
273%{__make} depend
274
275%{__make} %{?_smp_mflags}
276
277%install
278rm -rf ${RPM_BUILD_ROOT}
279%{__make} install DESTDIR=${RPM_BUILD_ROOT}
280
281#-----------------------------------------------------------FC9
282mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
283
284# Allow users to launch Windows programs by just clicking on the .exe file...
285mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
286install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
287
288# add wine dir to desktop
289mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
290install -p -m 644 %{SOURCE200} \
291${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
292
293mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
294install -p -m 644 %{SOURCE201} \
295${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
296
297## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
298## %%{_datadir}/applications
299
300# install desktop files
301desktop-file-install \
302  --vendor=vine \
303  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
304  %{SOURCE100}
305
306desktop-file-install \
307  --vendor=vine \
308  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
309  %{SOURCE101}
310
311desktop-file-install \
312  --vendor=vine \
313  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
314  %{SOURCE102}
315
316desktop-file-install \
317  --vendor=vine \
318  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
319  %{SOURCE103}
320
321desktop-file-install \
322  --vendor=vine \
323  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
324  %{SOURCE104}
325
326desktop-file-install \
327  --vendor=vine \
328  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
329  %{SOURCE105}
330
331desktop-file-install \
332  --vendor=vine \
333  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
334  %{SOURCE106}
335
336desktop-file-install \
337  --vendor=vine \
338  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
339  %{SOURCE107}
340
341desktop-file-install \
342  --vendor=vine \
343  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
344  --delete-original \
345  ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
346
347#mime-types
348desktop-file-install \
349  --vendor=vine \
350  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
351  %{SOURCE300}
352
353
354## other files
355cp %{SOURCE3} README-Fedora
356cp %{SOURCE803} README-Fedora.ja
357cp %{SOURCE801} documentation/README.ja
358cp %{SOURCE804} documentation/README_add.ja
359cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
360
361mkdir -p ${RPM_BUILD_ROOT}/%{_sysconfdir}/ld.so.conf.d/
362install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
363
364
365# deploy pulseaudio readme (802jp)
366cp %{SOURCE402} .
367cp %{SOURCE802} .
368
369# check desktop files
370%check
371desktop-file-validate \
372 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
373desktop-file-validate \
374 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
375desktop-file-validate \
376 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
377desktop-file-validate \
378 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
379desktop-file-validate \
380 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
381desktop-file-validate \
382 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
383desktop-file-validate \
384 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
385desktop-file-validate \
386 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
387desktop-file-validate \
388 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
389
390#--------------------------------------------------------------------
391%clean
392rm -rf ${RPM_BUILD_ROOT}
393
394%post
395/sbin/ldconfig
396update-desktop-database &>/dev/null || :
397### add vinelinux
398if [ "$LANG" = "ja_JP.UTF-8" ]; then
399  echo "WINEのシステムフォントをリプレースするには"
400  echo " fonts-replace-list.txt をお読み下さい。"
401else
402  echo "You need to Japanese fonts name replace, "
403  echo "See fonts-replace-list.txt ."
404fi
405
406%postun
407/sbin/ldconfig
408update-desktop-database &>/dev/null || :
409
410%post init
411if [ $1 = 1 ]; then
412/sbin/chkconfig --add wine
413/sbin/chkconfig --level 2345 wine on
414/sbin/service wine start &>/dev/null || :
415fi
416### add vinelinux
417if [ "$LANG" = "ja_JP.UTF-8" ]; then
418    echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
419    echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
420    echo "(ファイル名は /etc/init.d/wine です)"
421    echo "起動時にファイルシステムのマウントが必要です。"
422    echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
423    echo "(削除も手動でお願いします)"
424    echo ""
425    echo "# cp /etc/fstab /etc/fstab.before  ##バックアップの作成"
426    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
427    echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
428else
429    echo "WINE binfmt_misc feature from the boot files "
430    echo "to be installed and enabled 2,3,4,5 runlevel."
431    echo "(File name in the /etc/init.d/wine )"
432    echo "Filesystem mounted at boot time is required."
433    echo "Root privileges using the following command in the /etc/fstab"
434    echo "please Addenda.(Please delete manually.)"
435    echo ""
436    echo "# cp /etc/fstab /etc/fstab.before   ##(Create backup)"
437    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
438    echo "See also(en)http://www.linux.com/articles/56032 "
439fi
440
441%preun init
442if [ $1 = 0 ]; then
443        /sbin/service wine stop >/dev/null 2>&1
444        /sbin/chkconfig --del wine
445fi
446
447#--------------------------------------------------------------------
448## deleted /usr/share/applications/wine.desktop
449%files
450%defattr(-,root,root,-)
451%doc ANNOUNCE AUTHORS COPYING.LIB  LICENSE LICENSE.OLD
452%doc README VERSION
453%doc README-FEDORA-PULSEAUDIO
454%doc README-FEDORA-PULSEAUDIO.ja
455%doc README-Fedora
456%doc README-Fedora.ja
457%doc documentation/README* documentation/ChangeLog*
458%doc documentation/ja_fonts_replace*
459%doc documentation/fonts-replace-list.txt
460### %{_bindir}/*
461%{_bindir}/msiexec
462%{_bindir}/regedit
463%{_bindir}/regsvr32
464%{_bindir}/wine
465%{_bindir}/wineboot
466%{_bindir}/wineconsole
467## %{_bindir}/wineprefixcreate
468%{_bindir}/winecfg
469%{_bindir}/wine-preloader
470# winelauncher --> Remove
471%{_bindir}/wineserver
472%{_bindir}/notepad
473%{_bindir}/winedbg
474%{_bindir}/winedump
475%{_bindir}/winefile
476%{_bindir}/winemaker
477%{_bindir}/winemine
478%{_bindir}/winepath
479## winhelp -> renamed winhlp32.exe
480%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
481%{_sysconfdir}/ld.so.conf.d/wine-32.conf
482%{_libdir}/libwine.so.1*
483%dir %{_libdir}/wine
484%{_libdir}/wine/*.cpl.so
485%{_libdir}/wine/*.exe.so
486%{_libdir}/wine/*.exe16.so
487%{_libdir}/wine/*.dll.so
488%{_libdir}/wine/*.dll16.so
489%{_libdir}/wine/*.drv.so
490%{_libdir}/wine/*.drv16.so
491%{_libdir}/wine/*.mod16.so
492## %{_libdir}/wine/*.*16
493%{_libdir}/wine/*.ds.so
494%{_libdir}/wine/*.ocx.so
495%{_libdir}/wine/*.vxd.so
496%{_libdir}/wine/*.acm.so
497%{_libdir}/wine/*.sys.so
498%{_libdir}/wine/*.tlb.so
499%dir %{_libdir}/wine/fakedlls
500%{_libdir}/wine/fakedlls/*
501%dir %{_datadir}/wine
502%{_datadir}/wine/*
503%{_datadir}/applications/vine-wine-mime-msi.desktop
504%{_datadir}/applications/vine-wine.desktop
505%{_datadir}/applications/vine-wine-regedit.desktop
506%{_datadir}/applications/vine-wine-uninstaller.desktop
507%{_datadir}/applications/vine-wine-winecfg.desktop
508%{_datadir}/applications/vine-wine-wineboot.desktop
509%{_datadir}/applications/vine-wine-notepad.desktop
510%{_datadir}/applications/vine-wine-winefile.desktop
511%{_datadir}/applications/vine-wine-winemine.desktop
512%{_datadir}/applications/vine-wine-winhelp.desktop
513%{_datadir}/desktop-directories/Wine.directory
514%{_mandir}/man1/wine.1.*
515%{_mandir}/man1/wineserver.1*
516%{_mandir}/man1/msiexec.1*
517%{_mandir}/man1/notepad.1*
518%{_mandir}/man1/regedit.1*
519%{_mandir}/man1/regsvr32.1*
520%{_mandir}/man1/wineboot.1*
521%{_mandir}/man1/winecfg.1*
522%{_mandir}/man1/wineconsole.1*
523%{_mandir}/man1/winefile.1*
524%{_mandir}/man1/winemine.1*
525%{_mandir}/man1/winepath.1*
526## %{_mandir}/man1/wineprefixcreate.1*
527%lang(de) %{_mandir}/de.UTF-8/man1/*.1*
528%lang(fr) %{_mandir}/fr.UTF-8/man1/*
529%lang(pl) %{_mandir}/pl.UTF-8/man1/wine.1*
530
531#--------------------------------------------------------------------
532%files devel
533%defattr(-,root,root,-)
534%{_bindir}/function_grep.pl
535%{_bindir}/widl
536%{_bindir}/winebuild
537%{_bindir}/winecpp
538%{_bindir}/winedump
539%{_bindir}/wineg++
540%{_bindir}/winegcc
541%{_bindir}/winemaker
542%{_bindir}/wmc
543%{_bindir}/wrc
544%{_includedir}/wine
545%{_libdir}/*.so
546
547%{_libdir}/wine/*.a
548%{_libdir}/wine/*.def
549
550%{_mandir}/man1/widl.1*
551%{_mandir}/man1/winebuild.1*
552%{_mandir}/man1/winecpp.1*
553%{_mandir}/man1/winedump.1*
554%{_mandir}/man1/winegcc.1*
555%{_mandir}/man1/winemaker.1*
556%{_mandir}/man1/wmc.1*
557%{_mandir}/man1/wrc.1*
558%{_mandir}/man1/winedbg.1*
559%{_mandir}/man1/wineg++.1*
560
561
562#--------------------------------------------------------------------
563%files init
564%defattr(-,root,root,-)
565%{_initrddir}/wine
566%doc documentation/README_add.ja
567
568#--------------------------------------------------------------------
569%changelog
570* Sat Jan 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
571- new upstream release
572
573* Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
574- new upstream release
575
576* Sat Jul 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6-1
577- new upstream release
578- remove Patch1000 (wine-1.4.1-vine.patch)
579- update Patch2 (wine-1.6-x86_64_gstreamer.patch)
580
581* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.17-1
582- update to 1.5.17
583
584* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
585- new upstream release
586- update Patch1000 (wine-1.4.1-vine.patch)
587
588* Thu Mar 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4-1
589- new upstream release
590- add Patch2 (wine-1.4-x86_64_gstreamer.patch)
591- add BuildRequires: gstreamer-plugins-base-devel
592
593* Sat Jul 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
594- update to 1.2.3
595- add Requires: compat32-freetype2 (x86_64 only)
596
597* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
598- new upstream release
599
600* Thu Oct 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
601- new upstream release
602- drop Patch1
603
604* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
605- new upstream release
606- fix %configure (add configu:e and gcc option of x86_64)
607- fix %install (remove wine.desktop and change make install option)
608- add ExclusiveArch: %{ix86} x86_64
609- add BuildRequires for x86_64 (compat32 packages)
610
611* Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
612- update to 1.2-rc2
613- fix spec file
614  - if [ "$LANG" = "ja_JP.eucJP" ];
615  + if [ "$LANG" = "ja_JP.UTF-8" ];
616- convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
617  - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
618- fix %files
619- drop patches (Patch0, Patch400, Patch402)
620
621* Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
622- update BRs
623  - remove freetype-devel
624  - remove libungif-devel, add giflib-devel
625  - remove gphoto2-devel, add libgphoto2-devel
626
627* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
628- update to 1.1.29
629
630* Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
631- update to 1.1.28
632- update winepulse patches
633
634* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
635- update to 1.1.23
636- spec in utf-8
637- add patch1000 to enable FontSmoothing by deafult.
638- update pulseaudio patches
639- remove invalid Provides: Wine HQ
640- remove unneeded patches
641
642* Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
643- Wine development release 1.1.0.
644- Updated specfile (for VineSeed)
645
646#--------------------------------------------------------------------
647
648* Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
649- added  "ja_fonts_replace-*.reg" files.
650- Updated specfile
651
652* Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
653- version upgrade
654- Updated specfile
655- Update to 1.0
656- fix wine.desktop mime types (fc)
657- add desktop package including desktop files and binary handler (fc)
658- pull in some wine alsa/pulseaudio patches (fc)
659-- NEWS "June 17, 2008: Wine 1.0 Released"
660-- read http://www.winehq.org/?issue=348
661
662* Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
663- Updated specfile
664- Update to 1.0-rc4
665- NEWS "June 6, 2008: Wine 1.0-rc4 Released"
666-- ntdll: Add local defines for VIF and VIP flags.
667--  wininet: Include openssl/ssl.h before Windows headers.
668--  shell32: Fixed the French about box.
669--  ChangeLog: Moved to documentation/ChangeLog.BETA.
670--  fonts: Add a non-breaking space glyph to the Tahoma fonts.
671--  ....others , read ChangeLog
672--- Bug fixes only, we are in code freeze.
673
674* Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
675- Updated specfile
676- Update to 1.0-rc3
677- NEWS "May 30, 2008: Wine 1.0-rc3 Released"
678-- The default version is now Windows XP.
679-- Many Richedit improvements.
680-- Beginning of jscript dll support.
681-- Shell folders now respect XDG directory configuration.
682-- Many translation updates.
683-- Lots of bug fixes.
684-- * Bug fixes only, we are in code freeze.
685--- kernel32: Add a builtin 16-bit winhelp.exe.
686--- This should be moved to winhlp32.exe once we support 16-bit modules in
687--- executables.
688---- winhelp -> renamed winhlp32.exe
689---- programs: Remove winelauncher from install rules.
690
691* Fri Apr 04 2008 Seiichirou Babasaki 0.9.59
692- Updated specfile
693- Update to 0.9.59
694- NEWS.. "April 4, 2008: Wine 0.9.59 Released"
695-- * Improved support for the .NET framework.
696-- * Better services handling through a separate services.exe process.
697-- * Support for ATI fragment shader.
698-- * Better support for http proxies.
699-- * Window management fixes.
700-- * Pre-compiled fonts are now available in the source tree.
701-- * Lots of bug fixes.
702
703* Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
704- Updated specfile (split wine-init package)
705- Update to 0.9.58
706- NEWS.. "March 21, 2008: Wine 0.9.58 Released"
707--  * The default version is now Windows XP.
708--  * Many Richedit improvements.
709--  * Beginning of jscript dll support.
710--  * Shell folders now respect XDG directory configuration.
711--  * Many translation updates.
712--  * Lots of bug fixes.
713
714* Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
715- Updated specfile (*.desktop file %check .)
716- Update to 0.9.57
717- NEWS.. "March 7, 2008: Wine 0.9.57 Released"
718--  * Support for multiple OpenGL pixel formats.
719--  * Improved support for color profiles.
720--  * Many window management fixes.
721--  * Better fullscreen support.
722--  * Lots of bug fixes.
723
724* Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
725- Updated specfile
726- ("Build Tool" from the wine-package to move to devel-packages)
727- Update to 0.9.56
728- NEWS.. "February 22, 2008: Wine 0.9.56 Released"
729--  * Proper handling of OpenGL/Direct3D windows with menu bars.
730--  * Stubs for all the d3dx9_xx dlls.
731--  * Several graphics optimizations.
732--  * Many installer fixes.
733--  * Improved MIME message support.
734--  * Lots of bug fixes.
735
736* Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
737- Updated specfile (cf. VineLinux .spec file format)
738- Add Installed messages for "binfmt_misc" .
739- *.desktop file "Name" change to japanese. (UTF8)
740
741* Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
742- Import WINE - Packager: Babasaki
743- Updated specfile (SUSE base + FC9 cfg)
744- Update to 0.9.55
745- Update to 0.9.54 from FC9
746- Update to 0.9.53 from Private package
747
748# FC9 ------------------------------------------------------------- FC9
749
750* Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
751- 0.9.55-1
752- version upgrade
753
754* Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
755- 0.9.54-1
756- version upgrade
757- remove default pulseaudio workaround (#429420,#428745)
758- improve pulseaudio readme
759
760* Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
761- 0.9.53-2
762- add some missing BR
763
764* Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
765- 0.9.53-1
766- version upgrade
767
768* Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
769- 0.9.52-2
770- fix menu bug (#393641)
771
772* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
773- 0.9.52-1
774- version upgrade
775
776* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
777- 0.9.51-3
778- add -n Wine to pulseaudio workaround
779- try to fix menu bug #393641
780
781* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
782- 0.9.51-2
783- add fix for #344281 pulseaudio workaround
784- fix #253474: wine-jack should require jack-audio-connection-kit
785
786* Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
787- 0.9.51-1
788- version upgrade
789
790# ---- abbreviatio ----------------------------------------------------#
791
792# ----------and suse.
793# * Fri Mar 17 2006 - meissner@suse.de
794# - Avoid ulimit leading to out of memory situations by using
795#  the compat address space layout personality. #152115
796
Note: See TracBrowser for help on using the repository browser.