source: projects/specs/trunk/w/wine/wine-vl.spec @ 7112

Revision 7112, 24.7 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define pkg_major_version 1.5.17
2%define pkg_name wine
3%define pkg_release 1%{?_dist_release}
4
5# NEW Release: numbering rule. -- Release: 1%{?_dist_release}
6# spec file for package wine.. # base (SUSE10 and fedora core 9)
7
8Summary:        Allows running Windows 16/32/64 bit programs on Unix.
9Summary(ja):    Unix で 16/32/64ビットWindoowsプログラムを実行させます
10Name:           %{pkg_name}
11Version:        %{pkg_major_version}
12Release:        %{pkg_release}
13URL:            http://www.winehq.org/
14License:        LGPLv2+
15Group:          Applications/System
16
17#--------------------------------------------------------------------
18Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
19#--------------------------------------------------------------------
20
21Source1:        wine.init
22Source3:        wine-README-Fedora
23Source4:        wine-32.conf
24# desktop stuff
25Source100:      wine-notepad.desktop
26Source101:      wine-regedit.desktop
27Source102:      wine-uninstaller.desktop
28Source103:      wine-winecfg.desktop
29Source104:      wine-winefile.desktop
30Source105:      wine-winemine.desktop
31Source106:      wine-winhelp.desktop
32Source107:      wine-wineboot.desktop
33
34# desktop dir
35Source200:      wine.menu
36Source201:      wine.directory
37
38# mime types
39Source300:      wine-mime-msi.desktop
40
41# explain how to use wine with pulseaudio
42Source402:      README-FEDORA-PULSEAUDIO
43Patch400:       http://art.ified.ca/downloads/winepulse-0.30-configure.ac.patch
44Patch401:       http://art.ified.ca/downloads/winepulse-0.30.patch
45Patch402:       http://art.ified.ca/downloads/adding-pulseaudio-to-winecfg-0.4.1.patch
46
47Patch0:         wine-prefixfonts.patch
48Patch1:         wine-1.1.28-rpath.patch
49Patch2:         wine-1.4-x86_64_gstreamer.patch
50
51# fix #448338
52## Patch2:         wine-desktop-mime.patch
53
54# enable FontSmoothing by deafult
55Patch1000: wine-1.4.1-vine.patch
56
57# ADD ja
58Source801: wine_README.ja
59Source802: README-FEDORA-PULSEAUDIO.ja
60Source803: wine-README-Fedora.ja
61Source804: wine_README_add.ja
62Source805: fonts-replace-list.txt
63Source806: ja_fonts_replace-js2ipa.reg
64Source807: ja_fonts_replace-js2vl.reg
65Source808: ja_fonts_replace-ms2ipa.reg
66Source809: ja_fonts_replace-ms2vl.reg
67
68
69Vendor: Project Vine
70Distribution: Vine Linux
71Packager: daisuke, Takemikaduchi
72
73ExclusiveArch: %{ix86} x86_64
74
75#--------------------------------------------------------------------
76BuildRoot:      %{_tmppath}/%{name}-%{version}-root
77#--------------------------------------------------------------------
78
79## FedoraCore ##
80BuildRequires: bison, flex
81BuildRequires: audiofile, audiofile-devel
82BuildRequires: alsa-lib-devel
83BuildRequires: freeglut-devel, lcms-devel
84## BuildRequires:  libieee1284-devel
85BuildRequires: libjpeg-devel, libpng-devel
86BuildRequires: libstdc++-devel
87BuildRequires: libusb-devel
88BuildRequires: libxml2-devel, libxslt-devel
89BuildRequires: openldap-devel, ncurses-devel
90BuildRequires: unixODBC-devel, openssl-devel
91BuildRequires: sane-devel
92BuildRequires: zlib-devel
93BuildRequires: desktop-file-utils
94BuildRequires: fontforge
95## BuildRequires: gphoto2, gphoto2-devel
96## BuildRequires: jack-audio-connection-kit-devel
97## BuildRequires:  isdn4k-utils-devel
98BuildRequires: cups-devel
99BuildRequires: dbus-devel
100BuildRequires: gstreamer-plugins-base-devel
101## Requires:       %{_bindir}/xmessage
102
103## X modular(fc) > X 7.2
104BuildRequires:  libX11-devel
105BuildRequires:  mesa-libGL-devel, mesa-libGLU-devel
106BuildRequires:  libXxf86dga-devel, libXxf86vm-devel
107BuildRequires:  libXrandr-devel
108BuildRequires:  libXrender-devel
109BuildRequires:  libXext-devel
110BuildRequires:  libXinerama-devel
111BuildRequires:  libXcomposite-devel
112BuildRequires:  libXmu-devel
113BuildRequires:  libXi-devel
114BuildRequires:  libXcursor-devel
115BuildRequires:  fontconfig-devel
116BuildRequires:  giflib-devel
117BuildRequires:  libtiff-devel
118BuildRequires:  pkgconfig
119BuildRequires:  libicu-devel
120BuildRequires:  freetype2-devel
121
122%ifarch x86_64
123BuildRequires: compat32-glibc-devel
124BuildRequires: compat32-glibc-devel
125BuildRequires: compat32-libX11-devel
126BuildRequires: compat32-libxcb-devel
127BuildRequires: compat32-freetype2-devel
128BuildRequires: compat32-libSM-devel
129BuildRequires: compat32-libXext-devel
130BuildRequires: compat32-libXrender-devel
131BuildRequires: compat32-mesa-libGL-devel
132BuildRequires: compat32-mesa-libGLU-devel
133BuildRequires: compat32-libxml2-devel
134BuildRequires: compat32-libxslt-devel
135BuildRequires: compat32-openssl-devel
136BuildRequires: compat32-libjpeg-devel
137BuildRequires: compat32-libpng-devel
138BuildRequires: compat32-zlib-devel
139BuildRequires: compat32-alsa-lib-devel
140BuildRequires: compat32-dbus-devel
141BuildRequires: compat32-lcms-devel
142BuildRequires: compat32-cups-devel
143BuildRequires: compat32-gnutls-devel
144BuildRequires: compat32-gstreamer-plugins-base-devel
145## extension
146BuildRequires: compat32-libXcursor-devel
147BuildRequires: compat32-libXi-devel
148BuildRequires: compat32-libXxf86vm-devel
149BuildRequires: compat32-libXrandr-devel
150BuildRequires: compat32-libXinerama-devel
151BuildRequires: compat32-libXcomposite-devel
152BuildRequires: compat32-ncurses-devel
153BuildRequires: compat32-fontconfig-devel
154BuildRequires: compat32-libtiff-devel
155BuildRequires: compat32-openldap-devel
156
157Requires:       compat32-freetype2
158Requires:       compat32-ncurses
159%endif
160
161Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
162Requires(post): desktop-file-utils >= 0.8
163Requires(preun): /sbin/chkconfig, /sbin/service
164Requires(postun): /sbin/ldconfig
165Requires(postun): desktop-file-utils >= 0.8
166
167#--------------------------------------------------------------------
168
169%description
170(WINE Is Not an Emulator)
171 While Wine is usually thought of as a Windows(TM) emulator,
172the Wine developers would prefer that users thought of
173Wine as a Windows compatibility layer for UNIX.
174 This package includes a program loader, which allows
175unmodified Windows 3.x/9x/NT binaries to run on x86 and
176x86_64 Unixes.
177Wine does not require MS Windows, but it can use native
178system .dll files if they are available.
179
180
181%description -l ja
182(WINE Is Not an Emulator)
183 WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
184開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
185互換レイヤー」と考えてくれる事を好むでしょう。
186 このパッケージはプログラムローダーを含み、これは未修正の
187Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
188させます。
189 WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
190Windows システムの .dll ファイルが存在するのならば、それを使用する
191事もできます
192
193#--------------------------------------------------------------------
194%package devel
195Summary: Wine development environment
196Summary(ja):    WINE の開発ファイルです
197Group: System Environment/Libraries
198Requires: wine = %{version}-%{release}
199
200%description devel
201This RPM contains the header files and development tools
202for the WINE libraries.
203
204%description devel -l ja
205WINEの開発用ライブラリやヘッダーファイル、そして開発用の
206アプリケーション(例:winebuild)のパッケージです
207(development packages)
208
209#--------------------------------------------------------------------
210%package init
211Summary: WINE binfmt_misc kernel function used for init file.
212Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
213Group: System Environment/Libraries
214Requires: wine = %{version}-%{release}
215
216%description init
217WINE binfmt_misc kernel function used for init file.
218WIN32-binary attribute run with a Linux-binary run the same way as possible.
219(init.d packages)
220** example **
221Until now, "$ wine /file/to/path/arege.exe" and then you were running
222 from the usual binary Linux as "$ /file/to/path/arege.exe"
223 and just be able to run.
224Of course, please be mindful of security.
225
226
227%description init -l ja
228カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
229実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
230ようにします。
231(init.d packages)
232※ 例 ※
233これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
234が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
235だけで実行できるようになります。
236無論、セキュリティに留意して下さい。
237
238
239#--------------------------------------------------------------------
240
241%prep
242
243%setup -q -n %{name}-%{version}
244## %patch0
245## %patch1 -p1
246%ifarch x86_64
247%patch2 -p1
248%endif
249## %patch400 -p1
250%patch401 -p1
251## %patch402 -p1 -b .add-pa-to-winecfg
252%patch1000 -p1
253
254%build
255autoreconf -if
256%ifarch x86_64
257export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
258./configure \
259        --prefix=%{_prefix} \
260        --libdir=%{_libdir} \
261        --with-x \
262        --without-jack \
263        --without-capi
264%else
265export CFLAGS="$RPM_OPT_FLAGS"
266%{configure} \
267        --prefix=%{_prefix} \
268        --with-x \
269        --without-jack \
270        --without-capi
271%endif
272
273grep "have_x=yes" config.log || exit 1
274
275%{__make} depend
276
277%{__make} %{?_smp_mflags}
278
279%install
280rm -rf ${RPM_BUILD_ROOT}
281%{__make} install DESTDIR=${RPM_BUILD_ROOT}
282
283#-----------------------------------------------------------FC9
284mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
285
286# Allow users to launch Windows programs by just clicking on the .exe file...
287mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
288install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
289
290# add wine dir to desktop
291mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
292install -p -m 644 %{SOURCE200} \
293${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
294
295mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
296install -p -m 644 %{SOURCE201} \
297${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
298
299## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
300## %%{_datadir}/applications
301
302# install desktop files
303desktop-file-install \
304  --vendor=vine \
305  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
306  %{SOURCE100}
307
308desktop-file-install \
309  --vendor=vine \
310  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
311  %{SOURCE101}
312
313desktop-file-install \
314  --vendor=vine \
315  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
316  %{SOURCE102}
317
318desktop-file-install \
319  --vendor=vine \
320  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
321  %{SOURCE103}
322
323desktop-file-install \
324  --vendor=vine \
325  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
326  %{SOURCE104}
327
328desktop-file-install \
329  --vendor=vine \
330  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
331  %{SOURCE105}
332
333desktop-file-install \
334  --vendor=vine \
335  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
336  %{SOURCE106}
337
338desktop-file-install \
339  --vendor=vine \
340  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
341  %{SOURCE107}
342
343desktop-file-install \
344  --vendor=vine \
345  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
346  --delete-original \
347  ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
348
349#mime-types
350desktop-file-install \
351  --vendor=vine \
352  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
353  %{SOURCE300}
354
355
356## other files
357cp %{SOURCE3} README-Fedora
358cp %{SOURCE803} README-Fedora.ja
359cp %{SOURCE801} documentation/README.ja
360cp %{SOURCE804} documentation/README_add.ja
361cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
362
363mkdir -p ${RPM_BUILD_ROOT}/%{_sysconfdir}/ld.so.conf.d/
364install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
365
366
367# deploy pulseaudio readme (802jp)
368cp %{SOURCE402} .
369cp %{SOURCE802} .
370
371# check desktop files
372%check
373desktop-file-validate \
374 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
375desktop-file-validate \
376 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
377desktop-file-validate \
378 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
379desktop-file-validate \
380 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
381desktop-file-validate \
382 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
383desktop-file-validate \
384 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
385desktop-file-validate \
386 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
387desktop-file-validate \
388 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
389desktop-file-validate \
390 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
391
392#--------------------------------------------------------------------
393%clean
394rm -rf ${RPM_BUILD_ROOT}
395
396%post
397/sbin/ldconfig
398update-desktop-database &>/dev/null || :
399### add vinelinux
400if [ "$LANG" = "ja_JP.UTF-8" ]; then
401  echo "WINEのシステムフォントをリプレースするには"
402  echo " fonts-replace-list.txt をお読み下さい。"
403else
404  echo "You need to Japanese fonts name replace, "
405  echo "See fonts-replace-list.txt ."
406fi
407
408%postun
409/sbin/ldconfig
410update-desktop-database &>/dev/null || :
411
412%post init
413if [ $1 = 1 ]; then
414/sbin/chkconfig --add wine
415/sbin/chkconfig --level 2345 wine on
416/sbin/service wine start &>/dev/null || :
417fi
418### add vinelinux
419if [ "$LANG" = "ja_JP.UTF-8" ]; then
420    echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
421    echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
422    echo "(ファイル名は /etc/init.d/wine です)"
423    echo "起動時にファイルシステムのマウントが必要です。"
424    echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
425    echo "(削除も手動でお願いします)"
426    echo ""
427    echo "# cp /etc/fstab /etc/fstab.before  ##バックアップの作成"
428    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
429    echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
430else
431    echo "WINE binfmt_misc feature from the boot files "
432    echo "to be installed and enabled 2,3,4,5 runlevel."
433    echo "(File name in the /etc/init.d/wine )"
434    echo "Filesystem mounted at boot time is required."
435    echo "Root privileges using the following command in the /etc/fstab"
436    echo "please Addenda.(Please delete manually.)"
437    echo ""
438    echo "# cp /etc/fstab /etc/fstab.before   ##(Create backup)"
439    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
440    echo "See also(en)http://www.linux.com/articles/56032 "
441fi
442
443%preun init
444if [ $1 = 0 ]; then
445        /sbin/service wine stop >/dev/null 2>&1
446        /sbin/chkconfig --del wine
447fi
448
449#--------------------------------------------------------------------
450## deleted /usr/share/applications/wine.desktop
451%files
452%defattr(-,root,root,-)
453%doc ANNOUNCE AUTHORS COPYING.LIB  LICENSE LICENSE.OLD
454%doc README VERSION
455%doc README-FEDORA-PULSEAUDIO
456%doc README-FEDORA-PULSEAUDIO.ja
457%doc README-Fedora
458%doc README-Fedora.ja
459%doc documentation/README* documentation/ChangeLog*
460%doc documentation/ja_fonts_replace*
461%doc documentation/fonts-replace-list.txt
462### %{_bindir}/*
463%{_bindir}/msiexec
464%{_bindir}/regedit
465%{_bindir}/regsvr32
466%{_bindir}/wine
467%{_bindir}/wineboot
468%{_bindir}/wineconsole
469## %{_bindir}/wineprefixcreate
470%{_bindir}/winecfg
471%{_bindir}/wine-preloader
472# winelauncher --> Remove
473%{_bindir}/wineserver
474%{_bindir}/notepad
475%{_bindir}/winedbg
476%{_bindir}/winedump
477%{_bindir}/winefile
478%{_bindir}/winemaker
479%{_bindir}/winemine
480%{_bindir}/winepath
481## winhelp -> renamed winhlp32.exe
482%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
483%{_sysconfdir}/ld.so.conf.d/wine-32.conf
484%{_libdir}/libwine.so.1*
485%dir %{_libdir}/wine
486%{_libdir}/wine/*.cpl.so
487%{_libdir}/wine/*.exe.so
488%{_libdir}/wine/*.exe16.so
489%{_libdir}/wine/*.dll.so
490%{_libdir}/wine/*.dll16.so
491%{_libdir}/wine/*.drv.so
492%{_libdir}/wine/*.drv16.so
493%{_libdir}/wine/*.mod16.so
494## %{_libdir}/wine/*.*16
495%{_libdir}/wine/*.ds.so
496%{_libdir}/wine/*.ocx.so
497%{_libdir}/wine/*.vxd.so
498%{_libdir}/wine/*.acm.so
499%{_libdir}/wine/*.sys.so
500%{_libdir}/wine/*.tlb.so
501%dir %{_libdir}/wine/fakedlls
502%{_libdir}/wine/fakedlls/*
503%dir %{_datadir}/wine
504%{_datadir}/wine/*
505%{_datadir}/applications/vine-wine-mime-msi.desktop
506%{_datadir}/applications/vine-wine.desktop
507%{_datadir}/applications/vine-wine-regedit.desktop
508%{_datadir}/applications/vine-wine-uninstaller.desktop
509%{_datadir}/applications/vine-wine-winecfg.desktop
510%{_datadir}/applications/vine-wine-wineboot.desktop
511%{_datadir}/applications/vine-wine-notepad.desktop
512%{_datadir}/applications/vine-wine-winefile.desktop
513%{_datadir}/applications/vine-wine-winemine.desktop
514%{_datadir}/applications/vine-wine-winhelp.desktop
515%{_datadir}/desktop-directories/Wine.directory
516%{_mandir}/man1/wine.1.*
517%{_mandir}/man1/wineserver.1*
518%{_mandir}/man1/msiexec.1*
519%{_mandir}/man1/notepad.1*
520%{_mandir}/man1/regedit.1*
521%{_mandir}/man1/regsvr32.1*
522%{_mandir}/man1/wineboot.1*
523%{_mandir}/man1/winecfg.1*
524%{_mandir}/man1/wineconsole.1*
525%{_mandir}/man1/winefile.1*
526%{_mandir}/man1/winemine.1*
527%{_mandir}/man1/winepath.1*
528## %{_mandir}/man1/wineprefixcreate.1*
529%lang(de) %{_mandir}/de.UTF-8/man1/*.1*
530%lang(fr) %{_mandir}/fr.UTF-8/man1/*
531%lang(pl) %{_mandir}/pl.UTF-8/man1/wine.1*
532
533#--------------------------------------------------------------------
534%files devel
535%defattr(-,root,root,-)
536%{_bindir}/function_grep.pl
537%{_bindir}/widl
538%{_bindir}/winebuild
539%{_bindir}/winecpp
540%{_bindir}/winedump
541%{_bindir}/wineg++
542%{_bindir}/winegcc
543%{_bindir}/winemaker
544%{_bindir}/wmc
545%{_bindir}/wrc
546%{_includedir}/wine
547%{_libdir}/*.so
548
549%{_libdir}/wine/*.a
550%{_libdir}/wine/*.def
551
552%{_mandir}/man1/widl.1*
553%{_mandir}/man1/winebuild.1*
554%{_mandir}/man1/winecpp.1*
555%{_mandir}/man1/winedump.1*
556%{_mandir}/man1/winegcc.1*
557%{_mandir}/man1/winemaker.1*
558%{_mandir}/man1/wmc.1*
559%{_mandir}/man1/wrc.1*
560%{_mandir}/man1/winedbg.1*
561%{_mandir}/man1/wineg++.1*
562
563
564#--------------------------------------------------------------------
565%files init
566%defattr(-,root,root,-)
567%{_initrddir}/wine
568%doc documentation/README_add.ja
569
570#--------------------------------------------------------------------
571%changelog
572* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.17-1
573- update to 1.5.17
574
575* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
576- new upstream release
577- update Patch1000 (wine-1.4.1-vine.patch)
578
579* Thu Mar 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4-1
580- new upstream release
581- add Patch2 (wine-1.4-x86_64_gstreamer.patch)
582- add BuildRequires: gstreamer-plugins-base-devel
583
584* Sat Jul 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
585- update to 1.2.3
586- add Requires: compat32-freetype2 (x86_64 only)
587
588* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
589- new upstream release
590
591* Thu Oct 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
592- new upstream release
593- drop Patch1
594
595* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
596- new upstream release
597- fix %configure (add configu:e and gcc option of x86_64)
598- fix %install (remove wine.desktop and change make install option)
599- add ExclusiveArch: %{ix86} x86_64
600- add BuildRequires for x86_64 (compat32 packages)
601
602* Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
603- update to 1.2-rc2
604- fix spec file
605  - if [ "$LANG" = "ja_JP.eucJP" ];
606  + if [ "$LANG" = "ja_JP.UTF-8" ];
607- convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
608  - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
609- fix %files
610- drop patches (Patch0, Patch400, Patch402)
611
612* Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
613- update BRs
614  - remove freetype-devel
615  - remove libungif-devel, add giflib-devel
616  - remove gphoto2-devel, add libgphoto2-devel
617
618* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
619- update to 1.1.29
620
621* Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
622- update to 1.1.28
623- update winepulse patches
624
625* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
626- update to 1.1.23
627- spec in utf-8
628- add patch1000 to enable FontSmoothing by deafult.
629- update pulseaudio patches
630- remove invalid Provides: Wine HQ
631- remove unneeded patches
632
633* Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
634- Wine development release 1.1.0.
635- Updated specfile (for VineSeed)
636
637#--------------------------------------------------------------------
638
639* Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
640- added  "ja_fonts_replace-*.reg" files.
641- Updated specfile
642
643* Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
644- version upgrade
645- Updated specfile
646- Update to 1.0
647- fix wine.desktop mime types (fc)
648- add desktop package including desktop files and binary handler (fc)
649- pull in some wine alsa/pulseaudio patches (fc)
650-- NEWS "June 17, 2008: Wine 1.0 Released"
651-- read http://www.winehq.org/?issue=348
652
653* Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
654- Updated specfile
655- Update to 1.0-rc4
656- NEWS "June 6, 2008: Wine 1.0-rc4 Released"
657-- ntdll: Add local defines for VIF and VIP flags.
658--  wininet: Include openssl/ssl.h before Windows headers.
659--  shell32: Fixed the French about box.
660--  ChangeLog: Moved to documentation/ChangeLog.BETA.
661--  fonts: Add a non-breaking space glyph to the Tahoma fonts.
662--  ....others , read ChangeLog
663--- Bug fixes only, we are in code freeze.
664
665* Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
666- Updated specfile
667- Update to 1.0-rc3
668- NEWS "May 30, 2008: Wine 1.0-rc3 Released"
669-- The default version is now Windows XP.
670-- Many Richedit improvements.
671-- Beginning of jscript dll support.
672-- Shell folders now respect XDG directory configuration.
673-- Many translation updates.
674-- Lots of bug fixes.
675-- * Bug fixes only, we are in code freeze.
676--- kernel32: Add a builtin 16-bit winhelp.exe.
677--- This should be moved to winhlp32.exe once we support 16-bit modules in
678--- executables.
679---- winhelp -> renamed winhlp32.exe
680---- programs: Remove winelauncher from install rules.
681
682* Mon Apr 04 2008 Seiichirou Babasaki 0.9.59
683- Updated specfile
684- Update to 0.9.59
685- NEWS.. "April 4, 2008: Wine 0.9.59 Released"
686-- * Improved support for the .NET framework.
687-- * Better services handling through a separate services.exe process.
688-- * Support for ATI fragment shader.
689-- * Better support for http proxies.
690-- * Window management fixes.
691-- * Pre-compiled fonts are now available in the source tree.
692-- * Lots of bug fixes.
693
694* Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
695- Updated specfile (split wine-init package)
696- Update to 0.9.58
697- NEWS.. "March 21, 2008: Wine 0.9.58 Released"
698--  * The default version is now Windows XP.
699--  * Many Richedit improvements.
700--  * Beginning of jscript dll support.
701--  * Shell folders now respect XDG directory configuration.
702--  * Many translation updates.
703--  * Lots of bug fixes.
704
705* Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
706- Updated specfile (*.desktop file %check .)
707- Update to 0.9.57
708- NEWS.. "March 7, 2008: Wine 0.9.57 Released"
709--  * Support for multiple OpenGL pixel formats.
710--  * Improved support for color profiles.
711--  * Many window management fixes.
712--  * Better fullscreen support.
713--  * Lots of bug fixes.
714
715* Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
716- Updated specfile
717- ("Build Tool" from the wine-package to move to devel-packages)
718- Update to 0.9.56
719- NEWS.. "February 22, 2008: Wine 0.9.56 Released"
720--  * Proper handling of OpenGL/Direct3D windows with menu bars.
721--  * Stubs for all the d3dx9_xx dlls.
722--  * Several graphics optimizations.
723--  * Many installer fixes.
724--  * Improved MIME message support.
725--  * Lots of bug fixes.
726
727* Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
728- Updated specfile (cf. VineLinux .spec file format)
729- Add Installed messages for "binfmt_misc" .
730- *.desktop file "Name" change to japanese. (UTF8)
731
732* Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
733- Import WINE - Packager: Babasaki
734- Updated specfile (SUSE base + FC9 cfg)
735- Update to 0.9.55
736- Update to 0.9.54 from FC9
737- Update to 0.9.53 from Private package
738
739# FC9 ------------------------------------------------------------- FC9
740
741* Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
742- 0.9.55-1
743- version upgrade
744
745* Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
746- 0.9.54-1
747- version upgrade
748- remove default pulseaudio workaround (#429420,#428745)
749- improve pulseaudio readme
750
751* Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
752- 0.9.53-2
753- add some missing BR
754
755* Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
756- 0.9.53-1
757- version upgrade
758
759* Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
760- 0.9.52-2
761- fix menu bug (#393641)
762
763* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
764- 0.9.52-1
765- version upgrade
766
767* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
768- 0.9.51-3
769- add -n Wine to pulseaudio workaround
770- try to fix menu bug #393641
771
772* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
773- 0.9.51-2
774- add fix for #344281 pulseaudio workaround
775- fix #253474: wine-jack should require jack-audio-connection-kit
776
777* Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
778- 0.9.51-1
779- version upgrade
780
781# ---- abbreviatio ----------------------------------------------------#
782
783# ----------and suse.
784# * Fri Mar 17 2006 - meissner@suse.de
785# - Avoid ulimit leading to out of memory situations by using
786#  the compat address space layout personality. #152115
787
Note: See TracBrowser for help on using the repository browser.