source: projects/specs/trunk/w/wine/wine-vl.spec @ 521

Revision 521, 21.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pkg_major_version 1.1.29
2%define pkg_name wine
3%define pkg_release 1%{?_dist_release}
4
5# NEW Release: numbering rule. -- Release: 1%{?_dist_release}
6# spec file for package wine.. # base (SUSE10 and fedora core 9)
7
8Summary:        Allows running Windows 16/32/64 bit programs on Unix.
9Summary(ja):    Unix で 16/32/64ビットWindoowsプログラムを実行させます
10Name:           %{pkg_name}
11Version:        %{pkg_major_version}
12Release:        %{pkg_release}
13URL:            http://www.winehq.org/
14License:        LGPLv2+
15Group:          Applications/System
16
17#--------------------------------------------------------------------
18Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
19#--------------------------------------------------------------------
20
21Source1:        wine.init
22Source3:    wine-README-Fedora
23Source4:    wine-32.conf
24# desktop stuff
25Source100:      wine-notepad.desktop
26Source101:      wine-regedit.desktop
27Source102:      wine-uninstaller.desktop
28Source103:      wine-winecfg.desktop
29Source104:      wine-winefile.desktop
30Source105:      wine-winemine.desktop
31Source106:      wine-winhelp.desktop
32Source107:      wine-wineboot.desktop
33
34# desktop dir
35Source200:      wine.menu
36Source201:      wine.directory
37
38# mime types
39Source300:      wine-mime-msi.desktop
40
41# explain how to use wine with pulseaudio
42Source402:      README-FEDORA-PULSEAUDIO
43Patch400:       http://art.ified.ca/downloads/winepulse-0.30-configure.ac.patch
44Patch401:       http://art.ified.ca/downloads/winepulse-0.30.patch
45Patch402:       http://art.ified.ca/downloads/adding-pulseaudio-to-winecfg-0.4.1.patch
46
47Patch0:         wine-prefixfonts.patch
48Patch1:         wine-1.1.28-rpath.patch
49
50# fix #448338
51## Patch2:         wine-desktop-mime.patch
52
53# enable FontSmoothing by deafult
54Patch1000: wine-1.1.23-vine.patch
55
56# ADD ja
57Source801: wine_README.ja
58Source802: README-FEDORA-PULSEAUDIO.ja
59Source803: wine-README-Fedora.ja
60Source804: wine_README_add.ja
61Source805: fonts-replace-list.txt
62Source806: ja_fonts_replace-js2ipa.reg
63Source807: ja_fonts_replace-js2vl.reg
64Source808: ja_fonts_replace-ms2ipa.reg
65Source809: ja_fonts_replace-ms2vl.reg
66
67#--------------------------------------------------------------------
68BuildRoot:      %{_tmppath}/%{name}-%{version}-root
69#--------------------------------------------------------------------
70## FedoraCore ##
71BuildRequires: bison, flex
72BuildRequires: audiofile, audiofile-devel
73BuildRequires: alsa-lib-devel, esound-devel
74BuildRequires: freeglut-devel, lcms-devel
75## BuildRequires:  libieee1284-devel
76BuildRequires: libjpeg-devel, libpng-devel
77BuildRequires: libstdc++3-devel, libstdc++34-devel
78BuildRequires: libusb-devel
79BuildRequires: libxml2-devel, libxslt-devel
80BuildRequires: openldap-devel, ncurses-devel
81BuildRequires: unixODBC-devel, openssl-devel
82BuildRequires: sane-devel
83BuildRequires: zlib-devel
84BuildRequires: desktop-file-utils
85BuildRequires: fontforge
86BuildRequires: gphoto2, gphoto2-devel
87## BuildRequires: jack-audio-connection-kit-devel
88## BuildRequires:  isdn4k-utils-devel
89BuildRequires: cups-devel
90BuildRequires: dbus-devel, hal-devel
91Requires:       %{_bindir}/xmessage
92
93## X modular(fc) > X 7.2
94BuildRequires:  libX11-devel
95BuildRequires:  mesa-libGL-devel, mesa-libGLU-devel
96BuildRequires:  libXxf86dga-devel, libXxf86vm-devel
97BuildRequires:  libXrandr-devel
98BuildRequires:  libXrender-devel
99BuildRequires:  libXext-devel
100BuildRequires:  libXinerama-devel
101BuildRequires:  libXcomposite-devel
102BuildRequires:  libXmu-devel
103BuildRequires:  libXi-devel
104BuildRequires:  libXcursor-devel
105BuildRequires:  fontconfig-devel
106## libungif-devel <- giflib-devel(fc)
107BuildRequires:  libungif-devel, libtiff-devel
108
109## VineLinux ## < X 7.0
110## BuildRequires: XOrg-devel
111## XOrg-devel <- fontconfig-devel
112BuildRequires: pkgconfig
113BuildRequires: libicu-devel
114BuildRequires: freetype-devel, freetype2-devel
115
116Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
117Requires(post): desktop-file-utils >= 0.8
118Requires(preun): /sbin/chkconfig, /sbin/service
119Requires(postun): /sbin/ldconfig
120Requires(postun): desktop-file-utils >= 0.8
121
122#--------------------------------------------------------------------
123
124%description
125(WINE Is Not an Emulator)
126 While Wine is usually thought of as a Windows(TM) emulator,
127the Wine developers would prefer that users thought of
128Wine as a Windows compatibility layer for UNIX.
129 This package includes a program loader, which allows
130unmodified Windows 3.x/9x/NT binaries to run on x86 and
131x86_64 Unixes.
132Wine does not require MS Windows, but it can use native
133system .dll files if they are available.
134
135
136%description -l ja
137(WINE Is Not an Emulator)
138 WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
139開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
140互換レイヤー」と考えてくれる事を好むでしょう。
141 このパッケージはプログラムローダーを含み、これは未修正の
142Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
143させます。
144 WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
145Windows システムの .dll ファイルが存在するのならば、それを使用する
146事もできます
147
148#--------------------------------------------------------------------
149%package devel
150Summary: Wine development environment
151Summary(ja):    WINE の開発ファイルです
152Group: System Environment/Libraries
153Requires: wine = %{version}-%{release}
154
155%description devel
156This RPM contains the header files and development tools
157for the WINE libraries.
158
159%description devel -l ja
160WINEの開発用ライブラリやヘッダーファイル、そして開発用の
161アプリケーション(例:winebuild)のパッケージです
162(development packages)
163
164#--------------------------------------------------------------------
165%package init
166Summary: WINE binfmt_misc kernel function used for init file.
167Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
168Group: System Environment/Libraries
169Requires: wine = %{version}-%{release}
170
171%description init
172WINE binfmt_misc kernel function used for init file.
173WIN32-binary attribute run with a Linux-binary run the same way as possible.
174(init.d packages)
175** example **
176Until now, "$ wine /file/to/path/arege.exe" and then you were running
177 from the usual binary Linux as "$ /file/to/path/arege.exe"
178 and just be able to run.
179Of course, please be mindful of security.
180
181
182%description init -l ja
183カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
184実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
185ようにします。
186(init.d packages)
187※ 例 ※
188これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
189が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
190だけで実行できるようになります。
191無論、セキュリティに留意して下さい。
192
193
194#--------------------------------------------------------------------
195
196%prep
197
198%setup -q -n %{name}-%{version}
199%patch0
200%patch1 -p1
201%patch400 -p1
202%patch401 -p1
203%patch402 -p1 -b .add-pa-to-winecfg
204%patch1000 -p1
205
206%build
207
208export CFLAGS="$RPM_OPT_FLAGS"
209%{configure} \
210        --prefix=%{_prefix} \
211        --with-x \
212        --without-jack \
213        --without-capi
214
215grep "have_x=yes" config.log || exit 1
216
217%{__make} depend
218
219%{__make} %{?_smp_mflags}
220
221%install
222rm -rf ${RPM_BUILD_ROOT}
223%{__make} prefix=${RPM_BUILD_ROOT}/%{_prefix}/ install \
224        DESTDIR=${RPM_BUILD_ROOT}
225
226#-----------------------------------------------------------FC9
227mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
228
229# Allow users to launch Windows programs by just clicking on the .exe file...
230mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
231install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
232
233# add wine dir to desktop
234mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
235install -p -m 644 %{SOURCE200} \
236${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
237
238mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
239install -p -m 644 %{SOURCE201} \
240${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
241
242## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
243## %%{_datadir}/applications
244
245# install desktop files
246desktop-file-install \
247  --vendor=vine \
248  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
249  %{SOURCE100}
250
251desktop-file-install \
252  --vendor=vine \
253  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
254  %{SOURCE101}
255
256desktop-file-install \
257  --vendor=vine \
258  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
259  %{SOURCE102}
260
261desktop-file-install \
262  --vendor=vine \
263  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
264  %{SOURCE103}
265
266desktop-file-install \
267  --vendor=vine \
268  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
269  %{SOURCE104}
270
271desktop-file-install \
272  --vendor=vine \
273  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
274  %{SOURCE105}
275
276desktop-file-install \
277  --vendor=vine \
278  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
279  %{SOURCE106}
280
281desktop-file-install \
282  --vendor=vine \
283  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
284  %{SOURCE107}
285
286desktop-file-install \
287  --vendor=vine \
288  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
289  --delete-original \
290  ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
291
292#mime-types
293desktop-file-install \
294  --vendor=vine \
295  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
296  %{SOURCE300}
297
298
299## other files
300cp %{SOURCE3} README-Fedora
301cp %{SOURCE803} README-Fedora.ja
302cp %{SOURCE801} documentation/README.ja
303cp %{SOURCE804} documentation/README_add.ja
304cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
305
306mkdir -p ${RPM_BUILD_ROOT}/%{_sysconfdir}/ld.so.conf.d/
307install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
308
309
310# deploy pulseaudio readme (802jp)
311cp %{SOURCE402} .
312cp %{SOURCE802} .
313
314# check desktop files
315%check
316desktop-file-validate \
317 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
318desktop-file-validate \
319 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
320desktop-file-validate \
321 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
322desktop-file-validate \
323 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
324desktop-file-validate \
325 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
326desktop-file-validate \
327 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
328desktop-file-validate \
329 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
330desktop-file-validate \
331 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
332desktop-file-validate \
333 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
334
335#--------------------------------------------------------------------
336%clean
337rm -rf ${RPM_BUILD_ROOT}
338
339%post
340/sbin/ldconfig
341update-desktop-database &>/dev/null || :
342### add vinelinux
343if [ "$LANG" = "ja_JP.eucJP" ]; then
344  echo "WINEのシステムフォントをリプレースするには"
345  echo " fonts-replace-list.txt をお読み下さい。"
346else
347  echo "You need to Japanese fonts name replace, "
348  echo "See fonts-replace-list.txt ."
349fi
350
351%postun
352/sbin/ldconfig
353update-desktop-database &>/dev/null || :
354
355%post init
356if [ $1 = 1 ]; then
357/sbin/chkconfig --add wine
358/sbin/chkconfig --level 2345 wine on
359/sbin/service wine start &>/dev/null || :
360fi
361### add vinelinux
362if [ "$LANG" = "ja_JP.eucJP" ]; then
363    echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
364    echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
365    echo "(ファイル名は /etc/init.d/wine です)"
366    echo "起動時にファイルシステムのマウントが必要です。"
367    echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
368    echo "(削除も手動でお願いします)"
369    echo ""
370    echo "# cp /etc/fstab /etc/fstab.before  ##バックアップの作成"
371    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
372    echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
373else
374    echo "WINE binfmt_misc feature from the boot files "
375    echo "to be installed and enabled 2,3,4,5 runlevel."
376    echo "(File name in the /etc/init.d/wine )"
377    echo "Filesystem mounted at boot time is required."
378    echo "Root privileges using the following command in the /etc/fstab"
379    echo "please Addenda.(Please delete manually.)"
380    echo ""
381    echo "# cp /etc/fstab /etc/fstab.before   ##(Create backup)"
382    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
383    echo "See also(en)http://www.linux.com/articles/56032 "
384fi
385
386%preun init
387if [ $1 = 0 ]; then
388        /sbin/service wine stop >/dev/null 2>&1
389        /sbin/chkconfig --del wine
390fi
391
392#--------------------------------------------------------------------
393## deleted /usr/share/applications/wine.desktop
394%files
395%defattr(-,root,root,-)
396%doc ANNOUNCE AUTHORS COPYING.LIB  LICENSE LICENSE.OLD
397%doc README VERSION
398%doc README-FEDORA-PULSEAUDIO
399%doc README-FEDORA-PULSEAUDIO.ja
400%doc README-Fedora
401%doc README-Fedora.ja
402%doc documentation/README* documentation/ChangeLog*
403%doc documentation/ja_fonts_replace*
404%doc documentation/fonts-replace-list.txt
405### %{_bindir}/*
406%{_bindir}/msiexec
407%{_bindir}/regedit
408%{_bindir}/regsvr32
409%{_bindir}/wine
410%{_bindir}/wineboot
411%{_bindir}/wineconsole
412%{_bindir}/wineprefixcreate
413%{_bindir}/winecfg
414%{_bindir}/wine-preloader
415# winelauncher --> Remove
416%{_bindir}/wineserver
417%{_bindir}/notepad
418%{_bindir}/winedbg
419%{_bindir}/winedump
420%{_bindir}/winefile
421%{_bindir}/winemaker
422%{_bindir}/winemine
423%{_bindir}/winepath
424## winhelp -> renamed winhlp32.exe
425%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
426%{_sysconfdir}/ld.so.conf.d/wine-32.conf
427%{_libdir}/libwine.so.1*
428%dir %{_libdir}/wine
429%{_libdir}/wine/*.cpl.so
430%{_libdir}/wine/*.exe.so
431%{_libdir}/wine/*.exe16.so
432%{_libdir}/wine/*.dll.so
433%{_libdir}/wine/*.dll16.so
434%{_libdir}/wine/*.drv.so
435%{_libdir}/wine/*.drv16.so
436%{_libdir}/wine/*.mod16.so
437%{_libdir}/wine/*.*16
438%{_libdir}/wine/*.ds.so
439%{_libdir}/wine/*.ocx.so
440%{_libdir}/wine/*.vxd.so
441%{_libdir}/wine/*.acm.so
442%{_libdir}/wine/*.sys.so
443%{_libdir}/wine/*.tlb.so
444%dir %{_libdir}/wine/fakedlls
445%{_libdir}/wine/fakedlls/*
446%dir %{_datadir}/wine
447%{_datadir}/wine/*
448%{_datadir}/applications/vine-wine-mime-msi.desktop
449%{_datadir}/applications/vine-wine.desktop
450%{_datadir}/applications/vine-wine-regedit.desktop
451%{_datadir}/applications/vine-wine-uninstaller.desktop
452%{_datadir}/applications/vine-wine-winecfg.desktop
453%{_datadir}/applications/vine-wine-wineboot.desktop
454%{_datadir}/applications/vine-wine-notepad.desktop
455%{_datadir}/applications/vine-wine-winefile.desktop
456%{_datadir}/applications/vine-wine-winemine.desktop
457%{_datadir}/applications/vine-wine-winhelp.desktop
458%{_datadir}/desktop-directories/Wine.directory
459%{_mandir}/man1/wine.1.*
460%{_mandir}/man1/wineserver.1*
461%{_mandir}/man1/wineprefixcreate.1*
462%lang(de) %{_mandir}/de.UTF-8/man1/wine.1*
463%lang(fr) %{_mandir}/fr.UTF-8/man1/*
464
465#--------------------------------------------------------------------
466%files devel
467%defattr(-,root,root,-)
468%{_bindir}/function_grep.pl
469%{_bindir}/widl
470%{_bindir}/winebuild
471%{_bindir}/winecpp
472%{_bindir}/winedump
473%{_bindir}/wineg++
474%{_bindir}/winegcc
475%{_bindir}/winemaker
476%{_bindir}/wmc
477%{_bindir}/wrc
478%{_includedir}/wine
479%{_libdir}/*.so
480
481%{_libdir}/wine/*.a
482%{_libdir}/wine/*.def
483
484%{_mandir}/man1/widl.1*
485%{_mandir}/man1/winebuild.1*
486%{_mandir}/man1/winedump.1*
487%{_mandir}/man1/winegcc.1*
488%{_mandir}/man1/winemaker.1*
489%{_mandir}/man1/winedbg.1*
490%{_mandir}/man1/wineg++.1*
491%{_mandir}/man1/wmc.1*
492%{_mandir}/man1/wrc.1*
493
494#--------------------------------------------------------------------
495%files init
496%defattr(-,root,root,-)
497%{_initrddir}/wine
498%doc documentation/README_add.ja
499
500#--------------------------------------------------------------------
501%changelog
502* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
503- update to 1.1.29
504
505* Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
506- update to 1.1.28
507- update winepulse patches
508
509* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
510- update to 1.1.23
511- spec in utf-8
512- add patch1000 to enable FontSmoothing by deafult.
513- update pulseaudio patches
514- remove invalid Provides: Wine HQ
515- remove unneeded patches
516
517* Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
518- Wine development release 1.1.0.
519- Updated specfile (for VineSeed)
520
521#--------------------------------------------------------------------
522
523* Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
524- added  "ja_fonts_replace-*.reg" files.
525- Updated specfile
526
527* Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
528- version upgrade
529- Updated specfile
530- Update to 1.0
531- fix wine.desktop mime types (fc)
532- add desktop package including desktop files and binary handler (fc)
533- pull in some wine alsa/pulseaudio patches (fc)
534-- NEWS "June 17, 2008: Wine 1.0 Released"
535-- read http://www.winehq.org/?issue=348
536
537* Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
538- Updated specfile
539- Update to 1.0-rc4
540- NEWS "June 6, 2008: Wine 1.0-rc4 Released"
541-- ntdll: Add local defines for VIF and VIP flags.
542--  wininet: Include openssl/ssl.h before Windows headers.
543--  shell32: Fixed the French about box.
544--  ChangeLog: Moved to documentation/ChangeLog.BETA.
545--  fonts: Add a non-breaking space glyph to the Tahoma fonts.
546--  ....others , read ChangeLog
547--- Bug fixes only, we are in code freeze.
548
549* Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
550- Updated specfile
551- Update to 1.0-rc3
552- NEWS "May 30, 2008: Wine 1.0-rc3 Released"
553-- The default version is now Windows XP.
554-- Many Richedit improvements.
555-- Beginning of jscript dll support.
556-- Shell folders now respect XDG directory configuration.
557-- Many translation updates.
558-- Lots of bug fixes.
559-- * Bug fixes only, we are in code freeze.
560--- kernel32: Add a builtin 16-bit winhelp.exe.
561--- This should be moved to winhlp32.exe once we support 16-bit modules in
562--- executables.
563---- winhelp -> renamed winhlp32.exe
564---- programs: Remove winelauncher from install rules.
565
566* Mon Apr 04 2008 Seiichirou Babasaki 0.9.59
567- Updated specfile
568- Update to 0.9.59
569- NEWS.. "April 4, 2008: Wine 0.9.59 Released"
570-- * Improved support for the .NET framework.
571-- * Better services handling through a separate services.exe process.
572-- * Support for ATI fragment shader.
573-- * Better support for http proxies.
574-- * Window management fixes.
575-- * Pre-compiled fonts are now available in the source tree.
576-- * Lots of bug fixes.
577
578* Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
579- Updated specfile (split wine-init package)
580- Update to 0.9.58
581- NEWS.. "March 21, 2008: Wine 0.9.58 Released"
582--  * The default version is now Windows XP.
583--  * Many Richedit improvements.
584--  * Beginning of jscript dll support.
585--  * Shell folders now respect XDG directory configuration.
586--  * Many translation updates.
587--  * Lots of bug fixes.
588
589* Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
590- Updated specfile (*.desktop file %check .)
591- Update to 0.9.57
592- NEWS.. "March 7, 2008: Wine 0.9.57 Released"
593--  * Support for multiple OpenGL pixel formats.
594--  * Improved support for color profiles.
595--  * Many window management fixes.
596--  * Better fullscreen support.
597--  * Lots of bug fixes.
598
599* Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
600- Updated specfile
601- ("Build Tool" from the wine-package to move to devel-packages)
602- Update to 0.9.56
603- NEWS.. "February 22, 2008: Wine 0.9.56 Released"
604--  * Proper handling of OpenGL/Direct3D windows with menu bars.
605--  * Stubs for all the d3dx9_xx dlls.
606--  * Several graphics optimizations.
607--  * Many installer fixes.
608--  * Improved MIME message support.
609--  * Lots of bug fixes.
610
611* Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
612- Updated specfile (cf. VineLinux .spec file format)
613- Add Installed messages for "binfmt_misc" .
614- *.desktop file "Name" change to japanese. (UTF8)
615
616* Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
617- Import WINE - Packager: Babasaki
618- Updated specfile (SUSE base + FC9 cfg)
619- Update to 0.9.55
620- Update to 0.9.54 from FC9
621- Update to 0.9.53 from Private package
622
623# FC9 ------------------------------------------------------------- FC9
624
625* Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
626- 0.9.55-1
627- version upgrade
628
629* Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
630- 0.9.54-1
631- version upgrade
632- remove default pulseaudio workaround (#429420,#428745)
633- improve pulseaudio readme
634
635* Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
636- 0.9.53-2
637- add some missing BR
638
639* Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
640- 0.9.53-1
641- version upgrade
642
643* Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
644- 0.9.52-2
645- fix menu bug (#393641)
646
647* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
648- 0.9.52-1
649- version upgrade
650
651* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
652- 0.9.51-3
653- add -n Wine to pulseaudio workaround
654- try to fix menu bug #393641
655
656* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
657- 0.9.51-2
658- add fix for #344281 pulseaudio workaround
659- fix #253474: wine-jack should require jack-audio-connection-kit
660
661* Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
662- 0.9.51-1
663- version upgrade
664
665# ---- abbreviatio ----------------------------------------------------#
666
667# ----------and suse.
668# * Fri Mar 17 2006 - meissner@suse.de
669# - Avoid ulimit leading to out of memory situations by using
670#  the compat address space layout personality. #152115
671
Note: See TracBrowser for help on using the repository browser.