source: projects/specs/trunk/w/wine/wine-vl.spec @ 1718

Revision 1718, 23.2 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release

Line 
1%define pkg_major_version 1.2
2%define pkg_name wine
3%define pkg_release 2%{?_dist_release}
4
5# NEW Release: numbering rule. -- Release: 1%{?_dist_release}
6# spec file for package wine.. # base (SUSE10 and fedora core 9)
7
8Summary:        Allows running Windows 16/32/64 bit programs on Unix.
9Summary(ja):    Unix で 16/32/64ビットWindoowsプログラムを実行させます
10Name:           %{pkg_name}
11Version:        %{pkg_major_version}
12Release:        %{pkg_release}
13URL:            http://www.winehq.org/
14License:        LGPLv2+
15Group:          Applications/System
16
17#--------------------------------------------------------------------
18Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
19#--------------------------------------------------------------------
20
21Source1:        wine.init
22Source3:        wine-README-Fedora
23Source4:        wine-32.conf
24# desktop stuff
25Source100:      wine-notepad.desktop
26Source101:      wine-regedit.desktop
27Source102:      wine-uninstaller.desktop
28Source103:      wine-winecfg.desktop
29Source104:      wine-winefile.desktop
30Source105:      wine-winemine.desktop
31Source106:      wine-winhelp.desktop
32Source107:      wine-wineboot.desktop
33
34# desktop dir
35Source200:      wine.menu
36Source201:      wine.directory
37
38# mime types
39Source300:      wine-mime-msi.desktop
40
41# explain how to use wine with pulseaudio
42Source402:      README-FEDORA-PULSEAUDIO
43Patch400:       http://art.ified.ca/downloads/winepulse-0.30-configure.ac.patch
44Patch401:       http://art.ified.ca/downloads/winepulse-0.30.patch
45Patch402:       http://art.ified.ca/downloads/adding-pulseaudio-to-winecfg-0.4.1.patch
46
47Patch0:         wine-prefixfonts.patch
48Patch1:         wine-1.1.28-rpath.patch
49
50# fix #448338
51## Patch2:         wine-desktop-mime.patch
52
53# enable FontSmoothing by deafult
54Patch1000: wine-1.1.23-vine.patch
55
56# ADD ja
57Source801: wine_README.ja
58Source802: README-FEDORA-PULSEAUDIO.ja
59Source803: wine-README-Fedora.ja
60Source804: wine_README_add.ja
61Source805: fonts-replace-list.txt
62Source806: ja_fonts_replace-js2ipa.reg
63Source807: ja_fonts_replace-js2vl.reg
64Source808: ja_fonts_replace-ms2ipa.reg
65Source809: ja_fonts_replace-ms2vl.reg
66
67
68Vendor: Project Vine
69Distribution: Vine Linux
70Packager: daisuke, Takemikaduchi
71
72ExclusiveArch: %{ix86} x86_64
73
74#--------------------------------------------------------------------
75BuildRoot:      %{_tmppath}/%{name}-%{version}-root
76#--------------------------------------------------------------------
77
78## FedoraCore ##
79BuildRequires: bison, flex
80BuildRequires: audiofile, audiofile-devel
81BuildRequires: alsa-lib-devel, esound-devel
82BuildRequires: freeglut-devel, lcms-devel
83## BuildRequires:  libieee1284-devel
84BuildRequires: libjpeg-devel, libpng-devel
85BuildRequires: libstdc++3-devel, libstdc++34-devel
86BuildRequires: libusb-devel
87BuildRequires: libxml2-devel, libxslt-devel
88BuildRequires: openldap-devel, ncurses-devel
89BuildRequires: unixODBC-devel, openssl-devel
90BuildRequires: sane-devel
91BuildRequires: zlib-devel
92BuildRequires: desktop-file-utils
93BuildRequires: fontforge
94## BuildRequires: gphoto2, gphoto2-devel
95## BuildRequires: jack-audio-connection-kit-devel
96## BuildRequires:  isdn4k-utils-devel
97BuildRequires: cups-devel
98BuildRequires: dbus-devel, hal-devel
99## Requires:       %{_bindir}/xmessage
100
101## X modular(fc) > X 7.2
102BuildRequires:  libX11-devel
103BuildRequires:  mesa-libGL-devel, mesa-libGLU-devel
104BuildRequires:  libXxf86dga-devel, libXxf86vm-devel
105BuildRequires:  libXrandr-devel
106BuildRequires:  libXrender-devel
107BuildRequires:  libXext-devel
108BuildRequires:  libXinerama-devel
109BuildRequires:  libXcomposite-devel
110BuildRequires:  libXmu-devel
111BuildRequires:  libXi-devel
112BuildRequires:  libXcursor-devel
113BuildRequires:  fontconfig-devel
114BuildRequires:  giflib-devel
115BuildRequires:  libtiff-devel
116BuildRequires:  pkgconfig
117BuildRequires:  libicu-devel
118BuildRequires:  freetype2-devel
119
120%ifarch x86_64
121BuildRequires: compat32-glibc-devel
122BuildRequires: compat32-glibc-devel
123BuildRequires: compat32-libX11-devel
124BuildRequires: compat32-libxcb-devel
125BuildRequires: compat32-freetype2-devel
126BuildRequires: compat32-libSM-devel
127BuildRequires: compat32-libXext-devel
128BuildRequires: compat32-libXrender-devel
129BuildRequires: compat32-mesa-libGL-devel
130BuildRequires: compat32-mesa-libGLU-devel
131BuildRequires: compat32-libxml2-devel
132BuildRequires: compat32-libxslt-devel
133BuildRequires: compat32-openssl-devel
134BuildRequires: compat32-libjpeg-devel
135BuildRequires: compat32-libpng-devel
136BuildRequires: compat32-zlib-devel
137## extension
138BuildRequires: compat32-libXcursor-devel
139BuildRequires: compat32-libXi-devel
140BuildRequires: compat32-libXxf86vm-devel
141BuildRequires: compat32-libXrandr-devel
142BuildRequires: compat32-libXinerama-devel
143BuildRequires: compat32-libXcomposite-devel
144BuildRequires: compat32-ncurses-devel
145BuildRequires: compat32-fontconfig-devel
146BuildRequires: compat32-libtiff-devel
147BuildRequires: compat32-openldap-devel
148%endif
149
150Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
151Requires(post): desktop-file-utils >= 0.8
152Requires(preun): /sbin/chkconfig, /sbin/service
153Requires(postun): /sbin/ldconfig
154Requires(postun): desktop-file-utils >= 0.8
155
156#--------------------------------------------------------------------
157
158%description
159(WINE Is Not an Emulator)
160 While Wine is usually thought of as a Windows(TM) emulator,
161the Wine developers would prefer that users thought of
162Wine as a Windows compatibility layer for UNIX.
163 This package includes a program loader, which allows
164unmodified Windows 3.x/9x/NT binaries to run on x86 and
165x86_64 Unixes.
166Wine does not require MS Windows, but it can use native
167system .dll files if they are available.
168
169
170%description -l ja
171(WINE Is Not an Emulator)
172 WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
173開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
174互換レイヤー」と考えてくれる事を好むでしょう。
175 このパッケージはプログラムローダーを含み、これは未修正の
176Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
177させます。
178 WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
179Windows システムの .dll ファイルが存在するのならば、それを使用する
180事もできます
181
182#--------------------------------------------------------------------
183%package devel
184Summary: Wine development environment
185Summary(ja):    WINE の開発ファイルです
186Group: System Environment/Libraries
187Requires: wine = %{version}-%{release}
188
189%description devel
190This RPM contains the header files and development tools
191for the WINE libraries.
192
193%description devel -l ja
194WINEの開発用ライブラリやヘッダーファイル、そして開発用の
195アプリケーション(例:winebuild)のパッケージです
196(development packages)
197
198#--------------------------------------------------------------------
199%package init
200Summary: WINE binfmt_misc kernel function used for init file.
201Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
202Group: System Environment/Libraries
203Requires: wine = %{version}-%{release}
204
205%description init
206WINE binfmt_misc kernel function used for init file.
207WIN32-binary attribute run with a Linux-binary run the same way as possible.
208(init.d packages)
209** example **
210Until now, "$ wine /file/to/path/arege.exe" and then you were running
211 from the usual binary Linux as "$ /file/to/path/arege.exe"
212 and just be able to run.
213Of course, please be mindful of security.
214
215
216%description init -l ja
217カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
218実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
219ようにします。
220(init.d packages)
221※ 例 ※
222これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
223が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
224だけで実行できるようになります。
225無論、セキュリティに留意して下さい。
226
227
228#--------------------------------------------------------------------
229
230%prep
231
232%setup -q -n %{name}-%{version}
233## %patch0
234%patch1 -p1
235## %patch400 -p1
236%patch401 -p1
237## %patch402 -p1 -b .add-pa-to-winecfg
238%patch1000 -p1
239
240%build
241
242%ifarch x86_64
243export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
244./configure \
245        --prefix=%{_prefix} \
246        --libdir=%{_libdir} \
247        --with-x \
248        --without-jack \
249        --without-capi
250%else
251export CFLAGS="$RPM_OPT_FLAGS"
252%{configure} \
253        --prefix=%{_prefix} \
254        --with-x \
255        --without-jack \
256        --without-capi
257%endif
258
259grep "have_x=yes" config.log || exit 1
260
261%{__make} depend
262
263%{__make} %{?_smp_mflags}
264
265%install
266rm -rf ${RPM_BUILD_ROOT}
267%{__make} install DESTDIR=${RPM_BUILD_ROOT}
268
269#-----------------------------------------------------------FC9
270mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
271
272# Allow users to launch Windows programs by just clicking on the .exe file...
273mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
274install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
275
276# add wine dir to desktop
277mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
278install -p -m 644 %{SOURCE200} \
279${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
280
281mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
282install -p -m 644 %{SOURCE201} \
283${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
284
285## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
286## %%{_datadir}/applications
287
288# install desktop files
289desktop-file-install \
290  --vendor=vine \
291  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
292  %{SOURCE100}
293
294desktop-file-install \
295  --vendor=vine \
296  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
297  %{SOURCE101}
298
299desktop-file-install \
300  --vendor=vine \
301  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
302  %{SOURCE102}
303
304desktop-file-install \
305  --vendor=vine \
306  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
307  %{SOURCE103}
308
309desktop-file-install \
310  --vendor=vine \
311  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
312  %{SOURCE104}
313
314desktop-file-install \
315  --vendor=vine \
316  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
317  %{SOURCE105}
318
319desktop-file-install \
320  --vendor=vine \
321  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
322  %{SOURCE106}
323
324desktop-file-install \
325  --vendor=vine \
326  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
327  %{SOURCE107}
328
329desktop-file-install \
330  --vendor=vine \
331  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
332  --delete-original \
333  ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
334
335#mime-types
336desktop-file-install \
337  --vendor=vine \
338  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
339  %{SOURCE300}
340
341
342## other files
343cp %{SOURCE3} README-Fedora
344cp %{SOURCE803} README-Fedora.ja
345cp %{SOURCE801} documentation/README.ja
346cp %{SOURCE804} documentation/README_add.ja
347cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
348
349mkdir -p ${RPM_BUILD_ROOT}/%{_sysconfdir}/ld.so.conf.d/
350install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
351
352
353# deploy pulseaudio readme (802jp)
354cp %{SOURCE402} .
355cp %{SOURCE802} .
356
357# check desktop files
358%check
359desktop-file-validate \
360 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
361desktop-file-validate \
362 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
363desktop-file-validate \
364 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
365desktop-file-validate \
366 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
367desktop-file-validate \
368 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
369desktop-file-validate \
370 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
371desktop-file-validate \
372 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
373desktop-file-validate \
374 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
375desktop-file-validate \
376 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
377
378#--------------------------------------------------------------------
379%clean
380rm -rf ${RPM_BUILD_ROOT}
381
382%post
383/sbin/ldconfig
384update-desktop-database &>/dev/null || :
385### add vinelinux
386if [ "$LANG" = "ja_JP.UTF-8" ]; then
387  echo "WINEのシステムフォントをリプレースするには"
388  echo " fonts-replace-list.txt をお読み下さい。"
389else
390  echo "You need to Japanese fonts name replace, "
391  echo "See fonts-replace-list.txt ."
392fi
393
394%postun
395/sbin/ldconfig
396update-desktop-database &>/dev/null || :
397
398%post init
399if [ $1 = 1 ]; then
400/sbin/chkconfig --add wine
401/sbin/chkconfig --level 2345 wine on
402/sbin/service wine start &>/dev/null || :
403fi
404### add vinelinux
405if [ "$LANG" = "ja_JP.UTF-8" ]; then
406    echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
407    echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
408    echo "(ファイル名は /etc/init.d/wine です)"
409    echo "起動時にファイルシステムのマウントが必要です。"
410    echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
411    echo "(削除も手動でお願いします)"
412    echo ""
413    echo "# cp /etc/fstab /etc/fstab.before  ##バックアップの作成"
414    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
415    echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
416else
417    echo "WINE binfmt_misc feature from the boot files "
418    echo "to be installed and enabled 2,3,4,5 runlevel."
419    echo "(File name in the /etc/init.d/wine )"
420    echo "Filesystem mounted at boot time is required."
421    echo "Root privileges using the following command in the /etc/fstab"
422    echo "please Addenda.(Please delete manually.)"
423    echo ""
424    echo "# cp /etc/fstab /etc/fstab.before   ##(Create backup)"
425    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
426    echo "See also(en)http://www.linux.com/articles/56032 "
427fi
428
429%preun init
430if [ $1 = 0 ]; then
431        /sbin/service wine stop >/dev/null 2>&1
432        /sbin/chkconfig --del wine
433fi
434
435#--------------------------------------------------------------------
436## deleted /usr/share/applications/wine.desktop
437%files
438%defattr(-,root,root,-)
439%doc ANNOUNCE AUTHORS COPYING.LIB  LICENSE LICENSE.OLD
440%doc README VERSION
441%doc README-FEDORA-PULSEAUDIO
442%doc README-FEDORA-PULSEAUDIO.ja
443%doc README-Fedora
444%doc README-Fedora.ja
445%doc documentation/README* documentation/ChangeLog*
446%doc documentation/ja_fonts_replace*
447%doc documentation/fonts-replace-list.txt
448### %{_bindir}/*
449%{_bindir}/msiexec
450%{_bindir}/regedit
451%{_bindir}/regsvr32
452%{_bindir}/wine
453%{_bindir}/wineboot
454%{_bindir}/wineconsole
455## %{_bindir}/wineprefixcreate
456%{_bindir}/winecfg
457%{_bindir}/wine-preloader
458# winelauncher --> Remove
459%{_bindir}/wineserver
460%{_bindir}/notepad
461%{_bindir}/winedbg
462%{_bindir}/winedump
463%{_bindir}/winefile
464%{_bindir}/winemaker
465%{_bindir}/winemine
466%{_bindir}/winepath
467## winhelp -> renamed winhlp32.exe
468%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
469%{_sysconfdir}/ld.so.conf.d/wine-32.conf
470%{_libdir}/libwine.so.1*
471%dir %{_libdir}/wine
472%{_libdir}/wine/*.cpl.so
473%{_libdir}/wine/*.exe.so
474%{_libdir}/wine/*.exe16.so
475%{_libdir}/wine/*.dll.so
476%{_libdir}/wine/*.dll16.so
477%{_libdir}/wine/*.drv.so
478%{_libdir}/wine/*.drv16.so
479%{_libdir}/wine/*.mod16.so
480## %{_libdir}/wine/*.*16
481%{_libdir}/wine/*.ds.so
482%{_libdir}/wine/*.ocx.so
483%{_libdir}/wine/*.vxd.so
484%{_libdir}/wine/*.acm.so
485%{_libdir}/wine/*.sys.so
486%{_libdir}/wine/*.tlb.so
487%dir %{_libdir}/wine/fakedlls
488%{_libdir}/wine/fakedlls/*
489%dir %{_datadir}/wine
490%{_datadir}/wine/*
491%{_datadir}/applications/vine-wine-mime-msi.desktop
492%{_datadir}/applications/vine-wine.desktop
493%{_datadir}/applications/vine-wine-regedit.desktop
494%{_datadir}/applications/vine-wine-uninstaller.desktop
495%{_datadir}/applications/vine-wine-winecfg.desktop
496%{_datadir}/applications/vine-wine-wineboot.desktop
497%{_datadir}/applications/vine-wine-notepad.desktop
498%{_datadir}/applications/vine-wine-winefile.desktop
499%{_datadir}/applications/vine-wine-winemine.desktop
500%{_datadir}/applications/vine-wine-winhelp.desktop
501%{_datadir}/desktop-directories/Wine.directory
502%{_mandir}/man1/wine.1.*
503%{_mandir}/man1/wineserver.1*
504## %{_mandir}/man1/wineprefixcreate.1*
505%lang(de) %{_mandir}/de.UTF-8/man1/*.1*
506%lang(fr) %{_mandir}/fr.UTF-8/man1/*
507
508#--------------------------------------------------------------------
509%files devel
510%defattr(-,root,root,-)
511%{_bindir}/function_grep.pl
512%{_bindir}/widl
513%{_bindir}/winebuild
514%{_bindir}/winecpp
515%{_bindir}/winedump
516%{_bindir}/wineg++
517%{_bindir}/winegcc
518%{_bindir}/winemaker
519%{_bindir}/wmc
520%{_bindir}/wrc
521%{_includedir}/wine
522%{_libdir}/*.so
523
524%{_libdir}/wine/*.a
525%{_libdir}/wine/*.def
526
527%{_mandir}/man1/widl.1*
528%{_mandir}/man1/winebuild.1*
529%{_mandir}/man1/winedump.1*
530%{_mandir}/man1/winegcc.1*
531%{_mandir}/man1/winemaker.1*
532%{_mandir}/man1/winedbg.1*
533%{_mandir}/man1/wineg++.1*
534%{_mandir}/man1/wmc.1*
535%{_mandir}/man1/wrc.1*
536
537#--------------------------------------------------------------------
538%files init
539%defattr(-,root,root,-)
540%{_initrddir}/wine
541%doc documentation/README_add.ja
542
543#--------------------------------------------------------------------
544%changelog
545* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
546- new upstream release
547- fix %configure (add configu:e and gcc option of x86_64)
548- fix %install (remove wine.desktop and change make install option)
549- add ExclusiveArch: %{ix86} x86_64
550- add BuildRequires for x86_64 (compat32 packages)
551
552* Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
553- update to 1.2-rc2
554- fix spec file
555  - if [ "$LANG" = "ja_JP.eucJP" ];
556  + if [ "$LANG" = "ja_JP.UTF-8" ];
557- convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
558  - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
559- fix %files
560- drop patches (Patch0, Patch400, Patch402)
561
562* Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
563- update BRs
564  - remove freetype-devel
565  - remove libungif-devel, add giflib-devel
566  - remove gphoto2-devel, add libgphoto2-devel
567
568* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
569- update to 1.1.29
570
571* Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
572- update to 1.1.28
573- update winepulse patches
574
575* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
576- update to 1.1.23
577- spec in utf-8
578- add patch1000 to enable FontSmoothing by deafult.
579- update pulseaudio patches
580- remove invalid Provides: Wine HQ
581- remove unneeded patches
582
583* Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
584- Wine development release 1.1.0.
585- Updated specfile (for VineSeed)
586
587#--------------------------------------------------------------------
588
589* Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
590- added  "ja_fonts_replace-*.reg" files.
591- Updated specfile
592
593* Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
594- version upgrade
595- Updated specfile
596- Update to 1.0
597- fix wine.desktop mime types (fc)
598- add desktop package including desktop files and binary handler (fc)
599- pull in some wine alsa/pulseaudio patches (fc)
600-- NEWS "June 17, 2008: Wine 1.0 Released"
601-- read http://www.winehq.org/?issue=348
602
603* Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
604- Updated specfile
605- Update to 1.0-rc4
606- NEWS "June 6, 2008: Wine 1.0-rc4 Released"
607-- ntdll: Add local defines for VIF and VIP flags.
608--  wininet: Include openssl/ssl.h before Windows headers.
609--  shell32: Fixed the French about box.
610--  ChangeLog: Moved to documentation/ChangeLog.BETA.
611--  fonts: Add a non-breaking space glyph to the Tahoma fonts.
612--  ....others , read ChangeLog
613--- Bug fixes only, we are in code freeze.
614
615* Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
616- Updated specfile
617- Update to 1.0-rc3
618- NEWS "May 30, 2008: Wine 1.0-rc3 Released"
619-- The default version is now Windows XP.
620-- Many Richedit improvements.
621-- Beginning of jscript dll support.
622-- Shell folders now respect XDG directory configuration.
623-- Many translation updates.
624-- Lots of bug fixes.
625-- * Bug fixes only, we are in code freeze.
626--- kernel32: Add a builtin 16-bit winhelp.exe.
627--- This should be moved to winhlp32.exe once we support 16-bit modules in
628--- executables.
629---- winhelp -> renamed winhlp32.exe
630---- programs: Remove winelauncher from install rules.
631
632* Mon Apr 04 2008 Seiichirou Babasaki 0.9.59
633- Updated specfile
634- Update to 0.9.59
635- NEWS.. "April 4, 2008: Wine 0.9.59 Released"
636-- * Improved support for the .NET framework.
637-- * Better services handling through a separate services.exe process.
638-- * Support for ATI fragment shader.
639-- * Better support for http proxies.
640-- * Window management fixes.
641-- * Pre-compiled fonts are now available in the source tree.
642-- * Lots of bug fixes.
643
644* Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
645- Updated specfile (split wine-init package)
646- Update to 0.9.58
647- NEWS.. "March 21, 2008: Wine 0.9.58 Released"
648--  * The default version is now Windows XP.
649--  * Many Richedit improvements.
650--  * Beginning of jscript dll support.
651--  * Shell folders now respect XDG directory configuration.
652--  * Many translation updates.
653--  * Lots of bug fixes.
654
655* Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
656- Updated specfile (*.desktop file %check .)
657- Update to 0.9.57
658- NEWS.. "March 7, 2008: Wine 0.9.57 Released"
659--  * Support for multiple OpenGL pixel formats.
660--  * Improved support for color profiles.
661--  * Many window management fixes.
662--  * Better fullscreen support.
663--  * Lots of bug fixes.
664
665* Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
666- Updated specfile
667- ("Build Tool" from the wine-package to move to devel-packages)
668- Update to 0.9.56
669- NEWS.. "February 22, 2008: Wine 0.9.56 Released"
670--  * Proper handling of OpenGL/Direct3D windows with menu bars.
671--  * Stubs for all the d3dx9_xx dlls.
672--  * Several graphics optimizations.
673--  * Many installer fixes.
674--  * Improved MIME message support.
675--  * Lots of bug fixes.
676
677* Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
678- Updated specfile (cf. VineLinux .spec file format)
679- Add Installed messages for "binfmt_misc" .
680- *.desktop file "Name" change to japanese. (UTF8)
681
682* Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
683- Import WINE - Packager: Babasaki
684- Updated specfile (SUSE base + FC9 cfg)
685- Update to 0.9.55
686- Update to 0.9.54 from FC9
687- Update to 0.9.53 from Private package
688
689# FC9 ------------------------------------------------------------- FC9
690
691* Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
692- 0.9.55-1
693- version upgrade
694
695* Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
696- 0.9.54-1
697- version upgrade
698- remove default pulseaudio workaround (#429420,#428745)
699- improve pulseaudio readme
700
701* Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
702- 0.9.53-2
703- add some missing BR
704
705* Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
706- 0.9.53-1
707- version upgrade
708
709* Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
710- 0.9.52-2
711- fix menu bug (#393641)
712
713* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
714- 0.9.52-1
715- version upgrade
716
717* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
718- 0.9.51-3
719- add -n Wine to pulseaudio workaround
720- try to fix menu bug #393641
721
722* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
723- 0.9.51-2
724- add fix for #344281 pulseaudio workaround
725- fix #253474: wine-jack should require jack-audio-connection-kit
726
727* Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
728- 0.9.51-1
729- version upgrade
730
731# ---- abbreviatio ----------------------------------------------------#
732
733# ----------and suse.
734# * Fri Mar 17 2006 - meissner@suse.de
735# - Avoid ulimit leading to out of memory situations by using
736#  the compat address space layout personality. #152115
737
Note: See TracBrowser for help on using the repository browser.