source: projects/specs/trunk/w/wine/wine-vl.spec @ 1197

Revision 1197, 21.7 KB checked in by Takemikaduchi, 14 years ago (diff)

update wine and add wine-doors

Line 
1%define pkg_major_version 1.2
2%define pkg_name wine
3%define pkg_release 1.rc2%{?_dist_release}
4
5# NEW Release: numbering rule. -- Release: 1%{?_dist_release}
6# spec file for package wine.. # base (SUSE10 and fedora core 9)
7
8Summary:        Allows running Windows 16/32/64 bit programs on Unix.
9Summary(ja):    Unix で 16/32/64ビットWindoowsプログラムを実行させます
10Name:           %{pkg_name}
11Version:        %{pkg_major_version}
12Release:        %{pkg_release}
13URL:            http://www.winehq.org/
14License:        LGPLv2+
15Group:          Applications/System
16
17#--------------------------------------------------------------------
18Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}-rc2.tar.bz2
19#--------------------------------------------------------------------
20
21Source1:        wine.init
22Source3:    wine-README-Fedora
23Source4:    wine-32.conf
24# desktop stuff
25Source100:      wine-notepad.desktop
26Source101:      wine-regedit.desktop
27Source102:      wine-uninstaller.desktop
28Source103:      wine-winecfg.desktop
29Source104:      wine-winefile.desktop
30Source105:      wine-winemine.desktop
31Source106:      wine-winhelp.desktop
32Source107:      wine-wineboot.desktop
33
34# desktop dir
35Source200:      wine.menu
36Source201:      wine.directory
37
38# mime types
39Source300:      wine-mime-msi.desktop
40
41# explain how to use wine with pulseaudio
42Source402:      README-FEDORA-PULSEAUDIO
43Patch400:       http://art.ified.ca/downloads/winepulse-0.30-configure.ac.patch
44Patch401:       http://art.ified.ca/downloads/winepulse-0.30.patch
45Patch402:       http://art.ified.ca/downloads/adding-pulseaudio-to-winecfg-0.4.1.patch
46
47Patch0:         wine-prefixfonts.patch
48Patch1:         wine-1.1.28-rpath.patch
49
50# fix #448338
51## Patch2:         wine-desktop-mime.patch
52
53# enable FontSmoothing by deafult
54Patch1000: wine-1.1.23-vine.patch
55
56# ADD ja
57Source801: wine_README.ja
58Source802: README-FEDORA-PULSEAUDIO.ja
59Source803: wine-README-Fedora.ja
60Source804: wine_README_add.ja
61Source805: fonts-replace-list.txt
62Source806: ja_fonts_replace-js2ipa.reg
63Source807: ja_fonts_replace-js2vl.reg
64Source808: ja_fonts_replace-ms2ipa.reg
65Source809: ja_fonts_replace-ms2vl.reg
66
67
68Vendor: Project Vine
69Distribution: Vine Linux
70Packager: daisuke, Takemikaduchi
71
72#--------------------------------------------------------------------
73BuildRoot:      %{_tmppath}/%{name}-%{version}-root
74#--------------------------------------------------------------------
75
76## FedoraCore ##
77BuildRequires: bison, flex
78BuildRequires: audiofile, audiofile-devel
79BuildRequires: alsa-lib-devel, esound-devel
80BuildRequires: freeglut-devel, lcms-devel
81## BuildRequires:  libieee1284-devel
82BuildRequires: libjpeg-devel, libpng-devel
83BuildRequires: libstdc++3-devel, libstdc++34-devel
84BuildRequires: libusb-devel
85BuildRequires: libxml2-devel, libxslt-devel
86BuildRequires: openldap-devel, ncurses-devel
87BuildRequires: unixODBC-devel, openssl-devel
88BuildRequires: sane-devel
89BuildRequires: zlib-devel
90BuildRequires: desktop-file-utils
91BuildRequires: fontforge
92## BuildRequires: gphoto2, gphoto2-devel
93## BuildRequires: jack-audio-connection-kit-devel
94## BuildRequires:  isdn4k-utils-devel
95BuildRequires: cups-devel
96BuildRequires: dbus-devel, hal-devel
97## Requires:       %{_bindir}/xmessage
98
99## X modular(fc) > X 7.2
100BuildRequires:  libX11-devel
101BuildRequires:  mesa-libGL-devel, mesa-libGLU-devel
102BuildRequires:  libXxf86dga-devel, libXxf86vm-devel
103BuildRequires:  libXrandr-devel
104BuildRequires:  libXrender-devel
105BuildRequires:  libXext-devel
106BuildRequires:  libXinerama-devel
107BuildRequires:  libXcomposite-devel
108BuildRequires:  libXmu-devel
109BuildRequires:  libXi-devel
110BuildRequires:  libXcursor-devel
111BuildRequires:  fontconfig-devel
112BuildRequires:  giflib-devel
113BuildRequires:  libtiff-devel
114BuildRequires:  pkgconfig
115BuildRequires:  libicu-devel
116BuildRequires:  freetype2-devel
117
118Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
119Requires(post): desktop-file-utils >= 0.8
120Requires(preun): /sbin/chkconfig, /sbin/service
121Requires(postun): /sbin/ldconfig
122Requires(postun): desktop-file-utils >= 0.8
123
124#--------------------------------------------------------------------
125
126%description
127(WINE Is Not an Emulator)
128 While Wine is usually thought of as a Windows(TM) emulator,
129the Wine developers would prefer that users thought of
130Wine as a Windows compatibility layer for UNIX.
131 This package includes a program loader, which allows
132unmodified Windows 3.x/9x/NT binaries to run on x86 and
133x86_64 Unixes.
134Wine does not require MS Windows, but it can use native
135system .dll files if they are available.
136
137
138%description -l ja
139(WINE Is Not an Emulator)
140 WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
141開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
142互換レイヤー」と考えてくれる事を好むでしょう。
143 このパッケージはプログラムローダーを含み、これは未修正の
144Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
145させます。
146 WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
147Windows システムの .dll ファイルが存在するのならば、それを使用する
148事もできます
149
150#--------------------------------------------------------------------
151%package devel
152Summary: Wine development environment
153Summary(ja):    WINE の開発ファイルです
154Group: System Environment/Libraries
155Requires: wine = %{version}-%{release}
156
157%description devel
158This RPM contains the header files and development tools
159for the WINE libraries.
160
161%description devel -l ja
162WINEの開発用ライブラリやヘッダーファイル、そして開発用の
163アプリケーション(例:winebuild)のパッケージです
164(development packages)
165
166#--------------------------------------------------------------------
167%package init
168Summary: WINE binfmt_misc kernel function used for init file.
169Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
170Group: System Environment/Libraries
171Requires: wine = %{version}-%{release}
172
173%description init
174WINE binfmt_misc kernel function used for init file.
175WIN32-binary attribute run with a Linux-binary run the same way as possible.
176(init.d packages)
177** example **
178Until now, "$ wine /file/to/path/arege.exe" and then you were running
179 from the usual binary Linux as "$ /file/to/path/arege.exe"
180 and just be able to run.
181Of course, please be mindful of security.
182
183
184%description init -l ja
185カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
186実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
187ようにします。
188(init.d packages)
189※ 例 ※
190これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
191が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
192だけで実行できるようになります。
193無論、セキュリティに留意して下さい。
194
195
196#--------------------------------------------------------------------
197
198%prep
199
200%setup -q -n %{name}-%{version}-rc2
201## %patch0
202%patch1 -p1
203## %patch400 -p1
204%patch401 -p1
205## %patch402 -p1 -b .add-pa-to-winecfg
206%patch1000 -p1
207
208%build
209
210export CFLAGS="$RPM_OPT_FLAGS"
211%{configure} \
212        --prefix=%{_prefix} \
213        --with-x \
214        --without-jack \
215        --without-capi
216
217grep "have_x=yes" config.log || exit 1
218
219%{__make} depend
220
221%{__make} %{?_smp_mflags}
222
223%install
224rm -rf ${RPM_BUILD_ROOT}
225%{__make} prefix=${RPM_BUILD_ROOT}/%{_prefix}/ install \
226        DESTDIR=${RPM_BUILD_ROOT}
227
228#-----------------------------------------------------------FC9
229mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
230
231# Allow users to launch Windows programs by just clicking on the .exe file...
232mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
233install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
234
235# add wine dir to desktop
236mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
237install -p -m 644 %{SOURCE200} \
238${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
239
240mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
241install -p -m 644 %{SOURCE201} \
242${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
243
244## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
245## %%{_datadir}/applications
246
247# install desktop files
248desktop-file-install \
249  --vendor=vine \
250  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
251  %{SOURCE100}
252
253desktop-file-install \
254  --vendor=vine \
255  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
256  %{SOURCE101}
257
258desktop-file-install \
259  --vendor=vine \
260  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
261  %{SOURCE102}
262
263desktop-file-install \
264  --vendor=vine \
265  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
266  %{SOURCE103}
267
268desktop-file-install \
269  --vendor=vine \
270  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
271  %{SOURCE104}
272
273desktop-file-install \
274  --vendor=vine \
275  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
276  %{SOURCE105}
277
278desktop-file-install \
279  --vendor=vine \
280  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
281  %{SOURCE106}
282
283desktop-file-install \
284  --vendor=vine \
285  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
286  %{SOURCE107}
287
288desktop-file-install \
289  --vendor=vine \
290  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
291  --delete-original \
292  ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
293
294#mime-types
295desktop-file-install \
296  --vendor=vine \
297  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
298  %{SOURCE300}
299
300
301## other files
302cp %{SOURCE3} README-Fedora
303cp %{SOURCE803} README-Fedora.ja
304cp %{SOURCE801} documentation/README.ja
305cp %{SOURCE804} documentation/README_add.ja
306cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
307
308mkdir -p ${RPM_BUILD_ROOT}/%{_sysconfdir}/ld.so.conf.d/
309install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
310
311
312# deploy pulseaudio readme (802jp)
313cp %{SOURCE402} .
314cp %{SOURCE802} .
315
316# check desktop files
317%check
318desktop-file-validate \
319 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
320desktop-file-validate \
321 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
322desktop-file-validate \
323 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
324desktop-file-validate \
325 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
326desktop-file-validate \
327 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
328desktop-file-validate \
329 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
330desktop-file-validate \
331 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
332desktop-file-validate \
333 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
334desktop-file-validate \
335 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
336
337#--------------------------------------------------------------------
338%clean
339rm -rf ${RPM_BUILD_ROOT}
340
341%post
342/sbin/ldconfig
343update-desktop-database &>/dev/null || :
344### add vinelinux
345if [ "$LANG" = "ja_JP.UTF-8" ]; then
346  echo "WINEのシステムフォントをリプレースするには"
347  echo " fonts-replace-list.txt をお読み下さい。"
348else
349  echo "You need to Japanese fonts name replace, "
350  echo "See fonts-replace-list.txt ."
351fi
352
353%postun
354/sbin/ldconfig
355update-desktop-database &>/dev/null || :
356
357%post init
358if [ $1 = 1 ]; then
359/sbin/chkconfig --add wine
360/sbin/chkconfig --level 2345 wine on
361/sbin/service wine start &>/dev/null || :
362fi
363### add vinelinux
364if [ "$LANG" = "ja_JP.UTF-8" ]; then
365    echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
366    echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
367    echo "(ファイル名は /etc/init.d/wine です)"
368    echo "起動時にファイルシステムのマウントが必要です。"
369    echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
370    echo "(削除も手動でお願いします)"
371    echo ""
372    echo "# cp /etc/fstab /etc/fstab.before  ##バックアップの作成"
373    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
374    echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
375else
376    echo "WINE binfmt_misc feature from the boot files "
377    echo "to be installed and enabled 2,3,4,5 runlevel."
378    echo "(File name in the /etc/init.d/wine )"
379    echo "Filesystem mounted at boot time is required."
380    echo "Root privileges using the following command in the /etc/fstab"
381    echo "please Addenda.(Please delete manually.)"
382    echo ""
383    echo "# cp /etc/fstab /etc/fstab.before   ##(Create backup)"
384    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
385    echo "See also(en)http://www.linux.com/articles/56032 "
386fi
387
388%preun init
389if [ $1 = 0 ]; then
390        /sbin/service wine stop >/dev/null 2>&1
391        /sbin/chkconfig --del wine
392fi
393
394#--------------------------------------------------------------------
395## deleted /usr/share/applications/wine.desktop
396%files
397%defattr(-,root,root,-)
398%doc ANNOUNCE AUTHORS COPYING.LIB  LICENSE LICENSE.OLD
399%doc README VERSION
400%doc README-FEDORA-PULSEAUDIO
401%doc README-FEDORA-PULSEAUDIO.ja
402%doc README-Fedora
403%doc README-Fedora.ja
404%doc documentation/README* documentation/ChangeLog*
405%doc documentation/ja_fonts_replace*
406%doc documentation/fonts-replace-list.txt
407### %{_bindir}/*
408%{_bindir}/msiexec
409%{_bindir}/regedit
410%{_bindir}/regsvr32
411%{_bindir}/wine
412%{_bindir}/wineboot
413%{_bindir}/wineconsole
414## %{_bindir}/wineprefixcreate
415%{_bindir}/winecfg
416%{_bindir}/wine-preloader
417# winelauncher --> Remove
418%{_bindir}/wineserver
419%{_bindir}/notepad
420%{_bindir}/winedbg
421%{_bindir}/winedump
422%{_bindir}/winefile
423%{_bindir}/winemaker
424%{_bindir}/winemine
425%{_bindir}/winepath
426## winhelp -> renamed winhlp32.exe
427%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
428%{_sysconfdir}/ld.so.conf.d/wine-32.conf
429%{_libdir}/libwine.so.1*
430%dir %{_libdir}/wine
431%{_libdir}/wine/*.cpl.so
432%{_libdir}/wine/*.exe.so
433%{_libdir}/wine/*.exe16.so
434%{_libdir}/wine/*.dll.so
435%{_libdir}/wine/*.dll16.so
436%{_libdir}/wine/*.drv.so
437%{_libdir}/wine/*.drv16.so
438%{_libdir}/wine/*.mod16.so
439## %{_libdir}/wine/*.*16
440%{_libdir}/wine/*.ds.so
441%{_libdir}/wine/*.ocx.so
442%{_libdir}/wine/*.vxd.so
443%{_libdir}/wine/*.acm.so
444%{_libdir}/wine/*.sys.so
445%{_libdir}/wine/*.tlb.so
446%dir %{_libdir}/wine/fakedlls
447%{_libdir}/wine/fakedlls/*
448%dir %{_datadir}/wine
449%{_datadir}/wine/*
450%{_datadir}/applications/vine-wine-mime-msi.desktop
451%{_datadir}/applications/vine-wine.desktop
452%{_datadir}/applications/vine-wine-regedit.desktop
453%{_datadir}/applications/vine-wine-uninstaller.desktop
454%{_datadir}/applications/vine-wine-winecfg.desktop
455%{_datadir}/applications/vine-wine-wineboot.desktop
456%{_datadir}/applications/vine-wine-notepad.desktop
457%{_datadir}/applications/vine-wine-winefile.desktop
458%{_datadir}/applications/vine-wine-winemine.desktop
459%{_datadir}/applications/vine-wine-winhelp.desktop
460%{_datadir}/desktop-directories/Wine.directory
461%{_mandir}/man1/wine.1.*
462%{_mandir}/man1/wineserver.1*
463## %{_mandir}/man1/wineprefixcreate.1*
464%lang(de) %{_mandir}/de.UTF-8/man1/*.1*
465%lang(fr) %{_mandir}/fr.UTF-8/man1/*
466
467#--------------------------------------------------------------------
468%files devel
469%defattr(-,root,root,-)
470%{_bindir}/function_grep.pl
471%{_bindir}/widl
472%{_bindir}/winebuild
473%{_bindir}/winecpp
474%{_bindir}/winedump
475%{_bindir}/wineg++
476%{_bindir}/winegcc
477%{_bindir}/winemaker
478%{_bindir}/wmc
479%{_bindir}/wrc
480%{_includedir}/wine
481%{_libdir}/*.so
482
483%{_libdir}/wine/*.a
484%{_libdir}/wine/*.def
485
486%{_mandir}/man1/widl.1*
487%{_mandir}/man1/winebuild.1*
488%{_mandir}/man1/winedump.1*
489%{_mandir}/man1/winegcc.1*
490%{_mandir}/man1/winemaker.1*
491%{_mandir}/man1/winedbg.1*
492%{_mandir}/man1/wineg++.1*
493%{_mandir}/man1/wmc.1*
494%{_mandir}/man1/wrc.1*
495
496#--------------------------------------------------------------------
497%files init
498%defattr(-,root,root,-)
499%{_initrddir}/wine
500%doc documentation/README_add.ja
501
502#--------------------------------------------------------------------
503%changelog
504* Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
505- update to 1.2-rc2
506- fix spec file
507  - if [ "$LANG" = "ja_JP.eucJP" ];
508  + if [ "$LANG" = "ja_JP.UTF-8" ];
509- convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
510  - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
511- fix %files
512- drop patches (Patch0, Patch400, Patch402)
513
514* Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
515- update BRs
516  - remove freetype-devel
517  - remove libungif-devel, add giflib-devel
518  - remove gphoto2-devel, add libgphoto2-devel
519
520* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
521- update to 1.1.29
522
523* Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
524- update to 1.1.28
525- update winepulse patches
526
527* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
528- update to 1.1.23
529- spec in utf-8
530- add patch1000 to enable FontSmoothing by deafult.
531- update pulseaudio patches
532- remove invalid Provides: Wine HQ
533- remove unneeded patches
534
535* Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
536- Wine development release 1.1.0.
537- Updated specfile (for VineSeed)
538
539#--------------------------------------------------------------------
540
541* Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
542- added  "ja_fonts_replace-*.reg" files.
543- Updated specfile
544
545* Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
546- version upgrade
547- Updated specfile
548- Update to 1.0
549- fix wine.desktop mime types (fc)
550- add desktop package including desktop files and binary handler (fc)
551- pull in some wine alsa/pulseaudio patches (fc)
552-- NEWS "June 17, 2008: Wine 1.0 Released"
553-- read http://www.winehq.org/?issue=348
554
555* Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
556- Updated specfile
557- Update to 1.0-rc4
558- NEWS "June 6, 2008: Wine 1.0-rc4 Released"
559-- ntdll: Add local defines for VIF and VIP flags.
560--  wininet: Include openssl/ssl.h before Windows headers.
561--  shell32: Fixed the French about box.
562--  ChangeLog: Moved to documentation/ChangeLog.BETA.
563--  fonts: Add a non-breaking space glyph to the Tahoma fonts.
564--  ....others , read ChangeLog
565--- Bug fixes only, we are in code freeze.
566
567* Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
568- Updated specfile
569- Update to 1.0-rc3
570- NEWS "May 30, 2008: Wine 1.0-rc3 Released"
571-- The default version is now Windows XP.
572-- Many Richedit improvements.
573-- Beginning of jscript dll support.
574-- Shell folders now respect XDG directory configuration.
575-- Many translation updates.
576-- Lots of bug fixes.
577-- * Bug fixes only, we are in code freeze.
578--- kernel32: Add a builtin 16-bit winhelp.exe.
579--- This should be moved to winhlp32.exe once we support 16-bit modules in
580--- executables.
581---- winhelp -> renamed winhlp32.exe
582---- programs: Remove winelauncher from install rules.
583
584* Mon Apr 04 2008 Seiichirou Babasaki 0.9.59
585- Updated specfile
586- Update to 0.9.59
587- NEWS.. "April 4, 2008: Wine 0.9.59 Released"
588-- * Improved support for the .NET framework.
589-- * Better services handling through a separate services.exe process.
590-- * Support for ATI fragment shader.
591-- * Better support for http proxies.
592-- * Window management fixes.
593-- * Pre-compiled fonts are now available in the source tree.
594-- * Lots of bug fixes.
595
596* Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
597- Updated specfile (split wine-init package)
598- Update to 0.9.58
599- NEWS.. "March 21, 2008: Wine 0.9.58 Released"
600--  * The default version is now Windows XP.
601--  * Many Richedit improvements.
602--  * Beginning of jscript dll support.
603--  * Shell folders now respect XDG directory configuration.
604--  * Many translation updates.
605--  * Lots of bug fixes.
606
607* Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
608- Updated specfile (*.desktop file %check .)
609- Update to 0.9.57
610- NEWS.. "March 7, 2008: Wine 0.9.57 Released"
611--  * Support for multiple OpenGL pixel formats.
612--  * Improved support for color profiles.
613--  * Many window management fixes.
614--  * Better fullscreen support.
615--  * Lots of bug fixes.
616
617* Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
618- Updated specfile
619- ("Build Tool" from the wine-package to move to devel-packages)
620- Update to 0.9.56
621- NEWS.. "February 22, 2008: Wine 0.9.56 Released"
622--  * Proper handling of OpenGL/Direct3D windows with menu bars.
623--  * Stubs for all the d3dx9_xx dlls.
624--  * Several graphics optimizations.
625--  * Many installer fixes.
626--  * Improved MIME message support.
627--  * Lots of bug fixes.
628
629* Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
630- Updated specfile (cf. VineLinux .spec file format)
631- Add Installed messages for "binfmt_misc" .
632- *.desktop file "Name" change to japanese. (UTF8)
633
634* Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
635- Import WINE - Packager: Babasaki
636- Updated specfile (SUSE base + FC9 cfg)
637- Update to 0.9.55
638- Update to 0.9.54 from FC9
639- Update to 0.9.53 from Private package
640
641# FC9 ------------------------------------------------------------- FC9
642
643* Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
644- 0.9.55-1
645- version upgrade
646
647* Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
648- 0.9.54-1
649- version upgrade
650- remove default pulseaudio workaround (#429420,#428745)
651- improve pulseaudio readme
652
653* Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
654- 0.9.53-2
655- add some missing BR
656
657* Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
658- 0.9.53-1
659- version upgrade
660
661* Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
662- 0.9.52-2
663- fix menu bug (#393641)
664
665* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
666- 0.9.52-1
667- version upgrade
668
669* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
670- 0.9.51-3
671- add -n Wine to pulseaudio workaround
672- try to fix menu bug #393641
673
674* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
675- 0.9.51-2
676- add fix for #344281 pulseaudio workaround
677- fix #253474: wine-jack should require jack-audio-connection-kit
678
679* Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
680- 0.9.51-1
681- version upgrade
682
683# ---- abbreviatio ----------------------------------------------------#
684
685# ----------and suse.
686# * Fri Mar 17 2006 - meissner@suse.de
687# - Avoid ulimit leading to out of memory situations by using
688#  the compat address space layout personality. #152115
689
Note: See TracBrowser for help on using the repository browser.