source: projects/specs/trunk/w/wine/wine-vl.spec @ 10376

Revision 10376, 29.0 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1%define pkg_major_version 1.8.3
2%define pkg_name wine
3%define pkg_release 1%{?_dist_release}
4
5# NEW Release: numbering rule. -- Release: 1%{?_dist_release}
6# spec file for package wine.. # base (SUSE10 and fedora core 9)
7
8Summary:        Allows running Windows 16/32 bit programs on Unix.
9Summary(ja):    Unix で 16/32ビットWindoowsプログラムを実行させます
10Name:           %{pkg_name}
11Version:        %{pkg_major_version}
12Release:        %{pkg_release}
13URL:            http://www.winehq.org/
14License:        LGPLv2+
15Group:          Applications/System
16
17#--------------------------------------------------------------------
18Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
19#--------------------------------------------------------------------
20
21Source1:        wine.init
22Source3:        wine-README-Fedora
23Source4:        wine-32.conf
24Source5:        wine-64.conf
25# desktop stuff
26Source100:      wine-notepad.desktop
27Source101:      wine-regedit.desktop
28Source102:      wine-uninstaller.desktop
29Source103:      wine-winecfg.desktop
30Source104:      wine-winefile.desktop
31Source105:      wine-winemine.desktop
32Source106:      wine-winhelp.desktop
33Source107:      wine-wineboot.desktop
34
35# desktop dir
36Source200:      wine.menu
37Source201:      wine.directory
38
39# mime types
40Source300:      wine-mime-msi.desktop
41
42Patch0:         wine-prefixfonts.patch
43Patch1:         wine-1.1.28-rpath.patch
44Patch2:         wine-1.7.40-x86_64_gstreamer.patch
45Patch3:                 wine-cjk.patch
46
47# ADD ja
48Source801: wine_README.ja
49Source803: wine-README-Fedora.ja
50Source804: wine_README_add.ja
51Source805: fonts-replace-list.txt
52Source806: ja_fonts_replace-js2ipa.reg
53Source807: ja_fonts_replace-js2vl.reg
54Source808: ja_fonts_replace-ms2ipa.reg
55Source809: ja_fonts_replace-ms2vl.reg
56
57
58Vendor: Project Vine
59Distribution: Vine Linux
60Packager: daisuke, Takemikaduchi
61
62ExclusiveArch: %{ix86} x86_64
63
64#--------------------------------------------------------------------
65BuildRoot:      %{_tmppath}/%{name}-%{version}-root
66#--------------------------------------------------------------------
67
68## FedoraCore ##
69BuildRequires: bison, flex
70BuildRequires: audiofile, audiofile-devel
71BuildRequires: alsa-lib-devel
72BuildRequires: freeglut-devel, lcms-devel
73## BuildRequires:  libieee1284-devel
74BuildRequires: libjpeg-devel, libpng-devel
75BuildRequires: libstdc++-devel
76BuildRequires: libusb-devel
77BuildRequires: libxml2-devel, libxslt-devel
78BuildRequires: openldap-devel, ncurses-devel
79BuildRequires: unixODBC-devel, openssl-devel
80# BuildRequires: sane-devel
81BuildRequires: zlib-devel
82BuildRequires: desktop-file-utils
83BuildRequires: fontforge
84## BuildRequires: gphoto2, gphoto2-devel
85## BuildRequires: jack-audio-connection-kit-devel
86## BuildRequires:  isdn4k-utils-devel
87BuildRequires: cups-devel
88BuildRequires: dbus-devel
89BuildRequires: gstreamer-plugins-base-devel
90## Requires:       %{_bindir}/xmessage
91
92## X modular(fc) > X 7.2
93BuildRequires:  libX11-devel
94BuildRequires:  mesa-libGL-devel
95BuildRequires:  mesa-libGLU-devel
96BuildRequires:  mesa-libOSMesa-devel
97BuildRequires:  libXxf86dga-devel, libXxf86vm-devel
98BuildRequires:  libXrandr-devel
99BuildRequires:  libXrender-devel
100BuildRequires:  libXext-devel
101BuildRequires:  libXinerama-devel
102BuildRequires:  libXcomposite-devel
103BuildRequires:  libXmu-devel
104BuildRequires:  libXi-devel
105BuildRequires:  libXcursor-devel
106BuildRequires:  fontconfig-devel
107BuildRequires:  giflib-devel
108BuildRequires:  libtiff-devel
109BuildRequires:  pkgconfig
110BuildRequires:  libicu-devel
111BuildRequires:  freetype2-devel
112BuildRequires:  lcms2-devel
113BuildRequires:  gsm-devel
114
115%ifarch x86_64
116BuildRequires: compat32-glibc-devel
117BuildRequires: compat32-glibc-devel
118BuildRequires: compat32-libX11-devel
119BuildRequires: compat32-libxcb-devel
120BuildRequires: compat32-freetype2-devel
121BuildRequires: compat32-libSM-devel
122BuildRequires: compat32-libXext-devel
123BuildRequires: compat32-libXrender-devel
124BuildRequires: compat32-mesa-libGL-devel
125BuildRequires: compat32-mesa-libGLU-devel
126BuildRequires: compat32-mesa-libOSMesa-devel
127BuildRequires: compat32-libxml2-devel
128BuildRequires: compat32-libxslt-devel
129BuildRequires: compat32-openssl-devel
130BuildRequires: compat32-libjpeg-devel
131BuildRequires: compat32-libpng-devel
132BuildRequires: compat32-zlib-devel
133BuildRequires: compat32-alsa-lib-devel
134BuildRequires: compat32-dbus-devel
135BuildRequires: compat32-lcms2-devel
136BuildRequires: compat32-cups-devel
137BuildRequires: compat32-gnutls-devel
138BuildRequires: compat32-gstreamer-devel
139BuildRequires: compat32-gstreamer-plugins-base-devel
140BuildRequires: compat32-gsm-devel
141## extension
142BuildRequires: compat32-libXcursor-devel
143BuildRequires: compat32-libXi-devel
144BuildRequires: compat32-libXxf86vm-devel
145BuildRequires: compat32-libXrandr-devel
146BuildRequires: compat32-libXinerama-devel
147BuildRequires: compat32-libXcomposite-devel
148BuildRequires: compat32-ncurses-devel
149BuildRequires: compat32-fontconfig-devel
150BuildRequires: compat32-libtiff-devel
151BuildRequires: compat32-openldap-devel
152
153Requires:       compat32-freetype2
154Requires:       compat32-ncurses
155Requires:       compat32-eudev-libudev
156%endif
157
158Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
159Requires(post): desktop-file-utils >= 0.8
160Requires(preun): /sbin/chkconfig, /sbin/service
161Requires(postun): /sbin/ldconfig
162Requires(postun): desktop-file-utils >= 0.8
163
164#--------------------------------------------------------------------
165
166%description
167(WINE Is Not an Emulator)
168 While Wine is usually thought of as a Windows(TM) emulator,
169the Wine developers would prefer that users thought of
170Wine as a Windows compatibility layer for UNIX.
171 This package includes a program loader, which allows
172unmodified Windows 3.x/9x/NT binaries to run on x86 and
173x86_64 Unixes.
174Wine does not require MS Windows, but it can use native
175system .dll files if they are available.
176
177
178%description -l ja
179(WINE Is Not an Emulator)
180 WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
181開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
182互換レイヤー」と考えてくれる事を好むでしょう。
183 このパッケージはプログラムローダーを含み、これは未修正の
184Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
185させます。
186 WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
187Windows システムの .dll ファイルが存在するのならば、それを使用する
188事もできます
189
190#--------------------------------------------------------------------
191%package 64bit
192Summary: Allows running Windows 64 bit programs on Unix.
193Summary(ja): Unix で 64ビットWindoowsプログラムを実行させます
194Group: Applications/System
195Requires: %{name} = %{version}-%{release}
196
197%description 64bit
198(WINE Is Not an Emulator)
199 While Wine is usually thought of as a Windows(TM) emulator,
200the Wine developers would prefer that users thought of
201Wine as a Windows compatibility layer for UNIX.
202 This package includes a program loader, which allows
203unmodified Windows 64bit binaries to run on x86_64 Unixes.
204Wine does not require MS Windows, but it can use native
205system .dll files if they are available.
206
207#--------------------------------------------------------------------
208%package devel
209Summary: Wine development environment
210Summary(ja):    WINE の開発ファイルです
211Group: System Environment/Libraries
212Requires: %{name} = %{version}-%{release}
213
214%description devel
215This RPM contains the header files and development tools
216for the WINE libraries.
217
218%description devel -l ja
219WINEの開発用ライブラリやヘッダーファイル、そして開発用の
220アプリケーション(例:winebuild)のパッケージです
221(development packages)
222
223#--------------------------------------------------------------------
224%package init
225Summary: WINE binfmt_misc kernel function used for init file.
226Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
227Group: System Environment/Libraries
228Requires: %{name} = %{version}-%{release}
229
230%description init
231WINE binfmt_misc kernel function used for init file.
232WIN32-binary attribute run with a Linux-binary run the same way as possible.
233(init.d packages)
234** example **
235Until now, "$ wine /file/to/path/arege.exe" and then you were running
236 from the usual binary Linux as "$ /file/to/path/arege.exe"
237 and just be able to run.
238Of course, please be mindful of security.
239
240
241%description init -l ja
242カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
243実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
244ようにします。
245(init.d packages)
246※ 例 ※
247これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
248が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
249だけで実行できるようになります。
250無論、セキュリティに留意して下さい。
251
252
253#--------------------------------------------------------------------
254
255%prep
256
257%setup -q -n %{name}-%{version}
258%ifarch x86_64
259%patch2 -p1
260rm -rf ../64bit
261mkdir ../64bit
262cp -r * ../64bit/
263%endif
264%patch3 -p1 -b .cjk
265
266# fix typo
267sed -i "s|Thamoa|Tahoma|" po/ja.po
268
269%build
270autoreconf -if
271%ifarch x86_64
272export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
273./configure \
274        --prefix=%{_prefix} \
275        --libdir=%{_prefix}/lib \
276        --with-x \
277        --without-capi \
278        --without-gphoto \
279        --without-hal \
280        --without-mpg123 \
281        --without-sane
282
283pushd ../64bit
284autoreconf -if
285export CFLAGS="$RPM_OPT_FLAGS"
286%{configure} \
287        --prefix=%{_prefix} \
288        --with-x \
289        --without-capi \
290        --without-gphoto \
291        --without-hal \
292        --without-mpg123 \
293        --without-sane \
294    --enable-win64
295popd
296%else
297export CFLAGS="$RPM_OPT_FLAGS"
298%{configure} \
299        --prefix=%{_prefix} \
300        --with-x \
301        --without-jack \
302        --without-capi \
303        --without-gphoto \
304        --without-hal \
305        --without-mpg123 \
306        --without-sane
307%endif
308
309grep "have_x=yes" config.log || exit 1
310
311%ifarch x86_64
312export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
313%{__make} depend
314%{__make} %{?_smp_mflags}
315export CFLAGS="$RPM_OPT_FLAGS"
316pushd ../64bit
317%{__make} depend
318%{__make} %{?_smp_mflags}
319popd
320%else
321%{__make} depend
322%{__make} %{?_smp_mflags}
323%endif
324
325%install
326rm -rf ${RPM_BUILD_ROOT}
327%ifarch x86_64
328pushd ../64bit
329%{__make} install DESTDIR=${RPM_BUILD_ROOT}
330mv ${RPM_BUILD_ROOT}%{_bindir}/wineserver ${RPM_BUILD_ROOT}%{_bindir}/wineserver64
331popd
332%endif
333%{__make} install DESTDIR=${RPM_BUILD_ROOT}
334
335#-----------------------------------------------------------FC9
336mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
337
338# Allow users to launch Windows programs by just clicking on the .exe file...
339mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
340install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
341
342# add wine dir to desktop
343mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
344install -p -m 644 %{SOURCE200} \
345${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
346
347mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
348install -p -m 644 %{SOURCE201} \
349${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
350
351## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
352## %%{_datadir}/applications
353
354# install desktop files
355desktop-file-install \
356  --vendor=vine \
357  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
358  %{SOURCE100}
359
360desktop-file-install \
361  --vendor=vine \
362  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
363  %{SOURCE101}
364
365desktop-file-install \
366  --vendor=vine \
367  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
368  %{SOURCE102}
369
370desktop-file-install \
371  --vendor=vine \
372  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
373  %{SOURCE103}
374
375desktop-file-install \
376  --vendor=vine \
377  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
378  %{SOURCE104}
379
380desktop-file-install \
381  --vendor=vine \
382  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
383  %{SOURCE105}
384
385desktop-file-install \
386  --vendor=vine \
387  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
388  %{SOURCE106}
389
390desktop-file-install \
391  --vendor=vine \
392  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
393  %{SOURCE107}
394
395desktop-file-install \
396  --vendor=vine \
397  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
398  --delete-original \
399  ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
400
401#mime-types
402desktop-file-install \
403  --vendor=vine \
404  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
405  %{SOURCE300}
406
407
408## other files
409cp %{SOURCE3} README-Fedora
410cp %{SOURCE803} README-Fedora.ja
411cp %{SOURCE801} documentation/README.ja
412cp %{SOURCE804} documentation/README_add.ja
413cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
414
415mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
416install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
417%ifarch x86_64
418install -p -m644 %{SOURCE5} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
419%endif
420
421# check desktop files
422%check
423desktop-file-validate \
424 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
425desktop-file-validate \
426 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
427desktop-file-validate \
428 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
429desktop-file-validate \
430 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
431desktop-file-validate \
432 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
433desktop-file-validate \
434 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
435desktop-file-validate \
436 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
437desktop-file-validate \
438 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
439desktop-file-validate \
440 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
441
442#--------------------------------------------------------------------
443%clean
444rm -rf ${RPM_BUILD_ROOT}
445
446%post
447/sbin/ldconfig
448update-desktop-database &>/dev/null || :
449### add vinelinux
450if [ "$LANG" = "ja_JP.UTF-8" ]; then
451  echo "WINEのシステムフォントをリプレースするには"
452  echo " fonts-replace-list.txt をお読み下さい。"
453else
454  echo "You need to Japanese fonts name replace, "
455  echo "See fonts-replace-list.txt ."
456fi
457
458%postun
459/sbin/ldconfig
460update-desktop-database &>/dev/null || :
461
462%post 64bit -p /sbin/ldconfig
463
464%postun 64bit -p /sbin/ldconfig
465
466%post init
467if [ $1 = 1 ]; then
468/sbin/chkconfig --add wine
469/sbin/chkconfig --level 2345 wine on
470/sbin/service wine start &>/dev/null || :
471fi
472### add vinelinux
473if [ "$LANG" = "ja_JP.UTF-8" ]; then
474    echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
475    echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
476    echo "(ファイル名は /etc/init.d/wine です)"
477    echo "起動時にファイルシステムのマウントが必要です。"
478    echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
479    echo "(削除も手動でお願いします)"
480    echo ""
481    echo "# cp /etc/fstab /etc/fstab.before  ##バックアップの作成"
482    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
483    echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
484else
485    echo "WINE binfmt_misc feature from the boot files "
486    echo "to be installed and enabled 2,3,4,5 runlevel."
487    echo "(File name in the /etc/init.d/wine )"
488    echo "Filesystem mounted at boot time is required."
489    echo "Root privileges using the following command in the /etc/fstab"
490    echo "please Addenda.(Please delete manually.)"
491    echo ""
492    echo "# cp /etc/fstab /etc/fstab.before   ##(Create backup)"
493    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
494    echo "See also(en)http://www.linux.com/articles/56032 "
495fi
496
497%preun init
498if [ $1 = 0 ]; then
499        /sbin/service wine stop >/dev/null 2>&1
500        /sbin/chkconfig --del wine
501fi
502
503#--------------------------------------------------------------------
504## deleted /usr/share/applications/wine.desktop
505%files
506%defattr(-,root,root,-)
507%doc ANNOUNCE AUTHORS COPYING.LIB  LICENSE LICENSE.OLD
508%doc README VERSION
509%doc README-Fedora
510%doc README-Fedora.ja
511%doc documentation/README*
512%doc documentation/ja_fonts_replace*
513%doc documentation/fonts-replace-list.txt
514%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
515%{_sysconfdir}/ld.so.conf.d/wine-32.conf
516%{_bindir}/msiexec
517%{_bindir}/regedit
518%{_bindir}/regsvr32
519%{_bindir}/wine
520%{_bindir}/wineboot
521%{_bindir}/wineconsole
522%{_bindir}/winecfg
523%{_bindir}/wine-preloader
524%{_bindir}/wineserver
525%{_bindir}/notepad
526%{_bindir}/winedbg
527%{_bindir}/winedump
528%{_bindir}/winefile
529%{_bindir}/winemaker
530%{_bindir}/winemine
531%{_bindir}/winepath
532%ifarch x86_64
533%{_prefix}/lib/libwine.so.1*
534%dir %{_prefix}/lib/wine
535%{_prefix}/lib/wine/*.cpl.so
536%{_prefix}/lib/wine/*.exe.so
537%{_prefix}/lib/wine/*.exe16.so
538%{_prefix}/lib/wine/*.dll.so
539%{_prefix}/lib/wine/*.dll16.so
540%{_prefix}/lib/wine/*.drv.so
541%{_prefix}/lib/wine/*.drv16.so
542%{_prefix}/lib/wine/*.mod16.so
543%{_prefix}/lib/wine/*.ds.so
544%{_prefix}/lib/wine/*.ocx.so
545%{_prefix}/lib/wine/*.vxd.so
546%{_prefix}/lib/wine/*.acm.so
547%{_prefix}/lib/wine/*.sys.so
548%{_prefix}/lib/wine/*.tlb.so
549%dir %{_prefix}/lib/wine/fakedlls
550%{_prefix}/lib/wine/fakedlls/*
551%else
552%{_libdir}/libwine.so.1*
553%dir %{_libdir}/wine
554%{_libdir}/wine/*.cpl.so
555%{_libdir}/wine/*.exe.so
556%{_libdir}/wine/*.dll.so
557%{_libdir}/wine/*.drv.so
558%{_libdir}/wine/*.ds.so
559%{_libdir}/wine/*.ocx.so
560%{_libdir}/wine/*.acm.so
561%{_libdir}/wine/*.sys.so
562%{_libdir}/wine/*.tlb.so
563%{_libdir}/wine/*.exe16.so
564%{_libdir}/wine/*.dll16.so
565%{_libdir}/wine/*.drv16.so
566%{_libdir}/wine/*.mod16.so
567%{_libdir}/wine/*.vxd.so
568%dir %{_libdir}/wine/fakedlls
569%{_libdir}/wine/fakedlls/*
570%endif
571%dir %{_datadir}/wine
572%{_datadir}/wine/*
573%{_datadir}/applications/vine-wine-mime-msi.desktop
574%{_datadir}/applications/vine-wine.desktop
575%{_datadir}/applications/vine-wine-regedit.desktop
576%{_datadir}/applications/vine-wine-uninstaller.desktop
577%{_datadir}/applications/vine-wine-winecfg.desktop
578%{_datadir}/applications/vine-wine-wineboot.desktop
579%{_datadir}/applications/vine-wine-notepad.desktop
580%{_datadir}/applications/vine-wine-winefile.desktop
581%{_datadir}/applications/vine-wine-winemine.desktop
582%{_datadir}/applications/vine-wine-winhelp.desktop
583%{_datadir}/desktop-directories/Wine.directory
584%{_mandir}/man1/wine.1.*
585%{_mandir}/man1/wineserver.1*
586%{_mandir}/man1/msiexec.1*
587%{_mandir}/man1/notepad.1*
588%{_mandir}/man1/regedit.1*
589%{_mandir}/man1/regsvr32.1*
590%{_mandir}/man1/wineboot.1*
591%{_mandir}/man1/winecfg.1*
592%{_mandir}/man1/wineconsole.1*
593%{_mandir}/man1/winefile.1*
594%{_mandir}/man1/winemine.1*
595%{_mandir}/man1/winepath.1*
596%lang(de) %{_mandir}/de.UTF-8/man1/*.1*
597%lang(fr) %{_mandir}/fr.UTF-8/man1/*
598%lang(pl) %{_mandir}/pl.UTF-8/man1/wine.1*
599
600#--------------------------------------------------------------------
601%ifarch x86_64
602%files 64bit
603%defattr(-,root,root,-)
604%{_sysconfdir}/ld.so.conf.d/wine-64.conf
605%{_bindir}/wine64
606%{_bindir}/wine64-preloader
607%{_bindir}/wineserver64
608%{_libdir}/libwine.so.1*
609%dir %{_libdir}/wine
610%{_libdir}/wine/*.cpl.so
611%{_libdir}/wine/*.exe.so
612%{_libdir}/wine/*.dll.so
613%{_libdir}/wine/*.drv.so
614%{_libdir}/wine/*.ds.so
615%{_libdir}/wine/*.ocx.so
616%{_libdir}/wine/*.acm.so
617%{_libdir}/wine/*.sys.so
618%{_libdir}/wine/*.tlb.so
619%dir %{_libdir}/wine/fakedlls
620%{_libdir}/wine/fakedlls/*
621%endif
622#--------------------------------------------------------------------
623%files devel
624%defattr(-,root,root,-)
625%{_bindir}/function_grep.pl
626%{_bindir}/widl
627%{_bindir}/winebuild
628%{_bindir}/winecpp
629%{_bindir}/winedump
630%{_bindir}/wineg++
631%{_bindir}/winegcc
632%{_bindir}/winemaker
633%{_bindir}/wmc
634%{_bindir}/wrc
635%{_includedir}/wine
636%{_libdir}/*.so
637
638%{_libdir}/wine/*.a
639%{_libdir}/wine/*.def
640
641%ifarch x86_64
642%{_prefix}/lib/*.so
643%{_prefix}/lib/wine/*.a
644%{_prefix}/lib/wine/*.def
645%endif
646
647%{_mandir}/man1/widl.1*
648%{_mandir}/man1/winebuild.1*
649%{_mandir}/man1/winecpp.1*
650%{_mandir}/man1/winedump.1*
651%{_mandir}/man1/winegcc.1*
652%{_mandir}/man1/winemaker.1*
653%{_mandir}/man1/wmc.1*
654%{_mandir}/man1/wrc.1*
655%{_mandir}/man1/winedbg.1*
656%{_mandir}/man1/wineg++.1*
657
658#--------------------------------------------------------------------
659%files init
660%defattr(-,root,root,-)
661%{_initrddir}/wine
662%doc documentation/README_add.ja
663
664#--------------------------------------------------------------------
665%changelog
666* Sat Jun 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-1
667- new upstream release
668
669* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
670- new upstream release
671
672* Thu Feb 11 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
673- new upstream release
674- add Source5 (wine-64.conf)
675- add Patch3 (wine-cjk.patch) based on fedora
676- add Requires: compat32-eudev-libudev
677- add configure option (--enable-win64)
678- create wine-64bit subpackage
679
680* Sun Dec 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8-1
681- new upstream release
682- remove Patch400,401,402
683- remove Source402,802
684
685* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.54-1
686- update to 1.7.54
687
688* Sat Oct 24 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.53-1
689- update to 1.7.53
690
691* Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.52-1
692- update to 1.7.52
693
694* Sun Sep 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.51-1
695- update to 1.7.51
696
697* Sun Aug 23 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.50-1
698- update to 1.7.50
699
700* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.49-1
701- update to 1.7.49
702
703* Sat Aug 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.48-1
704- update to 1.7.48
705
706* Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.44-1
707- update to 1.7.44
708
709* Sun May 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.42-1
710- update to 1.7.42
711
712* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.40-1
713- update to 1.7.40
714- update Patch2 (wine-1.7.40-x86_64_gstreamer.patch)
715- add BuildRequires: compat32-mesa-libOSMesa-devel, compat32-lcms2-devel, compat32-gsm-devel (x86_64 only)
716- add BuildRequires: mesa-libOSMesa-devel, lcms2-devel, gsm-devel
717
718* Sat Jan 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
719- new upstream release
720
721* Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
722- new upstream release
723
724* Sat Jul 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6-1
725- new upstream release
726- remove Patch1000 (wine-1.4.1-vine.patch)
727- update Patch2 (wine-1.6-x86_64_gstreamer.patch)
728
729* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.17-1
730- update to 1.5.17
731
732* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
733- new upstream release
734- update Patch1000 (wine-1.4.1-vine.patch)
735
736* Thu Mar 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4-1
737- new upstream release
738- add Patch2 (wine-1.4-x86_64_gstreamer.patch)
739- add BuildRequires: gstreamer-plugins-base-devel
740
741* Sat Jul 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
742- update to 1.2.3
743- add Requires: compat32-freetype2 (x86_64 only)
744
745* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
746- new upstream release
747
748* Thu Oct 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
749- new upstream release
750- drop Patch1
751
752* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
753- new upstream release
754- fix %configure (add configu:e and gcc option of x86_64)
755- fix %install (remove wine.desktop and change make install option)
756- add ExclusiveArch: %{ix86} x86_64
757- add BuildRequires for x86_64 (compat32 packages)
758
759* Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
760- update to 1.2-rc2
761- fix spec file
762  - if [ "$LANG" = "ja_JP.eucJP" ];
763  + if [ "$LANG" = "ja_JP.UTF-8" ];
764- convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
765  - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
766- fix %files
767- drop patches (Patch0, Patch400, Patch402)
768
769* Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
770- update BRs
771  - remove freetype-devel
772  - remove libungif-devel, add giflib-devel
773  - remove gphoto2-devel, add libgphoto2-devel
774
775* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
776- update to 1.1.29
777
778* Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
779- update to 1.1.28
780- update winepulse patches
781
782* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
783- update to 1.1.23
784- spec in utf-8
785- add patch1000 to enable FontSmoothing by deafult.
786- update pulseaudio patches
787- remove invalid Provides: Wine HQ
788- remove unneeded patches
789
790* Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
791- Wine development release 1.1.0.
792- Updated specfile (for VineSeed)
793
794#--------------------------------------------------------------------
795
796* Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
797- added  "ja_fonts_replace-*.reg" files.
798- Updated specfile
799
800* Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
801- version upgrade
802- Updated specfile
803- Update to 1.0
804- fix wine.desktop mime types (fc)
805- add desktop package including desktop files and binary handler (fc)
806- pull in some wine alsa/pulseaudio patches (fc)
807-- NEWS "June 17, 2008: Wine 1.0 Released"
808-- read http://www.winehq.org/?issue=348
809
810* Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
811- Updated specfile
812- Update to 1.0-rc4
813- NEWS "June 6, 2008: Wine 1.0-rc4 Released"
814-- ntdll: Add local defines for VIF and VIP flags.
815--  wininet: Include openssl/ssl.h before Windows headers.
816--  shell32: Fixed the French about box.
817--  ChangeLog: Moved to documentation/ChangeLog.BETA.
818--  fonts: Add a non-breaking space glyph to the Tahoma fonts.
819--  ....others , read ChangeLog
820--- Bug fixes only, we are in code freeze.
821
822* Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
823- Updated specfile
824- Update to 1.0-rc3
825- NEWS "May 30, 2008: Wine 1.0-rc3 Released"
826-- The default version is now Windows XP.
827-- Many Richedit improvements.
828-- Beginning of jscript dll support.
829-- Shell folders now respect XDG directory configuration.
830-- Many translation updates.
831-- Lots of bug fixes.
832-- * Bug fixes only, we are in code freeze.
833--- kernel32: Add a builtin 16-bit winhelp.exe.
834--- This should be moved to winhlp32.exe once we support 16-bit modules in
835--- executables.
836---- winhelp -> renamed winhlp32.exe
837---- programs: Remove winelauncher from install rules.
838
839* Fri Apr 04 2008 Seiichirou Babasaki 0.9.59
840- Updated specfile
841- Update to 0.9.59
842- NEWS.. "April 4, 2008: Wine 0.9.59 Released"
843-- * Improved support for the .NET framework.
844-- * Better services handling through a separate services.exe process.
845-- * Support for ATI fragment shader.
846-- * Better support for http proxies.
847-- * Window management fixes.
848-- * Pre-compiled fonts are now available in the source tree.
849-- * Lots of bug fixes.
850
851* Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
852- Updated specfile (split wine-init package)
853- Update to 0.9.58
854- NEWS.. "March 21, 2008: Wine 0.9.58 Released"
855--  * The default version is now Windows XP.
856--  * Many Richedit improvements.
857--  * Beginning of jscript dll support.
858--  * Shell folders now respect XDG directory configuration.
859--  * Many translation updates.
860--  * Lots of bug fixes.
861
862* Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
863- Updated specfile (*.desktop file %check .)
864- Update to 0.9.57
865- NEWS.. "March 7, 2008: Wine 0.9.57 Released"
866--  * Support for multiple OpenGL pixel formats.
867--  * Improved support for color profiles.
868--  * Many window management fixes.
869--  * Better fullscreen support.
870--  * Lots of bug fixes.
871
872* Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
873- Updated specfile
874- ("Build Tool" from the wine-package to move to devel-packages)
875- Update to 0.9.56
876- NEWS.. "February 22, 2008: Wine 0.9.56 Released"
877--  * Proper handling of OpenGL/Direct3D windows with menu bars.
878--  * Stubs for all the d3dx9_xx dlls.
879--  * Several graphics optimizations.
880--  * Many installer fixes.
881--  * Improved MIME message support.
882--  * Lots of bug fixes.
883
884* Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
885- Updated specfile (cf. VineLinux .spec file format)
886- Add Installed messages for "binfmt_misc" .
887- *.desktop file "Name" change to japanese. (UTF8)
888
889* Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
890- Import WINE - Packager: Babasaki
891- Updated specfile (SUSE base + FC9 cfg)
892- Update to 0.9.55
893- Update to 0.9.54 from FC9
894- Update to 0.9.53 from Private package
895
896# FC9 ------------------------------------------------------------- FC9
897
898* Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
899- 0.9.55-1
900- version upgrade
901
902* Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
903- 0.9.54-1
904- version upgrade
905- remove default pulseaudio workaround (#429420,#428745)
906- improve pulseaudio readme
907
908* Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
909- 0.9.53-2
910- add some missing BR
911
912* Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
913- 0.9.53-1
914- version upgrade
915
916* Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
917- 0.9.52-2
918- fix menu bug (#393641)
919
920* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
921- 0.9.52-1
922- version upgrade
923
924* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
925- 0.9.51-3
926- add -n Wine to pulseaudio workaround
927- try to fix menu bug #393641
928
929* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
930- 0.9.51-2
931- add fix for #344281 pulseaudio workaround
932- fix #253474: wine-jack should require jack-audio-connection-kit
933
934* Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
935- 0.9.51-1
936- version upgrade
937
938# ---- abbreviatio ----------------------------------------------------#
939
940# ----------and suse.
941# * Fri Mar 17 2006 - meissner@suse.de
942# - Avoid ulimit leading to out of memory situations by using
943#  the compat address space layout personality. #152115
944
Note: See TracBrowser for help on using the repository browser.