source: projects/specs/trunk/w/wine/wine-vl.spec @ 9760

Revision 9760, 26.1 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define pkg_major_version 1.7.52
2%define pkg_name wine
3%define pkg_release 1%{?_dist_release}
4
5# NEW Release: numbering rule. -- Release: 1%{?_dist_release}
6# spec file for package wine.. # base (SUSE10 and fedora core 9)
7
8Summary:        Allows running Windows 16/32/64 bit programs on Unix.
9Summary(ja):    Unix で 16/32/64ビットWindoowsプログラムを実行させます
10Name:           %{pkg_name}
11Version:        %{pkg_major_version}
12Release:        %{pkg_release}
13URL:            http://www.winehq.org/
14License:        LGPLv2+
15Group:          Applications/System
16
17#--------------------------------------------------------------------
18Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
19#--------------------------------------------------------------------
20
21Source1:        wine.init
22Source3:        wine-README-Fedora
23Source4:        wine-32.conf
24# desktop stuff
25Source100:      wine-notepad.desktop
26Source101:      wine-regedit.desktop
27Source102:      wine-uninstaller.desktop
28Source103:      wine-winecfg.desktop
29Source104:      wine-winefile.desktop
30Source105:      wine-winemine.desktop
31Source106:      wine-winhelp.desktop
32Source107:      wine-wineboot.desktop
33
34# desktop dir
35Source200:      wine.menu
36Source201:      wine.directory
37
38# mime types
39Source300:      wine-mime-msi.desktop
40
41# explain how to use wine with pulseaudio
42Source402:      README-FEDORA-PULSEAUDIO
43Patch400:       http://art.ified.ca/downloads/winepulse-0.30-configure.ac.patch
44Patch401:       http://art.ified.ca/downloads/winepulse-0.30.patch
45Patch402:       http://art.ified.ca/downloads/adding-pulseaudio-to-winecfg-0.4.1.patch
46
47Patch0:         wine-prefixfonts.patch
48Patch1:         wine-1.1.28-rpath.patch
49Patch2:         wine-1.7.40-x86_64_gstreamer.patch
50
51# ADD ja
52Source801: wine_README.ja
53Source802: README-FEDORA-PULSEAUDIO.ja
54Source803: wine-README-Fedora.ja
55Source804: wine_README_add.ja
56Source805: fonts-replace-list.txt
57Source806: ja_fonts_replace-js2ipa.reg
58Source807: ja_fonts_replace-js2vl.reg
59Source808: ja_fonts_replace-ms2ipa.reg
60Source809: ja_fonts_replace-ms2vl.reg
61
62
63Vendor: Project Vine
64Distribution: Vine Linux
65Packager: daisuke, Takemikaduchi
66
67ExclusiveArch: %{ix86} x86_64
68
69#--------------------------------------------------------------------
70BuildRoot:      %{_tmppath}/%{name}-%{version}-root
71#--------------------------------------------------------------------
72
73## FedoraCore ##
74BuildRequires: bison, flex
75BuildRequires: audiofile, audiofile-devel
76BuildRequires: alsa-lib-devel
77BuildRequires: freeglut-devel, lcms-devel
78## BuildRequires:  libieee1284-devel
79BuildRequires: libjpeg-devel, libpng-devel
80BuildRequires: libstdc++-devel
81BuildRequires: libusb-devel
82BuildRequires: libxml2-devel, libxslt-devel
83BuildRequires: openldap-devel, ncurses-devel
84BuildRequires: unixODBC-devel, openssl-devel
85# BuildRequires: sane-devel
86BuildRequires: zlib-devel
87BuildRequires: desktop-file-utils
88BuildRequires: fontforge
89## BuildRequires: gphoto2, gphoto2-devel
90## BuildRequires: jack-audio-connection-kit-devel
91## BuildRequires:  isdn4k-utils-devel
92BuildRequires: cups-devel
93BuildRequires: dbus-devel
94BuildRequires: gstreamer-plugins-base-devel
95## Requires:       %{_bindir}/xmessage
96
97## X modular(fc) > X 7.2
98BuildRequires:  libX11-devel
99BuildRequires:  mesa-libGL-devel
100BuildRequires:  mesa-libGLU-devel
101BuildRequires:  mesa-libOSMesa-devel
102BuildRequires:  libXxf86dga-devel, libXxf86vm-devel
103BuildRequires:  libXrandr-devel
104BuildRequires:  libXrender-devel
105BuildRequires:  libXext-devel
106BuildRequires:  libXinerama-devel
107BuildRequires:  libXcomposite-devel
108BuildRequires:  libXmu-devel
109BuildRequires:  libXi-devel
110BuildRequires:  libXcursor-devel
111BuildRequires:  fontconfig-devel
112BuildRequires:  giflib-devel
113BuildRequires:  libtiff-devel
114BuildRequires:  pkgconfig
115BuildRequires:  libicu-devel
116BuildRequires:  freetype2-devel
117BuildRequires:  lcms2-devel
118BuildRequires:  gsm-devel
119
120%ifarch x86_64
121BuildRequires: compat32-glibc-devel
122BuildRequires: compat32-glibc-devel
123BuildRequires: compat32-libX11-devel
124BuildRequires: compat32-libxcb-devel
125BuildRequires: compat32-freetype2-devel
126BuildRequires: compat32-libSM-devel
127BuildRequires: compat32-libXext-devel
128BuildRequires: compat32-libXrender-devel
129BuildRequires: compat32-mesa-libGL-devel
130BuildRequires: compat32-mesa-libGLU-devel
131BuildRequires: compat32-mesa-libOSMesa-devel
132BuildRequires: compat32-libxml2-devel
133BuildRequires: compat32-libxslt-devel
134BuildRequires: compat32-openssl-devel
135BuildRequires: compat32-libjpeg-devel
136BuildRequires: compat32-libpng-devel
137BuildRequires: compat32-zlib-devel
138BuildRequires: compat32-alsa-lib-devel
139BuildRequires: compat32-dbus-devel
140BuildRequires: compat32-lcms2-devel
141BuildRequires: compat32-cups-devel
142BuildRequires: compat32-gnutls-devel
143BuildRequires: compat32-gstreamer-devel
144BuildRequires: compat32-gstreamer-plugins-base-devel
145BuildRequires: compat32-gsm-devel
146## extension
147BuildRequires: compat32-libXcursor-devel
148BuildRequires: compat32-libXi-devel
149BuildRequires: compat32-libXxf86vm-devel
150BuildRequires: compat32-libXrandr-devel
151BuildRequires: compat32-libXinerama-devel
152BuildRequires: compat32-libXcomposite-devel
153BuildRequires: compat32-ncurses-devel
154BuildRequires: compat32-fontconfig-devel
155BuildRequires: compat32-libtiff-devel
156BuildRequires: compat32-openldap-devel
157
158Requires:       compat32-freetype2
159Requires:       compat32-ncurses
160%endif
161
162Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
163Requires(post): desktop-file-utils >= 0.8
164Requires(preun): /sbin/chkconfig, /sbin/service
165Requires(postun): /sbin/ldconfig
166Requires(postun): desktop-file-utils >= 0.8
167
168#--------------------------------------------------------------------
169
170%description
171(WINE Is Not an Emulator)
172 While Wine is usually thought of as a Windows(TM) emulator,
173the Wine developers would prefer that users thought of
174Wine as a Windows compatibility layer for UNIX.
175 This package includes a program loader, which allows
176unmodified Windows 3.x/9x/NT binaries to run on x86 and
177x86_64 Unixes.
178Wine does not require MS Windows, but it can use native
179system .dll files if they are available.
180
181
182%description -l ja
183(WINE Is Not an Emulator)
184 WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
185開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
186互換レイヤー」と考えてくれる事を好むでしょう。
187 このパッケージはプログラムローダーを含み、これは未修正の
188Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
189させます。
190 WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
191Windows システムの .dll ファイルが存在するのならば、それを使用する
192事もできます
193
194#--------------------------------------------------------------------
195%package devel
196Summary: Wine development environment
197Summary(ja):    WINE の開発ファイルです
198Group: System Environment/Libraries
199Requires: wine = %{version}-%{release}
200
201%description devel
202This RPM contains the header files and development tools
203for the WINE libraries.
204
205%description devel -l ja
206WINEの開発用ライブラリやヘッダーファイル、そして開発用の
207アプリケーション(例:winebuild)のパッケージです
208(development packages)
209
210#--------------------------------------------------------------------
211%package init
212Summary: WINE binfmt_misc kernel function used for init file.
213Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
214Group: System Environment/Libraries
215Requires: wine = %{version}-%{release}
216
217%description init
218WINE binfmt_misc kernel function used for init file.
219WIN32-binary attribute run with a Linux-binary run the same way as possible.
220(init.d packages)
221** example **
222Until now, "$ wine /file/to/path/arege.exe" and then you were running
223 from the usual binary Linux as "$ /file/to/path/arege.exe"
224 and just be able to run.
225Of course, please be mindful of security.
226
227
228%description init -l ja
229カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
230実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
231ようにします。
232(init.d packages)
233※ 例 ※
234これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
235が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
236だけで実行できるようになります。
237無論、セキュリティに留意して下さい。
238
239
240#--------------------------------------------------------------------
241
242%prep
243
244%setup -q -n %{name}-%{version}
245%ifarch x86_64
246%patch2 -p1
247%endif
248%patch401 -p1
249
250# fix typo
251sed -i "s|Thamoa|Tahoma|" po/ja.po
252
253%build
254autoreconf -if
255%ifarch x86_64
256export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
257./configure \
258        --prefix=%{_prefix} \
259        --libdir=%{_libdir} \
260        --with-x \
261        --without-jack \
262        --without-capi \
263        --without-gphoto \
264        --without-hal \
265        --without-mpg123 \
266        --without-sane
267%else
268export CFLAGS="$RPM_OPT_FLAGS"
269%{configure} \
270        --prefix=%{_prefix} \
271        --with-x \
272        --without-jack \
273        --without-capi \
274        --without-gphoto \
275        --without-hal \
276        --without-mpg123 \
277        --without-sane
278%endif
279
280grep "have_x=yes" config.log || exit 1
281
282%{__make} depend
283
284%{__make} %{?_smp_mflags}
285
286%install
287rm -rf ${RPM_BUILD_ROOT}
288%{__make} install DESTDIR=${RPM_BUILD_ROOT}
289
290#-----------------------------------------------------------FC9
291mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
292
293# Allow users to launch Windows programs by just clicking on the .exe file...
294mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
295install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
296
297# add wine dir to desktop
298mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
299install -p -m 644 %{SOURCE200} \
300${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
301
302mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
303install -p -m 644 %{SOURCE201} \
304${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
305
306## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
307## %%{_datadir}/applications
308
309# install desktop files
310desktop-file-install \
311  --vendor=vine \
312  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
313  %{SOURCE100}
314
315desktop-file-install \
316  --vendor=vine \
317  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
318  %{SOURCE101}
319
320desktop-file-install \
321  --vendor=vine \
322  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
323  %{SOURCE102}
324
325desktop-file-install \
326  --vendor=vine \
327  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
328  %{SOURCE103}
329
330desktop-file-install \
331  --vendor=vine \
332  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
333  %{SOURCE104}
334
335desktop-file-install \
336  --vendor=vine \
337  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
338  %{SOURCE105}
339
340desktop-file-install \
341  --vendor=vine \
342  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
343  %{SOURCE106}
344
345desktop-file-install \
346  --vendor=vine \
347  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
348  %{SOURCE107}
349
350desktop-file-install \
351  --vendor=vine \
352  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
353  --delete-original \
354  ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
355
356#mime-types
357desktop-file-install \
358  --vendor=vine \
359  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
360  %{SOURCE300}
361
362
363## other files
364cp %{SOURCE3} README-Fedora
365cp %{SOURCE803} README-Fedora.ja
366cp %{SOURCE801} documentation/README.ja
367cp %{SOURCE804} documentation/README_add.ja
368cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
369
370mkdir -p ${RPM_BUILD_ROOT}/%{_sysconfdir}/ld.so.conf.d/
371install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
372
373
374# deploy pulseaudio readme (802jp)
375cp %{SOURCE402} .
376cp %{SOURCE802} .
377
378# check desktop files
379%check
380desktop-file-validate \
381 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
382desktop-file-validate \
383 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
384desktop-file-validate \
385 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
386desktop-file-validate \
387 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
388desktop-file-validate \
389 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
390desktop-file-validate \
391 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
392desktop-file-validate \
393 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
394desktop-file-validate \
395 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
396desktop-file-validate \
397 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
398
399#--------------------------------------------------------------------
400%clean
401rm -rf ${RPM_BUILD_ROOT}
402
403%post
404/sbin/ldconfig
405update-desktop-database &>/dev/null || :
406### add vinelinux
407if [ "$LANG" = "ja_JP.UTF-8" ]; then
408  echo "WINEのシステムフォントをリプレースするには"
409  echo " fonts-replace-list.txt をお読み下さい。"
410else
411  echo "You need to Japanese fonts name replace, "
412  echo "See fonts-replace-list.txt ."
413fi
414
415%postun
416/sbin/ldconfig
417update-desktop-database &>/dev/null || :
418
419%post init
420if [ $1 = 1 ]; then
421/sbin/chkconfig --add wine
422/sbin/chkconfig --level 2345 wine on
423/sbin/service wine start &>/dev/null || :
424fi
425### add vinelinux
426if [ "$LANG" = "ja_JP.UTF-8" ]; then
427    echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
428    echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
429    echo "(ファイル名は /etc/init.d/wine です)"
430    echo "起動時にファイルシステムのマウントが必要です。"
431    echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
432    echo "(削除も手動でお願いします)"
433    echo ""
434    echo "# cp /etc/fstab /etc/fstab.before  ##バックアップの作成"
435    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
436    echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
437else
438    echo "WINE binfmt_misc feature from the boot files "
439    echo "to be installed and enabled 2,3,4,5 runlevel."
440    echo "(File name in the /etc/init.d/wine )"
441    echo "Filesystem mounted at boot time is required."
442    echo "Root privileges using the following command in the /etc/fstab"
443    echo "please Addenda.(Please delete manually.)"
444    echo ""
445    echo "# cp /etc/fstab /etc/fstab.before   ##(Create backup)"
446    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
447    echo "See also(en)http://www.linux.com/articles/56032 "
448fi
449
450%preun init
451if [ $1 = 0 ]; then
452        /sbin/service wine stop >/dev/null 2>&1
453        /sbin/chkconfig --del wine
454fi
455
456#--------------------------------------------------------------------
457## deleted /usr/share/applications/wine.desktop
458%files
459%defattr(-,root,root,-)
460%doc ANNOUNCE AUTHORS COPYING.LIB  LICENSE LICENSE.OLD
461%doc README VERSION
462%doc README-FEDORA-PULSEAUDIO
463%doc README-FEDORA-PULSEAUDIO.ja
464%doc README-Fedora
465%doc README-Fedora.ja
466%doc documentation/README* documentation/ChangeLog*
467%doc documentation/ja_fonts_replace*
468%doc documentation/fonts-replace-list.txt
469### %{_bindir}/*
470%{_bindir}/msiexec
471%{_bindir}/regedit
472%{_bindir}/regsvr32
473%{_bindir}/wine
474%{_bindir}/wineboot
475%{_bindir}/wineconsole
476## %{_bindir}/wineprefixcreate
477%{_bindir}/winecfg
478%{_bindir}/wine-preloader
479# winelauncher --> Remove
480%{_bindir}/wineserver
481%{_bindir}/notepad
482%{_bindir}/winedbg
483%{_bindir}/winedump
484%{_bindir}/winefile
485%{_bindir}/winemaker
486%{_bindir}/winemine
487%{_bindir}/winepath
488## winhelp -> renamed winhlp32.exe
489%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
490%{_sysconfdir}/ld.so.conf.d/wine-32.conf
491%{_libdir}/libwine.so.1*
492%dir %{_libdir}/wine
493%{_libdir}/wine/*.cpl.so
494%{_libdir}/wine/*.exe.so
495%{_libdir}/wine/*.exe16.so
496%{_libdir}/wine/*.dll.so
497%{_libdir}/wine/*.dll16.so
498%{_libdir}/wine/*.drv.so
499%{_libdir}/wine/*.drv16.so
500%{_libdir}/wine/*.mod16.so
501## %{_libdir}/wine/*.*16
502%{_libdir}/wine/*.ds.so
503%{_libdir}/wine/*.ocx.so
504%{_libdir}/wine/*.vxd.so
505%{_libdir}/wine/*.acm.so
506%{_libdir}/wine/*.sys.so
507%{_libdir}/wine/*.tlb.so
508%dir %{_libdir}/wine/fakedlls
509%{_libdir}/wine/fakedlls/*
510%dir %{_datadir}/wine
511%{_datadir}/wine/*
512%{_datadir}/applications/vine-wine-mime-msi.desktop
513%{_datadir}/applications/vine-wine.desktop
514%{_datadir}/applications/vine-wine-regedit.desktop
515%{_datadir}/applications/vine-wine-uninstaller.desktop
516%{_datadir}/applications/vine-wine-winecfg.desktop
517%{_datadir}/applications/vine-wine-wineboot.desktop
518%{_datadir}/applications/vine-wine-notepad.desktop
519%{_datadir}/applications/vine-wine-winefile.desktop
520%{_datadir}/applications/vine-wine-winemine.desktop
521%{_datadir}/applications/vine-wine-winhelp.desktop
522%{_datadir}/desktop-directories/Wine.directory
523%{_mandir}/man1/wine.1.*
524%{_mandir}/man1/wineserver.1*
525%{_mandir}/man1/msiexec.1*
526%{_mandir}/man1/notepad.1*
527%{_mandir}/man1/regedit.1*
528%{_mandir}/man1/regsvr32.1*
529%{_mandir}/man1/wineboot.1*
530%{_mandir}/man1/winecfg.1*
531%{_mandir}/man1/wineconsole.1*
532%{_mandir}/man1/winefile.1*
533%{_mandir}/man1/winemine.1*
534%{_mandir}/man1/winepath.1*
535## %{_mandir}/man1/wineprefixcreate.1*
536%lang(de) %{_mandir}/de.UTF-8/man1/*.1*
537%lang(fr) %{_mandir}/fr.UTF-8/man1/*
538%lang(pl) %{_mandir}/pl.UTF-8/man1/wine.1*
539
540#--------------------------------------------------------------------
541%files devel
542%defattr(-,root,root,-)
543%{_bindir}/function_grep.pl
544%{_bindir}/widl
545%{_bindir}/winebuild
546%{_bindir}/winecpp
547%{_bindir}/winedump
548%{_bindir}/wineg++
549%{_bindir}/winegcc
550%{_bindir}/winemaker
551%{_bindir}/wmc
552%{_bindir}/wrc
553%{_includedir}/wine
554%{_libdir}/*.so
555
556%{_libdir}/wine/*.a
557%{_libdir}/wine/*.def
558
559%{_mandir}/man1/widl.1*
560%{_mandir}/man1/winebuild.1*
561%{_mandir}/man1/winecpp.1*
562%{_mandir}/man1/winedump.1*
563%{_mandir}/man1/winegcc.1*
564%{_mandir}/man1/winemaker.1*
565%{_mandir}/man1/wmc.1*
566%{_mandir}/man1/wrc.1*
567%{_mandir}/man1/winedbg.1*
568%{_mandir}/man1/wineg++.1*
569
570
571#--------------------------------------------------------------------
572%files init
573%defattr(-,root,root,-)
574%{_initrddir}/wine
575%doc documentation/README_add.ja
576
577#--------------------------------------------------------------------
578%changelog
579* Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.52-1
580- update to 1.7.52
581
582* Sun Sep 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.51-1
583- update to 1.7.51
584
585* Sun Aug 23 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.50-1
586- update to 1.7.50
587
588* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.49-1
589- update to 1.7.49
590
591* Sat Aug 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.48-1
592- update to 1.7.48
593
594* Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.44-1
595- update to 1.7.44
596
597* Sun May 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.42-1
598- update to 1.7.42
599
600* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.40-1
601- update to 1.7.40
602- update Patch2 (wine-1.7.40-x86_64_gstreamer.patch)
603- add BuildRequires: compat32-mesa-libOSMesa-devel, compat32-lcms2-devel, compat32-gsm-devel (x86_64 only)
604- add BuildRequires: mesa-libOSMesa-devel, lcms2-devel, gsm-devel
605
606* Sat Jan 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
607- new upstream release
608
609* Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
610- new upstream release
611
612* Sat Jul 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6-1
613- new upstream release
614- remove Patch1000 (wine-1.4.1-vine.patch)
615- update Patch2 (wine-1.6-x86_64_gstreamer.patch)
616
617* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.17-1
618- update to 1.5.17
619
620* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
621- new upstream release
622- update Patch1000 (wine-1.4.1-vine.patch)
623
624* Thu Mar 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4-1
625- new upstream release
626- add Patch2 (wine-1.4-x86_64_gstreamer.patch)
627- add BuildRequires: gstreamer-plugins-base-devel
628
629* Sat Jul 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
630- update to 1.2.3
631- add Requires: compat32-freetype2 (x86_64 only)
632
633* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
634- new upstream release
635
636* Thu Oct 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
637- new upstream release
638- drop Patch1
639
640* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
641- new upstream release
642- fix %configure (add configu:e and gcc option of x86_64)
643- fix %install (remove wine.desktop and change make install option)
644- add ExclusiveArch: %{ix86} x86_64
645- add BuildRequires for x86_64 (compat32 packages)
646
647* Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
648- update to 1.2-rc2
649- fix spec file
650  - if [ "$LANG" = "ja_JP.eucJP" ];
651  + if [ "$LANG" = "ja_JP.UTF-8" ];
652- convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
653  - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
654- fix %files
655- drop patches (Patch0, Patch400, Patch402)
656
657* Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
658- update BRs
659  - remove freetype-devel
660  - remove libungif-devel, add giflib-devel
661  - remove gphoto2-devel, add libgphoto2-devel
662
663* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
664- update to 1.1.29
665
666* Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
667- update to 1.1.28
668- update winepulse patches
669
670* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
671- update to 1.1.23
672- spec in utf-8
673- add patch1000 to enable FontSmoothing by deafult.
674- update pulseaudio patches
675- remove invalid Provides: Wine HQ
676- remove unneeded patches
677
678* Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
679- Wine development release 1.1.0.
680- Updated specfile (for VineSeed)
681
682#--------------------------------------------------------------------
683
684* Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
685- added  "ja_fonts_replace-*.reg" files.
686- Updated specfile
687
688* Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
689- version upgrade
690- Updated specfile
691- Update to 1.0
692- fix wine.desktop mime types (fc)
693- add desktop package including desktop files and binary handler (fc)
694- pull in some wine alsa/pulseaudio patches (fc)
695-- NEWS "June 17, 2008: Wine 1.0 Released"
696-- read http://www.winehq.org/?issue=348
697
698* Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
699- Updated specfile
700- Update to 1.0-rc4
701- NEWS "June 6, 2008: Wine 1.0-rc4 Released"
702-- ntdll: Add local defines for VIF and VIP flags.
703--  wininet: Include openssl/ssl.h before Windows headers.
704--  shell32: Fixed the French about box.
705--  ChangeLog: Moved to documentation/ChangeLog.BETA.
706--  fonts: Add a non-breaking space glyph to the Tahoma fonts.
707--  ....others , read ChangeLog
708--- Bug fixes only, we are in code freeze.
709
710* Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
711- Updated specfile
712- Update to 1.0-rc3
713- NEWS "May 30, 2008: Wine 1.0-rc3 Released"
714-- The default version is now Windows XP.
715-- Many Richedit improvements.
716-- Beginning of jscript dll support.
717-- Shell folders now respect XDG directory configuration.
718-- Many translation updates.
719-- Lots of bug fixes.
720-- * Bug fixes only, we are in code freeze.
721--- kernel32: Add a builtin 16-bit winhelp.exe.
722--- This should be moved to winhlp32.exe once we support 16-bit modules in
723--- executables.
724---- winhelp -> renamed winhlp32.exe
725---- programs: Remove winelauncher from install rules.
726
727* Fri Apr 04 2008 Seiichirou Babasaki 0.9.59
728- Updated specfile
729- Update to 0.9.59
730- NEWS.. "April 4, 2008: Wine 0.9.59 Released"
731-- * Improved support for the .NET framework.
732-- * Better services handling through a separate services.exe process.
733-- * Support for ATI fragment shader.
734-- * Better support for http proxies.
735-- * Window management fixes.
736-- * Pre-compiled fonts are now available in the source tree.
737-- * Lots of bug fixes.
738
739* Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
740- Updated specfile (split wine-init package)
741- Update to 0.9.58
742- NEWS.. "March 21, 2008: Wine 0.9.58 Released"
743--  * The default version is now Windows XP.
744--  * Many Richedit improvements.
745--  * Beginning of jscript dll support.
746--  * Shell folders now respect XDG directory configuration.
747--  * Many translation updates.
748--  * Lots of bug fixes.
749
750* Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
751- Updated specfile (*.desktop file %check .)
752- Update to 0.9.57
753- NEWS.. "March 7, 2008: Wine 0.9.57 Released"
754--  * Support for multiple OpenGL pixel formats.
755--  * Improved support for color profiles.
756--  * Many window management fixes.
757--  * Better fullscreen support.
758--  * Lots of bug fixes.
759
760* Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
761- Updated specfile
762- ("Build Tool" from the wine-package to move to devel-packages)
763- Update to 0.9.56
764- NEWS.. "February 22, 2008: Wine 0.9.56 Released"
765--  * Proper handling of OpenGL/Direct3D windows with menu bars.
766--  * Stubs for all the d3dx9_xx dlls.
767--  * Several graphics optimizations.
768--  * Many installer fixes.
769--  * Improved MIME message support.
770--  * Lots of bug fixes.
771
772* Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
773- Updated specfile (cf. VineLinux .spec file format)
774- Add Installed messages for "binfmt_misc" .
775- *.desktop file "Name" change to japanese. (UTF8)
776
777* Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
778- Import WINE - Packager: Babasaki
779- Updated specfile (SUSE base + FC9 cfg)
780- Update to 0.9.55
781- Update to 0.9.54 from FC9
782- Update to 0.9.53 from Private package
783
784# FC9 ------------------------------------------------------------- FC9
785
786* Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
787- 0.9.55-1
788- version upgrade
789
790* Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
791- 0.9.54-1
792- version upgrade
793- remove default pulseaudio workaround (#429420,#428745)
794- improve pulseaudio readme
795
796* Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
797- 0.9.53-2
798- add some missing BR
799
800* Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
801- 0.9.53-1
802- version upgrade
803
804* Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
805- 0.9.52-2
806- fix menu bug (#393641)
807
808* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
809- 0.9.52-1
810- version upgrade
811
812* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
813- 0.9.51-3
814- add -n Wine to pulseaudio workaround
815- try to fix menu bug #393641
816
817* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
818- 0.9.51-2
819- add fix for #344281 pulseaudio workaround
820- fix #253474: wine-jack should require jack-audio-connection-kit
821
822* Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
823- 0.9.51-1
824- version upgrade
825
826# ---- abbreviatio ----------------------------------------------------#
827
828# ----------and suse.
829# * Fri Mar 17 2006 - meissner@suse.de
830# - Avoid ulimit leading to out of memory situations by using
831#  the compat address space layout personality. #152115
832
Note: See TracBrowser for help on using the repository browser.