source: projects/specs/trunk/w/windowapplets/windowapplets-vl.spec @ 1484

Revision 1484, 3.5 KB checked in by kazutaka, 14 years ago (diff)

add a patch to exclude specific apps for window decoration

Line 
1%define domain_name     windowutils
2
3Summary:        Gnome panel applet for maximized window title lbar
4Summary(ja):    最大化したウィンドウのタイトルバー用 GNOME パネルアプレット
5Name:           windowapplets
6Version:        0.2.7
7Release:        2%{?_dist_release}
8Source0:        103732-gnome-window-applets-%{version}.tar.gz
9Source1:        windowapplets-0.2.5-ja.po
10Patch0:         windowapplets-metacity-notitlebar.patch
11Patch1:         windowapplets-0.2.5-locale-dir-fix.patch
12Patch2:         windowapplets-0.2.7-exclude-decorate.patch
13License:        GPLv3
14Group:          User Interface/Desktops
15URL:            http://gnome-look.org/content/show.php?content=103732
16
17BuildRequires:  libwnck-devel gnome-panel gnome-applets
18BuildRequires:  GConf2-devel libbonoboui-devel
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
21Packager:       kazutaka
22
23%description
24GNOME Panel applets that substitute the maximized window toolbar.
25This package contains these applets:
26        - Window Buttons Applet
27        - Window Title Applet
28
29%description -l ja
30最大化したウィンドウのタイトルバーを置き換える GNOME パネル
31アプレットです。
32このパッケージには次のアプレットが含まれます:
33        - ウィンドウボタン・アプレット
34        - ウィンドウタイトル・アプレット
35
36%prep
37%setup -q -n gnome-window-applets-%{version}
38%patch0 -p1 -b .notitlebar
39%patch1 -p1 -b .locale-fix
40%patch2 -p1 -b .exclude-decorate
41
42%build
43%configure --disable-schemas-install
44%{__make} %{?_smp_mflags}
45
46
47%install
48%{__rm} -rf $RPM_BUILD_ROOT
49%{__make} install DESTDIR=$RPM_BUILD_ROOT
50
51#install japanese massage catalog
52%{__mkdir_p} ${RPM_BUILD_ROOT}/%{_localedir}/ja/LC_MESSAGES
53msgfmt %{SOURCE1} -o ${RPM_BUILD_ROOT}/%{_localedir}/ja/LC_MESSAGES/%{domain_name}.mo
54
55# remove docs installed in /usr/doc/%{name}
56%{__rm} -rf $RPM_BUILD_ROOT/%{_prefix}/doc
57
58%find_lang %{domain_name}
59
60%pre
61if [ "$1" -gt 1 ]; then
62  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
63  for f in windowbuttons windowtitle; do
64    echo %{_sysconfdir}/gconf/schemas/${f}.schemas; done \
65    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
66fi
67
68%post
69export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
70for f in windowbuttons windowtitle; do
71  echo %{_sysconfdir}/gconf/schemas/${f}.schemas; done \
72  | xargs gconftool-2 --makefile-install-rule >& /dev/null || :
73
74%preun
75if [ "$1" -eq 0 ]; then
76  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
77  for f in windowbuttons windowtitle; do
78    echo %{_sysconfdir}/gconf/schemas/${f}.schemas; done \
79    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
80fi
81
82
83%clean
84%{__rm} -rf $RPM_BUILD_ROOT
85
86
87%files -f %{domain_name}.lang
88%defattr(-,root,root)
89%doc AUTHORS COPYING ChangeLog INSTALL NEWS README
90%{_sysconfdir}/gconf/schemas/windowbuttons.schemas
91%{_sysconfdir}/gconf/schemas/windowtitle.schemas
92%{_libdir}/bonobo/servers/WindowButtons.server
93%{_libdir}//bonobo/servers/WindowTitle.server
94%{_libexecdir}/windowbuttons
95%{_libexecdir}/windowtitle
96%{_datadir}/windowbuttons
97%{_datadir}/windowtitle
98
99
100%changelog
101* Sun Jul 25 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.2.7-2
102- add Patch2 to exclude specific apps for window decoration
103  (but now support guake only)
104
105* Sat Jul 17 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.2.7-1
106- new upstream release
107
108* Sun Mar 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.2.5-1
109- initial build for Vine Linux
110- add Patch0 to hide title bar of maximized window on metacity
111- add Patch1 to fix GNOMELOCALEDIR
112- add Source1 for japanese translation
113
Note: See TracBrowser for help on using the repository browser.