source: projects/specs/trunk/w/wicd/wicd-vl.spec @ 9331

Revision 9331, 8.4 KB checked in by inagaki, 9 years ago (diff)

2015-02-05 Ryoichi INAGAKI <ryo1@…>

  • wicd, wpa_supplicant: updated
  • xfce4-dict: fixed spec file
  • xfcet-settings: added patch


Line 
1#define python_sitelib %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')
2
3Summary: A wireless and wired network manager
4Summary(ja): 無線・有線ネットワークマネージャ
5Name: wicd
6Version: 1.7.3
7Release: 1%{?_dist_release}
8
9License: GPLv2
10Group: System Environment/Base
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12URL: https://launchpad.net/wicd
13
14Source0: %{name}-%{version}.tar.gz
15Patch0:  wicd-desktop.patch
16Patch1:  wicd-1.7.3-workaround_dhclient_bug.patch
17
18# Vine Patch
19Patch100: add_fix_ja.patch
20Patch101: wicd-1.7.3-setup.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildArch: noarch
24BuildRequires: gettext
25BuildRequires: desktop-file-utils
26BuildRequires: python >= 2.4
27BuildRequires: python-devel >= 2.4
28BuildRequires: python-babel
29BuildRequires: python-setuptools
30BuildRequires: pm-utils
31
32Requires: pm-utils >= 1.2.4
33
34Requires: %{name}-common
35Requires: %{name}-curses
36Requires: %{name}-gtk
37
38#Requires(post):   chkconfig
39#Requires(preun):  chkconfig
40#Requires(preun):  /sbin/service
41#Requires(postun): /sbin/service
42
43Conflicts: NetworkManager
44
45%description
46A complete network connection manager
47Wicd supports wired and wireless networks, and capable of
48creating and tracking profiles for both.  It has a
49template-based wireless encryption system, which allows the user
50to easily add encryption methods used.  It ships with some common
51encryption types, such as WPA and WEP. Wicd will automatically
52connect at startup to any preferred network within range.
53
54%package common
55Summary: Wicd common files
56Summary(ja): Wicd の共通ファイル
57Group: System Environment/Base
58BuildArch: noarch
59Requires: dbus
60Requires: dbus-python
61Requires: dhclient
62Requires: ethtool
63Requires: iproute
64Requires: logrotate
65Requires: net-tools
66Requires: pm-utils-devel
67Requires: wireless-tools
68Requires: wpa_supplicant
69
70Requires(post):   chkconfig
71Requires(preun):  chkconfig
72Requires(preun):  /sbin/service
73Requires(postun): /sbin/service
74#Requires(preun):  initscripts
75#Requires(postun): initscripts
76
77%description common
78This package provides the main wicd daemon and the wicd-cli front-end.
79
80%package curses
81Summary: Curses client for Wicd
82Summary(ja): Wicd の Curse クライアント
83Group: Applications/System
84BuildArch: noarch
85Requires: %{name}-common = %{version}-%{release}
86Requires: python-urwid >= 0.9.8.3
87
88%description curses
89Client program for wicd that uses a curses interface.
90
91%package gtk
92Summary: GTK+ client for Wicd
93Summary(ja): Wicd の GTK+ クライアント
94Group: Applications/System
95BuildArch: noarch
96Requires: %{name}-common = %{version}-%{release}
97Requires: pygtk2 >= 2.10
98Requires: pygtk2-libglade >= 2.10
99Requires: gksu
100
101%description gtk
102Client program for wicd that uses a GTK+ interface.
103
104
105%prep
106%setup -q
107%patch0 -p1
108%patch1 -p1
109%patch101 -p1
110
111%{__sed} -i 's/\r//' wicd/logfile.py
112
113%build
114python setup.py compile_translations
115
116%{__python} setup.py configure \
117       --share=%{_datadir}/%{name} \
118       --etc=%{_sysconfdir}/%{name} \
119       --bin=%{_bindir} \
120       --sbin=%{_sbindir} \
121       --mandir=%{_mandir} \
122       --varlib=%{_sharedstatedir}/wicd \
123       --pmutils=%{_libdir}/pm-utils/sleep.d \
124       --resume=%{_sysconfdir}/acpi/resume.d \
125       --suspend=%{_sysconfdir}/acpi/suspend.d \
126       --docdir=%{_docdir}/%{name}-%{version} \
127       --log=%{_localstatedir}/log \
128       --no-install-gnome-shell-extensions \
129       --no-install-kde \
130       --no-install-docs
131
132python setup.py build
133# python-babel currently doesn't support Asturian, using gettext
134# msgfmt po/ast.po -o translations/ast/LC_MESSAGES/wicd.mo
135
136%install
137[ -d "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
138python setup.py install -O1 --skip-build --root=$RPM_BUILD_ROOT
139install -D init/redhat/%{name} $RPM_BUILD_ROOT%{_initddir}/%{name}
140
141find $RPM_BUILD_ROOT -type f -name ".empty_on_purpose" | xargs rm
142
143desktop-file-install \
144    --remove-category="Application" \
145    --delete-original \
146    --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
147    $RPM_BUILD_ROOT%{_datadir}/applications/wicd.desktop
148
149desktop-file-install \
150    --dir=$RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart \
151    $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/wicd-tray.desktop
152
153%find_lang %{name}
154
155%post common
156touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
157/sbin/service %{name} restart >/dev/null 2>&1
158/sbin/chkconfig --add %{name}
159/sbin/chkconfig --level 345 %{name} on
160
161%preun common
162if [ $1 = 0 ] ; then
163     /sbin/service %{name} stop >/dev/null 2>&1
164     /sbin/chkconfig --del %{name}
165fi
166
167%postun common
168if [ "$1" -ge "1" ] ; then
169    /sbin/service %{name} condrestart >/dev/null 2>&1 || :
170fi
171
172if [ $1 -eq 0 ] ; then
173    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
174    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
175fi
176
177%post gtk
178touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
179
180%postun gtk
181if [ $1 -eq 0 ]; then
182    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
183    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
184fi
185
186%posttrans gtk
187gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
188
189%clean
190[ -d "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
191
192%files
193%defattr(-,root,root)
194%doc AUTHORS CHANGES INSTALL LICENSE NEWS README other/WHEREAREMYFILES
195%{_libdir}/pm-utils/sleep.d/55wicd
196
197%files common -f %{name}.lang
198%{_bindir}/wicd-cli
199%{_bindir}/wicd-client
200%{python_sitelib}/wicd
201%{python_sitelib}/*.egg-info
202%{_datadir}/applications/wicd.desktop
203%{_datadir}/dbus-1/system-services/
204%{_datadir}/man/man1/wicd-client.1*
205%{_datadir}/man/man5/wicd-manager-settings.conf.5*
206%{_datadir}/man/man5/wicd-wired-settings.conf.5*
207%{_datadir}/man/man5/wicd-wireless-settings.conf.5*
208%{_datadir}/man/man8/wicd-cli.8*
209%{_datadir}/man/man8/wicd.8*
210#{_datadir}/pixmaps/wicd*
211%dir %{_datadir}/wicd
212%dir %{_datadir}/wicd/backends
213%dir %{_datadir}/wicd/cli
214%dir %{_datadir}/wicd/daemon
215%{_datadir}/wicd/backends/*
216%{_datadir}/wicd/cli/*
217%{_datadir}/wicd/daemon/*
218%{_mandir}/nl/man?/%{name}*
219%{_sysconfdir}/%{name}
220%{_sysconfdir}/acpi/resume.d/80-wicd-connect.sh
221%{_sysconfdir}/acpi/suspend.d/50-wicd-suspend.sh
222%{_sysconfdir}/dbus-1/system.d/wicd.conf
223%{_sysconfdir}/logrotate.d/
224%{_sysconfdir}/rc.d/init.d/wicd
225%{_sysconfdir}/xdg/autostart/wicd-tray.desktop
226%{_sbindir}/wicd
227%{_localstatedir}/lib/wicd
228%exclude /lib/systemd/system/wicd.service
229
230%files curses
231%defattr(-,root,root,-)
232%dir %{_datadir}/wicd/curses
233%{_datadir}/wicd/curses/*
234%{_bindir}/wicd-curses
235%{_datadir}/man/man8/wicd-curses.8*
236%lang(nl) %{_datadir}/man/nl/man8/wicd-curses.8*
237
238%files gtk
239%defattr(-,root,root,-)
240%dir %{_datadir}/wicd/gtk
241%dir %{_datadir}/wicd/icons
242%{_sysconfdir}/xdg/autostart/wicd-tray.desktop
243%{_datadir}/wicd/gtk/*
244%{_datadir}/wicd/icons/*
245%{_datadir}/pixmaps/wicd-gtk.xpm
246%{_bindir}/wicd-gtk
247%{_datadir}/icons/hicolor/*/*/*
248
249%changelog
250* Thu Feb  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.7.3-1
251- new upstream release
252- updated Patch0 and 1
253- dropt Patch3 and 100
254- added Patch101
255
256* Sat Aug 30 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.2.4-2
257- rebuilt with current environment
258
259* Sat May 05 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.2.4-1
260- new upstream release
261- dropt patch2
262- added Patch3 from upstream
263- fixed patch100
264- added Requires: %%{name}-common, %%{name}-curses %%{name}-gtk in wicd
265- changed URL: https://launchpad.net/wicd
266
267* Sat Feb 18 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.1-1
268- dropt almost pathces
269  - enabled patch is wicd-desktop.patch (Patch0)
270- added patch1 and patch2 from Debian sid
271- added patch100 to fix Japanese translation
272- added BuildRequires: python-babel
273
274* Sun May 22 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.0-6
275- changed BuildArch to noarch
276- updated spec
277- splitted -common, -curses, -gtk packages
278- Added Patch4,5,6,7,8 from Debian
279
280* Wed Jun 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.0-5
281- improved service start process in %%post section
282- changed daemon start runlevel
283
284* Mon Jun 07 2010 Shu KONNO <owa@bg.wakwak.com> - 1.7.0-4
285- fixed %%python_sitelib
286
287* Sat Jun 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.0-3
288- added Rerquires: gksu
289- added Patch2,3 from Debian
290  - to stop running unexpected files in scripts
291  - to fix resolv.conf permission
292
293* Fri Jun 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.0-2
294- added chkconfig in %post
295- added Patch1 to add Japanese description for desktop file
296
297* Fri May 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.0-1
298- initial build for VineSeed
Note: See TracBrowser for help on using the repository browser.