source: projects/specs/trunk/w/wicd/wicd-vl.spec @ 9331

Revision 9331, 8.4 KB checked in by inagaki, 9 years ago (diff)

2015-02-05 Ryoichi INAGAKI <ryo1@…>

  • wicd, wpa_supplicant: updated
  • xfce4-dict: fixed spec file
  • xfcet-settings: added patch


RevLine 
[1161]1#define python_sitelib %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')
[1156]2
3Summary: A wireless and wired network manager
4Summary(ja): 無線・有線ネットワークマネージャ
5Name: wicd
[9331]6Version: 1.7.3
7Release: 1%{?_dist_release}
8
9License: GPLv2
10Group: System Environment/Base
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12URL: https://launchpad.net/wicd
13
[5710]14Source0: %{name}-%{version}.tar.gz
15Patch0:  wicd-desktop.patch
[9331]16Patch1:  wicd-1.7.3-workaround_dhclient_bug.patch
17
18# Vine Patch
[5710]19Patch100: add_fix_ja.patch
[9331]20Patch101: wicd-1.7.3-setup.patch
[1156]21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
[3932]23BuildArch: noarch
[1156]24BuildRequires: gettext
25BuildRequires: desktop-file-utils
[9331]26BuildRequires: python >= 2.4
27BuildRequires: python-devel >= 2.4
[5710]28BuildRequires: python-babel
[1156]29BuildRequires: python-setuptools
[9331]30BuildRequires: pm-utils
[1156]31
[3932]32Requires: pm-utils >= 1.2.4
[1156]33
[6140]34Requires: %{name}-common
35Requires: %{name}-curses
36Requires: %{name}-gtk
37
[3932]38#Requires(post):   chkconfig
39#Requires(preun):  chkconfig
40#Requires(preun):  /sbin/service
41#Requires(postun): /sbin/service
[1156]42
43Conflicts: NetworkManager
44
45%description
46A complete network connection manager
47Wicd supports wired and wireless networks, and capable of
48creating and tracking profiles for both.  It has a
49template-based wireless encryption system, which allows the user
50to easily add encryption methods used.  It ships with some common
51encryption types, such as WPA and WEP. Wicd will automatically
52connect at startup to any preferred network within range.
53
[3932]54%package common
55Summary: Wicd common files
56Summary(ja): Wicd の共通ファイル
57Group: System Environment/Base
58BuildArch: noarch
59Requires: dbus
60Requires: dbus-python
61Requires: dhclient
62Requires: ethtool
63Requires: iproute
64Requires: logrotate
65Requires: net-tools
[9331]66Requires: pm-utils-devel
[3932]67Requires: wireless-tools
68Requires: wpa_supplicant
[1156]69
[3932]70Requires(post):   chkconfig
71Requires(preun):  chkconfig
72Requires(preun):  /sbin/service
73Requires(postun): /sbin/service
74#Requires(preun):  initscripts
75#Requires(postun): initscripts
76
77%description common
78This package provides the main wicd daemon and the wicd-cli front-end.
79
80%package curses
81Summary: Curses client for Wicd
82Summary(ja): Wicd の Curse クライアント
83Group: Applications/System
84BuildArch: noarch
85Requires: %{name}-common = %{version}-%{release}
86Requires: python-urwid >= 0.9.8.3
87
88%description curses
89Client program for wicd that uses a curses interface.
90
91%package gtk
92Summary: GTK+ client for Wicd
93Summary(ja): Wicd の GTK+ クライアント
[9331]94Group: Applications/System
[3932]95BuildArch: noarch
96Requires: %{name}-common = %{version}-%{release}
97Requires: pygtk2 >= 2.10
98Requires: pygtk2-libglade >= 2.10
99Requires: gksu
100
101%description gtk
102Client program for wicd that uses a GTK+ interface.
103
104
[1156]105%prep
106%setup -q
[5710]107%patch0 -p1
[1156]108%patch1 -p1
[9331]109%patch101 -p1
[1156]110
111%{__sed} -i 's/\r//' wicd/logfile.py
112
113%build
[5710]114python setup.py compile_translations
115
[9331]116%{__python} setup.py configure \
117       --share=%{_datadir}/%{name} \
[1156]118       --etc=%{_sysconfdir}/%{name} \
119       --bin=%{_bindir} \
120       --sbin=%{_sbindir} \
121       --mandir=%{_mandir} \
122       --varlib=%{_sharedstatedir}/wicd \
123       --pmutils=%{_libdir}/pm-utils/sleep.d \
124       --resume=%{_sysconfdir}/acpi/resume.d \
125       --suspend=%{_sysconfdir}/acpi/suspend.d \
126       --docdir=%{_docdir}/%{name}-%{version} \
[9331]127       --log=%{_localstatedir}/log \
128       --no-install-gnome-shell-extensions \
[1156]129       --no-install-kde \
130       --no-install-docs
131
132python setup.py build
[6140]133# python-babel currently doesn't support Asturian, using gettext
[9331]134# msgfmt po/ast.po -o translations/ast/LC_MESSAGES/wicd.mo
[1156]135
136%install
[9331]137[ -d "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
138python setup.py install -O1 --skip-build --root=$RPM_BUILD_ROOT
139install -D init/redhat/%{name} $RPM_BUILD_ROOT%{_initddir}/%{name}
[1156]140
[9331]141find $RPM_BUILD_ROOT -type f -name ".empty_on_purpose" | xargs rm
[1156]142
[3932]143desktop-file-install \
144    --remove-category="Application" \
145    --delete-original \
[9331]146    --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
147    $RPM_BUILD_ROOT%{_datadir}/applications/wicd.desktop
[3932]148
149desktop-file-install \
[9331]150    --dir=$RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart \
151    $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/wicd-tray.desktop
[3932]152
[1156]153%find_lang %{name}
154
[3932]155%post common
[1156]156touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
[1178]157/sbin/service %{name} restart >/dev/null 2>&1
[1156]158/sbin/chkconfig --add %{name}
[1178]159/sbin/chkconfig --level 345 %{name} on
[1156]160
[3932]161%preun common
[1156]162if [ $1 = 0 ] ; then
163     /sbin/service %{name} stop >/dev/null 2>&1
164     /sbin/chkconfig --del %{name}
165fi
166
[3932]167%postun common
[1156]168if [ "$1" -ge "1" ] ; then
169    /sbin/service %{name} condrestart >/dev/null 2>&1 || :
170fi
171
172if [ $1 -eq 0 ] ; then
173    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
174    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
175fi
176
[3932]177%post gtk
178touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
179
180%postun gtk
181if [ $1 -eq 0 ]; then
182    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
183    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
184fi
185
186%posttrans gtk
[1156]187gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
188
189%clean
190[ -d "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
191
[3932]192%files
[1156]193%defattr(-,root,root)
194%doc AUTHORS CHANGES INSTALL LICENSE NEWS README other/WHEREAREMYFILES
[5710]195%{_libdir}/pm-utils/sleep.d/55wicd
[3932]196
197%files common -f %{name}.lang
198%{_bindir}/wicd-cli
199%{_bindir}/wicd-client
[1156]200%{python_sitelib}/wicd
201%{python_sitelib}/*.egg-info
202%{_datadir}/applications/wicd.desktop
[5710]203%{_datadir}/dbus-1/system-services/
[3932]204%{_datadir}/man/man1/wicd-client.1*
205%{_datadir}/man/man5/wicd-manager-settings.conf.5*
206%{_datadir}/man/man5/wicd-wired-settings.conf.5*
207%{_datadir}/man/man5/wicd-wireless-settings.conf.5*
208%{_datadir}/man/man8/wicd-cli.8*
209%{_datadir}/man/man8/wicd.8*
[9331]210#{_datadir}/pixmaps/wicd*
[3932]211%dir %{_datadir}/wicd
212%dir %{_datadir}/wicd/backends
213%dir %{_datadir}/wicd/cli
214%dir %{_datadir}/wicd/daemon
215%{_datadir}/wicd/backends/*
216%{_datadir}/wicd/cli/*
217%{_datadir}/wicd/daemon/*
[5710]218%{_mandir}/nl/man?/%{name}*
[1156]219%{_sysconfdir}/%{name}
220%{_sysconfdir}/acpi/resume.d/80-wicd-connect.sh
221%{_sysconfdir}/acpi/suspend.d/50-wicd-suspend.sh
222%{_sysconfdir}/dbus-1/system.d/wicd.conf
[5710]223%{_sysconfdir}/logrotate.d/
[1156]224%{_sysconfdir}/rc.d/init.d/wicd
225%{_sysconfdir}/xdg/autostart/wicd-tray.desktop
226%{_sbindir}/wicd
227%{_localstatedir}/lib/wicd
[5710]228%exclude /lib/systemd/system/wicd.service
[1156]229
[3932]230%files curses
231%defattr(-,root,root,-)
232%dir %{_datadir}/wicd/curses
233%{_datadir}/wicd/curses/*
234%{_bindir}/wicd-curses
235%{_datadir}/man/man8/wicd-curses.8*
236%lang(nl) %{_datadir}/man/nl/man8/wicd-curses.8*
237
238%files gtk
239%defattr(-,root,root,-)
240%dir %{_datadir}/wicd/gtk
[9331]241%dir %{_datadir}/wicd/icons
[3932]242%{_sysconfdir}/xdg/autostart/wicd-tray.desktop
243%{_datadir}/wicd/gtk/*
[9331]244%{_datadir}/wicd/icons/*
[3932]245%{_datadir}/pixmaps/wicd-gtk.xpm
246%{_bindir}/wicd-gtk
[9331]247%{_datadir}/icons/hicolor/*/*/*
[3932]248
[1156]249%changelog
[9331]250* Thu Feb  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.7.3-1
251- new upstream release
252- updated Patch0 and 1
253- dropt Patch3 and 100
254- added Patch101
255
[8921]256* Sat Aug 30 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.2.4-2
257- rebuilt with current environment
258
[6140]259* Sat May 05 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.2.4-1
260- new upstream release
261- dropt patch2
262- added Patch3 from upstream
263- fixed patch100
264- added Requires: %%{name}-common, %%{name}-curses %%{name}-gtk in wicd
265- changed URL: https://launchpad.net/wicd
266
[5710]267* Sat Feb 18 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.1-1
268- dropt almost pathces
269  - enabled patch is wicd-desktop.patch (Patch0)
270- added patch1 and patch2 from Debian sid
271- added patch100 to fix Japanese translation
272- added BuildRequires: python-babel
273
[3932]274* Sun May 22 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.0-6
275- changed BuildArch to noarch
276- updated spec
277- splitted -common, -curses, -gtk packages
278- Added Patch4,5,6,7,8 from Debian
279
[1178]280* Wed Jun 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.0-5
281- improved service start process in %%post section
282- changed daemon start runlevel
283
[1161]284* Mon Jun 07 2010 Shu KONNO <owa@bg.wakwak.com> - 1.7.0-4
285- fixed %%python_sitelib
286
[1156]287* Sat Jun 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.0-3
288- added Rerquires: gksu
289- added Patch2,3 from Debian
290  - to stop running unexpected files in scripts
291  - to fix resolv.conf permission
292
293* Fri Jun 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.0-2
294- added chkconfig in %post
295- added Patch1 to add Japanese description for desktop file
296
297* Fri May 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.0-1
298- initial build for VineSeed
Note: See TracBrowser for help on using the repository browser.