source: projects/specs/trunk/w/which/which-vl.spec @ 521

Revision 521, 4.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Displays where a particular program in your path is located.
2Summary(ja): プログラムがパスのどこにあるかを表示する
3Name: which
4Version: 2.20
5Release: 1%{?_dist_release}
6License: GPLv3
7Group: Applications/System
8Source0: ftp://ftp.gnu.org/gnu/which/%{name}-%{version}.tar.gz
9Source1: which-2.sh
10Source2: which-2.csh
11Patch0: which-2.19-afs.patch
12Patch1: which-2.19-broken.patch
13
14Buildroot: %{_tmppath}/%{name}-%{version}-root
15Requires(post): /sbin/install-info
16Requires(preun): /sbin/install-info
17Requires: dev
18
19
20%description
21The which command shows the full pathname of a specified program, if
22the specified program is in your PATH.
23
24%description -l ja
25which コマンドを使うと,プログラムのフルパスを表示出来ます
26(ただしプログラムが PATH に存在する場合).
27
28
29%prep
30%setup -q
31%patch0 -p1 -b .afs
32%patch1 -p1 -b .broken
33
34%build
35%configure
36make
37
38
39%install
40[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
41
42%makeinstall
43mkdir -p $RPM_BUILD_ROOT/etc/profile.d
44install -m 755 %{SOURCE1} %{SOURCE2} \
45        $RPM_BUILD_ROOT/etc/profile.d
46
47%post
48/sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/which.info.gz > /dev/null 2>&1
49
50%preun
51if [ $1 = 0 ]; then
52   /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/which.info.gz > /dev/null 2>&1
53fi
54
55%clean
56[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
57
58
59%files
60%defattr(-,root,root)
61%doc COPYING EXAMPLES NEWS README README.alias
62%{_bindir}/*
63%config /etc/profile.d/which-2.*
64%{_infodir}/which.info.gz
65%{_mandir}/*/*
66
67%changelog
68* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20-1
69- new upstream release
70- spec in UTF-8
71
72* Fri Mar 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.19-1vl5
73- new upstream release
74- updated Patch0 and 1
75
76* Tue Oct 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.17-0vl1
77- new upstream release
78
79* Mon Jul 10 2006 Shu KONNO <owa@bg.wakwak.com> 2.16-0vl5
80- rebuild
81
82* Tue Jun 22 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.16-0vl4
83- /etc/profile.d/which-2.sh: define "which" as function instead of alias
84
85* Thu Dec 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16-0vl3
86- rebuild with new toolchains
87
88* Sat Nov 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16-0vl2
89- added patches from Fedora
90
91* Mon Oct 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16-0vl1
92- updated to 2.16
93
94* Sun Dec  1 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14-0vl2
95- source updated to 2.14
96- rebuild with newer toolchains
97
98* Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
99- 2.12-1vl1
100- based on 2.12-1 from Rawhide
101- added Japanese summary and description
102
103* Sun Sep 10 2000 Florian La Roche <Florian.LaRoche@redhat.de>
104- 2.12 (only man-page fix)
105
106* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
107- automatic rebuild
108
109* Sun Jun 18 2000 Than Ngo <than@redhat.de>
110- FHS packaging.
111
112* Sun May 21 2000 Ngo Than <than@redhat.de>
113- put man pages in /usr/share/man/*
114
115* Thu Apr 20 2000 Florian La Roche <Florian.LaRoche@redhat.de>
116- update to 2.11
117- change from root:bin -> root:root
118
119* Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
120- rebuild to gzip man page
121
122* Sun Jan 16 2000 Preston Brown <pbrown@redhat.com>
123- newer stuff rom Carlo (2.10).  Author's email: carlo@gnu.org
124
125* Thu Jan 13 2000 Preston Brown <pbrown@redhat.com>
126- adopted Carlo's specfile.
127
128* Fri Sep 24 1999 Carlo Wood <carlo@gnu.org>
129- There should not be a reason anymore to include README.alias in the rpm docs.
130- Don't install as root.root in RPM_BUILD_ROOT, in order to allow to build
131  rpm as non-root.
132- Bug fix
133- Added /etc/profile.d for automatic alias inclusion.
134
135* Wed Aug 25 1999 Carlo Wood <carlo@gnu.org>
136- Added README.alias.
137
138* Wed Aug 11 1999 Carlo Wood <carlo@gnu.org>
139- Typo in comment.
140
141* Thu May 27 1999 Carlo Wood <carlo@gnu.org>
142- Typo fix
143- Moved maintainer targets from makefile to Makefile.am.
144
145* Tue May 18 1999 Carlo Wood <carlo@gnu.org>
146- Typo in appended changelog.
147- Appended the old change log of `which-2.0.spec' to (this) %changelog,
148  which is generated from the CVS log of `which-2.0.spec.in'.
149- Generate which-2.spec from which-2.spec.in with automatic VERSION
150  and CHANGELOG substitution.
151
152* Tue May 14 1999 Carlo Wood <carlo@gnu.org>
153- Moved assignment of CFLAGS to the configure line, using RPM_OPT_FLAGS now.
154- Corrected Source: line to point to ftp.gnu.org.
155
156* Sat Apr 17 1999 Carlo Wood <carlo@gnu.org>
157- Started to use automake and autoconf
158
159* Fri Apr 09 1999 Carlo Wood <carlo@gnu.org>
160- Renamed which-2.0.spec to which-2.spec
Note: See TracBrowser for help on using the repository browser.