source: projects/specs/trunk/w/wget/wget-vl.spec @ 521

Revision 521, 6.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A utility for retrieving files using the HTTP or FTP protocols.
2Summary(ja): HTTP/FTP プロトコルによるファイル取得ユーティリティ
3Name: wget
4Version: 1.11.4
5Release: 2%{?_dist_release}
6License: GPL
7Group: Applications/Internet
8Source0: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.bz2
9
10## Vine Patch(es)
11# Security Fix
12# Patch100: wget-1.10.2_CVE-2006-6719.patch
13Patch110: wget-1.11.4_openssl_null.patch
14
15Provides: webclient
16Prereq: install-info
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildPrereq: openssl-devel
19%{?nosrc:NoSource: 0}
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24%description
25GNU Wget is a file retrieval utility which can use either the HTTP or
26FTP protocols.  Wget features include the ability to work in the
27background while you're logged out, recursive retrieval of
28directories, file name wildcard matching, remote file timestamp
29storage and comparison, use of Rest with FTP servers and Range with
30HTTP servers to retrieve files over slow or unstable connections,
31support for Proxy servers, and configurability.
32
33Install wget if you need to retrieve large numbers of files with HTTP or
34FTP, or if you need a utility for mirroring web sites or FTP directories.
35
36#'
37%description -l ja
38GNU wget は HTTP や FTP プロトコルを使用してファイルを取得するユーティリ
39ティです。wget には次のような特徴があります。
40
41 - ログアウトしている間にバックグラウンドで実行可能
42 - ディレクトリの再帰的取得
43 - ファイル名のワイルドカードマッチング
44 - ファイルのタイムスタンプの保存と比較
45 - FTP サーバの Rest、HTTP サーバの Range を使用したダウンロードの再開
46 - プロキシサーバへの対応
47 - 設定の容易さ
48
49もし HTTP か FTP で大量のファイルを取得する必要があったり、Web サイトや
50FTP ディレクトリをミラーするユーティリティが必要なら wget をインストール
51してください。
52
53%prep
54%setup -q
55
56# Security Fix
57# %patch100 -p1 -b .CVE-2006-6719
58%patch110 -p1 -b .openssl_null
59
60%build
61%configure --with-ssl
62%__make %{?_smp_mflags}
63
64%install
65%__rm -rf $RPM_BUILD_ROOT
66%makeinstall
67%find_lang %{name}
68
69%post
70/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir
71
72%preun
73if [ "$1" = 0 ]; then
74        /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir
75fi
76
77%clean
78%__rm -rf $RPM_BUILD_ROOT
79
80%files -f %{name}.lang
81%defattr(-,root,root)
82%doc AUTHORS MAILING-LIST NEWS README INSTALL COPYING
83%config %{_sysconfdir}/wgetrc
84%{_bindir}/wget
85%{_infodir}/wget.info*
86%{_mandir}/man1/wget.1*
87
88%changelog
89* Fri Sep 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.11.4-2
90- patch110 for fix openssl null char issue
91
92* Wed Oct 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.11.4-1
93- new upstream release
94- SPEC in UTF-8
95
96* Wed Mar 26 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.11.1-1
97- new upstream release
98- drop patch100 which is in included in new release
99- build under new versioning policy
100
101* Wed May 30 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10.2-0vl3
102- rebuild with openssl-0.9.8
103
104* Fri Jan 12 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.10.2-0vl2
105- rebuilt for VineSeed
106- fix changelog typo
107
108* Fri Jan 12 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.10.2-0vl1.1
109- add pacth100 for fix CVE-2006-6719 (SYST Unchecked Boundary Condition)
110
111* Wed Oct 19 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.10.2-0vl1
112- [SECURITY FIX] upstream release
113  - Stack-based buffer overflow (CAN-2005-3185)
114
115* Thu Jul 07 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.10-0vl1
116- [SECURITY FIX] upstream release
117  - overwrite certain files via a redirection URL (CAN-2004-1487)
118  - execute arbitrary code (CAN-2004-1488)
119  - overwrite arbitrary files via a symlink attack (CAN-2004-2014)
120- %%doc
121  - add COPYING, TODO
122  - drop doc/ChangeLog
123- not compress info at %%install (should be done by %%__install_spec_post)
124- drop obsolete patches
125- update Japanese description
126
127* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.9.1-0vl1
128- source upgrade
129- build with openssl-0.9.7d
130- Prereq: install-info instead of /sbin/install-info
131- remove all patches
132
133* Sun Dec 15 2002 IWAI Masaharu <iwai@alib.jp> 1.8.1-0vl5
134- rebuild on VineSeed
135
136* Thu Dec 12 2002 IWAI Masaharu <iwai@alib.jp> 1.8.1-0vl4
137- fix directory traversal bug
138    add wget-1.8.2-filename.patch(Patch101) from RedHat updates 1.8.2-4.6x
139
140* Wed Mar 13 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.1-0vl3
141- revamped Patch10 to fit with 1.8.1 source. But disable it.
142
143* Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 1.8.1-0vl2
144- added patch from current CVS to fix broken recursive download.
145
146* Tue Dec 25 2001 Toru Sagami <sagami@vinelinux.org>
147- 1.8.1
148
149* Mon Dec 10 2001 Toru Sagami <sagami@vinelinux.org>
150- 1.8-0vl0: update to 1.8 with an ad-hoc patch for md5.h
151
152* Thu Nov 22 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.7.1-0vl2
153- added ppc patch derived from:
154  http://bugs.debian.org/cgi-bin/bugreport.cgi?archive=no&bug=109348
155
156* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
157- 1.7.1-0vl1: use ja.po included in source
158
159* Fri Aug 24 2001 Toru Sagami <sagami@vinelinux.org>
160- 1.7-0vl2: configure --with-ssl
161
162* Wed Jun 13 2001 <sagami@vinelinux.org>
163- 1.7-0vl1: update to 1.7 with updated ja.po
164
165* Tue May 29 2001 <sagami@vinelinux.org>
166- 1.6-0vl2: use better macros
167
168* Fri Jan 5 2001 Yoichi Imai <yoichi@silver-forest.com>
169- removed getmore patch, ja.patch, ja.po
170- removed gzip and strip
171- used environment variable of rpm
172- not used symlink patch
173
174* Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
175- 1.5.3_jp-6
176- modified %files section to handle compressed man page(s)
177- added Japanese summary
178
179* Wed Jan 26 2000 Norihito Ohmori <nono@vinelinux.org>
180- fix ja.po
181
182* Thu Jan 20 2000 HIROSE, Masaaki <hirose31@t3.rim.or.jp>
183- added getmore.patch. to get files like LINK HREF="XXX".
184
185* Sun Nov 7 1999 Toru Hoshina <t@kondara.org>
186- be a NoSrc :-P
187
188* Sat Sep 18 1999 Norihito Ohmori <ohmori@flatout.org>
189- add ja.po
190- add Japanese Summary and Description
191
192* Thu Aug 26 1999 Jeff Johnson <jbj@redhat.com>
193- don't permit chmod 777 on symlinks (#4725).
194
195* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
196- auto rebuild in the new build environment (release 4)
197
198* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
199- build for 6.0 tree
200- add Provides
201
202* Sat Oct 10 1998 Cristian Gafton <gafton@redhat.com>
203- strip binaries
204- version 1.5.3
205
206* Sat Jun 27 1998 Jeff Johnson <jbj@redhat.com>
207- updated to 1.5.2
208
209* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
210- modified group to Applications/Networking
211
212* Wed Apr 22 1998 Cristian Gafton <gafton@redhat.com>
213- upgraded to 1.5.0
214- they removed the man page from the distribution (Duh!) and I added it back
215  from 1.4.5. Hey, removing the man page is DUMB!
216
217* Fri Nov 14 1997 Cristian Gafton <gafton@redhat.com>
218- first build against glibc
Note: See TracBrowser for help on using the repository browser.