source: projects/specs/trunk/w/wbar/wbar-vl.spec @ 521

Revision 521, 8.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# -*- coding: utf-8-unix -*-
2%define wbarconfversion 0.5
3%define wbar_utilversion 1.0
4
5%if %{?_dist_release} == "vl5"
6#%define ttfontdir /usr/share/fonts
7%define ttfontdir /usr/share/fonts/TrueType-vlgothic
8%define vlgothic TrueType-vlgothic
9%endif
10%if %{?_dist_release} == "vl4"
11%define ttfontdir /usr/X11R6/lib/X11/fonts/TrueType
12%define vlgothic TrueType-sazanami
13%endif
14
15Version:        1.3.3
16Release:        6%{?_dist_release}
17
18Name:           wbar
19Summary:        Quick Launch Bar such as a Dock of Max OS X
20Summary(ja):    Mac OS X の Dock のようなクイックランチャーバー
21Source:         http://www.tecapli.com.ar/warlock/%{name}-%{version}.tbz2
22Source2:        http://kapsi.fi/ighea/wbarconf/%{name}conf-%{wbarconfversion}.tar.gz
23
24Patch1:         wbar-makefile.patch
25Patch2:         wbar-kde-above-desk.patch
26
27## vine
28Source1:        wbar.desktop
29Source3:        http://home.arcor.de/max.federle/wbarutil/downloads/%{name}_util-%{wbar_utilversion}.tar.bz2
30Source4:        wbar_util-bytecompile.py
31# scripts
32Source12:       wbar_session
33Source13:       wbar_gen
34Source14:       wbar_readme
35# icons
36Source20:       mlterm.png
37Source21:       urxvt.png
38Source22:       rox-filer.png
39Source23:       wbar_util-2.png
40Source24:       vine-wbar.png
41Source25:       readme.png
42Source26:       default.png
43Source27:       grape.png
44Source28:       xterm.png
45Source29:       unicode-term.png
46Source30:       mailer.png
47# conf-file template
48Source40:       dot.wbar.jp
49# documents
50Source41:       vine_readme_wbar.html
51Source42:       vine_readme_wbar.txt
52
53#Patch10:               wbar-default-setting.patch
54Patch11:        wbar_util-1.0-vine.patch
55#Patch12:       wbar-dot-bar-default.patch
56Patch13:        wbar-dot-bar-default2.patch
57Patch14:        wbar-session.patch
58
59## ja_po
60Source11:       wbar_util-1.0-ja.po
61
62URL:            http://freshmeat.net/projects/wbar/
63Group:          User Interface/Desktops
64License:        GPLv2
65BuildRoot:      %{_tmppath}/%{name}-%{version}-root
66BuildRequires:  imlib2-devel
67BuildRequires:  XOrg-devel
68BuildRequires:  freetype2-devel
69BuildRequires:  zlib-devel
70BuildRequires:  gcc-c++
71BuildRequires:  libstdc++34-devel
72BuildRequires:  make
73BuildRequires:  glibc-devel
74Requires:       imlib2-loader
75%if %{?_dist_release} == "vl5"
76Requires:       pyxdg zenity
77%endif
78
79## vine
80Requires:       %{vlgothic}
81
82## ja_po
83BuildRequires:  gettext
84
85%description
86wbar is a quick launch bar. Its fast, light and cool eye-candy.
87
88Its hacked in c++ trying to keep code as readable as possible with out
89sacrificing speed. It works directly on top of X to avoid going throug a lot
90of layers.
91
92Initially developed for Fluxbox, then tested on WindowMaker, Xfce, Gnome, etc.
93
94Since version 1.0 can run on top of desktops such as xfdesktop or nautilus
95with the -above-desk switch.
96
97This package contained in some wbar configuration utilityies:
98- wbarconf
99- wbar_util
100
101%description -l ja
102wbar は(Dock でありませんが Dock 風な)クイックランチャーバーです.
103速くて,軽くて,見た目にもクールです.
104
105wbar は可能な限り可読性のあるコードの保守を試みて C++ でハックされています.
106with out sacrificing speed.
107たくさんのレイヤーを通していくのを避けるために X 上で直接的に動作します.
108
109当初は Fluxbox に対して開発されていましたが、それから
110WindowMaker, Xfce, Gnome 上で試みていました。
111
112バージョン 1.0 以降、-above-desk オプションを付けることで
113Xfdesktop あるいは Nautilus のようなデスクトップの最前面で起動できます。
114
115このパッケージには、いくつかの wbar 環境設定ユーティリティーを同梱しています:
116- wbarconf
117- wbar_util
118
119
120%prep
121%setup -q -a 3
122%patch1
123%patch2
124
125## vine
126#% patch10
127%patch11 -p1
128#%patch12 -p1
129%patch13 -p1
130
131## tools
132%__install -m0755 %{SOURCE12} %{SOURCE13} %{SOURCE14} wbar_util/usr/local/bin/
133## icons
134%__install -m0644 %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23} %{SOURCE24} \
135    %{SOURCE25} %{SOURCE26} %{SOURCE27} %{SOURCE28} %{SOURCE29} %{SOURCE30} \
136    iconpack/wbar.osx/
137
138%patch14 -p1
139
140## ja_po
141%__install -d -m0755 wbar_util/opt/wbar_util/locale/ja/LC_MESSAGES
142%__install %{SOURCE11} wbar_util/opt/wbar_util/locale/ja/LC_MESSAGES/main.po
143pushd wbar_util/opt/wbar_util/locale/ja/LC_MESSAGES/
144msgfmt -o main.mo main.po
145popd
146
147%build
148%__make \
149    CXXFLAGS="`imlib2-config --cflags` %{optflags}" \
150    LDFLAGS="`imlib2-config --libs`" \
151    PREFIX="%{_datadir}/wbar"
152
153
154%install
155%{__rm} -rf $RPM_BUILD_ROOT
156#% makeinstall DESTDIR=%{buildroot} PREFIX=%{_datadir}/wbar
157%{__make} DESTDIR=$RPM_BUILD_ROOT install
158
159## make sybolic link to ttf font for subtitle
160#%if %{?_dist_release} == "vl5"
161#ln -sf %{ttfontdir}/TrueType-vlgothic/VL-PGothic-Regular.ttf \
162ln -sf %{ttfontdir}/VL-PGothic-Regular.ttf \
163    ${RPM_BUILD_ROOT}%{_datadir}/wbar/iconpack/wbar.osx/font.ttf;
164#%endif
165#%if %{?_dist_release} == "vl4"
166#ln -sf %{ttfontdir}/VL-PGothic-Regular.ttf \
167#    ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
168#%endif
169
170
171## install Gnome menu
172desktop-file-install \
173    --vendor vine \
174    --dir $RPM_BUILD_ROOT%{_datadir}/applications \
175    %{SOURCE1}
176
177
178## install wbarconf
179pushd $RPM_BUILD_ROOT%{_datadir}
180tar zxf %{SOURCE2}
181popd
182pushd $RPM_BUILD_ROOT%{_bindir}
183ln -sf %{_datadir}/wbarconf/wbarconf.py wbarconf
184popd
185
186
187## install wbar_util
188pushd wbar_util
189%__python %{SOURCE4}
190%__rm -f ./usr/share/wbar_util/wbar.desktop
191yes | DESTDIR=$RPM_BUILD_ROOT ./install.sh
192desktop-file-install \
193    --vendor "vine" \
194    --dir $RPM_BUILD_ROOT%{_datadir}/applications \
195    $(pwd)/usr/share/applications/wbar_util.desktop
196popd
197
198## install Japanese template
199%__install -m0644 %{SOURCE40} $RPM_BUILD_ROOT%{_datadir}/wbar/
200
201## install Vine documents
202%__install -m0644 %{SOURCE41} %{SOURCE42} \
203    $RPM_BUILD_ROOT%{_datadir}/wbar/
204
205
206
207%clean
208%__rm -rf "%{buildroot}"
209
210
211%post
212%{_bindir}/update-desktop-database %{_datadir}/applications || :
213
214
215%postun
216%{_bindir}/update-desktop-database %{_datadir}/applications
217
218
219%files
220%defattr(-,root,root)
221%doc gpl.txt AUTHORS COPYING NEWS README
222%{_bindir}/wbar*
223%dir %{_datadir}/wbar
224%config(noreplace) %{_datadir}/wbar/dot.wbar
225%{_datadir}/wbar/dot.wbar.jp
226%{_datadir}/wbar/vine_readme_wbar.*
227%dir %{_datadir}/wbar/iconpack
228%{_datadir}/wbar/iconpack/*.ttf
229%dir %{_datadir}/wbar/iconpack/wbar.*
230%{_datadir}/wbar/iconpack/*/*
231%{_datadir}/applications/*.desktop
232%{_datadir}/wbarconf
233%{_datadir}/wbar_util
234
235%changelog
236* Mon May 18 2009 KATO Masashi <mkato@par.odn.ne.jp> 1.3.3-6
237- added Requires for pyxdg (for main.py) and zenity (for warning messages)
238- updated wbar.desktop:
239  - changed Icon=/usr/share/wbar/iconpack/wbar.osx/vine-wbar.png
240- added dot.wbar.jp
241  - for Japanese title support
242- update wbar-dot-bar-default.patch:
243  - corrected a command name (soffice -> oofice)
244  - added some items (xterm,synaptic...etc.)
245- added wbar_gen (for Vine Linux):
246  - for extracting only executable items from dot.wbar
247- applied wbar-session-vine.patch (for wbar_session)
248  - generating initial user config file ('$HOME/.wbar'; by wbar_gen)
249  - overwritable options
250  - verification of icon-path
251  - supported help message
252  - setting '-above-desk' option automatically. (detecting DE or WM)
253
254* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-5
255- applied wbar-dot-bar-default.patch
256
257* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-4
258- added %%description -l ja
259
260* Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-3
261- added wbar_util-1.0-ja.po
262- added wbar_session (for Vine Linux)
263- updated wbar.desktop:
264  - changed Exec=wbar_session
265- updated wbar_util-1.0-vine.patch:
266  - for restarting wbar
267
268* Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-2
269- changed to Group: User Interface/Desktops
270- added comment[ja] in wbar.desktop
271- added wbar_util v1.0
272- applied wbar_util-1.0-vine.patch
273
274* Sat Apr 11 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-1
275- initial build
276
277* Tue Oct 23 2007 Pascal Bleser <guru@unixtech.be> 1.3.3-0.pm.2
278- added Requires for imlib2-loaders (for PNG support)
279
280* Fri Sep 28 2007 Pascal Bleser <guru@unixtech.be> 1.3.3-0.pm.1
281- new upstream version
282
283* Sun Sep 16 2007 Pascal Bleser <guru@unixtech.be> 1.3.2-0.pm.1
284- new package
Note: See TracBrowser for help on using the repository browser.