source: projects/specs/trunk/w/wbar/wbar-vl.spec @ 4166

Revision 4166, 8.2 KB checked in by Takemikaduchi, 13 years ago (diff)

fix patch

Line 
1# -*- coding: utf-8-unix -*-
2%define wbarconfversion 0.5
3%define wbar_utilversion 1.0
4
5%define ttfontdir /usr/share/fonts/TrueType-vlgothic
6%define vlgothic TrueType-vlgothic
7
8Version:        1.3.3
9Release:        7%{?_dist_release}
10
11Name:           wbar
12Summary:        Quick Launch Bar such as a Dock of Max OS X
13Summary(ja):    Mac OS X の Dock のようなクイックランチャーバー
14Source:         http://www.tecapli.com.ar/warlock/%{name}-%{version}.tbz2
15Source2:        http://kapsi.fi/ighea/wbarconf/%{name}conf-%{wbarconfversion}.tar.gz
16
17Patch1:         wbar-makefile.patch
18Patch2:         wbar-kde-above-desk.patch
19
20## vine
21Source1:        wbar.desktop
22Source3:        http://home.arcor.de/max.federle/wbarutil/downloads/%{name}_util-%{wbar_utilversion}.tar.bz2
23Source4:        wbar_util-bytecompile.py
24# scripts
25Source12:       wbar_session
26Source13:       wbar_gen
27Source14:       wbar_readme
28# icons
29Source20:       mlterm.png
30Source21:       urxvt.png
31Source22:       rox-filer.png
32Source23:       wbar_util-2.png
33Source24:       vine-wbar.png
34Source25:       readme.png
35Source26:       default.png
36Source27:       grape.png
37Source28:       xterm.png
38Source29:       unicode-term.png
39Source30:       mailer.png
40# conf-file template
41Source40:       dot.wbar.jp
42# documents
43Source41:       vine_readme_wbar.html
44Source42:       vine_readme_wbar.txt
45
46#Patch10:               wbar-default-setting.patch
47Patch11:        wbar_util-1.0-vine.patch
48#Patch12:       wbar-dot-bar-default.patch
49Patch13:        wbar-dot-bar-default2.patch
50Patch14:        wbar-session.patch
51Patch15:        wbar-1.3.3_gcc43_fixes.patch
52
53## ja_po
54Source11:       wbar_util-1.0-ja.po
55
56URL:            http://freshmeat.net/projects/wbar/
57Group:          User Interface/Desktops
58License:        GPLv2
59BuildRoot:      %{_tmppath}/%{name}-%{version}-root
60BuildRequires:  imlib2-devel
61BuildRequires:  XOrg-devel
62BuildRequires:  freetype2-devel
63BuildRequires:  zlib-devel
64BuildRequires:  gcc-c++
65BuildRequires:  libstdc++34-devel
66BuildRequires:  make
67BuildRequires:  glibc-devel
68BuildRequires:  desktop-file-utils
69Requires:       imlib2-loader
70%if %{?_dist_release} == "vl5"
71Requires:       pyxdg zenity
72%endif
73
74## vine
75Requires:       %{vlgothic}
76
77## ja_po
78BuildRequires:  gettext
79
80%description
81wbar is a quick launch bar. Its fast, light and cool eye-candy.
82
83Its hacked in c++ trying to keep code as readable as possible with out
84sacrificing speed. It works directly on top of X to avoid going throug a lot
85of layers.
86
87Initially developed for Fluxbox, then tested on WindowMaker, Xfce, Gnome, etc.
88
89Since version 1.0 can run on top of desktops such as xfdesktop or nautilus
90with the -above-desk switch.
91
92This package contained in some wbar configuration utilityies:
93- wbarconf
94- wbar_util
95
96%description -l ja
97wbar は(Dock でありませんが Dock 風な)クイックランチャーバーです.
98速くて,軽くて,見た目にもクールです.
99
100wbar は可能な限り可読性のあるコードの保守を試みて C++ でハックされています.
101with out sacrificing speed.
102たくさんのレイヤーを通していくのを避けるために X 上で直接的に動作します.
103
104当初は Fluxbox に対して開発されていましたが、それから
105WindowMaker, Xfce, Gnome 上で試みていました。
106
107バージョン 1.0 以降、-above-desk オプションを付けることで
108Xfdesktop あるいは Nautilus のようなデスクトップの最前面で起動できます。
109
110このパッケージには、いくつかの wbar 環境設定ユーティリティーを同梱しています:
111- wbarconf
112- wbar_util
113
114
115%prep
116%setup -q -a 3
117%patch1
118%patch2
119
120## vine
121#% patch10
122%patch11 -p1
123#%patch12 -p1
124%patch13 -p1
125
126## tools
127%__install -m0755 %{SOURCE12} %{SOURCE13} %{SOURCE14} wbar_util/usr/local/bin/
128## icons
129%__install -m0644 %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23} %{SOURCE24} \
130    %{SOURCE25} %{SOURCE26} %{SOURCE27} %{SOURCE28} %{SOURCE29} %{SOURCE30} \
131    iconpack/wbar.osx/
132
133%patch14 -p1
134%patch15 -p1
135
136## ja_po
137%__install -d -m0755 wbar_util/opt/wbar_util/locale/ja/LC_MESSAGES
138%__install %{SOURCE11} wbar_util/opt/wbar_util/locale/ja/LC_MESSAGES/main.po
139pushd wbar_util/opt/wbar_util/locale/ja/LC_MESSAGES/
140msgfmt -o main.mo main.po
141popd
142
143%build
144%__make \
145    CXXFLAGS="`imlib2-config --cflags` %{optflags}" \
146    LDFLAGS="`imlib2-config --libs`" \
147    PREFIX="%{_datadir}/wbar"
148
149
150%install
151%{__rm} -rf $RPM_BUILD_ROOT
152#% makeinstall DESTDIR=%{buildroot} PREFIX=%{_datadir}/wbar
153%{__make} DESTDIR=$RPM_BUILD_ROOT install
154
155## make sybolic link to ttf font for subtitle
156#%if %{?_dist_release} == "vl5"
157#ln -sf %{ttfontdir}/TrueType-vlgothic/VL-PGothic-Regular.ttf \
158ln -sf %{ttfontdir}/VL-PGothic-Regular.ttf \
159    ${RPM_BUILD_ROOT}%{_datadir}/wbar/iconpack/wbar.osx/font.ttf;
160#%endif
161#%if %{?_dist_release} == "vl4"
162#ln -sf %{ttfontdir}/VL-PGothic-Regular.ttf \
163#    ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
164#%endif
165
166
167## install Gnome menu
168desktop-file-install \
169    --vendor vine \
170    --dir $RPM_BUILD_ROOT%{_datadir}/applications \
171    %{SOURCE1}
172
173
174## install wbarconf
175pushd $RPM_BUILD_ROOT%{_datadir}
176tar zxf %{SOURCE2}
177popd
178pushd $RPM_BUILD_ROOT%{_bindir}
179ln -sf %{_datadir}/wbarconf/wbarconf.py wbarconf
180popd
181
182
183## install wbar_util
184pushd wbar_util
185%__python %{SOURCE4}
186%__rm -f ./usr/share/wbar_util/wbar.desktop
187yes | DESTDIR=$RPM_BUILD_ROOT ./install.sh
188desktop-file-install \
189    --vendor "vine" \
190    --dir $RPM_BUILD_ROOT%{_datadir}/applications \
191    $(pwd)/usr/share/applications/wbar_util.desktop
192popd
193
194## install Japanese template
195%__install -m0644 %{SOURCE40} $RPM_BUILD_ROOT%{_datadir}/wbar/
196
197## install Vine documents
198%__install -m0644 %{SOURCE41} %{SOURCE42} \
199    $RPM_BUILD_ROOT%{_datadir}/wbar/
200
201
202
203%clean
204%__rm -rf "%{buildroot}"
205
206
207%post
208%{_bindir}/update-desktop-database -q %{_datadir}/applications || :
209
210
211%postun
212%{_bindir}/update-desktop-database -q %{_datadir}/applications
213
214
215%files
216%defattr(-,root,root)
217%doc gpl.txt AUTHORS COPYING NEWS README
218%{_bindir}/wbar*
219%dir %{_datadir}/wbar
220%config(noreplace) %{_datadir}/wbar/dot.wbar
221%{_datadir}/wbar/dot.wbar.jp
222%{_datadir}/wbar/vine_readme_wbar.*
223%dir %{_datadir}/wbar/iconpack
224%{_datadir}/wbar/iconpack/*.ttf
225%dir %{_datadir}/wbar/iconpack/wbar.*
226%{_datadir}/wbar/iconpack/*/*
227%{_datadir}/applications/*.desktop
228%{_datadir}/wbarconf
229%{_datadir}/wbar_util
230
231%changelog
232* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.3-7
233- rebuild with current VineSeed environment
234- add Patch15 (wbar-1.3.3_gcc43_fixes.patch)
235- add BuildRequires: desktop-file-utils
236- fix Source40 and Patch14
237
238* Mon May 18 2009 KATO Masashi <mkato@par.odn.ne.jp> 1.3.3-6
239- added Requires for pyxdg (for main.py) and zenity (for warning messages)
240- updated wbar.desktop:
241  - changed Icon=/usr/share/wbar/iconpack/wbar.osx/vine-wbar.png
242- added dot.wbar.jp
243  - for Japanese title support
244- update wbar-dot-bar-default.patch:
245  - corrected a command name (soffice -> oofice)
246  - added some items (xterm,synaptic...etc.)
247- added wbar_gen (for Vine Linux):
248  - for extracting only executable items from dot.wbar
249- applied wbar-session-vine.patch (for wbar_session)
250  - generating initial user config file ('$HOME/.wbar'; by wbar_gen)
251  - overwritable options
252  - verification of icon-path
253  - supported help message
254  - setting '-above-desk' option automatically. (detecting DE or WM)
255
256* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-5
257- applied wbar-dot-bar-default.patch
258
259* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-4
260- added %%description -l ja
261
262* Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-3
263- added wbar_util-1.0-ja.po
264- added wbar_session (for Vine Linux)
265- updated wbar.desktop:
266  - changed Exec=wbar_session
267- updated wbar_util-1.0-vine.patch:
268  - for restarting wbar
269
270* Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-2
271- changed to Group: User Interface/Desktops
272- added comment[ja] in wbar.desktop
273- added wbar_util v1.0
274- applied wbar_util-1.0-vine.patch
275
276* Sat Apr 11 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-1
277- initial build
278
279* Tue Oct 23 2007 Pascal Bleser <guru@unixtech.be> 1.3.3-0.pm.2
280- added Requires for imlib2-loaders (for PNG support)
281
282* Fri Sep 28 2007 Pascal Bleser <guru@unixtech.be> 1.3.3-0.pm.1
283- new upstream version
284
285* Sun Sep 16 2007 Pascal Bleser <guru@unixtech.be> 1.3.2-0.pm.1
286- new package
Note: See TracBrowser for help on using the repository browser.