source: projects/specs/trunk/w/wayland/wayland-vl.spec @ 7353

Revision 7353, 6.3 KB checked in by iwaim, 11 years ago (diff)

Merge branch 'wayland'

Line 
1%define ver 1.0.3
2%define rel 1
3#global gitdate 20120424
4
5Name:           wayland
6Version:        %{ver}
7Release:        %{rel}%{?gitdate:.date%{gitdate}}%{?_dist_release}
8Summary:        Wayland Compositor Infrastructure
9
10Group:          User Interface/X
11License:        MIT
12URL:            http://%{name}.freedesktop.org/
13%if 0%{?gitdate}
14Source0:        wayland-%{gitdate}.tar.bz2
15%else
16Source0:        http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
17%endif
18Source1:        make-git-snapshot.sh
19
20BuildRequires:  autoconf automake libtool
21BuildRequires:  doxygen
22BuildRequires:  pkgconfig(libffi)
23BuildRequires:  expat-devel
24BuildRequires:  libxslt
25BuildRequires:  docbook-style-xsl
26
27Provides:       %{name}-common = %{version}-%{release}
28
29Distribution:   Vine Linux
30Vendor:         Project Vine
31Packager:       iwaim
32
33%description
34Wayland is a protocol for a compositor to talk to its clients as well as a C
35library implementation of that protocol. The compositor can be a standalone
36display server running on Linux kernel modesetting and evdev input devices,
37an X application, or a wayland client itself. The clients can be traditional
38applications, X servers (rootless or fullscreen) or other display servers.
39
40%package devel
41Summary: Common headers for wayland
42License: MIT
43%description devel
44Common headers for wayland
45
46%package -n libwayland-client
47Summary: Wayland client library
48License: MIT
49%description -n libwayland-client
50Wayland client library
51
52%package -n libwayland-cursor
53Summary: Wayland cursor library
54License: MIT
55%description -n libwayland-cursor
56Wayland cursor library
57
58%package -n libwayland-server
59Summary: Wayland server library
60License: MIT
61%description -n libwayland-server
62Wayland server library
63
64%package -n libwayland-client-devel
65Summary: Headers and symlinks for developing wayland client applications
66License: MIT
67Requires: libwayland-client%{?_isa} = %{version}-%{release}
68Requires: wayland-devel%{?_isa} = %{version}-%{release}
69%description -n libwayland-client-devel
70Headers and symlinks for developing wayland client applications.
71
72%package -n libwayland-cursor-devel
73Summary: Headers and symlinks for developing wayland cursor applications
74License: MIT
75Requires: libwayland-cursor%{?_isa} = %{version}-%{release}
76Requires: wayland-devel%{?_isa} = %{version}-%{release}
77%description -n libwayland-cursor-devel
78Headers and symlinks for developing wayland cursor applications.
79
80%package -n libwayland-server-devel
81Summary: Headers and symlinks for developing wayland server applications
82License: MIT
83Requires: libwayland-server%{?_isa} = %{version}-%{release}
84Requires: wayland-devel%{?_isa} = %{version}-%{release}
85%description -n libwayland-server-devel
86Headers and symlinks for developing wayland server applications.
87
88%prep
89%setup -q -n %{name}-%{?gitdate:%{gitdate}}%{!?gitdate:%{version}}
90
91%build
92autoreconf -v --install
93%configure --disable-static --enable-documentation
94make %{?_smp_mflags}
95
96
97%install
98rm -rf $RPM_BUILD_ROOT
99make install DESTDIR=$RPM_BUILD_ROOT
100
101find $RPM_BUILD_ROOT -name \*.la | xargs rm -f
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post -n libwayland-client -p /sbin/ldconfig
107%postun -n libwayland-client -p /sbin/ldconfig
108
109%post -n libwayland-server -p /sbin/ldconfig
110%postun -n libwayland-server -p /sbin/ldconfig
111
112
113%files
114%defattr(-,root,root,-)
115%doc README TODO
116#doc %{_datadir}/doc/wayland/*
117
118%files devel
119%defattr(-,root,root,-)
120%{_bindir}/wayland-scanner
121%{_includedir}/wayland-util.h
122%{_includedir}/wayland-egl.h
123%{_includedir}/wayland-version.h
124%{_datadir}/aclocal/wayland-scanner.m4
125%{_datadir}/aclocal/wayland-scanner.mk
126%{_mandir}/man3/*.3*
127
128%files -n libwayland-client
129%defattr(-,root,root,-)
130%{_libdir}/libwayland-client.so.0*
131
132%files -n libwayland-cursor
133%defattr(-,root,root,-)
134%{_libdir}/libwayland-cursor.so.0*
135
136%files -n libwayland-server
137%defattr(-,root,root,-)
138%{_libdir}/libwayland-server.so.0*
139
140%files -n libwayland-client-devel
141%defattr(-,root,root,-)
142%{_includedir}/wayland-client*.h
143%{_libdir}/libwayland-client.so
144%{_libdir}/pkgconfig/wayland-client.pc
145
146%files -n libwayland-cursor-devel
147%defattr(-,root,root,-)
148%{_includedir}/wayland-cursor*.h
149%{_libdir}/libwayland-cursor.so
150%{_libdir}/pkgconfig/wayland-cursor.pc
151
152%files -n libwayland-server-devel
153%defattr(-,root,root,-)
154%{_includedir}/wayland-server*.h
155%{_libdir}/libwayland-server.so
156%{_libdir}/pkgconfig/wayland-server.pc
157
158%changelog
159* Sun Jan  6 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.3-1
160- initial build for Vine Linux
161- drop Obsoletes: wayland-common
162
163* Wed Jan 02 2013 Adam Jackson <ajax@redhat.com> 1.0.3-1
164- wayland 1.0.3
165
166* Tue Oct 23 2012 Adam Jackson <ajax@redhat.com> 1.0.0-1
167- wayland 1.0
168
169* Thu Oct 18 2012 Adam Jackson <ajax@redhat.com> 0.99.0-1
170- wayland 0.99.0
171
172* Tue Sep 04 2012 Adam Jackson <ajax@redhat.com> 0.95.0-1
173- wayland 0.95.0 (#843738)
174
175* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.89.0-2.20120424
176- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
177
178* Tue Apr 24 2012 Richard Hughes <rhughes@redhat.com> - 0.89.0-1
179- Update to a git snapshot based on 0.89.0
180
181* Sat Feb 18 2012 Thorsten Leemhuis <fedora@leemhuis.info> - 0.85.0-1
182- update to 0.85.0
183- adjust license, as upstream changed it to MIT
184- update make-git-snapshot.sh to current locations and scheme
185- drop common package, not needed anymore
186- compositor is now in a separate package, hence reduce BuildRequires to what
187  is actually needed (a lot less) and adjust summary
188- make usage of a git checkout in spec file optional
189- a %%{?_isa} to requires where it makes sense
190
191* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1-0.6.20101221
192- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
193
194* Tue Dec 06 2011 Adam Jackson <ajax@redhat.com> - 0.1-0.5.20101221
195- Rebuild for new libpng
196
197* Wed Jun 15 2011 Lubomir Rintel <lkundrak@v3.sk> - 0.1-0.4.20101221
198- Install real compositor binary instead of a libtool wrapper
199
200* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1-0.3.20101221
201- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
202
203* Tue Dec 21 2010 Adam Jackson <ajax@redhat.com> 0.1-0.2.20101221
204- Today's git snap
205
206* Tue Nov 23 2010 Adam Jackson <ajax@redhat.com> 0.1-0.2.20101123
207- Today's git snap
208- Fix udev rule install (#653353)
209
210* Mon Nov 15 2010 Adam Jackson <ajax@redhat.com> 0.1-0.1.20101111
211- Initial packaging
Note: See TracBrowser for help on using the repository browser.