source: projects/specs/trunk/w/w3c-libwww/w3c-libwww-vl.spec @ 521

Revision 521, 3.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Note that this is NOT a relocatable package
2%define ver     5.4.0
3%define rel     1%{?_dist_release}
4%define name    w3c-libwww
5
6Name:           %name
7Version:        %ver
8Release:        %rel
9License:        W3C (see: http://www.w3.org/Consortium/Legal/copyright-software.html), (L)GPL compatible
10Group:          System Environment/Libraries
11Source:         http://www.w3.org/Library/Distribution/%{name}-%{ver}.tgz
12URL:            http://www.w3.org/Library
13BuildRoot:      %{_tmppath}/%{name}-%{ver}-root
14
15Summary: General-purpose Web API written in C
16
17%description
18Libwww is a general-purpose Web API written in C for Unix and Windows (Win32).
19With a highly extensible and layered API, it can accommodate many different
20types of applications including clients, robots, etc. The purpose of libwww
21is to provide a highly optimized HTTP sample implementation as well as other
22Internet protocols and to serve as a testbed for protocol experiments. Libwww
23also supports HTTPS, thru OpenSSL. Because of the US export restrictions, we
24can't distribute the libwwwssl pre-compiled library. You'll have to compile
25libwww yourself to use it.
26
27%package devel
28Summary: Libraries and header files for programs that use libwww.
29Group: Development/Libraries
30Requires: %{name} = %{ver}
31
32%description devel
33Static libraries and header files for libwww, which are available as public
34libraries.
35
36%package apps
37Summary: Applications built using Libwww web library: e.g. Robot, command line tool, etc.
38Group: Applications/Internet
39Requires: %{name} = %{ver}
40
41%description apps
42Web applications built using Libwww: Robot, Command line tool,
43line mode browser.  The Robot can crawl web sites faster, and
44with lower load, than any other web walker that we know of,
45due to its extensive pipelining and use of HTTP/1.1.
46
47The command line tool (w3c) is very useful for manipulation of
48Web sites that implement more than just HTTP GET (e.g. PUT,
49 POST, etc.).
50
51The line mode browser is a minimal line mode web browser;
52often useful to convert to ascii text.  Currently unavailable
53until someone updates it to some new interfaces. (hint, hint...)
54
55%prep
56%setup -q
57
58%build
59%configure --with-regex --with-zlib
60%__make %{?_smp_mflags}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64%makeinstall
65./config/mkinstalldirs $RPM_BUILD_ROOT/%{_datadir}/w3c-libwww
66mv $RPM_BUILD_ROOT/%{_datadir}/*.xbm $RPM_BUILD_ROOT/%{_datadir}/w3c-libwww/
67## remove unuse files
68rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%post -p /sbin/ldconfig
74
75%postun -p /sbin/ldconfig
76
77%files
78%defattr(-,root,root)
79%{_libdir}/*.so.*
80%{_datadir}/w3c-libwww
81
82%doc *.html Icons/*/*.gif
83
84%files apps
85%defattr(-,root,root)
86%{_bindir}/w3c
87%{_bindir}/webbot
88%{_bindir}/www
89
90%files devel
91%defattr(-,root,root)
92%{_bindir}/libwww-config
93%{_libdir}/*.a
94#%{_libdir}/*.la
95%{_libdir}/*.so
96%{_includedir}/*
97
98%changelog
99* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 5.4.0-1vl5
100- applied new versioning policy
101- removed *.la
102
103* Sun Aug 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.4.0-0vl1
104- Rebuild with new toolchains
105- updated to 5.4.0
106- s/Copyright/License/
107
108* Thu Dec 28 2000 Akira Tagoh <tagoh@gnome.gr.jp>
109- 5.3.1-3vl1
110- Rebuild for Vine
111
112* Fri Aug 04 2000 Jose Kahan <jose@w3.org)
113- Added blurb about the OpenSSL support, some esthetical changes
114
115* Mon Apr 12 1999 Jim Gettys <jg@w3.org)
116- down covert for older RPM currently widespread
117
118* Mon Apr 12 1999 Jeff Johnson <jbj@redhat.com>
119- repackage for Red Hat 6.0.
120
121
122
Note: See TracBrowser for help on using the repository browser.