source: projects/specs/trunk/v/vtk/vtk-vl.spec @ 11783

Revision 11783, 17.2 KB checked in by ara_t, 6 years ago (diff)

vtk: update to 6.3.0

Line 
1# Disable OSMesa builds for now - see Bug 744434
2%bcond_with OSMesa
3# Make Java conditional
4%bcond_without java
5
6%{!?tcl_version: %global tcl_version %(echo 'puts $tcl_version' | tclsh)}
7%{!?tcl_sitelib: %global tcl_sitelib %{_datadir}/tcl%{tcl_version}}
8
9%define _hdf5_version 1.8.20
10
11Summary: The Visualization Toolkit - A high level 3D visualization library
12Summary(ja): The Visualization Toolkit - ハイレベル3D可視化ライブラリ
13Name: vtk
14Version: 6.3.0
15Release: 1%{?_dist_release}
16
17# This is a variant BSD license, a cross between BSD and ZLIB.
18# For all intents, it has the same rights and restrictions as BSD.
19# http://fedoraproject.org/wiki/Licensing/BSD#VTKBSDVariant
20License: BSD style
21Group: System Environment/Libraries
22URL: http://www.vtk.org/
23
24Source0: http://www.vtk.org/files/release/6.1/VTK-%{version}.tar.gz
25Source1: http://www.vtk.org/files/release/6.1/VTKData-%{version}.tar.gz
26
27# Use system libraries
28# http://public.kitware.com/Bug/view.php?id=11823
29# Patch0: vtk-6.1.0-system.patch
30# Install some more needed cmake files to try to support paraview build
31# http://www.vtk.org/Bug/view.php?id=14157
32# Patch1: vtk-install.patch
33# Patch to vtk to use system netcdf library
34# Patch2: vtk-6.1.0-netcdf.patch
35# Fix compilation with mesa 10.4
36# https://bugzilla.redhat.com/show_bug.cgi?id=1138466
37Patch3: vtk-glext.patch
38# Fix types for std::min/man
39# http://www.vtk.org/Bug/view.php?id=15249
40# Patch4: vtk-type.patch
41
42BuildRoot: %{_tmppath}/%{name}-%{version}-root
43BuildRequires: cmake >= 2.0.0
44BuildRequires: gcc-c++
45%{?with_java:BuildRequires: java-devel}
46BuildRequires: libX11-devel, libXt-devel, libXext-devel
47BuildRequires: libICE-devel, libGL-devel
48%{?with_OSMesa:BuildRequires: mesa-libOSMesa-devel}
49BuildRequires: tk-devel, tcl-devel
50BuildRequires: python-devel
51BuildRequires: expat-devel, freetype2-devel, libjpeg-turbo-devel, libpng-devel
52BuildRequires: gl2ps-devel
53BuildRequires: libtiff-devel, zlib-devel
54BuildRequires: libxml2-devel
55BuildRequires: qt4-devel qt4-designer
56#BuildRequires: qtwebkit-devel
57BuildRequires: chrpath
58BuildRequires: doxygen, graphviz
59BuildRequires: gnuplot
60BuildRequires: libboost-devel
61BuildRequires: hdf5-devel
62BuildRequires: jsoncpp-devel
63BuildRequires: libtheora-devel
64#BuildRequires: mysql-devel
65BuildRequires: mariadb-devel
66BuildRequires: netcdf-cxx-devel
67#BuildRequires: postgresql-devel
68BuildRequires: libpq-devel
69BuildRequires: R
70BuildRequires: PyQt4-devel
71BuildRequires: sip-devel
72BuildRequires: sqlite3-devel
73BuildRequires: wget
74#BuildRequires: %{_includedir}/Xm
75BuildRequires: openMotif-devel
76BuildRequires: blas-devel
77BuildRequires: lapack-devel
78%{!?with_java:Conflicts: vtk-java}
79Requires: hdf5 = %{_hdf5_version}
80
81Distribution: Project Vine
82Vendor: Vine Linux
83Packager: owa
84
85# Do not check .so files in the python_sitearch directory
86%global __provides_exclude_from ^%{python_sitearch}/.*\\.so$
87
88%description
89VTK is an open-source software system for image processing, 3D
90graphics, volume rendering and visualization. VTK includes many
91advanced algorithms (e.g., surface reconstruction, implicit modeling,
92decimation) and rendering techniques (e.g., hardware-accelerated
93volume rendering, LOD control).
94
95%package devel
96Summary: VTK header files for building C++ code.
97Summary(ja): C++ プログラムをビルドするための VTK ヘッダファイル集
98Group: Development/Libraries
99Requires: %{name} = %{version}-%{release}
100%{?with_OSMesa:Requires: mesa-libOSMesa-devel}
101Requires: cmake
102Requires: blas-devel
103Requires: gl2ps-devel
104Requires: expat-devel
105Requires: freetype2-devel
106Requires: hdf5-devel
107Requires: lapack-devel
108Requires: libjpeg-turbo-devel
109Requires: libpng-devel
110Requires: libogg-devel
111Requires: libtheora-devel
112Requires: libtiff-devel
113Requires: libxml2-devel
114Requires: libpq-devel
115Requires: libmysqlclient-devel
116Requires: qt4-devel
117#Requires: qtwebkit-devel%{?_isa}
118#Requires: jsoncpp-devel%{?_isa}
119# bz #1183210 + #1183530
120Requires: python-devel
121
122%description devel
123This provides the VTK header files required to compile C++
124programs that use VTK to do 3D visualisation.
125
126
127%package tcl
128Summary: Tcl bindings for VTK
129Summary(ja): VTK の tcl バインディング
130Group: System Environment/Libraries
131Requires: %{name} = %{version}-%{release}
132Requires: tcl
133
134%description tcl
135tcl bindings for VTK
136
137%description tcl -l ja
138VTK の tcl バインディングです。
139
140
141%package python
142Summary: Python bindings for VTK.
143Summary(ja): VTK の python バインディング
144Group: System Environment/Libraries
145Requires: %{name} = %{version}-%{release}
146Requires: python
147
148%description python
149python bindings for VTK
150
151%description python -l ja
152VTK の python バインディングです。
153
154%if %{with java}
155%package java
156Summary: Java bindings for VTK
157Summary(ja): VTK の Java バインディング
158Group: System Environment/Libraries
159Requires: %{name} = %{version}-%{release}
160Requires: java
161
162%description java
163Java bindings for VTK
164
165%description java -l ja
166VTK の Java バインディングです。
167%endif
168
169
170%package qt
171Summary: Qt bindings for VTK
172Summary(ja): VTK の Qt バインディング
173Group: System Environment/Libraries
174Requires: %{name} = %{version}-%{release}
175
176%description qt
177Qt bindings for VTK
178
179%description qt -l ja
180VTK の Qt バインディングです。
181
182
183%package qt-python
184Summary: Qt Python bindings for VTK
185Summary(ja): VTK の Qt Python バインディング
186Group: System Environment/Libraries
187Requires: %{name} = %{version}-%{release}
188
189%description qt-python
190Qt Python bindings for VTK
191
192%description qt-python -l ja
193VTK の Qt Python バインディングです。
194
195%package qt-tcl
196Summary: Qt TCL bindings for VTK
197Summary(ja): VTK の Qt TCL バインディング
198Group: System Environment/Libraries
199Requires: %{name} = %{version}-%{release}
200
201%description qt-tcl
202Qt TCL bindings for VTK
203
204%description qt-tcl -l ja
205VTK の Qt TCL バインディングです。
206
207
208%package testing-progs
209Summary: Tests programs for VTK.
210Summary(ja): VTK のテスト用プログラム
211Group: Development/Libraries
212Requires: %{name} = %{version}-%{release}
213
214%description testing-progs
215Testing programs for VTK
216
217%description testing-progs -l ja
218VTK のテスト用プログラムです。
219
220
221%package examples
222Summary: Examples for VTK
223Summary(ja): VTK のサンプル集
224Group: Applications/Engineering
225Requires: %{name} = %{version}-%{release}
226Requires: vtk-data = %{version}
227
228%description examples
229This package contains all the examples from the VTK source.
230To compile the C++ examples you will need to install the vtk-devel
231package as well. The Python and Tcl examples can be run with the
232corresponding packages (vtk-python, vtk-tcl).
233
234%package data
235Summary: Example data file for VTK
236Summary(ja): VTK のサンプルデータファイル
237Group: Development/Libraries
238BuildArch: noarch
239
240%description data
241This package contains all the data from the VTKData repository.
242These data are required to run various examples from the examples package.
243
244%prep
245%setup -q -n VTK-%{version}
246# %patch0 -p1 -b .system
247# %patch1 -p1 -b .install
248# %patch2 -p1 -b .netcdf
249%patch3 -p1 -b .glext
250# %patch4 -p1 -b .type
251
252# Remove included thirdparty sources just to be sure
253# TODO - vtksqlite
254for x in autobahn vtkexpat vtkfreetype vtkgl2ps vtkhdf5 vtkjpeg vtklibxml2 vtknetcdf vtkoggtheora vtkpng vtktiff twisted vtkzlib zope
255do
256  rm -r ThirdParty/*/${x}
257done
258
259# Replace relative path ../../../VTKData with %{_datadir}/vtkdata-%{version}
260# otherwise it will break on symlinks.
261grep -rl '\.\./\.\./\.\./\.\./VTKData' . | xargs \
262  perl -pi -e's,\.\./\.\./\.\./\.\./VTKData,%{_datadir}/vtkdata-%{version},g'
263
264# Save an unbuilt copy of the Example's sources for %doc
265mkdir vtk-examples
266cp -a Examples vtk-examples
267# Don't ship Win32 examples
268rm -r vtk-examples/Examples/GUI/Win32
269find vtk-examples -type f | xargs chmod -R a-x
270
271%build
272export CFLAGS="%{optflags} -D_UNICODE"
273export CXXFLAGS="%{optflags} -D_UNICODE"
274%if %{with java}
275export JAVA_HOME=/usr/lib/jvm/java
276# Arm/Aarch64 builders have less ram
277# https://bugzilla.redhat.com/show_bug.cgi?id=1115920
278%ifnarch s390
279export JAVA_TOOL_OPTIONS=-Xmx2048m
280%endif
281%endif
282
283mkdir build
284pushd build
285%cmake \
286       -DBUILD_DOCUMENTATION:BOOL=ON \
287       -DBUILD_EXAMPLES:BOOL=ON \
288       -DBUILD_TESTING:BOOL=OFF \
289       -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
290       -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
291       -DVTK_INSTALL_DATA_DIR=share/vtk \
292       -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
293       -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
294       -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
295       -DVTK_INSTALL_PYTHON_MODULE_DIR:PATH=%{_lib}/python%{python_version}/site-packages \
296       -DVTK_INSTALL_QT_DIR:PATH=%{_lib}/qt4/plugins/designer \
297       -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
298       -DTK_INTERNAL_PATH:PATH=/usr/include/tk-private/generic \
299%if %{with OSMesa}
300       -DVTK_OPENGL_HAS_OSMESA:BOOL=ON \
301%endif
302%if %{with java}
303       -DVTK_WRAP_JAVA:BOOL=ON \
304       -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
305       -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
306       -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
307%else
308       -DVTK_WRAP_JAVA:BOOL=OFF \
309%endif
310       -DVTK_WRAP_PYTHON:BOOL=ON \
311       -DVTK_WRAP_PYTHON_SIP:BOOL=ON \
312       -DSIP_INCLUDE_DIR:PATH=/usr/include/python%{python_version} \
313       -DVTK_WRAP_TCL:BOOL=ON \
314       -DVTK_Group_Imaging:BOOL=ON \
315       -DVTK_Group_Qt:BOOL=ON \
316       -DVTK_Group_Rendering:BOOL=ON \
317       -DVTK_Group_StandAlone:BOOL=ON \
318       -DVTK_Group_Tk:BOOL=ON \
319       -DVTK_Group_Views:BOOL=ON \
320       -DModule_vtkFiltersStatisticsGnuR:BOOL=ON \
321       -DModule_vtkTestingCore:BOOL=ON \
322       -DModule_vtkTestingRendering:BOOL=ON \
323       -DVTK_USE_OGGTHEORA_ENCODER=ON \
324       -DVTK_USE_SYSTEM_LIBRARIES=ON \
325       -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
326       -DVTK_USE_SYSTEM_LIBPROJ4:BOOL=OFF \
327       -DVTK_USE_SYSTEM_NETCDF:BOOL=ON \
328       -DTCL_LIBRARY:FILEPATH=%{_libdir}/libtcl%{tcl_version}.so \
329       -DTK_LIBRARY:FILEPATH=%{_libdir}/libtk%{tcl_version}.so \
330       ..
331       
332# TODO - MPI
333#-DVTK_Group_MPI:BOOL=ON \
334# Needed for some tests.  Fails to compile at the moment.  We don't run test though.
335#  -DVTK_DATA_ROOT:PATH=%{_datadir}/vtkdata-%{version} \
336# Not working, see http://public.kitware.com/Bug/view.php?id=11978
337# -DVTK_USE_ODBC=ON \
338# Commented old flags in case we'd like to reactive some of them
339# -DVTK_USE_DISPLAY:BOOL=OFF \ # This prevents building of graphics tests
340# -DVTK_USE_MPI:BOOL=ON \
341
342# Got intermittent build error with -j
343make %{?_smp_mflags}
344
345# Remove executable bits from sources (some of which are generated)
346find . -name \*.c -or -name \*.cxx -or -name \*.h -or -name \*.hxx -or \
347       -name \*.gif | xargs chmod -x
348
349
350%install
351rm -rf $RPM_BUILD_ROOT
352pushd build
353make install DESTDIR=$RPM_BUILD_ROOT
354
355# ld config
356mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
357echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
358
359# Gather list of non-python/tcl libraries
360ls $RPM_BUILD_ROOT%{_libdir}/vtk/*.so.* \
361  | grep -Ev '(Java|Qt|Python27D|TCL)' | sed -e's,^%{buildroot},,' > libs.list
362
363# List of executable utilities
364cat > utils.list << EOF
365vtkEncodeString
366EOF
367
368# List of executable examples
369cat > examples.list << EOF
370HierarchicalBoxPipeline
371MultiBlock
372Arrays
373Cube
374RGrid
375SGrid
376Medical1
377Medical2
378Medical3
379finance
380AmbientSpheres
381Cylinder
382DiffuseSpheres
383SpecularSpheres
384Cone
385Cone2
386Cone3
387Cone4
388Cone5
389Cone6
390EOF
391
392# Install examples too
393for filelist in examples.list; do
394    for file in `cat $filelist`; do
395  install -p bin/$file $RPM_BUILD_ROOT%{_bindir}
396    done
397done
398
399# Fix up filelist paths
400for filelist in utils.list examples.list; do
401  perl -pi -e's,^,%{_bindir}/,' $filelist
402done
403
404# Remove any remnants of rpaths on files we install
405# Seems to be some kind of java path
406for file in `cat examples.list`; do
407  chrpath -d $RPM_BUILD_ROOT$file
408done
409chrpath -d  $RPM_BUILD_ROOT%{_qt4_plugindir}/designer/libQVTKWidgetPlugin.so
410
411# Main package contains utils and core libs
412cat libs.list utils.list > main.list
413popd
414
415# Make scripts executable
416#chmod a+x %{buildroot}%{_libdir}/vtk/doxygen/*.pl
417#chmod a+x %{buildroot}%{_libdir}/vtk/testing/*.{py,tcl}
418
419# Remove exec bit from non-scripts and %%doc
420for file in `find %{buildroot} -type f -perm 0755 \
421  | xargs -r file | grep ASCII | awk -F: '{print $1}'`; do
422    head -1 $file | grep '^#!' > /dev/null && continue
423    chmod 0644 $file
424done
425find Utilities/Upgrading -type f | xargs chmod -x
426
427# install VTKdata
428mkdir -p $RPM_BUILD_ROOT%{_datadir}
429pushd $RPM_BUILD_ROOT%{_datadir}
430tar -zpxf %{SOURCE1}
431mv VTK-%{version} %{name}-%{version}
432
433# (Verbosely) fix 0555 permissions
434find . -type f -perm 0555 | xargs -r echo chmod 0755 | sh -x
435# Remove execute bits from not-scripts
436for file in `find . -type f -perm 0755`; do
437  head -1 $file | grep '^#!' > /dev/null && continue
438  chmod 0644 $file
439done
440popd
441
442# Setup Wrapping docs tree
443rm -rf _docs
444mkdir -p _docs
445cp -pr --parents Wrapping/*/README* _docs/
446
447%clean
448rm -rf $RPM_BUILD_ROOT
449
450%post -p /sbin/ldconfig
451
452%postun -p /sbin/ldconfig
453
454%post tcl -p /sbin/ldconfig
455
456%postun tcl -p /sbin/ldconfig
457
458%post python -p /sbin/ldconfig
459
460%postun python -p /sbin/ldconfig
461
462%if %{with java}
463%post java -p /sbin/ldconfig
464
465%postun java -p /sbin/ldconfig
466%endif
467
468%post qt -p /sbin/ldconfig
469
470%postun qt -p /sbin/ldconfig
471
472%post qt-tcl -p /sbin/ldconfig
473
474%postun qt-tcl -p /sbin/ldconfig
475
476%post qt-python -p /sbin/ldconfig
477
478%postun qt-python -p /sbin/ldconfig
479
480
481%files -f build/main.list
482%defattr(-,root,root)
483%doc Copyright.txt README.html vtkLogo.jpg vtkBanner.gif _docs/Wrapping
484%config(noreplace) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
485%{_datadir}/vtk
486%dir %{_libdir}/vtk
487
488%files devel
489%defattr(-,root,root)
490%doc Utilities/Upgrading
491%{_bindir}/vtkHashSource
492%{_bindir}/vtkWrapHierarchy
493%{_includedir}/vtk
494%{_libdir}/vtk/*.so
495%{_libdir}/vtk/libvtkWrappingTools.a
496%{_libdir}/cmake/vtk/
497%{_bindir}/vtkParseOGLExt
498%{_docdir}/vtk-6.3/
499%{tcl_sitelib}/vtk/vtktcl.c
500
501%files tcl
502%defattr(-,root,root)
503%{_libdir}/vtk/*TCL.so.*
504%exclude %{_libdir}/vtk/*QtTCL.so.*
505%{_bindir}/vtk
506%{_bindir}/vtkWrapTcl
507%{_bindir}/vtkWrapTclInit
508%{tcl_sitelib}/vtk/
509%exclude %{tcl_sitelib}/vtk/vtktcl.c
510
511%files python
512%defattr(-,root,root)
513%{_bindir}/vtkpython
514%{_bindir}/vtkWrapPython
515%{_bindir}/vtkWrapPythonInit
516%{_libdir}/vtk/*Python27D.so.*
517%{python_sitearch}/*
518%exclude %{_libdir}/vtk/*QtPython27D.so.*
519
520%if %{with java}
521%files java
522%defattr(-,root,root)
523%{_libdir}/vtk/*Java.so.*
524%{_libdir}/vtk/vtk.jar
525%{_bindir}/vtkParseJava
526%{_bindir}/vtkWrapJava
527%endif
528
529%files qt
530%defattr(-,root,root)
531%{_libdir}/vtk/lib*Qt*.so.*
532%exclude %{_libdir}/vtk/*TCL.so.*
533%exclude %{_libdir}/vtk/*Python27D.so.*
534%{_qt4_plugindir}/designer/libQVTKWidgetPlugin.so
535
536%files qt-python
537%defattr(-,root,root)
538%{_libdir}/vtk/*Python27D.so.*
539
540%files qt-tcl
541%defattr(-,root,root)
542%{_libdir}/vtk/*TCL.so.*
543
544%files testing-progs
545#-f testing-progs-list
546
547%files examples -f build/examples.list
548%defattr(-,root,root)
549%doc vtk-examples/Examples
550
551%files data
552%defattr(-,root,root)
553%{_datadir}/%{name}-%{version}
554
555
556%changelog
557* Sat Aug 25 2018 Toshiaki Ara <ara_t@384.jp> 6.3.0-1
558- update to 6.3.0
559- drop some Patches
560
561* Thu Aug 23 2018 Toshiaki Ara <ara_t@384.jp> 6.1.0-3
562- rebuild with hdf-1.8.20
563- change BuildRequires: R-devel to BuildRequires: R
564
565* Sat Sep 03 2016 Toshiaki Ara <ara_t@384.jp> 6.1.0-2
566- rebuild with gcc-5.4.0
567
568* Wed Jan 28 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.1.0-1
569- updated to 6.1.0
570- built with tcl/tk 8.5.15, libpng 1.6.12 and hdf5 1.8.14
571- added java, qt-tcl and qt-python subpackage
572
573* Mon May 09 2011 Shu KONNO <owa@bg.wakwak.com> 5.4.2-3
574- s/qt-devel/qt4-devel/ at BR:
575- add BR: libxml2-devel
576
577* Sun May 08 2011 Shu KONNO <owa@bg.wakwak.com> 5.4.2-2
578- remove _smp_mflags
579- added tcl_ver macro
580- added TCL_LIBRARY, TK_LIBRARY to cmake
581
582* Tue May 04 2010 Shu KONNO <owa@bg.wakwak.com> 5.4.2-1
583- updated vtk to 5.4.2
584- updated vtkdata to 5.4.2
585- added Obsoletes: %%{name}-ruby < 5.4.2
586- added Patch2: vtk-5.2.1-boost-1.42.patch (from Mandriva)
587- dropt Patch0: vtk-5.0-getsockname.patch
588- dropt Patch1: vtk-ruby-060915.patch
589
590* Thu Jul 31 2008 Shu KONNO <owa@bg.wakwak.com> 5.0.4-1vl5
591- updated vtk to 5.0.4
592- updated vtkdata to 5.0.4
593- built with xorg-x11-devel, python-2.5
594- applied new versioning policy
595- spec in utf-8
596
597* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.0.2-0vl6
598- rebuild with expat-2.0.1
599- add BuildPrereq: freetype2-devel and drop freetype-devel
600- add BuildPrereq: qt-devel
601- add Requires: freetype2 and drop freetype
602
603* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 5.0.2-0vl5
604- rebuild with tcl/tk-8.4.18
605
606* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 5.0.2-0vl4
607- rebuild with tcl/tk-8.4.16
608
609* Mon Aug 27 2007 Shu KONNO <owa@bg.wakwak.com> 5.0.2-0vl3
610- added %%define py_ver, py_dir
611- added %%{?_smp_mflags} to make
612- change for x86_64
613  - changed lib to %%{_lib}
614  - added VTK_INSTALL_LIB_DIR=PATH=/%{_lib} in cmake
615  - added --install-lib at VTK_PYTHON_SETUP_ARGS in cmake
616
617* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.2-0vl2
618- rebuild with new environment/toolchain
619
620* Fri Sep 15 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 5.0.2-0vl1
621- new upstream
622- add ruby patch
623
624* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0.1-0vl1
625- new upstream
626- fixed spec file encoding
627- changed Group to System Environment/Libraries
628
629* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 5.0.0-0vl1
630- source verion up
631
632* Tue Mar 29 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 4.4.2-0vl1
633- source verion up
634
635* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 4.2.6-0vl1
636- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.