source: projects/specs/trunk/v/vnc/vnc-vl.spec @ 521

Revision 521, 30.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define vnc_version 4_1_2
2
3Summary:   A remote display system
4Summary(ja): 仮想ネットワークコンピューティング
5Name:      vnc
6Version:   4.1.2
7Release:   5%{?dist}
8URL:       http://www.realvnc.com
9License:   GPLv2
10Group:     User Interface/Desktops
11
12Source0:   http://www.realvnc.com/dist/vnc-%{vnc_version}-unixsrc.tar.gz
13Source1:   Makefile.am
14Source2:   vncserver.init
15Source3:   vnc-16x16.png
16Source4:   vnc-24x24.png
17Source5:   vnc-48x48.png
18Patch0:    vnc-cookie.patch
19Patch1:    vnc-gcc4.patch
20Patch2:    vnc-use-fb.patch
21Patch3:    vnc-xclients.patch
22Patch4:    vnc-idle.patch
23Patch5:    vnc-via.patch
24Patch8:    vnc-restart.patch
25Patch9:    vnc-vncpasswd.patch
26Patch11:   vnc-modular-xorg.patch
27Patch12:   vnc-nohttpd.patch
28Patch15:   vnc-viewer-reparent.patch
29Patch16:   vnc-64bit.patch
30Patch17:   vnc-select.patch
31Patch21:   vnc-newfbsize.patch
32Patch24:   vnc-102434.patch
33Patch25:   vnc-config.patch
34Patch28:   vnc-render.patch
35Patch31:   vnc-autotools.patch
36Patch32:   vnc-autotools-compile.patch
37Patch33:   vnc-always_use_fb.patch
38Patch34:   vnc-vsnprintf.patch
39Patch36:   vnc-24bit.patch
40Patch38:   vnc-gcc43.patch
41Patch40:   vnc-xorg.patch
42Patch41:   vnc-privates.patch
43Patch42:   vnc-mieq.patch
44Patch43:   vnc-allocate.patch
45Patch45:   vnc-paint.patch
46Patch46:   vnc-selections.patch
47Patch48:   vnc-manminor.patch
48Patch49:   vnc-clipboard.patch
49Patch50:   vnc-scrollbars.patch
50Patch51:   vnc-bounds.patch
51Patch52:   vnc-includes.patch
52Patch53:   vnc-viewerIPv6.patch
53Patch54:   vnc-rh212985.patch
54
55BuildRoot: %{_tmppath}/%{name}-%{version}-root
56BuildRequires: perl, openssl-devel, libpciaccess-devel
57BuildRequires: zlib-devel, libjpeg-devel
58BuildRequires: desktop-file-utils
59BuildRequires: autoconf,  automake, libtool, flex, pkgconfig, patchutils
60BuildRequires: expat-devel, freetype-devel
61BuildRequires: libX11-devel, xorg-x11-xtrans-devel
62BuildRequires: libxkbfile-devel, libXfont-devel
63BuildRequires: tcp_wrappers
64BuildRequires: libXtst-devel, xorg-x11-util-macros
65BuildRequires: libXt-devel, libXv-devel, pixman-devel
66BuildRequires: xorg-x11-server-source >= 1.4.99.905-3
67BuildRequires: mesa-libGL-devel >= 7.1, libdrm-devel >= 2.4.0
68
69Requires: gtk2 >= 2.6
70Requires: coreutils
71Obsoletes: vnc-doc <= 4.1.2-0vl3
72
73%description
74Virtual Network Computing (VNC) is a remote display system which
75allows you to view a computing 'desktop' environment not only on the
76machine where it is running, but from anywhere on the Internet and
77from a wide variety of machine architectures.  This package contains a
78client which will allow you to connect to other desktops running a VNC
79server.
80
81%package server
82Summary: A VNC server
83Summary(ja): VNC サーバ
84Requires: bash >= 2.0, util-linux, xorg-x11-xauth, chkconfig
85Group: User Interface/X
86
87%description server
88The VNC system allows you to access the same desktop from a wide
89variety of platforms.  This package is a VNC server, allowing others
90to access the desktop on your machine.
91
92%package libs
93Summary: VNC Remote framebuffer libraries
94Summary(ja): VNC リモートフレームバッファライブラリ
95Group: User Interface/X
96
97%description libs
98Remote framebuffer library which is used by vncviewer and vncserver
99
100%prep
101%setup -q -n vnc-%{vnc_version}-unixsrc
102cp -r %{_datadir}/xorg-x11-server-source unix
103mkdir -p unix/xorg-x11-server-source/hw/vnc
104cp %{SOURCE1} unix/xorg-x11-server-source/hw/vnc/
105
106%patch0 -p1 -b .cookie
107%patch1 -p1 -b .gcc4
108%patch2 -p1 -b .use-fb
109%patch3 -p1 -b .xclients
110%patch4 -p1 -b .idle
111%patch5 -p1 -b .via
112%patch8 -p1 -b .restart
113%patch9 -p1 -b .vncpasswd
114%patch11 -p1 -b .modular-xorg
115%patch40 -p1 -b .vnc
116%patch12 -p1 -b .nohttpd
117%patch15 -p1 -b .viewer-reparent
118%patch16 -p1 -b .64bit
119%patch17 -p1 -b .select
120%patch21 -p1 -b .newfbsize
121%patch24 -p1 -b .102434
122%patch25 -p1 -b .config
123%patch28 -p1 -b .render
124%patch31 -p1 -b .autotools
125%patch32 -p1 -b .autotools-compile
126%patch33 -p1 -b .always_use_fb
127%patch34 -p1 -b .vsnprintf
128%patch36 -p1 -b .24bit
129%patch38 -p1 -b .gcc43
130
131cp -a unix/xc/programs/Xserver/vnc/Xvnc/xvnc.cc \
132        unix/xc/programs/Xserver/Xvnc.man \
133        unix/xc/programs/Xserver/vnc/*.{h,cc} \
134        unix/xorg-x11-server-source/hw/vnc/
135
136pushd unix/xorg-x11-server-source/hw/vnc
137%patch41 -p5 -b .privates
138popd
139%patch42 -p1 -b .mieq
140%patch43 -p1 -b .alloc
141%patch45 -p1 -b .paint
142%patch46 -p1 -b .selections
143%patch48 -p1 -b .minor
144%patch49 -p1 -b .clipboard
145%patch50 -p1 -b .scrollbars
146%patch51 -p1 -b .bounds
147%patch52 -p1 -b .includes
148%patch53 -p1 -b .ipv6
149%patch54 -p1 -b .rh212985
150
151%build
152export CFLAGS="$CFLAGS $RPM_OPT_FLAGS -O0"
153export CXXFLAGS="$CFLAGS"
154
155pushd common
156autoreconf -fiv
157%configure
158make %{?_smp_mflags}
159popd
160
161pushd unix
162autoreconf -fiv
163%configure
164make %{?_smp_mflags}
165popd
166
167pushd unix/xorg-x11-server-source
168autoreconf -fiv
169%configure --disable-xorg \
170        --disable-xnest --disable-xvfb \
171        --disable-dmx --disable-xwin --disable-xephyr --disable-kdrive \
172        --with-pic \
173        --disable-xorgcfg \
174        --disable-xprint \
175        --disable-static \
176        --disable-composite \
177        --enable-xtrap \
178        --enable-xcsecurity \
179        --with-default-font-path="catalogue:/etc/X11/fontpath.d,built-ins" \
180        --with-fontdir=%{_datadir}/X11/fonts \
181        --with-os-name="Vine Linux 5" \
182        --with-os-vendor="Project Vine" \
183        --with-xkb-output=%{_localstatedir}/lib/xkb \
184        --with-rgb-path=%{_datadir}/X11/rgb \
185        --enable-install-libxf86config \
186        --disable-xevie \
187        --disable-dri2 \
188        --enable-glx \
189        --disable-config-dbus \
190        --disable-config-hal
191
192make %{?_smp_mflags}
193popd
194
195%install
196rm -rf $RPM_BUILD_ROOT
197
198cd common;
199make install DESTDIR=$RPM_BUILD_ROOT
200
201cd ../unix
202
203mandst=$RPM_BUILD_ROOT%{_mandir}/man1
204mkdir -p $mandst
205for f in xorg-x11-server-source/hw/vnc/Xvnc vncviewer/vncviewer vncpasswd/vncpasswd \
206         vncconfig/vncconfig vncserver x0vncserver/x0vncserver; do
207
208    cp -pf $f.man $mandst/`basename $f.1`
209    chmod 0444 $mandst/`basename $f.1`
210done
211make install DESTDIR=$RPM_BUILD_ROOT
212cp vncserver $RPM_BUILD_ROOT/usr/bin
213
214cd xorg-x11-server-source/hw/vnc
215make install DESTDIR=$RPM_BUILD_ROOT
216cd ../../../
217
218mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
219install -m755 %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/vncserver
220
221mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
222cat > $RPM_BUILD_ROOT/etc/sysconfig/vncservers << "EOF"
223# The VNCSERVERS variable is a list of display:user pairs.
224#
225# Uncomment the lines below to start a VNC server on display :2
226# as my 'myusername' (adjust this to your own).  You will also
227# need to set a VNC password; run 'man vncpasswd' to see how
228# to do that. 
229#
230# DO NOT RUN THIS SERVICE if your local area network is
231# untrusted!  For a secure way of using VNC, see
232# <URL:http://www.uk.research.att.com/archive/vnc/sshvnc.html>.
233
234# Use "-nolisten tcp" to prevent X connections to your VNC server via TCP.
235
236# Use "-nohttpd" to prevent web-based VNC clients connecting.
237
238# Use "-localhost" to prevent remote VNC clients connecting except when
239# doing so through a secure tunnel.  See the "-via" option in the
240# `man vncviewer' manual page.
241
242# VNCSERVERS="2:myusername"
243# VNCSERVERARGS[2]="-geometry 800x600 -nolisten tcp -nohttpd -localhost"
244EOF
245chmod 644 $RPM_BUILD_ROOT/etc/sysconfig/vncservers
246
247mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/{16x16,24x24,48x48}/apps
248install -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/vnc.png
249install -m 644 %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/vnc.png
250install -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/vnc.png
251mkdir -p $RPM_BUILD_ROOT/etc/X11/applnk/Applications
252cat > vncviewer.desktop << EOF
253[Desktop Entry]
254Encoding=UTF-8
255Name=VNC Viewer
256Comment=Connect to VNC server and display remote desktop
257Exec=/usr/bin/vncviewer
258Icon=vnc.png
259Terminal=false
260Type=Application
261StartupWMClass=VNC Viewer: Connection Details
262EOF
263# Desktop file installation.
264mkdir $RPM_BUILD_ROOT%{_datadir}/applications
265desktop-file-install --vendor ""   \
266  --dir $RPM_BUILD_ROOT%{_datadir}/applications        \
267  --add-category Network                               \
268  --add-category Application                           \
269  vncviewer.desktop
270
271# remove unwanted files
272rm -f $RPM_BUILD_ROOT%{_libdir}/librfb.a
273rm -f $RPM_BUILD_ROOT%{_libdir}/librfb.la
274rm -f $RPM_BUILD_ROOT%{_libdir}/librfb.so
275rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions/libvnc.la
276
277%clean
278rm -rf $RPM_BUILD_ROOT
279
280%post
281touch --no-create %{_datadir}/icons/hicolor
282if [ -x /usr/bin/gtk-update-icon-cache ] && [ -f %{_datadir}/icons/hicolor/index.theme ]; then
283  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
284fi
285
286%postun
287touch --no-create %{_datadir}/icons/hicolor
288if [ -x /usr/bin/gtk-update-icon-cache ] && [ -f %{_datadir}/icons/hicolor/index.theme ]; then
289  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
290fi
291
292%post server
293if [ "$1" = 1 ]; then
294  /sbin/chkconfig --add vncserver
295fi
296
297%preun server
298if [ "$1" = 0 ]; then
299  /sbin/service vncserver stop >/dev/null 2>&1
300  /sbin/chkconfig --del vncserver
301fi
302
303%post libs
304/sbin/ldconfig
305
306%postun libs
307/sbin/ldconfig
308
309%files
310%defattr(-,root,root)
311%doc LICENCE.txt README
312%{_bindir}/vncviewer
313%{_datadir}/applications/*
314%{_mandir}/man1/vncviewer.1*
315%{_datadir}/icons/hicolor/*/*/*
316
317%files server
318%defattr(-,root,root)
319%attr(0755,root,root) %config /etc/rc.d/init.d/vncserver
320%config(noreplace) /etc/sysconfig/vncservers
321%{_bindir}/Xvnc
322%{_bindir}/vncpasswd
323%{_bindir}/vncconfig
324%{_bindir}/vncserver
325%{_bindir}/x0vncserver
326%{_mandir}/man1/Xvnc.1*
327%{_mandir}/man1/vncpasswd.1*
328%{_mandir}/man1/vncconfig.1*
329%{_mandir}/man1/vncserver.1*
330%{_mandir}/man1/x0vncserver.1*
331%{_libdir}/xorg/modules/extensions/libvnc.so
332
333%files libs
334%defattr(-,root,root)
335%{_libdir}/librfb.so.*
336
337%changelog
338* Mon Nov 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.2-5
339- updated configure option to build with libdrm-2.4
340
341* Thu Jul 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.2-4
342- resync with F9 package to build with xorg-x11-7.3
343- new versioning policy
344- drop vnc-doc package, add vnc-libs package.
345- historical changelogs are below:
346  * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.1.2-0vl3
347  - add icon symlink
348  - fix dependency
349    - add BuildRequires: expat-devel, freetype2-devel, bison, flex
350  * Sat Sep 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.1.2-0vl2
351  - update to XOrg-6.9.0-0vl20
352  * Tue Sep 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.1.2-0vl1
353  - [SECURITY] new upstream release
354  - update to XOrg-6.9.0-0vl18
355  - not apply patch13
356  * Mon Apr 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.1-0vl1
357  - new upstream release
358  - import patches from FC package.
359  - update to XOrg-6.8.2-0vl4
360  * Sun May 09 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0-0.0.beta4.11
361  - new upstream version
362  - merged spec file to FedoraCore1
363  - obsoleted vnc-doc
364  * Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.3.3r2-26vl5
365  - added patch8
366        -- changed to use system-provided zlib
367  * Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.3.3r2-26vl4
368  - rebuild on zlib-1.1.4(security fix.)
369  * Mon Feb 18 2002 Yoshihiro Ota <ota@j.email.ne.jp> 3.3.3r2-26vl3
370  - moved config file in /etc/sysconfig from in /etc/vnc
371  * Sun Feb 17 2002 Yoshihiro Ota <ota@j.email.ne.jp> 3.3.3r2-26vl2
372  - corrected misplaced PreReq
373  * Sat Feb 16 2002 Yoshihiro Ota <ota@j.email.ne.jp> 3.3.3r2-26vl1
374  - catch up to rawhide
375  * Mon Jul 16 2000 Yoshihiro Ota <uyota@mcs.drexel.edu>
376  - modified SPEC file for ppc patch
377  * Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
378  - modified SPEC file for sparc patch
379  * Mon Jun 19 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
380  - added PPC and sparc patch
381
382* Thu Jul 17 2008 Adam Tkac <atkac redhat com> 4.1.2-34
383- vncserver script returns error when Xvnc fails to start
384
385* Wed Jul 16 2008 Adam Tkac <atkac redhat com> 4.1.2-33.1
386- update patches due rpm 4.6
387
388* Thu Jul 03 2008 Adam Tkac <atkac redhat com> 4.1.2-33
389- build with -rdynamic to make swrast_dri driver happy
390
391* Tue Jul 01 2008 Adam Tkac <atkac redhat com> 4.1.2-32
392- enabled XKEYBOARD extension (#450033)
393- icons have correct permissions (#453495)
394
395* Mon Jun 02 2008 Adam Tkac <atkac redhat com> 4.1.2-31.1
396- minor cleanup in IPv6 patch
397
398* Wed May 29 2008 Adam Tkac <atkac redhat com> 4.1.2-31
399- substituted vnc-210617.patch with improved version - vnc-viewerIPv6.patch
400  (#438422)
401
402* Fri Apr 25 2008 Adam Tkac <atkac redhat com> 4.1.2-30
403- rebuild against new mesa to fix GLX under anaconda (#443635)
404
405* Wed Apr 09 2008 Adam Tkac <atkac redhat com> 4.1.2-29
406- rebuild with -O2
407
408* Wed Mar 19 2008 Adam Tkac <atkac redhat com> 4.1.2-28
409- validate framebuffer bounds before GetImage call (#430468, improved fix)
410
411* Fri Mar 14 2008 Adam Tkac <atkac redhat com> 4.1.2-27.1
412- fixed assertion failed when only one scrollbar should be used (#428117)
413
414* Thu Mar 13 2008 Adam Tkac <atkac redhat com> 4.1.2-27
415- removed obsolete vnc-ppc64.patch
416- minor vncviewer manpage fixes (#427672, #427701)
417- fixed overflow on heap (#430468)
418- start vncconfig earlier in vncserver (#430965)
419- next BuildRequires cleanup
420
421* Tue Mar 11 2008 Adam Tkac <atkac redhat com> 4.1.2-26
422- BuildRequires and Requires cleanup
423- don't build java viewer (problems due new gcj)
424- use xorg codebase from xorg-x11-server-source package again
425  - vnc-selection.patch - new xserver selection API/ABI
426  - vnc-xkb.patch - disable XKEYBOARD extension
427  - vnc-paint.patch - PaintWindow{Background,Border} hooks have been removed
428  - vnc-privates.patch - update devPrivates handling
429  - vnc-mieq.patch - use event queue to handle input events
430
431* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.1.2-25
432- Autorebuild for GCC 4.3
433
434* Wed Jan 09 2008 Adam Tkac <atkac redhat com> 4.1.2-24
435- start use F8 xserver codebase
436- compat patches and gcc 4.3 patches
437- use catalogue:/etc/X11/fontpath.d,built-ins as default fontpath
438  (#390971)
439
440* Tue Oct 23 2007 Adam Tkac <atkac redhat com> 4.1.2-23
441- disabled Composite extension (#242280, #339811)
442
443* Mon Sep 24 2007 Adam Tkac <atkac redhat com> 4.1.2-22
444- obsoleted vnc-s390.patch
445- build with --disable-xorg
446
447* Wed Aug 22 2007 Adam Tkac <atkac redhat com> 4.1.2-21
448- rebuild (BuildID feature)
449- GPLv2 license
450
451* Mon Aug 06 2007 Adam Tkac <atkac redhat com> 4.1.2-20.2
452- updated vnc-s390 patch to latest xorg
453
454* Wed Aug 01 2007 Adam Tkac <atkac redhat com> 4.1.2-20.1
455- rebuild
456
457* Tue Jul 31 2007 Adam Tkac <atkac redhat com> 4.1.2-20
458- vnc service is now disabled in all runlevels by default (#250157)
459
460* Tue Jul 17 2007 Adam Tkac <atkac redhat com> 4.1.2-19
461- initscript is ready for parallel booting (#247092)
462
463* Thu Jun 08 2007 Adam Tkac <atkac redhat com> 4.1.2-18
464- added 24bit support to Xvnc
465- handle RENDER extension better
466  (+ moved module_crash patch into render patch)
467 
468* Mon Apr 23 2007 Adam Tkac <atkac redhat com> 4.1.2-17
469- removed patch to #188169 because patching this bug could do
470  more things bad than good
471- removed int10 module from vnc (with-int10 option)
472
473* Tue Mar 27 2007 Adam Tkac <atkac redhat com> 4.1.2-16.fc7
474- fixed vnc module crashing (#234124)
475- vncviewer has been moved from Utility group to Network group (#231765)
476
477* Mon Mar 05 2007 Adam Tkac <atkac redhat com> 4.1.2-15.fc7
478- improved vnc-always_use_fb patch (some screen defects on 64bits)
479- removed xserver tarball from source list
480
481* Fri Mar 02 2007 Adam Tkac <atkac redhat com> 4.1.2-14.fc7
482- enabled RENDER, Composite and GLX extensions by default on all architectures
483- new relation between Xvnc and xorg's source. Xvnc now uses latest xorg's sources
484  from xorg-x11-server-source package
485- fired away obsolete patches
486    - vnc-mesa-6.5.2.patch
487    - vnc-mesa.patch
488    - vnc-selinux.patch
489    - vnc-render-sigfault.patch
490    - vnc-fontpath.patch
491    - vnc-null-interface.patch
492
493* Mon Feb 26 2007 Adam Tkac <atkac redhat com> 4.1.2-13.fc7
494- remove wild implementation of vsnprintf (this caused sigfaults on 64bits) (#229702)
495- added post & postun sections to vnc-libs
496- menu tooltip is HIG compliant (#229941)
497- specfile has been standardized (checked by rpmlint)
498
499* Fri Feb 23 2007 Adam Tkac <atkac redhat com> 4.1.2-12.fc7
500- new colormap policy in Xvnc
501- Xvnc now always use framebuffer (like Xvfb)
502- obsolete patches have been removed
503
504* Wed Feb 16 2007 Adam Tkac <atkac redhat com> 4.1.2-11.fc7
505- major build-process changes in vnc
506    - vnc is now completely built by autotools
507- new package (vnc-libs) contains remote framebuffer library
508  and vncviewer and server is linked against this
509- specfile cleanup
510
511* Mon Jan 15 2007 Adam Tkac <atkac redhat com> 4.1.2-10.fc7
512- fixed render crashing when run in 8bpp
513
514* Mon Jan 08 2007 Adam Tkac <atkac redhat com> 4.1.2-9.fc7
515- enable render extensions by default on s390 & s390x
516
517* Wed Dec 13 2006 Adam Tkac <atkac redhat com> 4.1.2-8.1.fc7
518- changed __ppc64__ to __ppc__ in vnc-render.patch
519  all powerpc has render enabled by default, other archs no
520
521* Mon Dec 11 2006 Adam Tkac <atkac redhat com> 4.1.2-8.fc7
522- fixed building against mesa-6.5.2
523
524* Tue Dec 05 2006 Adam Tkac <atkac redhat com> 4.1.2-7.2.fc7
525- fixed vnc-102434.patch - potential buffer overflow error
526- only ppc64 architecture has enabled render extensions
527  default (conflict between glx&render)
528
529* Mon Dec  4 2006 Thomas Woerner <twoerner@redhat.com> 4.1.2-7.1.fc7
530- tcp_wrappers has a new devel and libs sub package, therefore changing build
531  requirement for tcp_wrappers to tcp_wrappers-devel
532
533* Thu Nov 23 2006 Adam Tkac <atkac@redhat.com> 4.1.2-7.fc7
534- Xvnc now starts with render extensions. We need test it. Disable with -render option
535- vncserver requires xorg-x11-xauth
536
537* Tue Nov 14 2006 Adam Tkac <atkac@redhat.com> 4.1.2-6.fc7
538- update to xorg-x11-server to version 1.1.1
539- fixed OpenGL extensions (#213215)
540- fixed vnc-188169.patch (#213609)
541- fixed RENDER problems (#162304)
542- build requires libstdc++-devel and gcc-c++, autoconf213 and libselinux-devel
543
544* Wed Oct 25 2006 Adam Tkac <atkac@redhat.com> 4.1.2-5
545- added xorg-x11-fonts-base dependency
546- fixed vncconfig crash on x64 (#179635)
547
548* Tue Oct 17 2006 Adam Tkac <atkac@redhat.com> 4.1.2-4
549- IPv6 support to vncviewer has been added (#210617)
550- fixed conflict between "locate pointer" option in control-center
551  and vncviewer (#188169)
552- fixed software group of vnc (#209229)
553- added support to get password from stdin (#102434)
554
555* Mon Jul 18 2006 Jitka Kudrnacova <jkudrnac@redhat.com> 4.1.2-3
556- vncviewer now supports NewFBSize pseudoencoding (#180939)
557- do not BuildRequire libdrm-devel on s390, s390x, ppc64 it is not available there
558
559* Tue Jun 13 2006 Jeremy Katz <katzj@redhat.com> 4.1.2-2
560- update xorg-x11-server to 1.1.0 to fix crashes in anaconda
561
562* Fri May 26 2006 Jitka Kudrnacova <jkudrnac@redhat.com> 4.1.2-1
563- enable OpenGL support
564
565* Thu May 25 2006 Jitka Kudrnacova <jkudrnac@redhat.com> 4.1.2-0.1
566- fixed building on ppc64
567
568* Thu May 18 2006 Jitka Kudrnacova <jkudrnac@redhat.com> 4.1.2-0
569- update to version 4.1.2
570
571* Wed May 10 2006 Jitka Kudrnacova <jkudrnac@redhat.com> 4.1.1-38
572- fixed crash of Xnvc caused by a NULL pointer in interfaces (bug #187607)
573- This also fixes crash of Xvnc when vpnc is running (bug #187069)
574- don't build on ppc64 due to intermittent build problems
575
576* Fri Apr 21 2006 Jitka Kudrnacova <jkudrnac@redhat.com> 4.1.1-37
577- removed liblbxutil-devel from BuildRequires
578
579* Tue Feb 28 2006 Jitka Kudrnacova <jkudrnac@redhat.com> 4.1.1-36
580- with default cofiguration, /etc/init.d/vncserver start will say
581  "no displays configured" (bug #182161)
582 
583* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.1.1-35.1
584- bump again for double-long bug on ppc(64)
585
586* Wed Feb 08 2006 Jitka Kudrnacova <jkudrnac@redhat.com> 4.1.1-35
587- Add a test for existence of index.theme before calling
588  gtk-update-icon-cache in post-(un)installation script,
589  bug #179704
590
591* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.1.1-34.1
592- rebuilt for new gcc4.1 snapshot and glibc changes
593
594* Tue Jan 31 2006 Tim Waugh <twaugh@redhat.com> 4.1.1-34
595- Updated xorg-x11-server to 1.0.1-1.
596
597* Tue Jan  3 2006 Tim Waugh <twaugh@redhat.com> 4.1.1-33
598- Use VNC-provided Xregion (bug #176435).
599- Prevent restorecon error message when not present (bug #176654).
600
601* Fri Dec 23 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-32
602- Use system libtool to fix libvnc.so build (bug #176435).
603
604* Wed Dec 21 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-31
605- Rebase on xorg-x11-server-1.0.0-2.
606
607* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
608- rebuilt
609
610* Thu Dec  8 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-30
611- Enable Xdmcp (bug #175298).
612
613* Thu Dec  8 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-29
614- Fix x0vncserver (bug #172410).
615
616* Tue Dec  6 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-28
617- Enable all the extensions, which were accidentally disabled.
618
619* Tue Dec  6 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-27
620- Fix 64-bit server (bug #174702).
621- Build requires freetype-devel.
622- Build requires libXext-devel, libXtst-devel, automake, libtool, pkgconfig,
623  libfontenc-devel, xorg-x11-util-macros.
624
625* Thu Dec  1 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-26
626- Apply patch to allow vncviewer window reparenting (bug #174640).
627- Build again on s390/s390x (bug #174569).
628
629* Thu Dec  1 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-25
630- Actually initialise the vnc extension in Xvnc.
631- Disable lbx.
632
633* Thu Dec  1 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-24
634- Build X extension module again.
635- Install X extension module into modules/ directory.
636- Remove xscreensaver patch, since it causes badness.
637
638* Fri Nov 25 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-23
639- ExcludeArch s390 s390x (see bug #174569).
640- Re-base on modular xorg-x11 (bug #173323).
641- Build requires modular X things.
642
643* Fri Nov 18 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-22
644- Extension module is not available on all architectures.
645
646* Fri Nov 18 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-21
647- Install extension module into the correct directory.
648
649* Fri Nov 18 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-20
650- Fix font path correctly (bug #173160).
651
652* Wed Nov 16 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-19
653- Remove xorg-x11-devel build requirement to see what breaks.
654- Hack font paths (bug #173160).
655
656* Tue Nov 15 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-18
657- Build requires xorg-x11-devel not XFree86-devel.
658
659* Tue Sep  6 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-17
660- Make vncviewer prevent xscreensaver from blanking screen (bug #106552).
661
662* Thu Aug 11 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-16
663- Added -nohttpd option to vncserver, based on patch from bug #161288.
664- Included -nohttpd, -nolisten tcp, and -localhost options in example
665  sysconfig file (bug #165334).
666
667* Mon Aug  8 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-15
668- Fixed xorg-x11 build (__SSP__ gets set by -fstack-protector).
669- Fixed desktop file again (bug #63689).
670
671* Wed Jul 14 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-14
672- Pulled RENDER support altogether.  It can cause Xvnc to get into a busy
673  loop somehow.
674
675* Wed Jul 13 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-13
676- RENDER clipping fix from Mark McLoughlin.
677
678* Mon Jun 27 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-12
679- Fixed vncpasswd crash (bug #160471).
680
681* Wed Jun 22 2005 Tim Waugh <twaugh@redhat.com>
682- Updated URL in vncservers file (bug #161334).
683
684* Tue Jun 21 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-11
685- Don't ship vncconfig.py any more.
686- Enable render by default for further testing.
687
688* Mon Jun 20 2005 Tim Waugh <twaugh@redhat.com>
689- Build requires expat-devel (bug #160982).
690
691* Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 4.1.1-10
692- silence %%post
693
694* Fri Apr 15 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-9
695- Disable render by default.  There are still screen artifacts from it.
696
697* Fri Apr  1 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-8
698- Further render patch fix for Peter Åstrand.
699
700* Thu Mar 31 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-7
701- Render patch fix from Peter Åstrand.  Enabled render by default again.
702
703* Mon Mar 28 2005 Christopher Aillon <caillon@redhat.com> 4.1.1-6
704- rebuilt
705
706* Fri Mar 25 2005 Christopher Aillon <caillon@redhat.com> 4.1.1-5
707- Update the GTK+ theme icon cache on (un)install
708
709* Thu Mar 24 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-4
710- Upgraded base package to xorg-x11-6.8.2-13.
711
712* Thu Mar 17 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-3
713- Disable render by default (+render turns it back on).
714
715* Fri Mar 11 2005 Tim Waugh <twaugh@redhat.com> 4.1.1-2
716- 4.1.1 (with 4.1 Java viewer).
717- No longer need module patch.
718
719* Thu Mar 10 2005 Tim Waugh <twaugh@redhat.com> 4.1-0.2
720- Improved render patch from Peter Åstrand.
721
722* Thu Mar  3 2005 Tim Waugh <twaugh@redhat.com> 4.1-0.1
723- 4.1 (but still 4.0 Java viewer for the moment).
724- Removed sparc patch.
725- Fixed VNC module link line (from upstream).
726
727* Wed Mar  2 2005 Tim Waugh <twaugh@redhat.com> 4.0-15
728- Upgraded base package to xorg-x11-6.8.2-6.
729- Rebuild for new GCC.
730
731* Wed Feb 23 2005 Tim Waugh <twaugh@redhat.com> 4.0-14
732- Render support from Peter Åstrand.
733
734* Thu Feb  3 2005 Tim Waugh <twaugh@redhat.com>
735- Don't restart the vncserver service on upgrade.
736
737* Tue Feb  1 2005 Tim Waugh <twaugh@redhat.com> 4.0-13
738- Upgraded base package to xorg-x11-6.8.1.903-2.
739
740* Fri Jan  7 2005 Tim Waugh <twaugh@redhat.com>
741- Build requires patchutils (bug #144450).
742
743* Wed Jan  5 2005 Tim Waugh <twaugh@redhat.com> 4.0-12
744- Don't use initlog in the initscript.
745
746* Fri Dec 31 2004 Tim Waugh <twaugh@redhat.com>
747- Cookie generation improvement from Jon Peatfield.
748
749* Mon Dec 13 2004 Tim Waugh <twaugh@redhat.com> 4.0-11
750- Create /tmp/.X11-unix if it doesn't already exist.
751
752* Wed Nov 24 2004 Tim Waugh <twaugh@redhat.com> 4.0-10
753- Use fastjar, not jar, so that the package rebuilds (bug #140671).
754
755* Wed Nov 17 2004 Tim Waugh <twaugh@redhat.com> 4.0-9
756- Don't build hw/xfree86/etc.
757- Prevent xorg-x11 build failure in rman.
758- Build requires autoconf, flex, bison.
759- Use correct PATH setting when started from initscript (bug #84167).
760
761* Wed Oct  6 2004 Tim Waugh <twaugh@redhat.com> 4.0-8
762- Use runuser not su in initscript (bug #134594).
763
764* Wed Sep 29 2004 Tim Waugh <twaugh@redhat.com> 4.0-7
765- Upgraded base package to xorg-x11-6.8.1-4.
766
767* Tue Aug 31 2004 Tim Waugh <twaugh@redhat.com> 4.0-6
768- Upgraded base package to xorg-x11-6.7.99.903-1.
769
770* Fri Aug 27 2004 Tim Waugh <twaugh@redhat.com> 4.0-5
771- Built for Fedora Core 2.
772
773* Wed Aug 25 2004 Tim Waugh <twaugh@redhat.com> 4.0-4
774- Apply and enable Kristian Høgsberg's --use-fb patch.
775
776* Mon Aug  2 2004 Tim Waugh <twaugh@redhat.com>
777- Fixed vnc-via patch (bug #128940).
778
779* Thu Jun 24 2004 Tim Waugh <twaugh@redhat.com> 4.0-3
780- 4.0.
781- No longer need hotspot patch.
782- Add sparc patch from bug #126382.
783
784* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
785- rebuilt
786
787* Tue Jun  1 2004 Tim Waugh <twaugh@redhat.com> 4.0-1.beta5.6
788- Turn ppc64 builds on again.
789
790* Tue Jun  1 2004 Tim Waugh <twaugh@redhat.com> 4.0-1.beta5.5
791- Exclude ppc64 until the build machine is fixed.
792- Undo last vnc.def change to get vnc.so back.
793
794* Fri May 28 2004 Tim Waugh <twaugh@redhat.com> 4.0-1.beta5.4
795- Further vnc.def fix.
796- Fix cursor handling for hotspots outside the bounding rectangle.
797
798* Thu May 27 2004 Tim Waugh <twaugh@redhat.com> 4.0-1.beta5.3
799- Fix ppc64 build.
800- Fix debuginfo package.
801- Another fix for REGION_INIT usage.
802
803* Wed May 26 2004 Tim Waugh <twaugh@redhat.com> 4.0-1.beta5.2
804- Switch to xorg-x11 (bug #119530).
805
806* Thu May 20 2004 Tim Waugh <twaugh@redhat.com> 4.0-1.beta5.1
807- 4.0beta5.
808- Removed compat, f8 and crash patches.
809- Fixed via patch now that NULL is not a valid parameter default.
810- Updated gcc34 patch.
811
812* Wed Apr 14 2004 Tim Waugh <twaugh@redhat.com> 4.0-1.beta4.11
813- Allow parameters to be specified in the init script (bug #60176).
814
815* Wed Mar 31 2004 Tim Waugh <twaugh@redhat.com> 4.0-1.beta4.10
816- Back down to XFree86 again, since the Xvnc binary in 4.0-1.beta4.9 doesn't
817  work at all.
818
819* Tue Mar 23 2004 Tim Waugh <twaugh@redhat.com> 4.0-1.beta4.9
820- Build against xorg-x11.
821
822* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
823- rebuilt
824
825* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
826- rebuilt
827
828* Sun Feb  1 2004 Tim Waugh <twaugh@redhat.com>
829- Build fixes for GCC 3.4.
830
831* Fri Jan 23 2004 Tim Waugh <twaugh@redhat.com> 4.0-0.beta4.8
832- Fix last fix (bug #114063).
833
834* Thu Jan 22 2004 Tim Waugh <twaugh@redhat.com> 4.0-0.beta4.7
835- Restart connect() if a signal interrupts it (bug #114063).
836
837* Thu Nov 27 2003 Tim Waugh <twaugh@redhat.com>
838- Fixed -via parsing bug in vncviewer (bug #110919).
839
840* Fri Nov 14 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta4.6
841- F8 fix (bug #109377).
842
843* Mon Nov 10 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta4.5
844- Better fix for bug #107455.
845
846* Sat Nov  8 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta4.4
847- Fixed zero-sized cursor problem (bug #107455).
848
849* Thu Oct  2 2003 Tim Waugh <twaugh@redhat.com>
850- Added icons (bug #105820).
851
852* Fri Sep 19 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta4.3
853- Avoid a potential Xvnc crash (bug #104702).
854
855* Fri Sep  5 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta4.2
856- 4.0beta4.
857- No longer need compile, dotvnc, norender patches.
858- Don't be so picky about which architectures to build on any more.
859- Build requires XFree86-devel.
860
861* Thu Aug 28 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta3.10
862- Fixed SSH tunnelling support (bug #102213).
863
864* Fri Aug 22 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta3.9
865- Add SSH tunnelling support (bug #102213).
866
867* Wed Aug 20 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta3.8
868- Disable IdleTimeout by default.
869
870* Mon Aug 18 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta3.7
871- Ship vncconfig(1) front-end.
872- In default xstartup, exec /etc/vnc/xstartup if it exists.
873- Track XFree86 package.
874- Fix compilation (bug #102547).
875- Fix vncpasswd (bug #102435).
876
877* Tue Aug 12 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta3.6
878- Use patched tarball from XFree86 package.
879- Build Java VNC viewer.
880
881* Wed Aug  6 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta3.5.1
882- Rebuilt.
883
884* Wed Aug  6 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta3.5
885- Make default xclients file include instructions for 'normal' desktop.
886- Server subpackage doesn't require XFree86.
887- desktop file: add StartupWMClass tag
888- init script: set USER (bug #101674).
889- init script: pause when restarting to give the server a chance to stop
890  (bug #84817).
891- vncpasswd: create ~/.vnc if it doesn't already exist.
892
893* Tue Aug  5 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta3.4
894- Allow old -dontdisconnect option, and behave a bit more like Xvnc used to
895  if it is given (default to no password, use RFB3.3 protocol).
896- Fixed DisconnectClients bug.
897
898* Mon Aug  4 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta3.3
899- Disable RENDER altogether for Xvnc.
900
901* Mon Aug  4 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta3.2
902- Reinstated init script.
903- Add work-around for Xcursor bug.
904
905* Thu Jul 31 2003 Tim Waugh <twaugh@redhat.com> 4.0-0.beta3.1
906- Initial package.
Note: See TracBrowser for help on using the repository browser.