source: projects/specs/trunk/v/vixie-cron/vixie-cron-vl.spec @ 521

Revision 521, 11.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The Vixie cron daemon for executing specified programs at set times.
2Summary(ja): Vixie cron デーモン - 指定された時刻に特定のプログラムを実行する
3Name: vixie-cron
4Version: 3.0.1
5Release: 89%{?_dist_release}
6License: distributable
7Group: System Environment/Base
8Source0: ftp://ftp.vix.com/pub/vixie/vixie-cron-3.0.1.tar.gz
9Source1: vixie-cron.init
10Patch0: vixie-cron-3.0.1-redhat.patch
11Patch1: vixie-cron-3.0.1-security.patch
12Patch2: vixie-cron-3.0.1-security2.patch
13Patch3: vixie-cron-3.0.1-badsig.patch
14Patch4: vixie-cron-3.0.1-crontab.patch
15Patch5: vixie-cron-3.0.1-sigchld.patch
16Patch6: vixie-cron-3.0.1-sprintf.patch
17Patch7: vixie-cron-3.0.1-sigchld2.patch
18Patch8: vixie-cron-3.0.1-crond.patch
19Patch9: vixie-cron-3.0.1-dst.patch
20Patch10: vixie-cron-3.0.1-0days.patch
21Patch11: vixie-cron-3.0.1-nodot.patch
22Patch12: vixie-cron-3.0.1-syslog.patch
23Patch13: vixie-cron-3.0.1-crontabloc.patch
24Patch14: vixie-cron-3.0.1-name.patch
25Patch15: vixie-cron-3.0.1-time.patch
26Patch16: vixie-cron-3.0.1-newtime.patch
27Patch17: vixie-cron-3.0.1-buffer.patch
28Patch18: vixie-cron-3.0.1-timeaftertime.patch
29Patch19: vixie-cron-3.0.1-cront_stdin.patch
30Patch20: vixie-cron-3.0.1-fprintf.patch
31Patch21: vixie-cron-3.0.1-nonstrip.patch
32Patch22: vixie-cron-3.0.1-root_-u-85879.patch
33Patch24: vixie-cron-3.0.1-vfork-105616.patch
34Patch25: vixie-cron-3.0.1-pie.patch
35# Vine Patch(es)
36Patch100: vixie-cron-3.0.1-linux.patch
37
38Buildroot: %{_tmppath}/%{name}-%{version}-root
39Requires: sysklogd >= 1.3.33-6 bash >= 2.0
40#Requires(pre): /sbin/chkconfig /etc/init.d /sbin/service
41Requires(pre): /sbin/chkconfig /sbin/service
42
43
44%description
45The vixie-cron package contains the Vixie version of cron.  Cron is a
46standard UNIX daemon that runs specified programs at scheduled times.
47Vixie cron adds better security and more powerful configuration
48options to the standard version of cron.
49
50%description -l ja
51vixie-cron パッケージには Vixie 版 cron が収録されています.
52cron とは標準的な UNIX のデーモンで,予め指定した時刻に特定の
53プログラムを実行するものです.Vixie cron は標準の cron に加え,
54セキュリティ面を強化し,設定オプションも豊富に追加されています.
55
56
57%prep
58%setup
59%patch0 -p1 -b .norh
60%patch1 -p1 -b .nomisc
61%patch2 -p1 -b .security2
62%patch3 -p1 -b .badsig
63%patch4 -p1 -b .crontabhole
64%patch5 -p1 -b .sigchld
65%patch6 -p1 -b .sprintf
66%patch7 -p1 -b .sigchld
67%patch8 -p1 -b .crond
68%patch9 -p1 -b .dst
69%patch10 -p1 -b .0days
70%patch11 -p1 -b .nodot
71%patch12 -p1 -b .syslog
72%patch13 -p1 -b .crontabloc
73%patch14 -p1 -b .name
74%patch15 -p1 -b .time
75%patch16 -p1 -b .newtime
76%patch17 -p1 -b .buffer
77%patch18 -p1 -b .timeaftertime
78%patch19 -p1 -b .cront_stdin
79%patch20 -p1 -b .fprintf
80%patch21 -p1 -b .nonstrip
81%patch22 -p1 -b .root_-u
82%patch24 -p1 -b .vfork
83%ifnarch alpha
84%patch25 -p1 -b .pie
85%endif
86# Vine Patch(es)
87%patch100 -p1 -b .linux
88
89
90%build
91make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
92
93
94%install
95[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
96mkdir -p $RPM_BUILD_ROOT/usr/{bin,sbin}
97mkdir -p $RPM_BUILD_ROOT%{_mandir}/man{1,5,8}
98mkdir -p $RPM_BUILD_ROOT%{_initdir}
99make install DESTDIR=$RPM_BUILD_ROOT DESTMAN=$RPM_BUILD_ROOT%{_mandir}
100mkdir -p $RPM_BUILD_ROOT/var/spool/cron
101chmod 700 $RPM_BUILD_ROOT/var/spool/cron
102mkdir -p $RPM_BUILD_ROOT/etc/cron.d
103chmod 755 $RPM_BUILD_ROOT/etc/cron.d
104
105install -m755 $RPM_SOURCE_DIR/vixie-cron.init $RPM_BUILD_ROOT%{_initdir}/crond
106
107%clean
108[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
109
110
111%post
112/sbin/chkconfig --add crond
113
114
115%preun
116if [ "$1" = 0 ]; then
117    [ -f /var/lock/subsys/crond ] && /sbin/service crond stop >/dev/null 2>&1
118    /sbin/chkconfig --del crond
119fi
120
121
122%postun
123if [ "$1" -ge "1" ]; then
124        /sbin/service crond condrestart >/dev/null 2>&1
125fi
126
127
128%triggerpostun -- vixie-cron < 3.0.1-56
129/sbin/chkconfig --del crond
130/sbin/chkconfig --add crond
131
132
133%files
134%defattr(-,root,root)
135/usr/sbin/crond
136/usr/bin/crontab
137%{_mandir}/man8/crond.*
138%{_mandir}/man8/cron.*
139%{_mandir}/man5/crontab.*
140%{_mandir}/man1/crontab.*
141
142%dir /var/spool/cron
143%dir /etc/cron.d
144
145%config %{_initdir}/crond
146
147%changelog
148* Wed Mar  3 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.1-89
149- fix a trivial typo s/crom/cron/ on the "Happy Dolls Festival" day :-P
150
151* Sun Feb 07 2010 NAKAMURA Kenta <kenta@vinelinux.org> 3.0.1-88
152- rebuilt with new toolchain
153
154* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.1-87vl5
155- applied new versioning policy, spec in utf-8
156
157* Mon Jul 03 2006 Shu KONNO <owa@bg.wakwak.com> 3.0.1-87vl3
158- s/Copylight/License/
159
160* Thu Mar 25 2004 Tomoya TAKA <taka@vinelinux.org> 3.0.1-87vl2
161- don't apply vixie-cron-3.0.1-pie.patch on alpha
162
163* Mon Mar 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.0.1-87vl1
164- rebuild with new toolchains
165- based on Fedora development 3.0.1-87
166  * Wed Feb 4 2004 Dan Walsh <dwalsh@redhat.com> - 3.0.1-86
167  - Add security_getenforce check.
168  * Mon Jan 26 2004 Dan Walsh <dwalsh@redhat.com> - 3.0.1-85
169  - Fix call to is_selinux_enabled()
170  * Mon Dec 8 2003 Dan Walsh <dwalsh@redhat.com> - 3.0.1-84
171  - change daemon flag to 1
172  * Wed Dec 3 2003 Dan Walsh <dwalsh@redhat.com> - 3.0.1-83
173  - Add daemon to make sure child is clean
174  * Fri Nov  7 2003 Jens Petersen <petersen@redhat.com> - 3.0.1-82
175  - add vixie-cron-3.0.1-pie.patch to build crond as pie (#108414)
176    [Ulrich Drepper]
177  * Tue Sep 30 2003 Jens Petersen <petersen@redhat.com> - 3.0.1-80
178  - add vixie-cron-3.0.1-vfork-105616.patch to use fork instead of vfork
179    (#105616) [report and patch from ian@caliban.org]
180  - update vixie-cron-3.0.1-redhat.patch not to change DESTMAN redundantly
181    (it is overrriden in the spec file anyway)
182  * Wed Mar 19 2003 Jens Petersen <petersen@redhat.com> - 3.0.1-75
183  - add patch from Valdis Kletnieks to allow root to run "crontab -u <user>"
184    even for users that aren't allowed to
185  * Wed Feb 19 2003 Jens Petersen <petersen@redhat.com> - 3.0.1-74
186  - fix preun script typo (#75137) [reported by Peter Bieringer]
187  * Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 3.0.1-73
188  - don't set SIGCHLD to SIG_IGN and then try and wait... (#84046)
189  * Fri Feb  7 2003 Nalin Dahyabhai <nalin@redhat.com> 3.0.1-72
190  - adjust cron.d patch so that it ignores file with names that begin with '#'
191  or end with '~', '.rpmorig', '.rpmsave', or '.rpmnew'
192  - merge hunk of buffer overflow patch into the cron.d patch
193  * Sat Jul 20 2002 Akira TAGOH <tagoh@redhat.com> 3.0.1-69
194  - vixie-cron-3.0.1-nonstrip.patch: applied to fix the stripped binary issue.
195  * Mon Jun 10 2002 Bill Huang <bhuang@redhat.com>
196  - Fix preun bugs.(#55340)
197  - Fix fprintf bugs.(#65209)
198  * Mon Apr 15 2002 Bill Huang <bhuang@redhat.com>
199  - Fixed #62963.
200
201* Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.0.1-63vl2
202- remove file depend (/etc/init.d)
203
204* Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.0.1-63vl1
205- based on 3.0.1-63 from Rawhide and rebuilt for Vine
206
207* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
208- Bump release + rebuild.
209
210* Thu Mar  8 2001 Bill Nottingham <notting@redhat.com>
211- add patch from Alan Eldridge <alane@geeksrus.net> to
212  fix double execution of jobs (#29868)
213
214* Mon Feb 11 2001 Bill Nottingham <notting@redhat.com>
215- fix buffer overflow in crontab
216
217* Wed Feb  7 2001 Trond Eivind Glomsr <teg@redhat.com>
218- fix usage string in initscript (#26533)
219
220* Tue Feb  6 2001 Bill Nottingham <notting@redhat.com>
221- fix build with new glibc (#25931)
222
223* Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
224- change i18n mechanism
225
226* Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
227- log as 'crond', not 'CROND' (#19410)
228- account for shifts in system clock (#23230, patch from <pererik@onedial.se>)
229- i18n-ize initscript
230
231* Thu Aug 24 2000 Than Ngo <than@redhat.com>
232- fix to set startup position correct at update
233
234* Wed Aug 24 2000 Than Ngo <than@redhat.com>
235- add /sbin/service to Prereq
236- call /sbin/service instead service
237- fix startup position (Bug #13353)
238
239* Mon Aug  7 2000 Bill Nottingham <notting@redhat.com>
240- fix crond logging patch (dan@doom.cmc.msu.ru)
241- log via syslog (suggestion from jos@xos.nl)
242- put system crontab location in crontab(5) (#14842)
243
244* Fri Jul 28 2000 Bill Nottingham <notting@redhat.com>
245- fix condrestart
246
247* Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
248- fix reload bug (#14065)
249
250* Fri Jul 14 2000 Bill Nottingham <notting@redhat.com>
251- move initscript back
252
253* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
254- automatic rebuild
255
256* Thu Jul  6 2000 Bill Nottingham <notting@redhat.com>
257- prereq /etc/init.d
258
259* Mon Jul  3 2000 Bill Nottingham <notting@redhat.com>
260- fix %%post; we do condrestart in %%postun
261
262* Thu Jun 29 2000 Bill Nottingham <notting@redhat.com>
263- oops, fix init script
264
265* Tue Jun 27 2000 Bill Nottingham <notting@redhat.com>
266- require new initscripts, not prereq
267
268* Mon Jun 26 2000 Bill Nottingham <notting@redhat.com>
269- initscript hacks
270
271* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
272- tweak logrotate config
273
274* Sun Jun 11 2000 Bill Nottingham <notting@redhat.com>
275- rebuild in new env.
276- FHS fixes
277- don't ship chkconfig links
278
279* Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
280- fix non-root builds (#10490)
281
282* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
283- do not remove log files
284
285* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
286- handle compressed man pages
287
288* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
289- chkconfig --del in %preun, not %postun
290
291* Wed Aug 25 1999 Bill Nottingham <notting@redhat.com>
292- fix buffer overflow
293
294* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
295- initscript munging
296
297* Fri Jul 30 1999 Michael K. Johnson <johnsonm@redhat.com>
298- dayofmonth and month can't be 0
299
300* Thu Jun  3 1999 Jeff Johnson <jbj@redhat.com>
301- in cron.log use "kill -HUP pid" not killall to preserve errors (#2241).
302
303* Wed Apr 14 1999 Michael K. Johnson <johnsonm@redhat.com>
304- add note to man page about DST conversion causing strangeness
305- documented cron.d patch
306
307* Tue Apr 13 1999 Michael K. Johnson <johnsonm@redhat.com>
308- improved cron.d patch
309
310* Mon Apr 12 1999 Erik Troan <ewt@redhat.com>
311- added cron.d patch
312
313* Tue Mar 23 1999 Bill Nottingham <notting@redhat.com>
314- logrotate changes
315
316* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
317- clean up log files on deinstallation
318
319* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
320- auto rebuild in the new build environment (release 28)
321
322* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
323- build for glibc 2.1
324
325* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
326- translations modified for de
327
328* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
329- reset SIGCHLD before grandchild execle (problem #732)
330
331* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
332- enhanced initscript
333
334* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
335- translations modified for de, fr, tr
336
337* Thu Dec 11 1997 Cristian Gafton <gafton@redhat.com>
338- added a patch to get rid of the dangerous sprintf() calls
339- added BuildRoot and Prereq: /sbin/chkconfig
340
341* Sun Nov 09 1997 Michael K. Johnson <johnsonm@redhat.com>
342- fixed cron/crond dichotomy in init file.
343
344* Wed Oct 29 1997 Donnie Barnes <djb@redhat.com>
345- fixed bad init symlinks
346
347* Thu Oct 23 1997 Erik Troan <ewt@redhat.com>
348- force it to use SIGCHLD instead of defunct SIGCLD
349
350* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
351- updated for chkconfig
352- added status, restart options to init script
353
354* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
355- built against glibc
356
357* Wed Feb 19 1997 Erik Troan <ewt@redhat.com>
358- Switch conditional from "axp" to "alpha"
359
Note: See TracBrowser for help on using the repository browser.