source: projects/specs/trunk/v/vino/vino-vl.spec @ 6890

Revision 6890, 7.4 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1%define gtk3_version 3.6.0
2%define libgcrypt_version 1.4.6
3%define avahi_version 0.6.31
4
5Summary: A remote desktop system for GNOME
6Summary(ja): GNOME 用リモートデスクトップシステム
7Name: vino
8Version: 3.6.0
9Release: 1%{?_dist_release}
10URL: http://www.gnome.org
11License: GPL
12Group: User Interface/Desktops
13
14Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.6/%{name}-%{version}.tar.xz
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18Requires: gtk3 >= %{gtk3_version}
19Requires: libgcrypt >= %{libgcrypt_version}
20Requires: avahi >= %{avahi_version}
21Requires: avahi-glib >= %{avahi_version}
22Requires: NetworkManager >= 0.8
23
24BuildRequires: gtk3-devel >= %{gtk3_version}
25BuildRequires: dbus-devel >= 1.4.0
26BuildRequires: libsoup-devel >= 2.32.0
27BuildRequires: libnotify-devel >= 0.4.5
28BuildRequires: libgcrypt-devel >= %{libgcrypt_version}
29BuildRequires: avahi-devel >= %{avahi_version}
30BuildRequires: avahi-glib-devel >= %{avahi_version}
31BuildRequires: libgnome-keyring-devel >= 2.32
32BuildRequires: NetworkManager-glib-devel >= 0.8
33BuildRequires: unique3-devel >= 3.0.0
34BuildRequires: libSM-devel
35BuildRequires: libXtst-devel
36BuildRequires: desktop-file-utils
37
38Vendor: Project Vine
39Distribution: Vine Linux
40
41%description
42Vino is a VNC server for GNOME. It allows remote users to
43connect to a running GNOME session using VNC.
44
45%description -l ja
46Vine は GNOME 用の VNC サーバです。Vino によりリモートユーザが
47VNC を利用して稼働中のGNOME セッション接続することができるよう
48になります。
49
50%prep
51%setup -q
52
53%build
54%configure \
55        --disable-schemas-install \
56        --enable-avahi \
57        --disable-gnutls \
58        --disable-session-support \
59        --disable-telepathy \
60        --enable-libnotify \
61        --enable-network-manager \
62        --enable-gnome-keyring \
63        --disable-http-server \
64        --enable-libunique=yes
65%__make %{?_smp_mflags}
66
67%install
68rm -rf $RPM_BUILD_ROOT
69
70export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
71make install DESTDIR=$RPM_BUILD_ROOT
72unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
73
74#desktop-file-install --vendor gnome --delete-original                   \
75#  --dir $RPM_BUILD_ROOT%{_datadir}/applications                                \
76#  --add-only-show-in GNOME                                              \
77#  $RPM_BUILD_ROOT%{_datadir}/applications/vino-preferences.desktop
78
79# stuff we don't want
80rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
81
82%find_lang %{name}
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post
88touch --no-create %{_datadir}/icons/hicolor
89
90%postun
91touch --no-create %{_datadir}/icons/hicolor
92if [ -x /usr/bin/gtk-update-icon-cache ]; then
93  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
94fi
95glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
96
97%posttrans
98gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
99glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
100
101
102
103%files -f %{name}.lang
104%defattr(-,root,root)
105%doc AUTHORS ChangeLog COPYING NEWS README docs/TODO docs/remote-desktop.txt
106%{_sysconfdir}/xdg/autostart/vino-server.desktop
107%{_bindir}/*
108%{_libexecdir}/*
109%{_datadir}/GConf/gsettings/org.gnome.Vino.convert
110%{_datadir}/applications/*.desktop
111%{_datadir}/dbus-1/services/*
112%{_datadir}/glib-2.0/schemas/*.xml
113%{_datadir}/vino
114
115%changelog
116* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
117- new upstream release
118- remove BuildRequires: GConf2-devel
119
120* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
121- new upstream release
122
123* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
124- new upstream release
125
126* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
127- new upstream release
128
129* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
130- new upstream release
131
132* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
133- new upstream release
134
135* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
136- new upstream release
137
138* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
139- new upstream release
140- add BuildRequires: libXtst-devel
141
142* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
143- new upstream release
144
145* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
146- new upstream release
147- change BuildRequires: unique3-devel instead of unique-devel
148
149* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
150- new upstream release
151- change BuildRequires: NetworkManager-glib-devel instead of NetworkManager-devel
152
153* Sun Dec 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
154- new upstream release
155
156* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
157- new upstream release
158
159* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
160- new upstream release
161- add BuildRequires: libSM-devel, desktop-file-utils
162- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
163
164* Sun Nov  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
165- new upstream release
166
167* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
168- new upstream release
169
170* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
171- new upstream release
172
173* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
174- new upstream release
175
176* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
177- new upstream release
178
179* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
180- new upstream release
181
182* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
183- new upstream release
184
185* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 2.18.1-1vl5
186- applied new versioning policy, spec in utf-8
187
188* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
189- new upstream release
190
191* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl3
192- run gtk-update-icon-cache in %%post script.
193
194* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
195- enable avahi, add BuildRequires: avahi-devel
196
197* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
198- new upstream release
199
200* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
201- new upstream release
202
203* Tue Mar 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
204- new upstream version
205
206* Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
207- initial build for Vine Linux
208- add japanese summary and description.
209
210* Tue Oct 12 2004 Mark McLoughlin <markmc@redhat.com> 2.8.1-1
211- Update to 2.8.1
212- Remove backported fixes
213
214* Thu Oct  7 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1.1
215- Don't hang with metacity's "reduced resources" mode (#134240)
216- Improve the key repeat rate situation a good deal (#134451)
217
218* Wed Sep 29 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1
219- Update to 2.8.0.1
220
221* Tue Sep 21 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0-1
222- Update to 2.8.0
223- Remove upstreamed work-without-gnutls patch
224
225* Tue Sep  7 2004 Matthias Clasen <mclasen@redhat.com> 2.7.92-3
226- Disable help button until there is help (#131632)
227 
228* Wed Sep  1 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-2
229- Add patch to fix hang without GNU TLS (bug #131354)
230
231* Mon Aug 30 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-1
232- Update to 2.7.92
233
234* Tue Aug 17 2004 Mark McLoughlin <markmc@redhat.com> 2.7.91-1
235- Update to 2.7.91
236
237* Mon Aug 16 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-2
238- Define libgcrypt_version
239
240* Thu Aug 12 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-1
241- Update to 2.7.90
242
243* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 2.7.4-1
244- Update to 2.7.4
245
246* Tue Jul 13 2004 Mark McLoughlin <markmc@redhat.com> 2.7.3.1-1
247- Initial build.
Note: See TracBrowser for help on using the repository browser.