source: projects/specs/trunk/v/vino/vino-vl.spec @ 521

Revision 521, 5.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define gtk2_version 2.16.0
2%define gconf2_version 2.24.0
3%define libgcrypt_version 1.2.0
4%define avahi_version 0.6.17
5
6Summary: A remote desktop system for GNOME
7Summary(ja): GNOME 用リモートデスクトップシステム
8Name: vino
9Version: 2.28.1
10Release: 1%{?_dist_release}
11URL: http://www.gnome.org
12License: GPL
13Group: User Interface/Desktops
14
15Source0: %{name}-%{version}.tar.bz2
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19Prereq: GConf2 >= %{gconf2_version}
20
21Requires: gtk2 >= %{gtk2_version}
22Requires: GConf2 >= %{gconf2_version}
23Requires: libgcrypt >= %{libgcrypt_version}
24Requires: avahi >= %{avahi_version}
25Requires: avahi-glib >= %{avahi_version}
26Requires: NetworkManager >= 0.7
27
28BuildRequires: gtk2-devel >= %{gtk2_version}
29BuildRequires: GConf2-devel >= %{gconf2_version}
30BuildRequires: dbus-devel >= 1.2.3
31BuildRequires: libsoup-devel >= 2.24.0
32BuildRequires: libnotify-devel >= 0.4.4
33BuildRequires: libgcrypt-devel >= %{libgcrypt_version}
34BuildRequires: avahi-devel >= %{avahi_version}
35BuildRequires: avahi-glib-devel >= %{avahi_version}
36BuildRequires: gnome-keyring-devel
37BuildRequires: NetworkManager-devel >= 0.7
38BuildRequires: unique-devel >= 1.0.0
39
40%description
41Vino is a VNC server for GNOME. It allows remote users to
42connect to a running GNOME session using VNC.
43
44%description -l ja
45Vine は GNOME 用の VNC サーバです。Vino によりリモートユーザが
46VNC を利用して稼働中のGNOME セッション接続することができるよう
47になります。
48
49%prep
50%setup -q
51
52%build
53%configure \
54        --disable-schemas-install \
55        --enable-avahi \
56        --disable-gnutls \
57        --disable-session-support \
58        --disable-telepathy \
59        --enable-libnotify \
60        --enable-network-manager \
61        --enable-gnome-keyring \
62        --disable-http-server \
63        --enable-libunique=yes
64%__make %{?_smp_mflags}
65
66%install
67rm -rf $RPM_BUILD_ROOT
68
69export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
70%makeinstall
71unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
72
73desktop-file-install --vendor gnome --delete-original                   \
74  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
75  --add-only-show-in GNOME                                              \
76  $RPM_BUILD_ROOT%{_datadir}/applications/vino-preferences.desktop
77
78# stuff we don't want
79rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
80
81%find_lang %{name}
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post
87export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
88SCHEMAS="vino-server.schemas"
89for S in $SCHEMAS; do
90  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >& /dev/null ||:
91done
92touch --no-create %{_datadir}/icons/hicolor
93if [ -x /usr/bin/gtk-update-icon-cache ]; then
94  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
95fi
96
97%postun
98touch --no-create %{_datadir}/icons/hicolor
99if [ -x /usr/bin/gtk-update-icon-cache ]; then
100  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
101fi
102
103
104%files -f %{name}.lang
105%defattr(-,root,root)
106%doc AUTHORS ChangeLog COPYING NEWS README docs/TODO docs/remote-desktop.txt
107%{_bindir}/*
108%{_libexecdir}/*
109%{_datadir}/applications/*.desktop
110%{_datadir}/dbus-1/services/*
111%{_datadir}/vino
112%{_sysconfdir}/gconf/schemas/*.schemas
113%{_sysconfdir}/xdg/autostart/vino-server.desktop
114
115%changelog
116* Sun Nov  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
117- new upstream release
118
119* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
120- new upstream release
121
122* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
123- new upstream release
124
125* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
126- new upstream release
127
128* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
129- new upstream release
130
131* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
132- new upstream release
133
134* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
135- new upstream release
136
137* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 2.18.1-1vl5
138- applied new versioning policy, spec in utf-8
139
140* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
141- new upstream release
142
143* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl3
144- run gtk-update-icon-cache in %%post script.
145
146* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
147- enable avahi, add BuildRequires: avahi-devel
148
149* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
150- new upstream release
151
152* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
153- new upstream release
154
155* Tue Mar 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
156- new upstream version
157
158* Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
159- initial build for Vine Linux
160- add japanese summary and description.
161
162* Tue Oct 12 2004 Mark McLoughlin <markmc@redhat.com> 2.8.1-1
163- Update to 2.8.1
164- Remove backported fixes
165
166* Thu Oct  7 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1.1
167- Don't hang with metacity's "reduced resources" mode (#134240)
168- Improve the key repeat rate situation a good deal (#134451)
169
170* Wed Sep 29 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1
171- Update to 2.8.0.1
172
173* Tue Sep 21 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0-1
174- Update to 2.8.0
175- Remove upstreamed work-without-gnutls patch
176
177* Tue Sep  7 2004 Matthias Clasen <mclasen@redhat.com> 2.7.92-3
178- Disable help button until there is help (#131632)
179 
180* Wed Sep  1 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-2
181- Add patch to fix hang without GNU TLS (bug #131354)
182
183* Mon Aug 30 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-1
184- Update to 2.7.92
185
186* Tue Aug 17 2004 Mark McLoughlin <markmc@redhat.com> 2.7.91-1
187- Update to 2.7.91
188
189* Mon Aug 16 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-2
190- Define libgcrypt_version
191
192* Thu Aug 12 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-1
193- Update to 2.7.90
194
195* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 2.7.4-1
196- Update to 2.7.4
197
198* Tue Jul 13 2004 Mark McLoughlin <markmc@redhat.com> 2.7.3.1-1
199- Initial build.
Note: See TracBrowser for help on using the repository browser.