source: projects/specs/trunk/v/vino/vino-vl.spec @ 4704

Revision 4704, 6.9 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2 beta 1 (3.1.90)

Line 
1%define gtk3_version 3.0.9
2%define gconf2_version 2.32.0
3%define libgcrypt_version 1.4.6
4%define avahi_version 0.6.25
5
6Summary: A remote desktop system for GNOME
7Summary(ja): GNOME 用リモートデスクトップシステム
8Name: vino
9Version: 3.1.90
10Release: 1%{?_dist_release}
11URL: http://www.gnome.org
12License: GPL
13Group: User Interface/Desktops
14
15Source0: http://ftp.gnome.org/pub/GNOME/sources/vino/3.1/%{name}-%{version}.tar.xz
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19Requires: GConf2 >= %{gconf2_version}
20
21Requires: gtk3 >= %{gtk3_version}
22Requires: GConf2 >= %{gconf2_version}
23Requires: libgcrypt >= %{libgcrypt_version}
24Requires: avahi >= %{avahi_version}
25Requires: avahi-glib >= %{avahi_version}
26Requires: NetworkManager >= 0.8
27
28BuildRequires: gtk3-devel >= %{gtk3_version}
29BuildRequires: GConf2-devel >= %{gconf2_version}
30BuildRequires: dbus-devel >= 1.4.0
31BuildRequires: libsoup-devel >= 2.32.0
32BuildRequires: libnotify-devel >= 0.4.5
33BuildRequires: libgcrypt-devel >= %{libgcrypt_version}
34BuildRequires: avahi-devel >= %{avahi_version}
35BuildRequires: avahi-glib-devel >= %{avahi_version}
36BuildRequires: libgnome-keyring-devel >= 2.32
37BuildRequires: NetworkManager-glib-devel >= 0.8
38BuildRequires: unique3-devel >= 3.0.0
39BuildRequires: libSM-devel
40BuildRequires: libXtst-devel
41BuildRequires: desktop-file-utils
42
43Vendor: Project Vine
44Distribution: Vine Linux
45
46%description
47Vino is a VNC server for GNOME. It allows remote users to
48connect to a running GNOME session using VNC.
49
50%description -l ja
51Vine は GNOME 用の VNC サーバです。Vino によりリモートユーザが
52VNC を利用して稼働中のGNOME セッション接続することができるよう
53になります。
54
55%prep
56%setup -q
57
58%build
59%configure \
60        --disable-schemas-install \
61        --enable-avahi \
62        --disable-gnutls \
63        --disable-session-support \
64        --disable-telepathy \
65        --enable-libnotify \
66        --enable-network-manager \
67        --enable-gnome-keyring \
68        --disable-http-server \
69        --enable-libunique=yes
70%__make %{?_smp_mflags}
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
75export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
76make install DESTDIR=$RPM_BUILD_ROOT
77unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
78
79#desktop-file-install --vendor gnome --delete-original                   \
80#  --dir $RPM_BUILD_ROOT%{_datadir}/applications                                \
81#  --add-only-show-in GNOME                                              \
82#  $RPM_BUILD_ROOT%{_datadir}/applications/vino-preferences.desktop
83
84# stuff we don't want
85rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
86
87%find_lang %{name}
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post
93touch --no-create %{_datadir}/icons/hicolor
94
95%postun
96touch --no-create %{_datadir}/icons/hicolor
97if [ -x /usr/bin/gtk-update-icon-cache ]; then
98  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
99fi
100glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
101
102%posttrans
103gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
104glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
105
106
107
108%files -f %{name}.lang
109%defattr(-,root,root)
110%doc AUTHORS ChangeLog COPYING NEWS README docs/TODO docs/remote-desktop.txt
111%{_sysconfdir}/xdg/autostart/vino-server.desktop
112%{_bindir}/*
113%{_libexecdir}/*
114%{_datadir}/GConf/gsettings/org.gnome.Vino.convert
115%{_datadir}/applications/*.desktop
116%{_datadir}/dbus-1/services/*
117%{_datadir}/glib-2.0/schemas/*.xml
118%{_datadir}/vino
119
120%changelog
121* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
122- new upstream release
123- add BuildRequires: libXtst-devel
124
125* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
126- new upstream release
127
128* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
129- new upstream release
130- change BuildRequires: unique3-devel instead of unique-devel
131
132* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
133- new upstream release
134- change BuildRequires: NetworkManager-glib-devel instead of NetworkManager-devel
135
136* Sun Dec 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
137- new upstream release
138
139* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
140- new upstream release
141
142* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
143- new upstream release
144- add BuildRequires: libSM-devel, desktop-file-utils
145- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
146
147* Sun Nov  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
148- new upstream release
149
150* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
151- new upstream release
152
153* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
154- new upstream release
155
156* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
157- new upstream release
158
159* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
160- new upstream release
161
162* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
163- new upstream release
164
165* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
166- new upstream release
167
168* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 2.18.1-1vl5
169- applied new versioning policy, spec in utf-8
170
171* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
172- new upstream release
173
174* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl3
175- run gtk-update-icon-cache in %%post script.
176
177* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
178- enable avahi, add BuildRequires: avahi-devel
179
180* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
181- new upstream release
182
183* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
184- new upstream release
185
186* Tue Mar 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
187- new upstream version
188
189* Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
190- initial build for Vine Linux
191- add japanese summary and description.
192
193* Tue Oct 12 2004 Mark McLoughlin <markmc@redhat.com> 2.8.1-1
194- Update to 2.8.1
195- Remove backported fixes
196
197* Thu Oct  7 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1.1
198- Don't hang with metacity's "reduced resources" mode (#134240)
199- Improve the key repeat rate situation a good deal (#134451)
200
201* Wed Sep 29 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1
202- Update to 2.8.0.1
203
204* Tue Sep 21 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0-1
205- Update to 2.8.0
206- Remove upstreamed work-without-gnutls patch
207
208* Tue Sep  7 2004 Matthias Clasen <mclasen@redhat.com> 2.7.92-3
209- Disable help button until there is help (#131632)
210 
211* Wed Sep  1 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-2
212- Add patch to fix hang without GNU TLS (bug #131354)
213
214* Mon Aug 30 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-1
215- Update to 2.7.92
216
217* Tue Aug 17 2004 Mark McLoughlin <markmc@redhat.com> 2.7.91-1
218- Update to 2.7.91
219
220* Mon Aug 16 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-2
221- Define libgcrypt_version
222
223* Thu Aug 12 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-1
224- Update to 2.7.90
225
226* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 2.7.4-1
227- Update to 2.7.4
228
229* Tue Jul 13 2004 Mark McLoughlin <markmc@redhat.com> 2.7.3.1-1
230- Initial build.
Note: See TracBrowser for help on using the repository browser.