source: projects/specs/trunk/v/vine-printfilters/vine-printfilters-vl.spec @ 521

Revision 521, 10.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define orig_name rhs-printfilters
2%define version 1.81
3
4Summary: Vine Linux Print Filter System
5Summary(ja): Vine Linux 印刷フィルター・システム
6
7Name: vine-printfilters
8Version: %{version}
9Release: 1%{?_dist_release}
10License: GPL
11Group: Applications/Publishing
12Source0: rhs-printfilters-%{version}.tar.gz
13Source1: testpages-vine.tar.gz
14Source2: printerdb-1.81.ja
15# Vine patch
16Patch0: printerdb-vine.diff
17Patch1: vine-printfilters-1.81-2.diff
18Patch2: rhs-printfilters-1.81-pips5.patch
19Patch5: rhs-printfilters-1.81-lang.patch
20# security fix
21Patch6: rhs-printfilters-1.63-PARANOIDSAFER.patch
22#BuildPreReq: transfig >= 3.2.3c
23Requires: mpage >= 2.4, lpr >= 0.17, ghostscript >= 5.10, findutils >= 4.1-23, nkf, pnm2ppa, diffutils, sed
24Obsoletes: rhs-printfilters
25Provides: rhs-printfilters
26Buildroot: %{_tmppath}/%{name}-root
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31#
32# these conflcts exists because Dr Mike changes the location of the filters
33#
34Conflicts: libgr-progs < 2.0.9-7
35
36%description
37The vine-printfilters package contains a set of print filters which
38are primarily meant to be used with the Vine printtool.  These
39print filters provide an easy way for users to handle printing
40numerous file formats.
41
42%description -l ja
43vnie-printfilters パッケージには Vine printtool で使用される
44印刷フィルタが含まれています。これらの印刷フィルターは様々な
45ファイルフォーマットの印刷を使用者が簡単に取り扱えるように
46なっています。
47
48%prep
49%setup -q -a 1 -n rhs-printfilters-%{version}
50cp %SOURCE2 printerdb.ja
51%patch0     -b .db
52%patch1 -p1 -b .filter
53
54%ifarch i386 i486 i586 i686
55%patch2 -p1 -b .epson
56%endif
57
58%patch5 -p1 -b .lang
59%patch6 -p1
60
61%build
62cp testpages-vine/testpage* .
63cp testpages-vine/vinelogos* .
64
65%install
66rm -rf %{buildroot}
67
68mkdir -p INSTALL_DIR=%{buildroot}/usr/lib/rhs/rhs-printfilters
69make INSTALLBIN="install -m0755" INSTALLDATA="install -m0644" \
70        INSTALL_DIR=%{buildroot} install
71#cp %SOURCE2 $RPM_BUILD_ROOT/usr/lib/rhs/rhs-printfilters/printerdb.ja
72install -m 644 printerdb.ja %{buildroot}/usr/lib/rhs/rhs-printfilters
73
74%clean
75rm -rf %{buildroot}
76
77%pre
78# Requires:
79# bash, sed, grep, diff, rm, cat
80# Where is the printcap?
81PRINTCAP='/etc/printcap'
82# Where is the master filter?
83MASTER_FILTER='/usr/lib/rhs/rhs-printfilters/master-filter'
84# Make sure that we actually have these files
85if [ -f $PRINTCAP ] && [ -f $MASTER_FILTER ]
86then
87# Open printcap
88cat $PRINTCAP | (
89        # Read each line (forcing it to ignore the '\' convention).
90        while read -r line;
91        do
92                # if a line looks like ':if=filename:', but aint commented,
93                if echo ${line} | grep -q -E -e '^[^#]{0}[[:space:]]*:if='
94                then
95                        # strip it down to the file name,
96                        # (We can be a little messy, 'cause printcap uses
97                        # ':' as a control character, to it can't be in
98                        # the file name)
99                        FILTER=`echo ${line} | sed -e 's/^:if=//; s/:.*//'`
100                        # and if the filter it names is the same as the
101                        # master-filter, or does not exist, then
102                        case $FILTER in
103                        "/var/spool/lpd/"*"/filter" )
104                                # All filters we want to find match this pattern
105                                if [ ! -a $FILTER ] || diff -q $MASTER_FILTER $FILTER > /dev/null
106                                then
107                                        # remove the named filter
108                                        rm -f $FILTER
109
110                                        # Adjust the printcap file to use the
111                                        # master filter directly
112                                        sed -e "s:$FILTER:$MASTER_FILTER:g" < $PRINTCAP > $PRINTCAP.tmp
113                                        mv $PRINTCAP.tmp $PRINTCAP
114                                fi
115                                ;;
116
117                        * )
118                                ;;
119                        esac
120                fi
121        done
122)
123fi
124
125%files
126%defattr(-,root,root)
127%doc README READMEj CHANGES
128%dir /usr/lib/rhs/rhs-printfilters
129/usr/lib/rhs/rhs-printfilters/asc-to-escp
130/usr/lib/rhs/rhs-printfilters/asc-to-escpage
131/usr/lib/rhs/rhs-printfilters/asc-to-lips3
132/usr/lib/rhs/rhs-printfilters/asc-to-npdl
133/usr/lib/rhs/rhs-printfilters/asc-to-printer.fpi
134/usr/lib/rhs/rhs-printfilters/asc-to-ps.fpi
135/usr/lib/rhs/rhs-printfilters/general.cfg.in
136/usr/lib/rhs/rhs-printfilters/master-filter
137/usr/lib/rhs/rhs-printfilters/postscript.cfg.in
138/usr/lib/rhs/rhs-printfilters/printerdb
139/usr/lib/rhs/rhs-printfilters/printerdb.ja
140/usr/lib/rhs/rhs-printfilters/ps-to-printer.fpi
141/usr/lib/rhs/rhs-printfilters/rpm-to-asc.fpi
142/usr/lib/rhs/rhs-printfilters/ncpprint
143/usr/lib/rhs/rhs-printfilters/ppaprint
144/usr/lib/rhs/rhs-printfilters/smbprint
145/usr/lib/rhs/rhs-printfilters/directprint
146/usr/lib/rhs/rhs-printfilters/testpage.asc
147/usr/lib/rhs/rhs-printfilters/testpage.euc
148/usr/lib/rhs/rhs-printfilters/testpage.jis
149/usr/lib/rhs/rhs-printfilters/testpage.sj
150/usr/lib/rhs/rhs-printfilters/testpage.ps
151/usr/lib/rhs/rhs-printfilters/testpage-a4.ps
152/usr/lib/rhs/rhs-printfilters/textonly.cfg.in
153
154%changelog
155* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 1.81-1vl5
156- applied new versioning policy, spec in utf-8
157
158* Sat Jul 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.81-0vl10
159- rebuilt and docdir moved to /usr/share/doc
160- s/Copyright/License/
161
162* Wed Mar  6 2002 Jun Nishii <jun@vinelinux.org> 1.81-0vl9
163- add lang patch again
164
165* Wed Jan 30 2002 Jun Nishii <jun@vinelinux.org> 1.81-0vl8
166- added pips (ver.2.x) entries in printerdb
167  (rhs-printfilters-1.81-pips5.patch)
168
169* Fri Jan 25 2002 Jun Nishii <jun@vinelinux.org> 1.81-0vl7
170- added pips/eplaser entries in printerdb
171  (rhs-printfilters-1.81-pips4.patch)
172- security fix
173        * added rhs-printfilters-1.63-PARANOIDSAFER.patch
174        * replace %pre by the script in rhs-printfilters-1.63-4.rh6.2j.src.rpm
175          so as not to put filter in spool directory
176
177* Sun Apr  8 2001 Jun Nishii <jun@vinelinux.org> 1.81-0vl6
178- added many newest pips filters(670,780,880,900,2200,3300,3500)
179  by epson kowa
180
181* Sun Apr  8 2001 Jun Nishii <jun@vinelinux.org> 1.81-0vl5
182- added eplaser db by epson kowa
183
184* Thu Feb 15 2001 Jun Nishii <jun@vinelinux.org>
185- 1.81-0vl4
186- added pips db epson kowa
187
188* Wed Feb 14 2001 Jun Nishii <jun@vinelinux.org>
189- 1.81-0vl3
190- bug fix in ps-to-printer.fpi, thanks Mr. Masaki Kawamura
191- added lang patch to exec gs on LANG env.
192
193* Fri Feb  9 2001 Jun Nishii <jun@vinelinux.org>
194- 1.81-0vl2
195- try to merge Duplex patch
196
197* Mon Oct 30 2000 Jun Nishii <jun@vinelinux.org>
198- 1.81-0vl1
199
200* Sun Oct  8 2000 Jun Nishii <jun@vinelinux.org>
201- 1.63-0vl3
202- bug fix for GSDriver: EPSONc and EPSON in printerdb.ja
203  by Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp>, thanks!
204
205* Wed Oct  4 2000 Jun Nishii <jun@vinelinux.org>
206- 1.63-0vl2
207- requires pnm2pba (obsoletes pbm2ppa)
208
209* Sun Aug 20 2000 Jun Nishii <jun@vinelinux.org>
210- 1.63-0vl1
211- fix for EPSON 820C
212- follow up with RHL62
213
214* Mon Jul 10 2000 AYUHANA Tomonori <l@kondara.org>
215- (1.59-2k)
216- add -q at %setup
217- add -b at %patch
218
219* Tue Jul  4 2000 Norihito Ohmori <nono@kondara.org>
220- fix DJ720C bug (#585)
221
222* Mon Mar 13 2000 Daiki Matsuda <dyky@kondara.org>
223- fix for EPSON 770C/800C
224
225* Wed Feb 17 2000 Norihito Ohmori <nono@kondara.org>
226- fix duplex printing bug (#398)
227
228* Mon Feb 14 2000 Norihito Ohmori <nono@kondara.org>
229- RPM_OPT_FLAGS support
230- ad-hoc i18n
231- Change Name vine-printfilters
232- be a NoSrc :-P
233- Support Duplex/Simplex Printing.
234- HP DeskJet 710C/720C support using pbm2ppa.
235- printerdb modified for gs510j55
236- add ESC/P, ESC/Page ,LIPS III and NPDL text filters
237- Add printerdb.ja
238
239* Wed Jan 26 2000 Bill Nottingham <notting@redhat.com>
240- add stylus color 740 to printerdb
241
242* Mon Nov  8 1999 Bill Nottingham <notting@redhat.com>
243- revert ps-to-printer tempfile usage. There has
244  to be a better way to do this.
245
246* Wed Jul 21 1999 Bill Nottingham <notting@redhat.com>
247- munge smbprint Yet Again(tm)
248
249* Thu Jul  8 1999 Bill Nottingham <notting@redhat.com>
250- make printerdb config(noreplace)
251
252* Thu Jul  1 1999 Bill Nottingham <notting@redhat.com>
253- add more drivers
254
255* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
256- fix rpm printing
257
258* Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
259- use smbclient's -c command. Makes much more sense.
260
261* Mon May 24 1999 Bill Nottingham <notting@redhat.com>
262- hmm. The translate option went away at some point. Oops.
263
264* Mon May  3 1999 Bill Nottingham <notting@redhat.com>
265- yet another typo in SMB stuff. Urg.
266
267* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
268- strip binaries
269
270* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
271- fix some printerdb stuff for ghostscript brokenness
272
273* Fri Mar 19 1999 Bill Nottingham <notting@redhat.com>
274- remove some oboslete text
275
276* Mon Feb  8 1999 Bill Nottingham <notting@redhat.com>
277- uniprint support
278
279* Tue Dec 29 1998 Bill Nottingham <notting@redhat.com>
280- add workaround for Adobe(!) postscript driver
281
282* Mon Dec 28 1998 Bill Nottingham <notting@redhat.com>
283- remove 1bpp from cdj-based drivers, 'cos it's broken.
284
285* Wed Nov 18 1998 Bill Nottingham <notting@redhat.com>
286- add workgroup support to smbprint, fix quoting issues
287
288* Wed Sep 30 1998 Bill Nottingham <notting@redhat.com>
289- fix typo in ncpprint
290
291* Wed Sep 15 1998 Bill Nottingham <notting@redhat.com>
292- Added ncpprint to %files section (oops!)
293
294* Thu Sep  2 1998 Bill Nottingham <notting@redhat.com>
295- Added NCP printing support
296
297* Tue Jun 30 1998 Michael Maher <mike@redhat.com>
298- Fixed BUG 703,  added findutils dependecy.
299- Added buildroot.
300
301* Fri May 08 1998 Prospector System <bugs@redhat.com>
302- translations modified for de, fr, tr
303
304* Wed Oct 22 1997 Michael Fulbright <msf@redhat.com>
305- Fixed printerdb to include 300x300 resolution for LaserJet 4 models
306- Restored troff file handling now troff fpi is 'safe'
307
308* Tue Oct 14 1997 Michael Fulbright <msf@redhat.com>
309- Fixed master-filter to NOT handle troff files automatically
310
311* Thu Jul 31 1997 Erik Troan <ewt@redhat.com>
312- built against glibc
313
314* Wed Apr 23 1997 Michael Fulbright <msf@redhat.com>
315- Fixed problem with asc-to-printer.fpi not handling cr/lf trans correct
316
317* Fri Apr 18 1997 Michael Fulbright <msf@redhat.com>
318- fixed up Canon 600/4000 printerdb def
319- added some HP Deskjets which I know work
320
321* Thu Apr 10 1997 Michael Fulbright <msf@redhat.com>
322- Added requirement that gs is installed. Pretty useless w/o it if
323  you print anything interesting.
324
325* Fri Mar 13 1997 Michael Fulbright <msf@redhat.com>
326- Added conflicts so that packages with old filter loc won't hurt us.
327- Moved to version 1.2.
328- Added mpage support to allow nup printing.
329
330* Wed Mar 13 1997 Michael Fulbright <msf@redhat.com>
331- Added a DeskJet500Mono driver which links to the gs driver djet500.
332- Added a A4 paper size test page.
333- Fixed Makefile to build .ps test pages from the .fig files.
334
335* Mon Mar 10 1997 Michael Fulbright <msf@redhat.com>
336- Split filters off from printtool into this package .
Note: See TracBrowser for help on using the repository browser.