source: projects/specs/trunk/v/vinagre/vinagre-vl.spec @ 521

Revision 521, 5.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        VNC client for the GNOME desktop
2Summary(ja):    GNOME デスクトップ用 VNC クライアント
3
4Name:           vinagre
5Version:        2.28.1
6Release:        1%{?_dist_release}
7
8Group:          Applications/System
9License:        GPLv2+
10URL:            http://www.gnome.org/projects/vinagre/
11Source0:        http://download.gnome.org/sources/%{name}/2.28/%{name}-%{version}.tar.bz2
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires:  gtk-vnc-devel >= 0.3.9
16BuildRequires:  glib2-devel >= 2.20.0
17BuildRequires:  gtk2-devel >= 2.16.0
18BuildRequires:  GConf2-devel >= 2.24.0
19BuildRequires:  avahi-ui-devel >= 0.6.22
20BuildRequires:  avahi-gobject-devel >= 0.6.22
21BuildRequires:  perl(XML::Parser) gettext intltool
22BuildRequires:  desktop-file-utils
23BuildRequires:  gnome-doc-utils
24BuildRequires:  gnome-keyring-devel
25BuildRequires:  gnome-panel
26BuildRequires:  libxml2-devel >= 2.6.31
27BuildRequires:  vte-devel >= 0.20
28
29%description
30Vinagre is a VNC client for the GNOME desktop environment.
31
32%prep
33%setup -q
34
35%build
36%configure \
37    --disable-scrollkeeper \
38    --disable-schemas-install \
39    --disable-telepathy \
40    --enable-avahi
41make %{?_smp_mflags}
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
47make install DESTDIR=$RPM_BUILD_ROOT
48
49# Remove text files installed by vinagre, we install them in a versioned
50# directory in the files section
51rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/vinagre/
52
53desktop-file-install                                            \
54        --remove-category=Application                           \
55        --add-category=GTK                                      \
56        --delete-original                                       \
57        --dir=$RPM_BUILD_ROOT%{_datadir}/applications           \
58        $RPM_BUILD_ROOT%{_datadir}/applications/vinagre.desktop
59
60%find_lang vinagre --with-gnome
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%post
66update-desktop-database -q
67export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
68gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/vinagre.schemas > /dev/null || :
69touch %{_datadir}/icons/hicolor
70if [ -x /usr/bin/gtk-update-icon-cache ]; then
71  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
72fi
73
74
75%pre
76if [ "$1" -gt 1 -a -f %{_sysconfdir}/gconf/schemas/vinagre.schemas ]; then
77  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
78  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/vinagre.schemas > /dev/null || :
79fi
80
81%preun
82if [ "$1" -eq 0 ]; then
83  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
84  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/vinagre.schemas > /dev/null || :
85fi
86
87%postun
88update-desktop-database -q
89update-mime-database %{_datadir}/mime >/dev/null
90touch %{_datadir}/icons/hicolor
91if [ -x /usr/bin/gtk-update-icon-cache ]; then
92  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
93fi
94
95
96%files -f vinagre.lang
97%defattr(-,root,root,-)
98%{_sysconfdir}/gconf/schemas/vinagre.schemas
99%{_bindir}/*
100%{_libdir}/bonobo/servers/GNOME_VinagreApplet.server
101%{_libdir}/vinagre-1
102%{_libexecdir}/vinagre-applet
103%{_datadir}/applications/*.desktop
104%{_datadir}/icons/hicolor/*/*/*
105%{_datadir}/mime/packages/vinagre-mime.xml
106%{_datadir}/%{name}/
107
108%doc %{_mandir}/man1/vinagre.1.gz
109%doc README NEWS COPYING AUTHORS
110
111%changelog
112* Sun Nov  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
113- new upstream release
114
115* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
116- new upstream release
117
118* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
119- new upstream release
120
121* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
122- new upstream release
123
124* Mon Jan 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
125- new upstream release
126- build with gnutls-2.6.3
127
128* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
129- new upstream release
130
131* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
132- new upstream release
133
134* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  2.23.92-1
135- initial build for Vine Linux
136
137* Mon Sep  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
138- Update to 2.23.92
139
140* Tue Sep  2 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
141- Update to 2.23.91
142
143* Fri Aug 22 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.90-1
144- Update to 2.23.90
145
146* Wed Jun 25 2008 - Bastien Nocera <bnocera@redhat.com> - 2.23.4-2
147- Rebuild
148
149* Tue Jun 17 2008 - Bastien Nocera <bnocera@redhat.com> - 2.23.4-1
150- Update to 2.23.4
151- Fix URL (#451746)
152
153* Wed Jun  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.3.1-1
154- Update to 2.23.3.1
155
156* Fri Apr 25 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.1-1
157- Update to 2.23.1
158
159* Mon Apr  7 2008 Matthias Clasen <mclasen@redhat.com> - 0.5.1-1
160- Update to 0.5.1
161
162* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 0.5.0-1
163- Update to 0.5.0
164
165* Mon Feb 25 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.92-1
166- Update to 0.4.92
167
168* Mon Feb 18 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.91-2
169- Spec file fixes
170
171* Tue Feb 12 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.91-1
172- Update to 0.4.91
173
174* Tue Jan 29 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.90-1
175- Update to 0.4.90
176
177* Thu Dec 13 2007 - Bastien Nocera <bnocera@redhat.com> - 0.4-1
178- Update to 0.4 and drop obsolete patches
179
180* Fri Nov 23 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-3
181- Fix crasher when passing broken options on the command-line (#394671)
182
183* Thu Oct 25 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-2
184- Fix crasher when setting a favourite with no password (#352371)
185
186* Mon Sep 24 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-1
187- Update to 0.3
188
189* Wed Aug 22 2007 - Bastien Nocera <bnocera@redhat.com> - 0.2-1
190- First version
191- Fix plenty of comments from Ray Strode as per review
192- Have work-around for BZ #253734
193
Note: See TracBrowser for help on using the repository browser.