source: projects/specs/trunk/v/vinagre/vinagre-vl.spec @ 2041

Revision 2041, 6.1 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1Summary:        VNC client for the GNOME desktop
2Summary(ja):    GNOME デスクトップ用 VNC クライアント
3
4Name:           vinagre
5Version:        2.30.3
6Release:        1%{?_dist_release}
7
8Group:          Applications/System
9License:        GPLv2+
10URL:            http://www.gnome.org/projects/vinagre/
11Source0:        http://download.gnome.org/sources/%{name}/2.32/%{name}-%{version}.tar.bz2
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires:  gtk-vnc-devel >= 0.3.10
16BuildRequires:  glib2-devel >= 2.26.0
17BuildRequires:  gtk2-devel >= 2.22.0
18BuildRequires:  GConf2-devel >= 2.32.0
19BuildRequires:  avahi-ui-devel >= 0.6.22
20BuildRequires:  avahi-gobject-devel >= 0.6.22
21BuildRequires:  perl(XML::Parser) gettext intltool
22BuildRequires:  desktop-file-utils
23BuildRequires:  gnome-doc-utils
24BuildRequires:  libgnome-keyring-devel >= 2.32.0
25BuildRequires:  gnome-panel-devel
26BuildRequires:  libxml2-devel >= 2.6.31
27BuildRequires:  vte-devel >= 0.26
28
29%description
30Vinagre is a VNC client for the GNOME desktop environment.
31
32%prep
33%setup -q
34
35%build
36%configure \
37    --disable-scrollkeeper \
38    --disable-schemas-install \
39    --disable-telepathy \
40    --enable-avahi
41make %{?_smp_mflags}
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
47make install DESTDIR=$RPM_BUILD_ROOT
48
49# Remove text files installed by vinagre, we install them in a versioned
50# directory in the files section
51rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/vinagre/
52
53desktop-file-install                                            \
54        --remove-category=Application                           \
55        --add-category=GTK                                      \
56        --delete-original                                       \
57        --dir=$RPM_BUILD_ROOT%{_datadir}/applications           \
58        $RPM_BUILD_ROOT%{_datadir}/applications/vinagre.desktop
59
60%find_lang vinagre --with-gnome
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%post
66update-desktop-database -q
67export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
68gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/vinagre.schemas > /dev/null || :
69touch %{_datadir}/icons/hicolor
70if [ -x /usr/bin/gtk-update-icon-cache ]; then
71  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
72fi
73
74
75%pre
76if [ "$1" -gt 1 -a -f %{_sysconfdir}/gconf/schemas/vinagre.schemas ]; then
77  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
78  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/vinagre.schemas > /dev/null || :
79fi
80
81%preun
82if [ "$1" -eq 0 ]; then
83  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
84  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/vinagre.schemas > /dev/null || :
85fi
86
87%postun
88update-desktop-database -q
89update-mime-database %{_datadir}/mime >/dev/null
90touch %{_datadir}/icons/hicolor
91if [ -x /usr/bin/gtk-update-icon-cache ]; then
92  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
93fi
94
95
96%files -f vinagre.lang
97%defattr(-,root,root,-)
98%{_sysconfdir}/gconf/schemas/vinagre.schemas
99%{_bindir}/*
100%{_libdir}/bonobo/servers/GNOME_VinagreApplet.server
101%{_libdir}/vinagre-1
102%{_libexecdir}/vinagre-applet
103%{_datadir}/applications/*.desktop
104%{_datadir}/icons/hicolor/*/*/*
105%{_datadir}/mime/packages/vinagre-mime.xml
106%{_datadir}/%{name}/
107%{_datadir}/%{name}-1/
108## for development
109%{_includedir}/%{name}-1.0/
110%{_libdir}/pkgconfig/%{name}-1.0.pc
111
112%doc %{_mandir}/man1/vinagre.1.gz
113%doc README NEWS COPYING AUTHORS
114
115%changelog
116* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
117- new upstream release
118- change BuildRequires: gnome-panel-devel instead of gnome-panel
119
120* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.2-2
121- rebuilt with rpm-4.8.1 for pkg-config
122
123* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
124- new upstream release
125
126* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
127- new upstream release
128- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
129
130* Sun Nov  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
131- new upstream release
132
133* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
134- new upstream release
135
136* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
137- new upstream release
138
139* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
140- new upstream release
141
142* Mon Jan 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
143- new upstream release
144- build with gnutls-2.6.3
145
146* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
147- new upstream release
148
149* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
150- new upstream release
151
152* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  2.23.92-1
153- initial build for Vine Linux
154
155* Mon Sep  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
156- Update to 2.23.92
157
158* Tue Sep  2 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
159- Update to 2.23.91
160
161* Fri Aug 22 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.90-1
162- Update to 2.23.90
163
164* Wed Jun 25 2008 - Bastien Nocera <bnocera@redhat.com> - 2.23.4-2
165- Rebuild
166
167* Tue Jun 17 2008 - Bastien Nocera <bnocera@redhat.com> - 2.23.4-1
168- Update to 2.23.4
169- Fix URL (#451746)
170
171* Wed Jun  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.3.1-1
172- Update to 2.23.3.1
173
174* Fri Apr 25 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.1-1
175- Update to 2.23.1
176
177* Mon Apr  7 2008 Matthias Clasen <mclasen@redhat.com> - 0.5.1-1
178- Update to 0.5.1
179
180* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 0.5.0-1
181- Update to 0.5.0
182
183* Mon Feb 25 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.92-1
184- Update to 0.4.92
185
186* Mon Feb 18 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.91-2
187- Spec file fixes
188
189* Tue Feb 12 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.91-1
190- Update to 0.4.91
191
192* Tue Jan 29 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.90-1
193- Update to 0.4.90
194
195* Thu Dec 13 2007 - Bastien Nocera <bnocera@redhat.com> - 0.4-1
196- Update to 0.4 and drop obsolete patches
197
198* Fri Nov 23 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-3
199- Fix crasher when passing broken options on the command-line (#394671)
200
201* Thu Oct 25 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-2
202- Fix crasher when setting a favourite with no password (#352371)
203
204* Mon Sep 24 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-1
205- Update to 0.3
206
207* Wed Aug 22 2007 - Bastien Nocera <bnocera@redhat.com> - 0.2-1
208- First version
209- Fix plenty of comments from Ray Strode as per review
210- Have work-around for BZ #253734
211
Note: See TracBrowser for help on using the repository browser.