source: projects/specs/trunk/v/viewnior/viewnior-vl.spec @ 8294

Revision 8294, 3.5 KB checked in by kudoh, 10 years ago (diff)

rebuilt and new upstream release

Line 
1# We don't build with Gnome support by default to avoid a GConf dependency.
2# If you would like to set the Gnome background image with Viewnior, rebuild
3# the srpm with:
4#   rpmbuild --rebuild viewnior-*-src.rpm --with gnome
5# or use bcond_without to change the default
6#%bcond_with gnome
7
8Name:           viewnior
9Version:        1.4
10Release:        1%{?_dist_release}
11Summary:        Elegant image viewer
12Summary(ja):    エレガントな画像ビューア
13
14Group:          Applications/Graphics
15License:        GPLv3+
16URL:            http://xsisqox.github.com/Viewnior
17Source0:        http://cloud.github.com/downloads/xsisqox/Viewnior/%{name}-%{version}.tar.gz
18Patch0:         viewnior-0.7-dsofix.patch
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
21BuildRequires:  exiv2-devel
22BuildRequires:  gdk-pixbuf2-devel >= 2.4.0
23BuildRequires:  glib2-devel >= 2.24
24BuildRequires:  gtk2-devel >= 2.20
25BuildRequires:  desktop-file-utils
26BuildRequires:  gettext
27BuildRequires:  intltool >= 0.35.0
28BuildRequires:  perl-XML-Parser
29BuildRequires:  shared-mime-info >= 0.20
30#%if %{with gnome}
31#BuildRequires:  GConf2-devel
32#%endif
33
34
35%description
36Viewnior is an image viewer program. Created to be simple, fast and elegant.
37It's minimalistic interface provides more screen space for your images. Among
38its features are:
39
40* Fullscreen & Slideshow
41* Rotate, flip, save, delete images
42* Animation support
43* Browse only selected images
44* Navigation window
45* Simple interface
46* Configurable mouse actions
47
48
49%prep
50%setup -q
51%patch0 -p1 -b .dsofix
52# fix spurious executable perms
53chmod 0644 AUTHORS ChangeLog COPYING NEWS README TODO src/*
54
55
56%build
57%configure --enable-static=no \
58#%if %{with gnome}
59#   --enable-wallpaper
60#%endif
61
62make %{?_smp_mflags} V=1
63
64
65%install
66rm -rf %{buildroot}
67make install DESTDIR=%{buildroot} INSTALL='install -p'
68%find_lang %{name}
69desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
70
71
72%clean
73rm -rf %{buildroot}
74
75
76%post
77touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
78update-desktop-database &> /dev/null || :
79
80
81%postun
82if [ $1 -eq 0 ] ; then
83    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
84    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
85fi
86update-desktop-database &> /dev/null || :
87
88
89%posttrans
90gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
91
92
93%files -f %{name}.lang
94%defattr(-,root,root,-)
95%doc AUTHORS ChangeLog COPYING NEWS README TODO
96%{_bindir}/%{name}
97%{_datadir}/applications/%{name}.desktop
98%{_datadir}/icons/hicolor/*/apps/%{name}.*
99%{_datadir}/%{name}/
100%{_mandir}/man?/
101
102
103%changelog
104* Sat Mar 08 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.4-1
105- new upstream release
106- added BuildRequires: exiv2-devel
107
108* Tue Feb 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3-1
109- new upstream release
110- dropt patch1
111
112* Sat Feb 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2-1
113- new upstream release
114- added patch1 to fix typo
115- added configure option: --enable-static=no
116
117* Thu Dec 16 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1-1
118- initial build for VineSeed
119
120* Wed Mar 31 2010 Christoph Wickert <cwickert@fedoraproject.org> - 1.0-1
121- Update to 1.0
122
123* Tue Feb 16 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7-2
124- Add patch to fix DSO linking (#565018)
125- Switch to %%bcond macro
126
127* Mon Sep 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.7-1
128- Update to 0.7
129
130* Sat Sep 05 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6-2
131- Spec file cleanups from review.
132
133* Sat Aug 01 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6-1
134- Initial package
Note: See TracBrowser for help on using the repository browser.