source: projects/specs/trunk/v/viewnior/viewnior-vl.spec @ 2356

Revision 2356, 3.1 KB checked in by kudoh, 13 years ago (diff)
Line 
1# We don't build with Gnome support by default to avoid a GConf dependency.
2# If you would like to set the Gnome background image with Viewnior, rebuild
3# the srpm with:
4#   rpmbuild --rebuild viewnior-*-src.rpm --with gnome
5# or use bcond_without to change the defaul
6%bcond_with gnome
7
8Name:           viewnior
9Version:        1.1
10Release:        1%{?_dist_release}
11Summary:        Elegant image viewer
12Summary(ja):    エレガントな画像ビューア
13
14Group:          Applications/Graphics
15License:        GPLv3+
16URL:            http://xsisqox.github.com/Viewnior
17Source0:        http://cloud.github.com/downloads/xsisqox/Viewnior/%{name}-%{version}.tar.gz
18Patch0:         viewnior-0.7-dsofix.patch
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
21BuildRequires:  gdk-pixbuf2-devel >= 2.4.0
22BuildRequires:  glib2-devel >= 2.24
23BuildRequires:  gtk2-devel >= 2.20
24BuildRequires:  desktop-file-utils
25BuildRequires:  gettext
26BuildRequires:  intltool >= 0.35.0
27BuildRequires:  perl-XML-Parser
28BuildRequires:  shared-mime-info >= 0.20
29%if %{with gnome}
30BuildRequires:  GConf2-devel
31%endif
32
33
34%description
35Viewnior is an image viewer program. Created to be simple, fast and elegant.
36It's minimalistic interface provides more screen space for your images. Among
37its features are:
38
39* Fullscreen & Slideshow
40* Rotate, flip, save, delete images
41* Animation support
42* Browse only selected images
43* Navigation window
44* Simple interface
45* Configurable mouse actions
46
47
48%prep
49%setup -q
50%patch0 -p1 -b .dsofix
51# fix spurious executable perms
52chmod 0644 AUTHORS ChangeLog COPYING NEWS README TODO src/*
53
54
55%build
56%configure \
57%if %{with gnome}
58   --enable-wallpaper
59%endif
60
61make %{?_smp_mflags} V=1
62
63
64%install
65rm -rf %{buildroot}
66make install DESTDIR=%{buildroot} INSTALL='install -p'
67%find_lang %{name}
68desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
69
70
71%clean
72rm -rf %{buildroot}
73
74
75%post
76touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
77update-desktop-database &> /dev/null || :
78
79
80%postun
81if [ $1 -eq 0 ] ; then
82    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
83    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
84fi
85update-desktop-database &> /dev/null || :
86
87
88%posttrans
89gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
90
91
92%files -f %{name}.lang
93%defattr(-,root,root,-)
94%doc AUTHORS ChangeLog COPYING NEWS README TODO
95%{_bindir}/%{name}
96%{_datadir}/applications/%{name}.desktop
97%{_datadir}/icons/hicolor/*/apps/%{name}.*
98%{_datadir}/%{name}/
99%{_mandir}/man?/
100
101
102%changelog
103* Thu Dec 16 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1-1
104- initial build for VineSeed
105
106* Wed Mar 31 2010 Christoph Wickert <cwickert@fedoraproject.org> - 1.0-1
107- Update to 1.0
108
109* Tue Feb 16 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7-2
110- Add patch to fix DSO linking (#565018)
111- Switch to %%bcond macro
112
113* Mon Sep 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.7-1
114- Update to 0.7
115
116* Sat Sep 05 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6-2
117- Spec file cleanups from review.
118
119* Mon Aug 01 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6-1
120- Initial package
Note: See TracBrowser for help on using the repository browser.