source: projects/specs/trunk/v/viewnior/viewnior-vl.spec @ 10523

Revision 10523, 3.9 KB checked in by kudoh, 8 years ago (diff)

rebuilt

Line 
1# We don't build with Gnome support by default to avoid a GConf dependency.
2# If you would like to set the Gnome background image with Viewnior, rebuild
3# the srpm with:
4#   rpmbuild --rebuild viewnior-*-src.rpm --with gnome
5# or use bcond_without to change the default
6#%bcond_with gnome
7
8Name:           viewnior
9Version:        1.6
10Release:        2%{?_dist_release}
11Summary:        Elegant image viewer
12Summary(ja):    エレガントな画像ビューア
13
14Group:          Applications/Graphics
15License:        GPLv3+
16URL:            http://xsisqox.github.com/Viewnior
17Source0:        http://cloud.github.com/downloads/xsisqox/Viewnior/%{name}-%{version}.tar.gz
18#Patch0:         viewnior-0.7-dsofix.patch
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
21BuildRequires:  exiv2-devel
22BuildRequires:  gdk-pixbuf2-devel >= 2.4.0
23BuildRequires:  glib2-devel >= 2.24
24BuildRequires:  gtk2-devel >= 2.20
25BuildRequires:  gnome-common
26BuildRequires:  desktop-file-utils
27BuildRequires:  gettext
28BuildRequires:  intltool >= 0.35.0
29BuildRequires:  perl-XML-Parser
30BuildRequires:  shared-mime-info >= 0.20
31#%if %{with gnome}
32#BuildRequires:  GConf2-devel
33#%endif
34
35
36%description
37Viewnior is an image viewer program. Created to be simple, fast and elegant.
38It's minimalistic interface provides more screen space for your images. Among
39its features are:
40
41* Fullscreen & Slideshow
42* Rotate, flip, save, delete images
43* Animation support
44* Browse only selected images
45* Navigation window
46* Simple interface
47* Configurable mouse actions
48
49
50%prep
51%setup -q -n Viewnior-%{name}-%{version}
52#%patch0 -p1 -b .dsofix
53# fix spurious executable perms
54chmod 0644 AUTHORS COPYING NEWS README TODO src/*
55
56
57%build
58./autogen.sh
59%configure --enable-static=no \
60#%if %{with gnome}
61#   --enable-wallpaper
62#%endif
63
64make %{?_smp_mflags} V=1
65
66
67%install
68rm -rf %{buildroot}
69make install DESTDIR=%{buildroot} INSTALL='install -p'
70%find_lang %{name}
71desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
72
73
74%clean
75rm -rf %{buildroot}
76
77
78%post
79touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
80update-desktop-database &> /dev/null || :
81
82
83%postun
84if [ $1 -eq 0 ] ; then
85    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
86    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
87fi
88update-desktop-database &> /dev/null || :
89
90
91%posttrans
92gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
93
94
95%files -f %{name}.lang
96%defattr(-,root,root,-)
97%doc AUTHORS COPYING NEWS README TODO
98%{_bindir}/%{name}
99%{_datadir}/applications/%{name}.desktop
100%{_datadir}/icons/hicolor/*/apps/%{name}.*
101%{_datadir}/%{name}/
102%{_mandir}/man?/
103
104
105%changelog
106* Sat Jul 02 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.6-2
107- rebuilt with new toolchain
108
109* Thu Mar 31 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.6-1
110- new upstream release
111- fixed %%doc in %%files
112
113* Sat Nov 14 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5-1
114- new upstream release
115- deleted Patch0
116- added BuildRequires: gnome-common
117
118* Sat Mar 08 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.4-1
119- new upstream release
120- added BuildRequires: exiv2-devel
121
122* Tue Feb 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3-1
123- new upstream release
124- dropt patch1
125
126* Sat Feb 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2-1
127- new upstream release
128- added patch1 to fix typo
129- added configure option: --enable-static=no
130
131* Thu Dec 16 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1-1
132- initial build for VineSeed
133
134* Wed Mar 31 2010 Christoph Wickert <cwickert@fedoraproject.org> - 1.0-1
135- Update to 1.0
136
137* Tue Feb 16 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7-2
138- Add patch to fix DSO linking (#565018)
139- Switch to %%bcond macro
140
141* Mon Sep 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.7-1
142- Update to 0.7
143
144* Sat Sep 05 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6-2
145- Spec file cleanups from review.
146
147* Sat Aug 01 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6-1
148- Initial package
Note: See TracBrowser for help on using the repository browser.