source: projects/specs/trunk/v/vcdimager/vcdimager-vl.spec @ 3145

Revision 3145, 6.0 KB checked in by munepi, 13 years ago (diff)

added vcdimager-vl.spec

Line 
1Summary: VideoCD (pre-)mastering and ripping tool
2Name: vcdimager
3Version: 0.7.23
4Release: 1%{?_dist_release}
5License: GPLv2+
6Group: Applications/Multimedia
7URL: http://www.gnu.org/software/vcdimager/
8Source: ftp://ftp.gnu.org/pub/gnu/vcdimager/vcdimager-%{version}.tar.gz
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10Requires(post): info
11Requires(preun): info
12BuildRequires: libcdio-devel >= 0.72
13BuildRequires: libxml2-devel >= 2.3.8
14BuildRequires: zlib-devel
15BuildRequires: pkgconfig >= 0.9
16BuildRequires: popt-devel
17
18%description
19VCDImager allows you to create VideoCD BIN/CUE CD images from MPEG
20files. These can be burned with cdrdao or any other program capable of
21burning BIN/CUE files.
22
23Also included is VCDRip which does the reverse operation, that is to
24rip MPEG streams from images or burned VideoCDs and to show
25information about a VideoCD.
26
27%package devel
28Summary: Header files and static library for VCDImager
29Group: Development/Libraries
30Requires: %{name} = %{version}-%{release}
31
32Requires: pkgconfig
33Requires: libcdio-devel
34
35%description devel
36VCDImager allows you to create VideoCD BIN/CUE CD images from mpeg
37files which can be burned with cdrdao or any other program capable of
38burning BIN/CUE files.
39
40This package contains the header files and a static library to develop
41applications that will use VCDImager.
42
43
44%prep
45%setup -q
46
47
48%build
49%configure --disable-static --disable-dependency-tracking
50%{__make} %{?_smp_mflags}
51
52
53%install
54%{__rm} -rf %{buildroot}
55%{__make} DESTDIR=%{buildroot} install INSTALL="install -p"
56find $RPM_BUILD_ROOT -type f -name "*.la" -exec %__rm -f {} ';'
57
58# Sometimes this file gets created... but we don't want it!
59%__rm -f %{buildroot}%{_infodir}/dir
60
61
62%clean
63%__rm -rf %{buildroot}
64
65
66%post
67/sbin/ldconfig
68
69for infofile in vcdxrip.info vcdimager.info vcd-info.info; do
70  /sbin/install-info %{_infodir}/${infofile} %{_infodir}/dir 2>/dev/null || :
71done
72
73%preun
74/sbin/ldconfig
75
76if [ $1 -eq 0 ]; then
77  for infofile in vcdxrip.info vcdimager.info vcd-info.info; do
78    /sbin/install-info --delete %{_infodir}/${infofile} %{_infodir}/dir \
79      2>/dev/null || :
80  done
81fi
82
83
84%files
85%defattr(-,root,root,-)
86%doc AUTHORS BUGS ChangeLog* COPYING FAQ NEWS README THANKS TODO
87%doc frontends/xml/videocd.dtd
88%{_bindir}/*
89%{_infodir}/vcdxrip.info*
90%{_infodir}/vcdimager.info*
91%{_infodir}/vcd-info.info*
92%{_mandir}/man1/*
93## libs
94%{_libdir}/libvcdinfo.so.*
95
96%files devel
97%defattr(-,root,root,-)
98%doc HACKING
99%{_includedir}/libvcd/
100%{_libdir}/libvcdinfo.so
101%{_libdir}/pkgconfig/libvcdinfo.pc
102
103
104%changelog
105* Thu Jul 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.23-1
106- initial build
107
108* Sun Jan 24 2010 Nicolas Chauvet <kwizart@fedoraproject.org> - 0.7.23-13
109- Rebuild for libcdio
110
111* Wed Nov 25 2009 Nicolas Chauvet <kwizart@fedoraproject.org> - 0.7.23-11
112- Rebuild for F-12
113
114* Sun Mar 29 2009 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 0.7.23-10
115- rebuild for new F11 features
116
117* Thu Jan 15 2009 kwizart < kwizart at gmail.com > - 0.7.23-9
118- Rebuild for libcdio
119
120* Thu Sep  4 2008 kwizart < kwizart at gmail.com > - 0.7.23-8
121- Fix URL
122- vcdimager-devel Requires libcdio-devel
123- Split libs (multilibs compliance)
124
125* Sat Aug 09 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 0.7.23-7
126- merge a few bits from livna spec
127
128* Fri May 16 2008 Matthias Saou <http://freshrpms.net/> 0.7.23-6
129- Rebuild for Fedora 9.
130- Add missing ldconfig calls and scriplet info requirements.
131
132* Sun Sep 24 2006 Matthias Saou <http://freshrpms.net/> 0.7.23-5
133- Rebuild against new libcdio.
134
135* Fri Mar 17 2006 Matthias Saou <http://freshrpms.net/> 0.7.23-4
136- Release bump to drop the disttag number in FC5 build.
137
138* Fri Jan 13 2006 Matthias Saou <http://freshrpms.net/> 0.7.23-3
139- Silence install-info scriplets.
140
141* Sat Jul 30 2005 Matthias Saou <http://freshrpms.net/> 0.7.23-2
142- Rebuild against new libcdio.
143
144* Tue Jul 12 2005 Matthias Saou <http://freshrpms.net/> 0.7.23-1
145- Update to 0.7.23.
146- Update libcdio-devel requirement to >= 0.72.
147- Change source location from vcdimager.org to gnu.org for this release...
148
149* Tue Jun 28 2005 Matthias Saou <http://freshrpms.net/> 0.7.22-2
150- Prevent scriplets from failing if the info calls return an error.
151
152* Tue May 17 2005 Matthias Saou <http://freshrpms.net/> 0.7.22-1
153- Update to 0.7.22.
154
155* Sun Apr 17 2005 Matthias Saou <http://freshrpms.net/> 0.7.21-1
156- Update to 0.7.21 at last.
157- Split off new -devel package.
158- Added libcdio build requirement.
159- Update Source URL, it's not "UNSTABLE" anymore.
160- Remove vcddump.info and add vcd-info.info. Remove .gz from scriplets.
161
162* Mon Aug 30 2004 Matthias Saou <http://freshrpms.net/> 0.7.14-4
163- Added missing install-info calls.
164
165* Mon May 24 2004 Matthias Saou <http://freshrpms.net/> 0.7.14-3
166- Tried and update to 0.7.20, but the looping libcd* deps are a problem.
167- Rebuild for Fedora Core 2.
168
169* Fri Nov  7 2003 Matthias Saou <http://freshrpms.net/> 0.7.14-2
170- Rebuild for Fedora Core 1.
171
172* Fri May  2 2003 Matthias Saou <http://freshrpms.net/>
173- Update to 0.7.14.
174- Remove infodir/dir, thanks to Florin Andrei.
175- Updated URL/Source.
176
177* Mon Mar 31 2003 Matthias Saou <http://freshrpms.net/>
178- Rebuilt for Red Hat Linux 9.
179
180* Fri Feb 28 2003 Matthias Saou <http://freshrpms.net/>
181- Update to 0.7.13.
182- Removed the now unnecessary libxml fix.
183
184* Tue Jan 14 2003 Matthias Saou <http://freshrpms.net/>
185- Fix xmlversion.h include path in configure since xml is disabled otherwise,
186  thanks to Rudolf Kastl for spotting the problem.
187
188* Fri Jan  3 2003 Matthias Saou <http://freshrpms.net/>
189- Let's try the 1 year old 0.7 development branch!
190
191* Mon Dec  9 2002 Matthias Saou <http://freshrpms.net/>
192- Spec file cleanup.
193
194* Sat Jan 20 2001 Herbert Valerio Riedel <hvr@gnu.org>
195- added THANKS file as doc
196
197* Thu Jan  4 2001 Herbert Valerio Riedel <hvr@gnu.org>
198- fixed removal of info pages on updating packages
199
200* Sat Dec 23 2000 Herbert Valerio Riedel <hvr@gnu.org>
201- added vcdrip
202- removed glib dependancy
203
204* Sat Aug 26 2000 Herbert Valerio Riedel <hvr@gnu.org>
205- spec file improvements
206
207* Mon Aug 14 2000 Herbert Valerio Riedel <hvr@gnu.org>
208- first spec file
209
Note: See TracBrowser for help on using the repository browser.