source: projects/specs/trunk/v/vblade/vblade-vl.spec @ 521

Revision 521, 3.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           vblade
2Version:        14
3Release:        4%{?_dist_release}
4Summary:        Virtual EtherDrive (R) blade daemon
5Summary(ja):    仮想 EtherDrive (R) ブレードデーモン
6
7Group:          System Environment/Daemons
8License:        GPLv2
9URL:            http://sourceforge.net/projects/aoetools/
10Source0:        http://dl.sf.net/aoetools/%{name}-%{version}.tgz
11Source1:        %{name}.init
12Source2:        %{name}.conf
13Patch0:         %{name}-makefile.patch
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15
16PreReq:         chkconfig initscripts
17#Requires(post):  /sbin/chkconfig
18#Requires(post):  /sbin/service
19#Requires(preun): /sbin/chkconfig
20#Requires(preun): /sbin/service
21
22
23%description
24The vblade is the virtual EtherDrive (R) blade, a program that makes a
25seekable file available over an ethernet local area network (LAN) via
26the ATA over Ethernet (AoE) protocol.
27
28The seekable file is typically a block device like /dev/md0 but even
29regular files will work.  When vblade exports the block storage over
30AoE it becomes a storage target.  Another host on the same LAN can
31access the storage if it has a compatible aoe kernel driver.
32
33%description -l ja
34vblade は仮想 EtherDrive (R) ブレードとして動作するプログラムです。
35ATA over Ethernet (AoE) プロトコルを介して、イーサネットで構築された
36ローカルエリアネットワーク (LAN) 上にシーク可能なファイルを提供します。
37
38シーク可能なファイルというのは例えば /dev/md0 のようなブロックデバイス
39のことですが、通常ファイルでも動作するはずです。vblade が AoE を介して
40ブロックストレージをエクスポートしさえすれば、簡単にストレージターゲットに
41なることができます。同一 LAN 内の他のホストは、対応するカーネルドライバ
42aoe をロードしれば、そのストレージにアクセスすることができます。
43
44
45%prep
46%setup -q
47%patch0 -p1
48
49
50%build
51make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
52
53
54%install
55rm -rf $RPM_BUILD_ROOT
56make install DESTDIR=$RPM_BUILD_ROOT
57mkdir -p $RPM_BUILD_ROOT/var/run/%{name}
58install -D -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/%{name}
59install -D -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
60
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65
66%post
67if [ "$1" = "2" ]; then # if we're being upgraded
68    /sbin/service %{name} condrestart >/dev/null 2>&1 || :
69else # if we're being installed
70    /sbin/chkconfig --add %{name}
71fi
72
73%preun
74if [ "$1" = "0" ]; then     # execute this only if we are NOT doing an upgrade
75    /sbin/service %{name} stop >/dev/null 2>&1 || :
76    /sbin/chkconfig --del %{name}
77fi
78
79
80%files
81%defattr(-,root,root,-)
82%doc COPYING HACKING NEWS README
83%config(noreplace) %{_sysconfdir}/%{name}.conf
84%dir /var/run/%{name}
85%{_initrddir}/%{name}
86%{_sbindir}/vblade
87%{_sbindir}/vbladed
88%{_mandir}/man8/vblade.8*
89
90
91%changelog
92* Mon Oct 13 2008 Shu KONNO <owa@bg.wakwak.com> 14-4vl5
93- applied new versioning policy, spec in utf-8
94
95* Tue Dec 04 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 14-3vl2
96- initial package for VineSeed
97
98* Wed Aug 22 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 14-3
99- Add missing /var/run/vblade/
100- Rebuild for BuildID
101- License clarification
102
103* Sat Apr 07 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 14-2
104- Forced CFLAGS on build
105
106* Wed Apr 04 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 14-1
107- Initial Fedora RPM
Note: See TracBrowser for help on using the repository browser.