source: projects/specs/trunk/v/vala/vala-vl.spec @ 805

Revision 805, 8.8 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file of gnome-2.30

Line 
1Summary:        A modern programming language for GNOME
2Summary:        GNOME 用のモダンなプログラミング言語
3
4Name:           vala
5Version:        0.8.0
6Release:        1%{?_dist_release}
7
8Group:          Development/Languages
9# Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
10License:        LGPLv2+ and BSD
11URL:            http://live.gnome.org/Vala
12Source0:        http://download.gnome.org/sources/vala/0.7/vala-%{version}.tar.bz2
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14
15BuildRequires:  gtk2-devel flex bison devhelp xulrunner-devel >= 1.9
16Requires:       gtk2-devel
17
18%description
19Vala is a new programming language that aims to bring modern programming
20language features to GNOME developers without imposing any additional
21runtime requirements and without using a different ABI compared to
22applications and libraries written in C.
23
24valac, the Vala compiler, is a self-hosting compiler that translates
25Vala source code into C source and header files. It uses the GObject
26type system to create classes and interfaces declared in the Vala source
27code. It's also planned to generate GIDL files when gobject-
28introspection is ready.
29
30The syntax of Vala is similar to C#, modified to better fit the GObject
31type system.
32
33
34%package        devel
35Summary:        Development files for %{name}
36Group:          Development/Libraries
37Requires:       %{name} = %{version}-%{release}
38Requires:       pkgconfig
39
40%description    devel
41Vala is a new programming language that aims to bring modern programming
42language features to GNOME developers without imposing any additional
43runtime requirements and without using a different ABI compared to
44applications and libraries written in C.
45
46This package contains development files for %{name}. This is not necessary for
47using the %{name} compiler.
48
49
50%package        tools
51Summary:        Tools for creating projects and bindings for %{name}
52Group:          Development/Languages
53License:        LGPLv2+
54Requires:       %{name} = %{version}-%{release}
55Requires:       gnome-common intltool libtool
56Provides:       %{name}-vapigen = %{version}-%{release}
57Obsoletes:      %{name}-vapigen < %{version}-%{release}
58
59%description    tools
60Vala is a new programming language that aims to bring modern programming
61language features to GNOME developers without imposing any additional
62runtime requirements and without using a different ABI compared to
63applications and libraries written in C.
64
65This package contains tools to generate Vala projects, as well as API bindings
66from existing C libraries, allowing access from Vala programs.
67
68
69%package        doc
70Summary:        Documentation for %{name}
71Group:          Documentation
72License:        LGPLv2+
73Requires:       %{name} = %{version}-%{release}
74Requires:       devhelp
75Provides:       %{name}-docs = %{version}-%{release}
76Obsoletes:      %{name}-docs < %{version}-%{release}
77
78
79%description    doc
80Vala is a new programming language that aims to bring modern programming
81language features to GNOME developers without imposing any additional
82runtime requirements and without using a different ABI compared to
83applications and libraries written in C.
84
85This package contains documentation in a devhelp HTML book.
86
87
88%prep
89%setup -q
90
91
92%build
93%configure --enable-vapigen
94# Don't use rpath!
95sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
96sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
97make %{?_smp_mflags}
98
99
100# checks currently utilize installed Vala, not the one being compiled
101#%check
102#make check
103
104
105%install
106rm -rf $RPM_BUILD_ROOT
107make install DESTDIR=$RPM_BUILD_ROOT
108rm $RPM_BUILD_ROOT%{_libdir}/libvala.la
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(-,root,root,-)
119%doc AUTHORS ChangeLog COPYING INSTALL MAINTAINERS NEWS README THANKS
120%{_bindir}/valac
121%{_datadir}/vala
122%{_libdir}/libvala.so.*
123%{_mandir}/*/valac*
124
125%files devel
126%defattr(-,root,root,-)
127%{_includedir}/vala-1.0
128%{_libdir}/libvala.so
129%{_libdir}/pkgconfig/vala-1.0.pc
130
131%files tools
132%defattr(-,root,root,-)
133%{_bindir}/*gen*
134%{_bindir}/vapicheck
135%{_libdir}/vala
136%{_mandir}/*/*gen*
137
138%files doc
139%defattr(-,root,root,-)
140%{_datadir}/devhelp/books/vala
141
142
143%changelog
144* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
145- new upstream release
146- change BuildRequires: gecko-libs -> xulrunner-devel
147
148* Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
149- new upstream release
150
151* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
152- new upstream release
153
154* Tue Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
155- new upstream release
156
157* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
158- initial build for Vine Linux
159
160* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
161- Update to 0.7.5
162
163* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
164- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
165
166* Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
167- Patch broken ModuleInit attribute (upstream bug 587444)
168
169* Tue Jul  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
170- Update to 0.7.4
171
172* Wed Jun  3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
173- Update to 0.7.3
174
175* Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
176- Update to 0.6.1
177
178* Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
179- Update to 0.5.7
180
181* Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
182- Update to 0.5.6
183
184* Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
185- Update to 0.5.3
186
187* Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
188- Fix bug in Emacs version detection
189
190* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
191- Use buildsystem variables to determine available Emacs version
192- BR on gecko-devel >= 1.9, since older version is also in RHEL repo
193
194* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
195- Update to 0.5.2
196
197* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
198- Update to 0.5.1
199
200* Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
201- Update to 0.3.5
202
203* Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
204- Add vala-mode for editing Vala code in Emacs
205
206* Tue Jul  1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
207- Update to 0.3.4
208
209* Wed Jun  4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
210- Update to 0.3.3
211
212* Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
213- Update to 0.3.2
214
215* Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
216- Update to 0.2.0
217
218* Wed Mar  5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
219- Update to 0.1.7
220- -tool subpackage now requires gnome-common, intltool and libtoolize
221  for out-of-the-box vala-gen-project support
222
223* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
224- Autorebuild for GCC 4.3
225
226* Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
227- Update to 0.1.6
228- Revert vapi addition, needed declarations have been inlined (r846)
229- Rename -docs subpackage to -doc, to comply with guidelines
230
231* Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
232- Manually add Gee vapi file to package (bz #428692)
233
234* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
235- Backport patch to autodetect location of automake shared files
236
237* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
238- Add build dependency on gtk2-devel
239
240* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
241- Enable project generator tool
242
243* Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
244- Update to 0.1.5
245
246* Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
247- Add build dependency on devhelp
248
249* Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
250- Update to 0.1.4
251- Put newly-added documentation in its own subpackage (depends on devhelp)
252
253* Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
254- vapigen subpackage: add missing Require: on perl-XML-Twig
255
256* Sat Sep  8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
257- Split -vapigen subpackage. It is functionally self-contained and the license
258  is more restricted
259- Updated license declarations
260
261* Wed Sep  5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
262- Licensing and URL updates
263
264* Tue Sep  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
265- Enable binding generation tools
266
267* Sun Sep  2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
268- Update to 0.1.3
269
270* Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
271- Update to 0.0.8
272
273* Wed Mar  7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
274- Update to 0.0.7
275
276* Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
277- Update to 0.0.6
278
279* Mon Nov  6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
280- Initial package
Note: See TracBrowser for help on using the repository browser.